Kixforms

KiXforms.NET Class Library

Kixforms Namespace

Namespace hierarchy

Classes

Class | Description
Application | Provides methods and properties to manage an application, such as methods to start and stop an application, and properties to get information about an application.
ArrayList | Represents an array whose size is dynamically increased as required.
Bitmap | Encapsulates a GDI+ bitmap, which consists of the pixel data for a graphics image and its attributes. A Bitmap object is an object used to work with images defined by pixel data.
Brush | Classes derived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.
Button | Represents a Windows button control.
ButtonBase | Implements the basic functionality common to button controls.
CancelEventArgs | Provides data for a cancelable event.
CheckBox | Represents a Windows check box.
Collection | Represents an ordered set of items that can be referred to as a unit.
CollectionBase |
Color | Represents an ARGB color.
ColumnClickEventArgs | Provides data for the ColumnClick event.
ColumnHeader | Displays a single column header in a ListView control.
ComboBox | Represents a Windows combo box control.
ComboBoxObjectCollection | Represents the collection of items in a ComboBox.
CommonDialog | Specifies the base class used for displaying dialog boxes on the screen.
Component | Provides functionality required by all components.
ContainerControl | Provides focus management functionality for controls that can function as a container for other controls.
ContextMenu | Represents a shortcut menu.
Control | Defines the base class for controls, which are components with visual representation.
ControlCollection | A collection of Control objects that represents all the controls contained within a control.
ControlEventArgs | Provides data for the ControlAdded and ControlRemoved events.
Cursor | Represents the image used to paint the mouse pointer.
Cursors | Provides a collection of Cursor objects for use by a Windows Forms application.
DataCollectionBase | Under development.
DataColumn | Under development.
DataColumnCollection | Under development.
DataGrid | Under development.
DataGridCell | Under development.
DataGridColumnStyle | Specifies the appearance and text formatting and behavior of a DataGrid control column. This class is abstract.
DataGridTableStyle | Represents the table drawn by the DataGrid control at run time.
DataItem | Under development.
DataRow | Under development.
DataRowCollection | Under development.
DataRowView | Under development.
DataSet | Under development.
DataTable | Under development.
DataTableCollection | Under development.
DataView | Under development.
DictionaryEntry | Defines a dictionary key-and-value pair that can be set or retrieved.
Dns | Provides simple domain name resolution functionality.
DockPaddingEdges | Determines the border padding for docked controls.
Encoding | Represents a character encoding.
Environment | Provides information about, and means to manipulate, the current environment and platform.
EventArgs | EventArgs is the base class for classes containing event data.
File | Provides static methods for the creation, copying, deletion, moving, and opening of files, and aids in the creation of FileStream objects.
FileDialog | Displays a dialog window from which the user can select a file. FileDialog is an abstract class, and cannot be instantiated directly.
FileStream | Implements a FileStream that reads and or writes to a file.
FolderBrowserDialog | Represents a common dialog box that allows the user to choose a folder.
Font | Defines a particular format for text, including font face, size, and style attributes.
FontDialog | Represents a common dialog box that displays a list of fonts that are currently installed on the system.
Form | Represents a window or dialog box that makes up an application's user interface.
Graphics | Encapsulates a GDI+ drawing surface.
GridColumnStylesCollection | Represents a collection of DataGridColumnStyle objects in the DataGrid control.
GridTableStylesCollection | Represents a collection of DataGridTableStyle objects in the DataGrid control.
GroupBox | Represents a Windows group box.
HatchBrush | Defines a rectangular brush with a hatch style, a foreground color, and a background color.
Icon | Represents a Windows icon, which is a small bitmap image used to represent an object. Icons can be thought of as transparent bitmaps, although their size is determined by the system.
Image | An abstract base class that provides functionality for Bitmap, Icon and Metafile descended classes.
ImageCollection | Encapsulates the collection of Image objects in an ImageList.
ImageFormat | Specifies the format of the image.
ImageList | Provides methods to manage a collection of Image objects.
InputBox | Displays a prompt in a dialog box, waits for the user to input text or click a button, and then returns a string containing the contents of the text box.
IpAddress | Provides an Internet Protocol (IP) address.
IpHostEntry | Provides a container class for Internet host address information.
ItemCheckEventArgs | Provides data for the ItemCheck event of the CheckedListBox and ListView controls.
KeyEventArgs | Provides data for the KeyDown or KeyUp event.
KeyPressEventArgs | Provides data for the KeyPress event.
Label | Represents a Windows Label control.
LinkClickedEventArgs | Provides data for the LinkClicked event.
ListBox | Represents a Windows list box control.
ListBoxObjectCollection | Represents the collection of items in a ListBox.
ListBoxSelectedIndexCollection | Represents the collection containing the indexes to the selected items in a ListBox.
ListBoxSelectedObjectCollection | Represents the collection of selected items in the ListBox.
ListControl | Provides a common implementation of members for the ListBox and ComboBox classes.
ListItem | Represents a data item in a data-bound list control.
ListView | Represents a Windows ListView Control.
ListViewCheckedItemCollection | Represents the collection of checked items in a list view control.
ListViewColumnHeaderCollection | Represents the collection of column headers in a ListView control.
ListViewItem | Represents an item in a ListView control.
ListViewItemCollection | Represents the collection of items in a ListView control.
ListViewSelectedItemCollection | Represents the collection of selected items in a list view control.
ListViewSubItem | Represents a subitem of a ListViewItem.
ListViewSubItemCollection | Represents a collection of ListViewSubItem objects stored in a ListViewItem.
MainMenu | Represents the menu structure of a form.
Math | Provides constants and static methods for trigonometric, logarithmic, and other common mathematical functions.
MemoryStream | Creates a stream whose backing store is memory.
Menu | Represents the base functionality for all menus.
MenuItem | Represents an individual item that is displayed within a MainMenu or ContextMenu.
MenuItemCollection | Represents a collection of MenuItem objects.
MessageBox | Displays a message box that can contain text, buttons, and symbols that inform and instruct the user.
MouseEventArgs | Provides data for the MouseUp, MouseDown, and MouseMove events.
NetworkStream | Provides the underlying stream of data for network access.
NodeLabelEditEventArgs | Provides data for the BeforeLabelEdit and AfterLabelEdit events.
NotifyIcon | Specifies a component that creates an icon in the status area.
NumericUpDown | Represents a Windows up-down control that displays numeric values.
OpenFileDialog | Represents a common dialog box that displays the control that allows the user to open a file.
PaintEventArgs | Provides data for the Paint event.
Panel | Represents a Windows Panel control.
Pen | Defines an object used to draw lines and curves.
PictureBox | Represents a Windows picture box control for displaying an image.
Point | Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.
Process | Provides access to local and remote processes and enables you to start and stop local system processes.
ProcessStartInfo | Specifies a set of values used when starting a process.
ProgressBar | Represents a Windows progress bar control.
PropertyGrid | Provides a user interface for browsing the properties of an object.
PropertyValueChangedEventArgs | Provides data for the PropertyValueChanged event of a PropertyGrid.
RadioButton | Represents a Windows radio button.
Rectangle | Stores the location and size of a rectangular region.
RichTextBox | Represents a Windows rich text box control.
SaveFileDialog | Represents a common dialog box that allows the user to specify options for saving a file.
Screen | Represents a display device or multiple display devices on a single system.
ScrollableControl | Defines a base class for controls that support auto-scrolling behavior.
ScrollBar | Implements the basic functionality of a scroll bar control.
Size | Represents the size of a rectangular region with an ordered pair of width and height.
SolidBrush | Defines a brush of a single color. Brushes are used to fill graphics shapes, such as rectangles, ellipses, pies, polygons, and paths.
SortedList | Represents a collection of key-and-value pairs that are sorted by the keys and are accessible by key and by index.
Sound | Under Development.
Splitter | Represents a splitter control that allows the user to resize docked controls.
StatusBar | Represents a Windows status bar control.
StatusBarPanel | Represents a panel in a StatusBar control.
StatusBarPanelCollection | Represents the collection of panels in a StatusBar control.
Stream | Provides a generic view of a sequence of bytes.
StreamReader | Implements a TextReader that reads characters from a byte stream in a particular encoding.
StreamWriter | Implements a TextWriter for writing characters to a stream in a particular encoding.
System | Represents the entire system namespace. The System object contains fields, properties and methods that return top-level objects, such as Forms, Files, Processes, Enumerations and so on.
TabControl | Manages a related set of tab pages.
TabPage | Represents a single tab page in a TabControl.
TabPageCollection | Contains a collection of TabPage objects.
TCPClient | Provides the underlying stream of data for network access.
TCPListener | Listens for connections from TCP network clients.
TextBox | Represents a Windows text box control.
TextBoxBase | Implements the basic functionality required by text controls.
TextureBrush | Each property of the TextureBrush class is a Brush object that uses an image to fill the interior of a shape.
Timer | Implements a timer that raises an event at user-defined intervals.
ToolBar | Represents a Windows toolbar.
ToolBarButton | Represents a Windows toolbar button.
ToolBarButtonClickEventArgs | Provides data for the ButtonClick event.
ToolBarButtonCollection | Encapsulates a collection of ToolBarButton controls for use by the ToolBar class.
ToolTip | Represents a small rectangular pop-up window that displays a brief description of a control's purpose when the mouse hovers over the control.
TreeNode | Represents a node of a TreeView.
TreeNodeCollection | Represents a collection of TreeNode objects.
TreeView | Displays a hierarchical collection of labeled items, each represented by a TreeNode.
TreeViewCancelEventArgs | Provides data for the BeforeCheck, BeforeCollapse, BeforeExpand, or BeforeSelect events of a TreeView control.
TreeViewEventArgs | Provides data for the AfterCheck, AfterCollapse, AfterExpand, or AfterSelect events of a TreeView control.
Type |
UpDownBase | Implements the basic functionality required by an up-down control.
UserControl | Experimental. Provides an empty control that can be used to create other controls.
Version | Represents the version number for a common language runtime assembly.
VScrollBar | Represents a standard Windows vertical scroll bar.

Enumerations

Enumeration | Description
AnchorStyles | Specifies how a control anchors to the edges of its container.
Appearance |
BorderStyle |
CharacterCasing |
CheckState |
ColorDepth |
ColumnHeaderStyle |
ComboBoxStyle |
ContentAlignment |
DialogResult |
DockStyle |
FileAccess |
FileMode |
FileShare |
FlatStyle |
FontStyle |
FormBorderStyle |
FormStartPosition |
FormWindowState |
HatchStyle |
HorizontalAlignment |
ItemActivation |
Keys | Specifies key codes and modifiers.
ListViewAlignment | Specifies how items align in the ListView.
MdiLayout |
MenuMerge |
MessageBoxButtons |
MessageBoxIcon |
MouseButtons |
PictureBoxSizeMode |
ProcessWindowStyle |
PropertySort |
RichTextBoxFinds |
RichTextBoxStreamType |
ScrollBars |
SeekOrigin |
SelectionMode | Specifies the selection behavior of a list box.
Shortcut |
SortOrder |
SpecialFolder |
StatusBarPanelAutoSize |
StatusBarPanelBorderStyle |
TabAlignment |
TabAppearance |
TabSizeMode |
ToolBarAppearance |
ToolBarButtonStyle |
ToolBarTextAlign |
TreeViewAction |
View |
XmlReadMode |
XmlWriteMode |


AnchorStyles Enumeration

Specifies how a control anchors to the edges of its container.

[Visual Basic]
Public Enum AnchorStyles
[C#]
public enum AnchorStyles

Members

Member Name | Description
Bottom | The control is anchored to the bottom edge of its container.
Left |
None |
Right |
Top |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Appearance Enumeration

[Visual Basic]
Public Enum Appearance
[C#]
public enum Appearance

Members

Member Name | Description
Button |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Application Class

Provides methods and properties to manage an application, such as methods to start and stop an application, and properties to get information about an application.

For a list of all members of this type, see Application Members.

System.Object
Kixforms.Application

[Visual Basic]
Public Class Application
[C#]
public class Application

Remarks

Use the System.Application method to initialize a new instance of the Application class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Application Members | Kixforms Namespace


Application Members

Application overview

Public Instance Properties

ProductName | Gets the product name associated with this application.
ProductVersion | Gets the product version associated with this application.
UserAppDataPath | Gets the path for the application data of a roaming user.
Version | Gets a Version object that describes the major, minor, build, and revision numbers associated with this application.

Public Instance Methods

DoEvents | Processes all Windows messages currently in the message queue.
EnableVisualStyles | Enables Windows XP visual styles for the application.

See Also

Application Class | Kixforms Namespace


Application Properties

The properties of the Application class are listed below. For a complete list of Application class members, see the Application Members topic.

Public Instance Properties

ProductName | Gets the product name associated with this application.
ProductVersion | Gets the product version associated with this application.
UserAppDataPath | Gets the path for the application data of a roaming user.
Version | Gets a Version object that describes the major, minor, build, and revision numbers associated with this application.

See Also

Application Class | Kixforms Namespace


ProductName Property

KiXforms.NET Class Library

Application.ProductName Property

Gets the product name associated with this application.

[Visual Basic]
Public ReadOnly Property ProductName As String
[C#]
public string ProductName {get;}

See Also

Application Class | Kixforms Namespace


ProductVersion Property

KiXforms.NET Class Library

Application.ProductVersion Property

Gets the product version associated with this application.

[Visual Basic]
Public ReadOnly Property ProductVersion As String
[C#]
public string ProductVersion {get;}

Property Value

The product version. Typically, a version number displays as "major number.minor number.build number.private part number".

See Also

Application Class | Kixforms Namespace


UserAppDataPath Property

KiXforms.NET Class Library

Application.UserAppDataPath Property

Gets the path for the application data of a roaming user.

[Visual Basic]
Public ReadOnly Property UserAppDataPath As String
[C#]
public string UserAppDataPath {get;}

Property Value

The path for the application data of a roaming user.

Remarks

If a path does not exist, one is created in the following format:

Base Path\ CompanyName\ ProductName\ ProductVersion

A roaming user works on more than one computer in a network. The user profile for a roaming user is kept on a server on the network and is loaded onto a system when the user logs on.

See Also

Application Class | Kixforms Namespace


Version Property

KiXforms.NET Class Library

Application.Version Property

Gets a Version object that describes the major, minor, build, and revision numbers associated with this application.

[Visual Basic]
Public ReadOnly Property Version As Version
[C#]
public Version Version {get;}

Property Value

A Version object.

See Also

Application Class | Kixforms Namespace


Application Methods

The methods of the Application class are listed below. For a complete list of Application class members, see the Application Members topic.

Public Instance Methods

DoEvents | Processes all Windows messages currently in the message queue.
EnableVisualStyles | Enables Windows XP visual styles for the application.

See Also

Application Class | Kixforms Namespace


Application.DoEvents Method

Processes all Windows messages currently in the message queue.

[Visual Basic]
Public Function DoEvents( _
Optional ByVal wait As Boolean = True _
) As String
[C#]
public string DoEvents(
bool wait
);

See Also

Application Class | Kixforms Namespace


Application.EnableVisualStyles Method

Enables Windows XP visual styles for the application.

[Visual Basic]
Public Sub EnableVisualStyles()
[C#]
public void EnableVisualStyles();

See Also

Application Class | Kixforms Namespace


ArrayList Class

Represents an array whose size is dynamically increased as required.

For a list of all members of this type, see ArrayList Members.

System.Object
Kixforms.ArrayList

[Visual Basic]
Public Class ArrayList
Implements IEnumerable, IEnumerator
[C#]
public class ArrayList : IEnumerable, IEnumerator

Remarks

Use the System.ArrayList method to create a new instance of the ArrayList class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ArrayList Members | Kixforms Namespace


ArrayList Members

ArrayList overview

Public Instance Properties

Count | Gets the number of elements actually contained in the ArrayList.
Item | Gets or sets the element at the specified index.

Public Instance Methods

Add | Adds an object to the end of the ArrayList.
Clear | Removes all elements from the ArrayList.
GetEnumerator |
IndexOf | Returns the index within the collection of the specified item.
Insert | Inserts an element into the ArrayList at the specified index.
Remove | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt | Removes the element at the specified index of the ArrayList.
Sort |

See Also

ArrayList Class | Kixforms Namespace


ArrayList Properties

The properties of the ArrayList class are listed below. For a complete list of ArrayList class members, see the ArrayList Members topic.

Public Instance Properties

Count | Gets the number of elements actually contained in the ArrayList.
Item | Gets or sets the element at the specified index.

See Also

ArrayList Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

ArrayList.Count Property

Gets the number of elements actually contained in the ArrayList.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer
[C#]
public virtual int Count {get;}

Property Value

The number of elements actually contained in the ArrayList.

See Also

ArrayList Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ArrayList.Item Property

Gets or sets the element at the specified index.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Object
[C#]
public object this[
int index
] {get;}

Parameters

index
The zero-based index of the element to get or set.

See Also

ArrayList Class | Kixforms Namespace


ArrayList Methods

The methods of the ArrayList class are listed below. For a complete list of ArrayList class members, see the ArrayList Members topic.

Public Instance Methods

Add | Adds an object to the end of the ArrayList.
Clear | Removes all elements from the ArrayList.
GetEnumerator |
IndexOf | Returns the index within the collection of the specified item.
Insert | Inserts an element into the ArrayList at the specified index.
Remove | Removes the first occurrence of a specific object from the ArrayList.
RemoveAt | Removes the element at the specified index of the ArrayList.
Sort |

See Also

ArrayList Class | Kixforms Namespace


ArrayList.Add Method

Adds an object to the end of the ArrayList.

[Visual Basic]
Public Function Add( _
ByVal value As Object _
) As Object
[C#]
public object Add(
object value
);

Parameters

value
The object to be added to the end of the ArrayList.

Return Value

The object that was added to the end of the ArrayList.

See Also

ArrayList Class | Kixforms Namespace


ArrayList.Clear Method

Removes all elements from the ArrayList.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

ArrayList Class | Kixforms Namespace


ArrayList.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

ArrayList Class | Kixforms Namespace


ArrayList.IndexOf Method

Returns the index within the collection of the specified item.

[Visual Basic]
Public Function IndexOf( _
ByVal value As Object _
) As Integer
[C#]
public int IndexOf(
object value
);

Parameters

value
An object representing the item to locate in the collection.

Return Value

The zero-based index of the item in the collection; otherwise, -1.

See Also

ArrayList Class | Kixforms Namespace


ArrayList.Insert Method

Inserts an element into the ArrayList at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal Index As Integer, _
ByVal Value As Object _
) As Object
[C#]
public object Insert(
int Index,
object Value
);

Parameters

Index
Value

Return Value

The object that was added.

See Also

ArrayList Class | Kixforms Namespace


ArrayList.Remove Method

Removes the first occurrence of a specific object from the ArrayList.

[Visual Basic]
Public Sub Remove( _
ByVal obj As Object _
)
[C#]
public void Remove(
object obj
);

Parameters

obj
The Object to remove from the ArrayList.

See Also

ArrayList Class | Kixforms Namespace


ArrayList.RemoveAt Method

Removes the element at the specified index of the ArrayList.

[Visual Basic]
Overridable Public Sub RemoveAt( _
ByVal Index As Integer _
)
[C#]
public virtual void RemoveAt(
int Index
);

See Also

ArrayList Class | Kixforms Namespace


ArrayList.Sort Method

[Visual Basic]
Public Sub Sort()
[C#]
public void Sort();

See Also

ArrayList Class | Kixforms Namespace


Bitmap Class

Encapsulates a GDI+ bitmap, which consists of the pixel data for a graphics image and its attributes. A Bitmap object is an object used to work with images defined by pixel data.

For a list of all members of this type, see Bitmap Members.

System.Object
Kixforms.Image
Kixforms.Bitmap

[Visual Basic]
Public Class Bitmap
Inherits Image
[C#]
public class Bitmap : Image

Remarks

Use the System.Bitmap method to initialize a new instance of the Bitmap class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Bitmap Members | Kixforms Namespace


Bitmap Members

Bitmap overview

Public Instance Properties

Height (inherited from Image) | Gets the height of this Image object.
RawFormat (inherited from Image) | Gets the height of this Image object.
Size (inherited from Image) | Gets the width and height of this Image object.
Width (inherited from Image) | Gets the width of this Image object.

Public Instance Methods

Clone | Creates a copy of the section of this Bitmap defined with a specified PixelFormat.
Dispose (inherited from Image) | Releases all resources used by this Image object.
FromBase64String | Converts the specified String representation of a bitmap consisting of base 64 digits to an equivalent bitmap.
FromFile (inherited from Image) | Creates an Image object from the specified file.
FromSize | Creates a Bitmap object with the specified Size.
FromStream (inherited from Image) | Creates an Image object from the specified data stream.
MakeTransparent | Makes the specified color transparent for this Bitmap object.
Save (inherited from Image) | Saves this Image object to the specified file in the specified format.
ToBase64String | Converts the Bitmap to a string consisting of base 64 digits.

See Also

Bitmap Class | Kixforms Namespace


Bitmap Methods

The methods of the Bitmap class are listed below. For a complete list of Bitmap class members, see the Bitmap Members topic.

Public Instance Methods

Clone | Creates a copy of the section of this Bitmap defined with a specified PixelFormat.
Dispose (inherited from Image) | Releases all resources used by this Image object.
FromBase64String | Converts the specified String representation of a bitmap consisting of base 64 digits to an equivalent bitmap.
FromFile (inherited from Image) | Creates an Image object from the specified file.
FromSize | Creates a Bitmap object with the specified Size.
FromStream (inherited from Image) | Creates an Image object from the specified data stream.
MakeTransparent | Makes the specified color transparent for this Bitmap object.
Save (inherited from Image) | Saves this Image object to the specified file in the specified format.
ToBase64String | Converts the Bitmap to a string consisting of base 64 digits.

See Also

Bitmap Class | Kixforms Namespace


Bitmap.Clone Method

Creates a copy of the section of this Bitmap defined with a specified PixelFormat.

[Visual Basic]
Public Function Clone( _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
) As Bitmap
[C#]
public Bitmap Clone(
float x,
float y,
float width,
float height
);

See Also

Bitmap Class | Kixforms Namespace


Bitmap.FromBase64String Method

Converts the specified String representation of a bitmap consisting of base 64 digits to an equivalent bitmap.

[Visual Basic]
Public Function FromBase64String( _
ByVal s As String _
) As Bitmap
[C#]
public Bitmap FromBase64String(
string s
);

Parameters

s
A String.

See Also

Bitmap Class | Kixforms Namespace


Bitmap.FromSize Method

Creates a Bitmap object with the specified Size.

[Visual Basic]
Public Function FromSize( _
ByVal Size As Size _
) As Bitmap
[C#]
public Bitmap FromSize(
Size Size
);

See Also

Bitmap Class | Kixforms Namespace


Bitmap.MakeTransparent Method

Makes the specified color transparent for this Bitmap object.

[Visual Basic]
Public Sub MakeTransparent( _
ByVal transparentColor As Color _
)
[C#]
public void MakeTransparent(
Color transparentColor
);

See Also

Bitmap Class | Kixforms Namespace


Bitmap.ToBase64String Method

Converts the Bitmap to a string consisting of base 64 digits.

[Visual Basic]
Public Function ToBase64String( _
Optional ByVal format As ImageFormat = Nothing _
) As String
[C#]
public string ToBase64String(
ImageFormat format
);

Parameters

format
Optional. The ImageFormat class for this Image object.

Return Value

The base64 string representation of the bitmap.

See Also

Bitmap Class | Kixforms Namespace


BorderStyle Enumeration

[Visual Basic]
Public Enum BorderStyle
[C#]
public enum BorderStyle

Members

Member Name | Description
Fixed3D |
FixedSingle |
None |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Brush Class

Classes derived from this abstract base class define objects used to fill the interiors of graphical shapes such as rectangles, ellipses, pies, polygons, and paths.

System.Object
Kixforms.Brush
Kixforms.HatchBrush
Kixforms.SolidBrush
Kixforms.TextureBrush

[Visual Basic]
Public Class Brush
[C#]
public class Brush

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Button Class

Represents a Windows button control.

For a list of all members of this type, see Button Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ButtonBase
Kixforms.Button

[Visual Basic]
Public Class Button
Inherits ButtonBase
[C#]
public class Button : ButtonBase

Remarks

Use the System.Button method to initialize a new instance of the Button class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Button Members | Kixforms Namespace


Button Members

Button overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Button Class | Kixforms Namespace


Button Properties

The properties of the Button class are listed below. For a complete list of Button class members, see the Button Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DialogResult | Gets or sets a value that is returned to the parent form when the button is clicked.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

Button Class | Kixforms Namespace


DialogResult Property

KiXforms.NET Class Library

Button.DialogResult Property

Gets or sets a value that is returned to the parent form when the button is clicked.

[Visual Basic]
Public Property DialogResult As DialogResult
[C#]
public DialogResult DialogResult {get; set;}

See Also

Button Class | Kixforms Namespace


ButtonBase Class

Implements the basic functionality common to button controls.

For a list of all members of this type, see ButtonBase Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ButtonBase
Kixforms.Button
Kixforms.CheckBox
Kixforms.RadioButton

[Visual Basic]
Public Class ButtonBase
Inherits Control
[C#]
public class ButtonBase : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ButtonBase Members | Kixforms Namespace


ButtonBase Members

ButtonBase overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that is displayed on a button control.
ImageAlign | Gets or sets the alignment of the image on the button control.
ImageIndex | Gets or sets the image list index value of the image displayed on the button control.
ImageList | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ButtonBase Class | Kixforms Namespace


ButtonBase Properties

The properties of the ButtonBase class are listed below. For a complete list of ButtonBase class members, see the ButtonBase Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that is displayed on a button control.
ImageAlign | Gets or sets the alignment of the image on the button control.
ImageIndex | Gets or sets the image list index value of the image displayed on the button control.
ImageList | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ButtonBase Class | Kixforms Namespace


FlatStyle Property

KiXforms.NET Class Library

ButtonBase.FlatStyle Property

Gets or sets the flat style appearance of the button control.

[Visual Basic]
Public Property FlatStyle As FlatStyle
[C#]
public FlatStyle FlatStyle {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


Image Property

KiXforms.NET Class Library

ButtonBase.Image Property

Gets or sets the image that is displayed on a button control.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


ImageAlign Property

KiXforms.NET Class Library

ButtonBase.ImageAlign Property

Gets or sets the alignment of the image on the button control.

[Visual Basic]
Public Property ImageAlign As ContentAlignment
[C#]
public ContentAlignment ImageAlign {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

ButtonBase.ImageIndex Property

Gets or sets the image list index value of the image displayed on the button control.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

ButtonBase.ImageList Property

Gets or sets the ImageList that contains the Image displayed on a button control.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


TextAlign Property

KiXforms.NET Class Library

ButtonBase.TextAlign Property

Gets or sets the alignment of the text on the button control.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign {get; set;}

See Also

ButtonBase Class | Kixforms Namespace


CancelEventArgs Class

Provides data for a cancelable event.

For a list of all members of this type, see CancelEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.CancelEventArgs
Kixforms.TreeViewCancelEventArgs

[Visual Basic]
Public Class CancelEventArgs
Inherits EventArgs
[C#]
public class CancelEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

CancelEventArgs Members | Kixforms Namespace


CancelEventArgs Members

CancelEventArgs overview

Public Instance Properties

Cancel Gets or sets a value indicating whether the event should be canceled.

See Also

CancelEventArgs Class | Kixforms Namespace


CancelEventArgs Properties

The properties of the CancelEventArgs class are listed below. For a complete list of CancelEventArgs class members, see the CancelEventArgs Members topic.

Public Instance Properties

Cancel Gets or sets a value indicating whether the event should be canceled.

See Also

CancelEventArgs Class | Kixforms Namespace


Cancel Property

KiXforms.NET Class Library

CancelEventArgs.Cancel Property

Gets or sets a value indicating whether the event should be canceled.

[Visual Basic]
Public Property Cancel As Boolean
[C#]
public bool Cancel {get; set;}

See Also

CancelEventArgs Class | Kixforms Namespace


CharacterCasing Enumeration

[Visual Basic]
Public Enum CharacterCasing
[C#]
public enum CharacterCasing

Members

Member Name | Description
Lower |
Normal |
Upper |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


CheckBox Class

Represents a Windows check box.

For a list of all members of this type, see CheckBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ButtonBase
Kixforms.CheckBox

[Visual Basic]
Public Class CheckBox
Inherits ButtonBase
[C#]
public class CheckBox : ButtonBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

CheckBox Members | Kixforms Namespace


CheckBox Members

CheckBox overview

Public Instance Constructors

CheckBox Constructor Initializes a new instance of the CheckBox class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the value that determines the appearance of a check box control.
AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckAlign | Gets or sets the horizontal and vertical alignment of a check box on a check box control.
CheckChanged | Gets or sets the code to execute when the value of the Checked property changes.
Checked | Gets or set a value indicating whether the check box is in the checked state.
CheckState | Gets or sets the state of the check box.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

CheckBox Class | Kixforms Namespace


CheckBox Constructor

Initializes a new instance of the CheckBox class.

[Visual Basic]
Public Sub New()
[C#]
public CheckBox();

See Also

CheckBox Class | Kixforms Namespace


CheckBox Properties

The properties of the CheckBox class are listed below. For a complete list of CheckBox class members, see the CheckBox Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the value that determines the appearance of a check box control.
AutoCheck | Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckAlign | Gets or sets the horizontal and vertical alignment of a check box on a check box control.
CheckChanged | Gets or sets the code to execute when the value of the Checked property changes.
Checked | Gets or set a value indicating whether the check box is in the checked state.
CheckState | Gets or sets the state of the check box.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

CheckBox Class | Kixforms Namespace


Appearance Property

KiXforms.NET Class Library

CheckBox.Appearance Property

Gets or sets the value that determines the appearance of a check box control.

[Visual Basic]
Public Property Appearance As Appearance
[C#]
public Appearance Appearance {get; set;}

See Also

CheckBox Class | Kixforms Namespace


AutoCheck Property

KiXforms.NET Class Library

CheckBox.AutoCheck Property

Gets or set a value indicating whether the Checked or CheckState values and the check box's appearance are automatically changed when the check box is clicked.

[Visual Basic]
Public Property AutoCheck As Boolean
[C#]
public bool AutoCheck {get; set;}

See Also

CheckBox Class | Kixforms Namespace


CheckAlign Property

KiXforms.NET Class Library

CheckBox.CheckAlign Property

Gets or sets the horizontal and vertical alignment of a check box on a check box control.

[Visual Basic]
Public Property CheckAlign As ContentAlignment
[C#]
public ContentAlignment CheckAlign {get; set;}

See Also

CheckBox Class | Kixforms Namespace


CheckChanged Property

KiXforms.NET Class Library

CheckBox.CheckChanged Property

Gets or sets the code to execute when the value of the Checked property changes.

[Visual Basic]
Public Property CheckChanged As String
[C#]
public string CheckChanged {get; set;}

See Also

CheckBox Class | Kixforms Namespace


Checked Property

KiXforms.NET Class Library

CheckBox.Checked Property

Gets or set a value indicating whether the check box is in the checked state.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

CheckBox Class | Kixforms Namespace


CheckState Property

KiXforms.NET Class Library

CheckBox.CheckState Property

Gets or sets the state of the check box.

[Visual Basic]
Public Property CheckState As CheckState
[C#]
public CheckState CheckState {get; set;}

See Also

CheckBox Class | Kixforms Namespace


CheckState Enumeration

[Visual Basic]
Public Enum CheckState
[C#]
public enum CheckState

Members

Member Name | Description
Checked |
Indeterminate |
Unchecked |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Collection Class

Represents an ordered set of items that can be referred to as a unit.

For a list of all members of this type, see Collection Members.

System.Object
Kixforms.CollectionBase
Kixforms.Collection

[Visual Basic]
Public Class Collection
Inherits CollectionBase
[C#]
public class Collection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Collection Members | Kixforms Namespace


Collection Members

Collection overview

Public Instance Constructors

Collection Constructor Initializes a new instance of the Collection class.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Retrieves the item at the specified index within the collection.

Public Instance Methods

Add | Adds an item to collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Remove | Removes the specified item from the ComboBox.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

Collection Class | Kixforms Namespace


Collection Constructor

Initializes a new instance of the Collection class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Collection();

See Also

Collection Class | Kixforms Namespace


Collection Properties

The properties of the Collection class are listed below. For a complete list of Collection class members, see the Collection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Retrieves the item at the specified index within the collection.

See Also

Collection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

Collection.Item Property

Retrieves the item at the specified index within the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) _
Implements IList.Item
As Object _
Implements IList.Item
[C#]
new public object this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to retrieve.

Implements

IList.Item

See Also

Collection Class | Kixforms Namespace


Collection Methods

The methods of the Collection class are listed below. For a complete list of Collection class members, see the Collection Members topic.

Public Instance Methods

Add | Adds an item to collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Remove | Removes the specified item from the ComboBox.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

Collection Class | Kixforms Namespace


Collection.Add Method

Adds an item to collection.

[Visual Basic]
Public Function Add( _
ByVal item As Object _
) As Integer _
Implements IList.Add
[C#]
new public int Add(
object item
);

Parameters

item
An object representing the item to add to the collection.

Return Value

The zero-based index of the item in the collection.

Implements

IList.Add

See Also

Collection Class | Kixforms Namespace


Collection.Remove Method

Removes the specified item from the ComboBox.

[Visual Basic]
Public Sub Remove( _
ByVal item As Object _
) _
Implements IList.Remove
[C#]
new public void Remove(
object item
);

Parameters

item
The Object to remove from the list.

Implements

IList.Remove

See Also

Collection Class | Kixforms Namespace


CollectionBase Class

For a list of all members of this type, see CollectionBase Members.

System.Object
Kixforms.CollectionBase
Derived types

[Visual Basic]
Public Class CollectionBase
Implements IList, ICollection, IEnumerable, IEnumerator
[C#]
public class CollectionBase : IList, ICollection, IEnumerable, IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

CollectionBase Members | Kixforms Namespace


CollectionBase Members

CollectionBase overview

Public Instance Properties

Count | Gets the total number of objects in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.

Public Instance Methods

Clear | Removes all objects from the collection.
RemoveAt | Removes an object, at the specified index location, from the collection.

See Also

CollectionBase Class | Kixforms Namespace


CollectionBase Properties

The properties of the CollectionBase class are listed below. For a complete list of CollectionBase class members, see the CollectionBase Members topic.

Public Instance Properties

Count | Gets the total number of objects in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.

See Also

CollectionBase Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

CollectionBase.Count Property

Gets the total number of objects in the collection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public virtual int Count {get;}

Implements

ICollection.Count

See Also

CollectionBase Class | Kixforms Namespace


IsReadOnly Property

KiXforms.NET Class Library

CollectionBase.IsReadOnly Property

Gets a value indicating whether the collection is read-only.

[Visual Basic]
Overridable Public ReadOnly Property IsReadOnly As Boolean _
Implements IList.IsReadOnly
[C#]
public virtual bool IsReadOnly {get;}

Property Value

This property always returns false.

Implements

IList.IsReadOnly

See Also

CollectionBase Class | Kixforms Namespace


CollectionBase Methods

The methods of the CollectionBase class are listed below. For a complete list of CollectionBase class members, see the CollectionBase Members topic.

Public Instance Methods

Clear | Removes all objects from the collection.
RemoveAt | Removes an object, at the specified index location, from the collection.

See Also

CollectionBase Class | Kixforms Namespace


CollectionBase.Clear Method

Removes all objects from the collection.

[Visual Basic]
Overridable Public Sub Clear() _
Implements IList.Clear
[C#]
public virtual void Clear();

Implements

IList.Clear

See Also

CollectionBase Class | Kixforms Namespace


CollectionBase.RemoveAt Method

Removes an object, at the specified index location, from the collection.

[Visual Basic]
Overridable Public Sub RemoveAt( _
ByVal Index As Integer _
) _
Implements IList.RemoveAt
[C#]
public virtual void RemoveAt(
int Index
);

Implements

IList.RemoveAt

See Also

CollectionBase Class | Kixforms Namespace


Color Class

Represents an ARGB color.

For a list of all members of this type, see Color Members.

System.Object
Kixforms.Color

[Visual Basic]
Public Class Color
[C#]
public class Color

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Color Members | Kixforms Namespace


Color Members

Color overview

Public Instance Constructors

Color Constructor Initializes a new instance of the Color class.

Public Instance Properties

A | Gets the alpha component value of this Color structure.
ActiveBorder | A system-defined color.
ActiveCaption | A system-defined color.
ActiveCaptionText | A system-defined color.
AliceBlue | A system-defined color.
AntiqueWhite | A system-defined color.
AppWorkspace | A system-defined color.
Aqua | A system-defined color.
Aquamarine | A system-defined color.
Azure | A system-defined color.
B | Gets the blue component value of this Color structure.
Beige | A system-defined color.
Bisque | A system-defined color.
Black | A system-defined color.
BlanchedAlmond | A system-defined color.
Blue | A system-defined color.
BlueViolet | A system-defined color.
Brown | A system-defined color.
BurlyWood | A system-defined color.
CadetBlue | A system-defined color.
Chartreuse | A system-defined color.
Chocolate | A system-defined color.
Control | A system-defined color.
ControlDark | A system-defined color.
ControlDarkDark | A system-defined color.
ControlLight | A system-defined color.
ControlLightLight | A system-defined color.
ControlText | A system-defined color.
Coral | A system-defined color.
CornflowerBlue | [To be supplied.]
Cornsilk | A system-defined color.
Crimson | A system-defined color.
Cyan | A system-defined color.
DarkBlue | A system-defined color.
DarkCyan | A system-defined color.
DarkGoldenrod | A system-defined color.
DarkGray | A system-defined color.
DarkGreen | A system-defined color.
DarkKhaki | A system-defined color.
DarkMagenta | A system-defined color.
DarkOliveGreen | A system-defined color.
DarkOrange | A system-defined color.
DarkOrchid | A system-defined color.
DarkRed | A system-defined color.
DarkSalmon | A system-defined color.
DarkSeaGreen | A system-defined color.
DarkSlateBlue | A system-defined color.
DarkSlateGray | A system-defined color.
DarkTurquoise | A system-defined color.
DarkViolet | A system-defined color.
DeepPink | A system-defined color.
DeepSkyBlue | A system-defined color.
Desktop | A system-defined color.
DimGray | A system-defined color.
DodgerBlue | A system-defined color.
Firebrick | A system-defined color.
FloralWhite | A system-defined color.
ForestGreen | A system-defined color.
Fuchsia | A system-defined color.
G | Gets the green component value of this Color structure.
Gainsboro | A system-defined color.
GhostWhite | A system-defined color.
Gold | A system-defined color.
Goldenrod | A system-defined color.
Gray | A system-defined color.
GrayText | A system-defined color.
Green | A system-defined color.
GreenYellow | A system-defined color.
Highlight | A system-defined color.
HighlightText | A system-defined color.
Honeydew | A system-defined color.
HotPink | A system-defined color.
HotTrack | A system-defined color.
InactiveBorder | A system-defined color.
InactiveCaption | A system-defined color.
InactiveCaptionText | A system-defined color.
IndianRed | A system-defined color.
Indigo | A system-defined color.
Info | A system-defined color.
InfoText | A system-defined color.
IsEmpty | Specifies whether this Color structure is uninitialized.
Ivory | A system-defined color.
Khaki | A system-defined color.
Lavender | A system-defined color.
LavenderBlush | A system-defined color.
LawnGreen | A system-defined color.
LemonChiffon | A system-defined color.
LightBlue | A system-defined color.
LightCoral | A system-defined color.
LightCyan | A system-defined color.
LightGoldenrodYellow | A system-defined color.
LightGray | A system-defined color.
LightGreen | A system-defined color.
LightPink | A system-defined color.
LightSalmon | A system-defined color.
LightSeaGreen | A system-defined color.
LightSkyBlue | A system-defined color.
LightSlateGray | A system-defined color.
LightSteelBlue | A system-defined color.
LightYellow | A system-defined color.
Lime | A system-defined color.
LimeGreen | A system-defined color.
Linen | A system-defined color.
Magenta | A system-defined color.
Maroon | A system-defined color.
MediumAquamarine | A system-defined color.
MediumBlue | A system-defined color.
MediumOrchid | A system-defined color.
MediumPurple | A system-defined color.
MediumSeaGreen | A system-defined color.
MediumSlateBlue | A system-defined color.
MediumSpringGreen | A system-defined color.
MediumTurquoise | A system-defined color.
MediumVioletRed | A system-defined color.
Menu | A system-defined color.
MenuText | A system-defined color.
MidnightBlue | A system-defined color.
MintCream | A system-defined color.
MistyRose | A system-defined color.
Moccasin | A system-defined color.
Name | Gets the name of this Color Name. This will either return the user-defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.
NavajoWhite | A system-defined color.
Navy | A system-defined color.
OldLace | A system-defined color.
Olive | A system-defined color.
OliveDrab | A system-defined color.
Orange | A system-defined color.
OrangeRed | A system-defined color.
Orchid | A system-defined color.
PaleGoldenrod | A system-defined color.
PaleGreen | A system-defined color.
PaleTurquoise | A system-defined color.
PaleVioletRed | A system-defined color.
PapayaWhip | A system-defined color.
PeachPuff | A system-defined color.
Peru | A system-defined color.
Pink | A system-defined color.
Plum | A system-defined color.
PowderBlue | A system-defined color.
Purple | A system-defined color.
R | Gets the red component value of this Color structure.
Red | A system-defined color.
RosyBrown | A system-defined color.
RoyalBlue | A system-defined color.
SaddleBrown | A system-defined color.
Salmon | A system-defined color.
SandyBrown | A system-defined color.
ScrollBar | A system-defined color.
SeaGreen | A system-defined color.
SeaShell | A system-defined color.
Sienna | A system-defined color.
Silver | A system-defined color.
SkyBlue | A system-defined color.
SlateBlue | A system-defined color.
SlateGray | A system-defined color.
Snow | A system-defined color.
SpringGreen | A system-defined color.
SteelBlue | A system-defined color.
Tan | A system-defined color.
Teal | A system-defined color.
Thistle | A system-defined color.
Tomato | A system-defined color.
Transparent | A system-defined color.
Turquoise | A system-defined color.
Violet | A system-defined color.
Wheat | A system-defined color.
White | A system-defined color.
WhiteSmoke | A system-defined color.
Window | A system-defined color.
WindowFrame | A system-defined color.
WindowText | A system-defined color.
Yellow | A system-defined color.
YellowGreen | A system-defined color.

Public Instance Methods

FromArgb | Creates a Color structure from the four 8-bit ARGB component (alpha, red, green, and blue) values.
FromName | Creates a Color structure from the specified name of a pre-defined color.
FromRgb | Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (fully opaque).
ToArgb | Gets the 32-bit ARGB value of this Color structure.

See Also

Color Class | Kixforms Namespace


Color Constructor

Initializes a new instance of the Color class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Color();

See Also

Color Class | Kixforms Namespace


Color Properties

The properties of the Color class are listed below. For a complete list of Color class members, see the Color Members topic.

Public Instance Properties

A | Gets the alpha component value of this Color structure.
ActiveBorder | A system-defined color.
ActiveCaption | A system-defined color.
ActiveCaptionText | A system-defined color.
AliceBlue | A system-defined color.
AntiqueWhite | A system-defined color.
AppWorkspace | A system-defined color.
Aqua | A system-defined color.
Aquamarine | A system-defined color.
Azure | A system-defined color.
B | Gets the blue component value of this Color structure.
Beige | A system-defined color.
Bisque | A system-defined color.
Black | A system-defined color.
BlanchedAlmond | A system-defined color.
Blue | A system-defined color.
BlueViolet | A system-defined color.
Brown | A system-defined color.
BurlyWood | A system-defined color.
CadetBlue | A system-defined color.
Chartreuse | A system-defined color.
Chocolate | A system-defined color.
Control | A system-defined color.
ControlDark | A system-defined color.
ControlDarkDark | A system-defined color.
ControlLight | A system-defined color.
ControlLightLight | A system-defined color.
ControlText | A system-defined color.
Coral | A system-defined color.
CornflowerBlue | [To be supplied.]
Cornsilk | A system-defined color.
Crimson | A system-defined color.
Cyan | A system-defined color.
DarkBlue | A system-defined color.
DarkCyan | A system-defined color.
DarkGoldenrod | A system-defined color.
DarkGray | A system-defined color.
DarkGreen | A system-defined color.
DarkKhaki | A system-defined color.
DarkMagenta | A system-defined color.
DarkOliveGreen | A system-defined color.
DarkOrange | A system-defined color.
DarkOrchid | A system-defined color.
DarkRed | A system-defined color.
DarkSalmon | A system-defined color.
DarkSeaGreen | A system-defined color.
DarkSlateBlue | A system-defined color.
DarkSlateGray | A system-defined color.
DarkTurquoise | A system-defined color.
DarkViolet | A system-defined color.
DeepPink | A system-defined color.
DeepSkyBlue | A system-defined color.
Desktop | A system-defined color.
DimGray | A system-defined color.
DodgerBlue | A system-defined color.
Firebrick | A system-defined color.
FloralWhite | A system-defined color.
ForestGreen | A system-defined color.
Fuchsia | A system-defined color.
G | Gets the green component value of this Color structure.
Gainsboro | A system-defined color.
GhostWhite | A system-defined color.
Gold | A system-defined color.
Goldenrod | A system-defined color.
Gray | A system-defined color.
GrayText | A system-defined color.
Green | A system-defined color.
GreenYellow | A system-defined color.
Highlight | A system-defined color.
HighlightText | A system-defined color.
Honeydew | A system-defined color.
HotPink | A system-defined color.
HotTrack | A system-defined color.
InactiveBorder | A system-defined color.
InactiveCaption | A system-defined color.
InactiveCaptionText | A system-defined color.
IndianRed | A system-defined color.
Indigo | A system-defined color.
Info | A system-defined color.
InfoText | A system-defined color.
IsEmpty | Specifies whether this Color structure is uninitialized.
Ivory | A system-defined color.
Khaki | A system-defined color.
Lavender | A system-defined color.
LavenderBlush | A system-defined color.
LawnGreen | A system-defined color.
LemonChiffon | A system-defined color.
LightBlue | A system-defined color.
LightCoral | A system-defined color.
LightCyan | A system-defined color.
LightGoldenrodYellow | A system-defined color.
LightGray | A system-defined color.
LightGreen | A system-defined color.
LightPink | A system-defined color.
LightSalmon | A system-defined color.
LightSeaGreen | A system-defined color.
LightSkyBlue | A system-defined color.
LightSlateGray | A system-defined color.
LightSteelBlue | A system-defined color.
LightYellow | A system-defined color.
Lime | A system-defined color.
LimeGreen | A system-defined color.
Linen | A system-defined color.
Magenta | A system-defined color.
Maroon | A system-defined color.
MediumAquamarine | A system-defined color.
MediumBlue | A system-defined color.
MediumOrchid | A system-defined color.
MediumPurple | A system-defined color.
MediumSeaGreen | A system-defined color.
MediumSlateBlue | A system-defined color.
MediumSpringGreen | A system-defined color.
MediumTurquoise | A system-defined color.
MediumVioletRed | A system-defined color.
Menu | A system-defined color.
MenuText | A system-defined color.
MidnightBlue | A system-defined color.
MintCream | A system-defined color.
MistyRose | A system-defined color.
Moccasin | A system-defined color.
Name | Gets the name of this Color Name. This will either return the user-defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.
NavajoWhite | A system-defined color.
Navy | A system-defined color.
OldLace | A system-defined color.
Olive | A system-defined color.
OliveDrab | A system-defined color.
Orange | A system-defined color.
OrangeRed | A system-defined color.
Orchid | A system-defined color.
PaleGoldenrod | A system-defined color.
PaleGreen | A system-defined color.
PaleTurquoise | A system-defined color.
PaleVioletRed | A system-defined color.
PapayaWhip | A system-defined color.
PeachPuff | A system-defined color.
Peru | A system-defined color.
Pink | A system-defined color.
Plum | A system-defined color.
PowderBlue | A system-defined color.
Purple | A system-defined color.
R | Gets the red component value of this Color structure.
Red | A system-defined color.
RosyBrown | A system-defined color.
RoyalBlue | A system-defined color.
SaddleBrown | A system-defined color.
Salmon | A system-defined color.
SandyBrown | A system-defined color.
ScrollBar | A system-defined color.
SeaGreen | A system-defined color.
SeaShell | A system-defined color.
Sienna | A system-defined color.
Silver | A system-defined color.
SkyBlue | A system-defined color.
SlateBlue | A system-defined color.
SlateGray | A system-defined color.
Snow | A system-defined color.
SpringGreen | A system-defined color.
SteelBlue | A system-defined color.
Tan | A system-defined color.
Teal | A system-defined color.
Thistle | A system-defined color.
Tomato | A system-defined color.
Transparent | A system-defined color.
Turquoise | A system-defined color.
Violet | A system-defined color.
Wheat | A system-defined color.
White | A system-defined color.
WhiteSmoke | A system-defined color.
Window | A system-defined color.
WindowFrame | A system-defined color.
WindowText | A system-defined color.
Yellow | A system-defined color.
YellowGreen | A system-defined color.

See Also

Color Class | Kixforms Namespace


A Property

KiXforms.NET Class Library

Color.A Property

Gets the alpha component value of this Color structure.

[Visual Basic]
Public ReadOnly Property A As Integer
[C#]
public int A {get;}

See Also

Color Class | Kixforms Namespace


ActiveBorder Property

KiXforms.NET Class Library

Color.ActiveBorder Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ActiveBorder As Color
[C#]
public Color ActiveBorder {get;}

See Also

Color Class | Kixforms Namespace


ActiveCaption Property

KiXforms.NET Class Library

Color.ActiveCaption Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ActiveCaption As Color
[C#]
public Color ActiveCaption {get;}

See Also

Color Class | Kixforms Namespace


ActiveCaptionText Property

KiXforms.NET Class Library

Color.ActiveCaptionText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ActiveCaptionText As Color
[C#]
public Color ActiveCaptionText {get;}

See Also

Color Class | Kixforms Namespace


AliceBlue Property

KiXforms.NET Class Library

Color.AliceBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property AliceBlue As Color
[C#]
public Color AliceBlue {get;}

See Also

Color Class | Kixforms Namespace


AntiqueWhite Property

KiXforms.NET Class Library

Color.AntiqueWhite Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property AntiqueWhite As Color
[C#]
public Color AntiqueWhite {get;}

See Also

Color Class | Kixforms Namespace


AppWorkspace Property

KiXforms.NET Class Library

Color.AppWorkspace Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property AppWorkspace As Color
[C#]
public Color AppWorkspace {get;}

See Also

Color Class | Kixforms Namespace


Aqua Property

KiXforms.NET Class Library

Color.Aqua Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Aqua As Color
[C#]
public Color Aqua {get;}

See Also

Color Class | Kixforms Namespace


Aquamarine Property

KiXforms.NET Class Library

Color.Aquamarine Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Aquamarine As Color
[C#]
public Color Aquamarine {get;}

See Also

Color Class | Kixforms Namespace


Azure Property

KiXforms.NET Class Library

Color.Azure Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Azure As Color
[C#]
public Color Azure {get;}

See Also

Color Class | Kixforms Namespace


B Property

KiXforms.NET Class Library

Color.B Property

Gets the blue component value of this Color structure.

[Visual Basic]
Public ReadOnly Property B As Integer
[C#]
public int B {get;}

See Also

Color Class | Kixforms Namespace


Beige Property

KiXforms.NET Class Library

Color.Beige Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Beige As Color
[C#]
public Color Beige {get;}

See Also

Color Class | Kixforms Namespace


Bisque Property

KiXforms.NET Class Library

Color.Bisque Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Bisque As Color
[C#]
public Color Bisque {get;}

See Also

Color Class | Kixforms Namespace


Black Property

KiXforms.NET Class Library

Color.Black Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Black As Color
[C#]
public Color Black {get;}

See Also

Color Class | Kixforms Namespace


BlanchedAlmond Property

KiXforms.NET Class Library

Color.BlanchedAlmond Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property BlanchedAlmond As Color
[C#]
public Color BlanchedAlmond {get;}

See Also

Color Class | Kixforms Namespace


Blue Property

KiXforms.NET Class Library

Color.Blue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Blue As Color
[C#]
public Color Blue {get;}

See Also

Color Class | Kixforms Namespace


BlueViolet Property

KiXforms.NET Class Library

Color.BlueViolet Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property BlueViolet As Color
[C#]
public Color BlueViolet {get;}

See Also

Color Class | Kixforms Namespace


Brown Property

KiXforms.NET Class Library

Color.Brown Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Brown As Color
[C#]
public Color Brown {get;}

See Also

Color Class | Kixforms Namespace


BurlyWood Property

KiXforms.NET Class Library

Color.BurlyWood Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property BurlyWood As Color
[C#]
public Color BurlyWood {get;}

See Also

Color Class | Kixforms Namespace


CadetBlue Property

KiXforms.NET Class Library

Color.CadetBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property CadetBlue As Color
[C#]
public Color CadetBlue {get;}

See Also

Color Class | Kixforms Namespace


Chartreuse Property

KiXforms.NET Class Library

Color.Chartreuse Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Chartreuse As Color
[C#]
public Color Chartreuse {get;}

See Also

Color Class | Kixforms Namespace


Chocolate Property

KiXforms.NET Class Library

Color.Chocolate Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Chocolate As Color
[C#]
public Color Chocolate {get;}

See Also

Color Class | Kixforms Namespace


Control Property

KiXforms.NET Class Library

Color.Control Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Control As Color
[C#]
public Color Control {get;}

See Also

Color Class | Kixforms Namespace


ControlDark Property

KiXforms.NET Class Library

Color.ControlDark Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ControlDark As Color
[C#]
public Color ControlDark {get;}

See Also

Color Class | Kixforms Namespace


ControlDarkDark Property

KiXforms.NET Class Library

Color.ControlDarkDark Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ControlDarkDark As Color
[C#]
public Color ControlDarkDark {get;}

See Also

Color Class | Kixforms Namespace


ControlLight Property

KiXforms.NET Class Library

Color.ControlLight Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ControlLight As Color
[C#]
public Color ControlLight {get;}

See Also

Color Class | Kixforms Namespace


ControlLightLight Property

KiXforms.NET Class Library

Color.ControlLightLight Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ControlLightLight As Color
[C#]
public Color ControlLightLight {get;}

See Also

Color Class | Kixforms Namespace


ControlText Property

KiXforms.NET Class Library

Color.ControlText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ControlText As Color
[C#]
public Color ControlText {get;}

See Also

Color Class | Kixforms Namespace


Coral Property

KiXforms.NET Class Library

Color.Coral Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Coral As Color
[C#]
public Color Coral {get;}

See Also

Color Class | Kixforms Namespace


CornflowerBlue Property

KiXforms.NET Class Library

Color.CornflowerBlue Property

[To be supplied.]

[Visual Basic]
Public ReadOnly Property CornflowerBlue As Color
[C#]
public Color CornflowerBlue {get;}

See Also

Color Class | Kixforms Namespace


Cornsilk Property

KiXforms.NET Class Library

Color.Cornsilk Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Cornsilk As Color
[C#]
public Color Cornsilk {get;}

See Also

Color Class | Kixforms Namespace


Crimson Property

KiXforms.NET Class Library

Color.Crimson Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Crimson As Color
[C#]
public Color Crimson {get;}

See Also

Color Class | Kixforms Namespace


Cyan Property

KiXforms.NET Class Library

Color.Cyan Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Cyan As Color
[C#]
public Color Cyan {get;}

See Also

Color Class | Kixforms Namespace


DarkBlue Property

KiXforms.NET Class Library

Color.DarkBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkBlue As Color
[C#]
public Color DarkBlue {get;}

See Also

Color Class | Kixforms Namespace


DarkCyan Property

KiXforms.NET Class Library

Color.DarkCyan Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkCyan As Color
[C#]
public Color DarkCyan {get;}

See Also

Color Class | Kixforms Namespace


DarkGoldenrod Property

KiXforms.NET Class Library

Color.DarkGoldenrod Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkGoldenrod As Color
[C#]
public Color DarkGoldenrod {get;}

See Also

Color Class | Kixforms Namespace


DarkGray Property

KiXforms.NET Class Library

Color.DarkGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkGray As Color
[C#]
public Color DarkGray {get;}

See Also

Color Class | Kixforms Namespace


DarkGreen Property

KiXforms.NET Class Library

Color.DarkGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkGreen As Color
[C#]
public Color DarkGreen {get;}

See Also

Color Class | Kixforms Namespace


DarkKhaki Property

KiXforms.NET Class Library

Color.DarkKhaki Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkKhaki As Color
[C#]
public Color DarkKhaki {get;}

See Also

Color Class | Kixforms Namespace


DarkMagenta Property

KiXforms.NET Class Library

Color.DarkMagenta Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkMagenta As Color
[C#]
public Color DarkMagenta {get;}

See Also

Color Class | Kixforms Namespace


DarkOliveGreen Property

KiXforms.NET Class Library

Color.DarkOliveGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkOliveGreen As Color
[C#]
public Color DarkOliveGreen {get;}

See Also

Color Class | Kixforms Namespace


DarkOrange Property

KiXforms.NET Class Library

Color.DarkOrange Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkOrange As Color
[C#]
public Color DarkOrange {get;}

See Also

Color Class | Kixforms Namespace


DarkOrchid Property

KiXforms.NET Class Library

Color.DarkOrchid Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkOrchid As Color
[C#]
public Color DarkOrchid {get;}

See Also

Color Class | Kixforms Namespace


DarkRed Property

KiXforms.NET Class Library

Color.DarkRed Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkRed As Color
[C#]
public Color DarkRed {get;}

See Also

Color Class | Kixforms Namespace


DarkSalmon Property

KiXforms.NET Class Library

Color.DarkSalmon Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkSalmon As Color
[C#]
public Color DarkSalmon {get;}

See Also

Color Class | Kixforms Namespace


DarkSeaGreen Property

KiXforms.NET Class Library

Color.DarkSeaGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkSeaGreen As Color
[C#]
public Color DarkSeaGreen {get;}

See Also

Color Class | Kixforms Namespace


DarkSlateBlue Property

KiXforms.NET Class Library

Color.DarkSlateBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkSlateBlue As Color
[C#]
public Color DarkSlateBlue {get;}

See Also

Color Class | Kixforms Namespace


DarkSlateGray Property

KiXforms.NET Class Library

Color.DarkSlateGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkSlateGray As Color
[C#]
public Color DarkSlateGray {get;}

See Also

Color Class | Kixforms Namespace


DarkTurquoise Property

KiXforms.NET Class Library

Color.DarkTurquoise Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkTurquoise As Color
[C#]
public Color DarkTurquoise {get;}

See Also

Color Class | Kixforms Namespace


DarkViolet Property

KiXforms.NET Class Library

Color.DarkViolet Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DarkViolet As Color
[C#]
public Color DarkViolet {get;}

See Also

Color Class | Kixforms Namespace


DeepPink Property

KiXforms.NET Class Library

Color.DeepPink Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DeepPink As Color
[C#]
public Color DeepPink {get;}

See Also

Color Class | Kixforms Namespace


DeepSkyBlue Property

KiXforms.NET Class Library

Color.DeepSkyBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DeepSkyBlue As Color
[C#]
public Color DeepSkyBlue {get;}

See Also

Color Class | Kixforms Namespace


Desktop Property

KiXforms.NET Class Library

Color.Desktop Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Desktop As Color
[C#]
public Color Desktop {get;}

See Also

Color Class | Kixforms Namespace


DimGray Property

KiXforms.NET Class Library

Color.DimGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DimGray As Color
[C#]
public Color DimGray {get;}

See Also

Color Class | Kixforms Namespace


DodgerBlue Property

KiXforms.NET Class Library

Color.DodgerBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property DodgerBlue As Color
[C#]
public Color DodgerBlue {get;}

See Also

Color Class | Kixforms Namespace


Firebrick Property

KiXforms.NET Class Library

Color.Firebrick Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Firebrick As Color
[C#]
public Color Firebrick {get;}

See Also

Color Class | Kixforms Namespace


FloralWhite Property

KiXforms.NET Class Library

Color.FloralWhite Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property FloralWhite As Color
[C#]
public Color FloralWhite {get;}

See Also

Color Class | Kixforms Namespace


ForestGreen Property

KiXforms.NET Class Library

Color.ForestGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ForestGreen As Color
[C#]
public Color ForestGreen {get;}

See Also

Color Class | Kixforms Namespace


Fuchsia Property

KiXforms.NET Class Library

Color.Fuchsia Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Fuchsia As Color
[C#]
public Color Fuchsia {get;}

See Also

Color Class | Kixforms Namespace


G Property

KiXforms.NET Class Library

Color.G Property

Gets the green component value of this Color structure.

[Visual Basic]
Public ReadOnly Property G As Integer
[C#]
public int G {get;}

See Also

Color Class | Kixforms Namespace


Gainsboro Property

KiXforms.NET Class Library

Color.Gainsboro Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Gainsboro As Color
[C#]
public Color Gainsboro {get;}

See Also

Color Class | Kixforms Namespace


GhostWhite Property

KiXforms.NET Class Library

Color.GhostWhite Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property GhostWhite As Color
[C#]
public Color GhostWhite {get;}

See Also

Color Class | Kixforms Namespace


Gold Property

KiXforms.NET Class Library

Color.Gold Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Gold As Color
[C#]
public Color Gold {get;}

See Also

Color Class | Kixforms Namespace


Goldenrod Property

KiXforms.NET Class Library

Color.Goldenrod Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Goldenrod As Color
[C#]
public Color Goldenrod {get;}

See Also

Color Class | Kixforms Namespace


Gray Property

KiXforms.NET Class Library

Color.Gray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Gray As Color
[C#]
public Color Gray {get;}

See Also

Color Class | Kixforms Namespace


GrayText Property

KiXforms.NET Class Library

Color.GrayText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property GrayText As Color
[C#]
public Color GrayText {get;}

See Also

Color Class | Kixforms Namespace


Green Property

KiXforms.NET Class Library

Color.Green Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Green As Color
[C#]
public Color Green {get;}

See Also

Color Class | Kixforms Namespace


GreenYellow Property

KiXforms.NET Class Library

Color.GreenYellow Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property GreenYellow As Color
[C#]
public Color GreenYellow {get;}

See Also

Color Class | Kixforms Namespace


Highlight Property

KiXforms.NET Class Library

Color.Highlight Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Highlight As Color
[C#]
public Color Highlight {get;}

See Also

Color Class | Kixforms Namespace


HighlightText Property

KiXforms.NET Class Library

Color.HighlightText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property HighlightText As Color
[C#]
public Color HighlightText {get;}

See Also

Color Class | Kixforms Namespace


Honeydew Property

KiXforms.NET Class Library

Color.Honeydew Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Honeydew As Color
[C#]
public Color Honeydew {get;}

See Also

Color Class | Kixforms Namespace


HotPink Property

KiXforms.NET Class Library

Color.HotPink Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property HotPink As Color
[C#]
public Color HotPink {get;}

See Also

Color Class | Kixforms Namespace


HotTrack Property

KiXforms.NET Class Library

Color.HotTrack Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property HotTrack As Color
[C#]
public Color HotTrack {get;}

See Also

Color Class | Kixforms Namespace


InactiveBorder Property

KiXforms.NET Class Library

Color.InactiveBorder Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property InactiveBorder As Color
[C#]
public Color InactiveBorder {get;}

See Also

Color Class | Kixforms Namespace


InactiveCaption Property

KiXforms.NET Class Library

Color.InactiveCaption Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property InactiveCaption As Color
[C#]
public Color InactiveCaption {get;}

See Also

Color Class | Kixforms Namespace


InactiveCaptionText Property

KiXforms.NET Class Library

Color.InactiveCaptionText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property InactiveCaptionText As Color
[C#]
public Color InactiveCaptionText {get;}

See Also

Color Class | Kixforms Namespace


IndianRed Property

KiXforms.NET Class Library

Color.IndianRed Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property IndianRed As Color
[C#]
public Color IndianRed {get;}

See Also

Color Class | Kixforms Namespace


Indigo Property

KiXforms.NET Class Library

Color.Indigo Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Indigo As Color
[C#]
public Color Indigo {get;}

See Also

Color Class | Kixforms Namespace


Info Property

KiXforms.NET Class Library

Color.Info Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Info As Color
[C#]
public Color Info {get;}

See Also

Color Class | Kixforms Namespace


InfoText Property

KiXforms.NET Class Library

Color.InfoText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property InfoText As Color
[C#]
public Color InfoText {get;}

See Also

Color Class | Kixforms Namespace


IsEmpty Property

KiXforms.NET Class Library

Color.IsEmpty Property

Specifies whether this Color structure is uninitialized.

[Visual Basic]
Public ReadOnly Property IsEmpty As Boolean
[C#]
public bool IsEmpty {get;}

See Also

Color Class | Kixforms Namespace


Ivory Property

KiXforms.NET Class Library

Color.Ivory Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Ivory As Color
[C#]
public Color Ivory {get;}

See Also

Color Class | Kixforms Namespace


Khaki Property

KiXforms.NET Class Library

Color.Khaki Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Khaki As Color
[C#]
public Color Khaki {get;}

See Also

Color Class | Kixforms Namespace


Lavender Property

KiXforms.NET Class Library

Color.Lavender Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Lavender As Color
[C#]
public Color Lavender {get;}

See Also

Color Class | Kixforms Namespace


LavenderBlush Property

KiXforms.NET Class Library

Color.LavenderBlush Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LavenderBlush As Color
[C#]
public Color LavenderBlush {get;}

See Also

Color Class | Kixforms Namespace


LawnGreen Property

KiXforms.NET Class Library

Color.LawnGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LawnGreen As Color
[C#]
public Color LawnGreen {get;}

See Also

Color Class | Kixforms Namespace


LemonChiffon Property

KiXforms.NET Class Library

Color.LemonChiffon Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LemonChiffon As Color
[C#]
public Color LemonChiffon {get;}

See Also

Color Class | Kixforms Namespace


LightBlue Property

KiXforms.NET Class Library

Color.LightBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightBlue As Color
[C#]
public Color LightBlue {get;}

See Also

Color Class | Kixforms Namespace


LightCoral Property

KiXforms.NET Class Library

Color.LightCoral Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightCoral As Color
[C#]
public Color LightCoral {get;}

See Also

Color Class | Kixforms Namespace


LightCyan Property

KiXforms.NET Class Library

Color.LightCyan Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightCyan As Color
[C#]
public Color LightCyan {get;}

See Also

Color Class | Kixforms Namespace


LightGoldenrodYellow Property

KiXforms.NET Class Library

Color.LightGoldenrodYellow Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightGoldenrodYellow As Color
[C#]
public Color LightGoldenrodYellow {get;}

See Also

Color Class | Kixforms Namespace


LightGray Property

KiXforms.NET Class Library

Color.LightGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightGray As Color
[C#]
public Color LightGray {get;}

See Also

Color Class | Kixforms Namespace


LightGreen Property

KiXforms.NET Class Library

Color.LightGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightGreen As Color
[C#]
public Color LightGreen {get;}

See Also

Color Class | Kixforms Namespace


LightPink Property

KiXforms.NET Class Library

Color.LightPink Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightPink As Color
[C#]
public Color LightPink {get;}

See Also

Color Class | Kixforms Namespace


LightSalmon Property

KiXforms.NET Class Library

Color.LightSalmon Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightSalmon As Color
[C#]
public Color LightSalmon {get;}

See Also

Color Class | Kixforms Namespace


LightSeaGreen Property

KiXforms.NET Class Library

Color.LightSeaGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightSeaGreen As Color
[C#]
public Color LightSeaGreen {get;}

See Also

Color Class | Kixforms Namespace


LightSkyBlue Property

KiXforms.NET Class Library

Color.LightSkyBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightSkyBlue As Color
[C#]
public Color LightSkyBlue {get;}

See Also

Color Class | Kixforms Namespace


LightSlateGray Property

KiXforms.NET Class Library

Color.LightSlateGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightSlateGray As Color
[C#]
public Color LightSlateGray {get;}

See Also

Color Class | Kixforms Namespace


LightSteelBlue Property

KiXforms.NET Class Library

Color.LightSteelBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightSteelBlue As Color
[C#]
public Color LightSteelBlue {get;}

See Also

Color Class | Kixforms Namespace


LightYellow Property

KiXforms.NET Class Library

Color.LightYellow Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LightYellow As Color
[C#]
public Color LightYellow {get;}

See Also

Color Class | Kixforms Namespace


Lime Property

KiXforms.NET Class Library

Color.Lime Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Lime As Color
[C#]
public Color Lime {get;}

See Also

Color Class | Kixforms Namespace


LimeGreen Property

KiXforms.NET Class Library

Color.LimeGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property LimeGreen As Color
[C#]
public Color LimeGreen {get;}

See Also

Color Class | Kixforms Namespace


Linen Property

KiXforms.NET Class Library

Color.Linen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Linen As Color
[C#]
public Color Linen {get;}

See Also

Color Class | Kixforms Namespace


Magenta Property

KiXforms.NET Class Library

Color.Magenta Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Magenta As Color
[C#]
public Color Magenta {get;}

See Also

Color Class | Kixforms Namespace


Maroon Property

KiXforms.NET Class Library

Color.Maroon Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Maroon As Color
[C#]
public Color Maroon {get;}

See Also

Color Class | Kixforms Namespace


MediumAquamarine Property

KiXforms.NET Class Library

Color.MediumAquamarine Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumAquamarine As Color
[C#]
public Color MediumAquamarine {get;}

See Also

Color Class | Kixforms Namespace


MediumBlue Property

KiXforms.NET Class Library

Color.MediumBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumBlue As Color
[C#]
public Color MediumBlue {get;}

See Also

Color Class | Kixforms Namespace


MediumOrchid Property

KiXforms.NET Class Library

Color.MediumOrchid Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumOrchid As Color
[C#]
public Color MediumOrchid {get;}

See Also

Color Class | Kixforms Namespace


MediumPurple Property

KiXforms.NET Class Library

Color.MediumPurple Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumPurple As Color
[C#]
public Color MediumPurple {get;}

See Also

Color Class | Kixforms Namespace


MediumSeaGreen Property

KiXforms.NET Class Library

Color.MediumSeaGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumSeaGreen As Color
[C#]
public Color MediumSeaGreen {get;}

See Also

Color Class | Kixforms Namespace


MediumSlateBlue Property

KiXforms.NET Class Library

Color.MediumSlateBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumSlateBlue As Color
[C#]
public Color MediumSlateBlue {get;}

See Also

Color Class | Kixforms Namespace


MediumSpringGreen Property

KiXforms.NET Class Library

Color.MediumSpringGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumSpringGreen As Color
[C#]
public Color MediumSpringGreen {get;}

See Also

Color Class | Kixforms Namespace


MediumTurquoise Property

KiXforms.NET Class Library

Color.MediumTurquoise Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumTurquoise As Color
[C#]
public Color MediumTurquoise {get;}

See Also

Color Class | Kixforms Namespace


MediumVioletRed Property

KiXforms.NET Class Library

Color.MediumVioletRed Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MediumVioletRed As Color
[C#]
public Color MediumVioletRed {get;}

See Also

Color Class | Kixforms Namespace


Menu Property

KiXforms.NET Class Library

Color.Menu Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Menu As Color
[C#]
public Color Menu {get;}

See Also

Color Class | Kixforms Namespace


MenuText Property

KiXforms.NET Class Library

Color.MenuText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MenuText As Color
[C#]
public Color MenuText {get;}

See Also

Color Class | Kixforms Namespace


MidnightBlue Property

KiXforms.NET Class Library

Color.MidnightBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MidnightBlue As Color
[C#]
public Color MidnightBlue {get;}

See Also

Color Class | Kixforms Namespace


MintCream Property

KiXforms.NET Class Library

Color.MintCream Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MintCream As Color
[C#]
public Color MintCream {get;}

See Also

Color Class | Kixforms Namespace


MistyRose Property

KiXforms.NET Class Library

Color.MistyRose Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property MistyRose As Color
[C#]
public Color MistyRose {get;}

See Also

Color Class | Kixforms Namespace


Moccasin Property

KiXforms.NET Class Library

Color.Moccasin Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Moccasin As Color
[C#]
public Color Moccasin {get;}

See Also

Color Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

Color.Name Property

Gets the name of this Color Name. This will either return the user-defined name of the color, if the color was created from a name, or the name of the known color. For custom colors, the RGB value will be returned.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

See Also

Color Class | Kixforms Namespace


NavajoWhite Property

KiXforms.NET Class Library

Color.NavajoWhite Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property NavajoWhite As Color
[C#]
public Color NavajoWhite {get;}

See Also

Color Class | Kixforms Namespace


Navy Property

KiXforms.NET Class Library

Color.Navy Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Navy As Color
[C#]
public Color Navy {get;}

See Also

Color Class | Kixforms Namespace


OldLace Property

KiXforms.NET Class Library

Color.OldLace Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property OldLace As Color
[C#]
public Color OldLace {get;}

See Also

Color Class | Kixforms Namespace


Olive Property

KiXforms.NET Class Library

Color.Olive Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Olive As Color
[C#]
public Color Olive {get;}

See Also

Color Class | Kixforms Namespace


OliveDrab Property

KiXforms.NET Class Library

Color.OliveDrab Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property OliveDrab As Color
[C#]
public Color OliveDrab {get;}

See Also

Color Class | Kixforms Namespace


Orange Property

KiXforms.NET Class Library

Color.Orange Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Orange As Color
[C#]
public Color Orange {get;}

See Also

Color Class | Kixforms Namespace


OrangeRed Property

KiXforms.NET Class Library

Color.OrangeRed Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property OrangeRed As Color
[C#]
public Color OrangeRed {get;}

See Also

Color Class | Kixforms Namespace


Orchid Property

KiXforms.NET Class Library

Color.Orchid Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Orchid As Color
[C#]
public Color Orchid {get;}

See Also

Color Class | Kixforms Namespace


PaleGoldenrod Property

KiXforms.NET Class Library

Color.PaleGoldenrod Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PaleGoldenrod As Color
[C#]
public Color PaleGoldenrod {get;}

See Also

Color Class | Kixforms Namespace


PaleGreen Property

KiXforms.NET Class Library

Color.PaleGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PaleGreen As Color
[C#]
public Color PaleGreen {get;}

See Also

Color Class | Kixforms Namespace


PaleTurquoise Property

KiXforms.NET Class Library

Color.PaleTurquoise Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PaleTurquoise As Color
[C#]
public Color PaleTurquoise {get;}

See Also

Color Class | Kixforms Namespace


PaleVioletRed Property

KiXforms.NET Class Library

Color.PaleVioletRed Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PaleVioletRed As Color
[C#]
public Color PaleVioletRed {get;}

See Also

Color Class | Kixforms Namespace


PapayaWhip Property

KiXforms.NET Class Library

Color.PapayaWhip Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PapayaWhip As Color
[C#]
public Color PapayaWhip {get;}

See Also

Color Class | Kixforms Namespace


PeachPuff Property

KiXforms.NET Class Library

Color.PeachPuff Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PeachPuff As Color
[C#]
public Color PeachPuff {get;}

See Also

Color Class | Kixforms Namespace


Peru Property

KiXforms.NET Class Library

Color.Peru Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Peru As Color
[C#]
public Color Peru {get;}

See Also

Color Class | Kixforms Namespace


Pink Property

KiXforms.NET Class Library

Color.Pink Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Pink As Color
[C#]
public Color Pink {get;}

See Also

Color Class | Kixforms Namespace


Plum Property

KiXforms.NET Class Library

Color.Plum Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Plum As Color
[C#]
public Color Plum {get;}

See Also

Color Class | Kixforms Namespace


PowderBlue Property

KiXforms.NET Class Library

Color.PowderBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property PowderBlue As Color
[C#]
public Color PowderBlue {get;}

See Also

Color Class | Kixforms Namespace


Purple Property

KiXforms.NET Class Library

Color.Purple Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Purple As Color
[C#]
public Color Purple {get;}

See Also

Color Class | Kixforms Namespace


R Property

KiXforms.NET Class Library

Color.R Property

Gets the red component value of this Color structure.

[Visual Basic]
Public ReadOnly Property R As Integer
[C#]
public int R {get;}

See Also

Color Class | Kixforms Namespace


Red Property

KiXforms.NET Class Library

Color.Red Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Red As Color
[C#]
public Color Red {get;}

See Also

Color Class | Kixforms Namespace


RosyBrown Property

KiXforms.NET Class Library

Color.RosyBrown Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property RosyBrown As Color
[C#]
public Color RosyBrown {get;}

See Also

Color Class | Kixforms Namespace


RoyalBlue Property

KiXforms.NET Class Library

Color.RoyalBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property RoyalBlue As Color
[C#]
public Color RoyalBlue {get;}

See Also

Color Class | Kixforms Namespace


SaddleBrown Property

KiXforms.NET Class Library

Color.SaddleBrown Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SaddleBrown As Color
[C#]
public Color SaddleBrown {get;}

See Also

Color Class | Kixforms Namespace


Salmon Property

KiXforms.NET Class Library

Color.Salmon Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Salmon As Color
[C#]
public Color Salmon {get;}

See Also

Color Class | Kixforms Namespace


SandyBrown Property

KiXforms.NET Class Library

Color.SandyBrown Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SandyBrown As Color
[C#]
public Color SandyBrown {get;}

See Also

Color Class | Kixforms Namespace


ScrollBar Property

KiXforms.NET Class Library

Color.ScrollBar Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property ScrollBar As Color
[C#]
public Color ScrollBar {get;}

See Also

Color Class | Kixforms Namespace


SeaGreen Property

KiXforms.NET Class Library

Color.SeaGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SeaGreen As Color
[C#]
public Color SeaGreen {get;}

See Also

Color Class | Kixforms Namespace


SeaShell Property

KiXforms.NET Class Library

Color.SeaShell Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SeaShell As Color
[C#]
public Color SeaShell {get;}

See Also

Color Class | Kixforms Namespace


Sienna Property

KiXforms.NET Class Library

Color.Sienna Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Sienna As Color
[C#]
public Color Sienna {get;}

See Also

Color Class | Kixforms Namespace


Silver Property

KiXforms.NET Class Library

Color.Silver Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Silver As Color
[C#]
public Color Silver {get;}

See Also

Color Class | Kixforms Namespace


SkyBlue Property

KiXforms.NET Class Library

Color.SkyBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SkyBlue As Color
[C#]
public Color SkyBlue {get;}

See Also

Color Class | Kixforms Namespace


SlateBlue Property

KiXforms.NET Class Library

Color.SlateBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SlateBlue As Color
[C#]
public Color SlateBlue {get;}

See Also

Color Class | Kixforms Namespace


SlateGray Property

KiXforms.NET Class Library

Color.SlateGray Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SlateGray As Color
[C#]
public Color SlateGray {get;}

See Also

Color Class | Kixforms Namespace


Snow Property

KiXforms.NET Class Library

Color.Snow Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Snow As Color
[C#]
public Color Snow {get;}

See Also

Color Class | Kixforms Namespace


SpringGreen Property

KiXforms.NET Class Library

Color.SpringGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SpringGreen As Color
[C#]
public Color SpringGreen {get;}

See Also

Color Class | Kixforms Namespace


SteelBlue Property

KiXforms.NET Class Library

Color.SteelBlue Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property SteelBlue As Color
[C#]
public Color SteelBlue {get;}

See Also

Color Class | Kixforms Namespace


Tan Property

KiXforms.NET Class Library

Color.Tan Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Tan As Color
[C#]
public Color Tan {get;}

See Also

Color Class | Kixforms Namespace


Teal Property

KiXforms.NET Class Library

Color.Teal Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Teal As Color
[C#]
public Color Teal {get;}

See Also

Color Class | Kixforms Namespace


Thistle Property

KiXforms.NET Class Library

Color.Thistle Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Thistle As Color
[C#]
public Color Thistle {get;}

See Also

Color Class | Kixforms Namespace


Tomato Property

KiXforms.NET Class Library

Color.Tomato Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Tomato As Color
[C#]
public Color Tomato {get;}

See Also

Color Class | Kixforms Namespace


Transparent Property

KiXforms.NET Class Library

Color.Transparent Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Transparent As Color
[C#]
public Color Transparent {get;}

See Also

Color Class | Kixforms Namespace


Turquoise Property

KiXforms.NET Class Library

Color.Turquoise Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Turquoise As Color
[C#]
public Color Turquoise {get;}

See Also

Color Class | Kixforms Namespace


Violet Property

KiXforms.NET Class Library

Color.Violet Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Violet As Color
[C#]
public Color Violet {get;}

See Also

Color Class | Kixforms Namespace


Wheat Property

KiXforms.NET Class Library

Color.Wheat Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Wheat As Color
[C#]
public Color Wheat {get;}

See Also

Color Class | Kixforms Namespace


White Property

KiXforms.NET Class Library

Color.White Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property White As Color
[C#]
public Color White {get;}

See Also

Color Class | Kixforms Namespace


WhiteSmoke Property

KiXforms.NET Class Library

Color.WhiteSmoke Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property WhiteSmoke As Color
[C#]
public Color WhiteSmoke {get;}

See Also

Color Class | Kixforms Namespace


Window Property

KiXforms.NET Class Library

Color.Window Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Window As Color
[C#]
public Color Window {get;}

See Also

Color Class | Kixforms Namespace


WindowFrame Property

KiXforms.NET Class Library

Color.WindowFrame Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property WindowFrame As Color
[C#]
public Color WindowFrame {get;}

See Also

Color Class | Kixforms Namespace


WindowText Property

KiXforms.NET Class Library

Color.WindowText Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property WindowText As Color
[C#]
public Color WindowText {get;}

See Also

Color Class | Kixforms Namespace


Yellow Property

KiXforms.NET Class Library

Color.Yellow Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property Yellow As Color
[C#]
public Color Yellow {get;}

See Also

Color Class | Kixforms Namespace


YellowGreen Property

KiXforms.NET Class Library

Color.YellowGreen Property

A system-defined color.

[Visual Basic]
Public ReadOnly Property YellowGreen As Color
[C#]
public Color YellowGreen {get;}

See Also

Color Class | Kixforms Namespace


Color Methods

The methods of the Color class are listed below. For a complete list of Color class members, see the Color Members topic.

Public Instance Methods

FromArgb | Creates a Color structure from the four 8-bit ARGB component (alpha, red, green, and blue) values.
FromName | Creates a Color structure from the specified name of a pre-defined color.
FromRgb | Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (fully opaque).
ToArgb | Gets the 32-bit ARGB value of this Color structure.

See Also

Color Class | Kixforms Namespace


Color.FromArgb Method

Creates a Color structure from the four 8-bit ARGB component (alpha, red, green, and blue) values.

[Visual Basic]
Public Function FromArgb( _
ByVal alpha As Integer, _
ByVal red As Integer, _
ByVal green As Integer, _
ByVal blue As Integer _
) As Color
[C#]
public Color FromArgb(
int alpha,
int red,
int green,
int blue
);

See Also

Color Class | Kixforms Namespace


Color.FromName Method

Creates a Color structure from the specified name of a pre-defined color.

[Visual Basic]
Public Function FromName( _
ByVal name As String _
) As Color
[C#]
public Color FromName(
string name
);

See Also

Color Class | Kixforms Namespace


Color.FromRgb Method

Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (fully opaque).

[Visual Basic]
Public Function FromRgb( _
ByVal red As Integer, _
ByVal green As Integer, _
ByVal blue As Integer _
) As Color
[C#]
public Color FromRgb(
int red,
int green,
int blue
);

See Also

Color Class | Kixforms Namespace


Color.ToArgb Method

Gets the 32-bit ARGB value of this Color structure.

[Visual Basic]
Public Function ToArgb() As Integer
[C#]
public int ToArgb();

See Also

Color Class | Kixforms Namespace


ColorDepth Enumeration

[Visual Basic]
Public Enum ColorDepth
[C#]
public enum ColorDepth

Members

Member Name | Description
Depth16Bit |
Depth24Bit |
Depth32Bit |
Depth4Bit |
Depth8Bit |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ColumnClickEventArgs Class

Provides data for the ColumnClick event.

For a list of all members of this type, see ColumnClickEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.ColumnClickEventArgs

[Visual Basic]
Public Class ColumnClickEventArgs
Inherits EventArgs
[C#]
public class ColumnClickEventArgs : EventArgs

Remarks

The ColumnClickEventArgs class provides the zero-based index within the ListViewColumnHeaderCollection class of the column that is clicked in the ListView control. You can use this information in an event handler for the ColumnClick event to determine which column is being clicked to perform tasks on the data within the column.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ColumnClickEventArgs Members | Kixforms Namespace


ColumnClickEventArgs Members

ColumnClickEventArgs overview

Public Instance Properties

Column Gets or sets the zero-based index of the column that is clicked.

See Also

ColumnClickEventArgs Class | Kixforms Namespace


ColumnClickEventArgs Properties

The properties of the ColumnClickEventArgs class are listed below. For a complete list of ColumnClickEventArgs class members, see the ColumnClickEventArgs Members topic.

Public Instance Properties

Column Gets or sets the zero-based index of the column that is clicked.

See Also

ColumnClickEventArgs Class | Kixforms Namespace


Column Property

KiXforms.NET Class Library

ColumnClickEventArgs.Column Property

Gets or sets the zero-based index of the column that is clicked.

[Visual Basic]
Public Property Column As Integer
[C#]
public int Column {get; set;}

Property Value

The zero-based index within the ListViewColumnHeaderCollection of the column that is clicked.

See Also

ColumnClickEventArgs Class | Kixforms Namespace


ColumnHeader Class

Displays a single column header in a ListView control.

For a list of all members of this type, see ColumnHeader Members.

System.Object
Kixforms.ColumnHeader

[Visual Basic]
Public Class ColumnHeader
[C#]
public class ColumnHeader

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ColumnHeader Members | Kixforms Namespace


ColumnHeader Members

ColumnHeader overview

Public Instance Constructors

ColumnHeader Constructor Initializes a new instance of the ColumnHeader class, with specified text, width, and alignment settings.

Public Instance Properties

Index | Gets the location with the ListView control's ListView.ColumnHeaderCollection of this column.
Text | Gets or sets the text displayed in the column header.
TextAlign | Gets or sets the horizontal alignment of the text displayed in the ColumnHeader.
Width | Gets or sets the width of the column.

See Also

ColumnHeader Class | Kixforms Namespace


ColumnHeader Constructor

Initializes a new instance of the ColumnHeader class, with specified text, width, and alignment settings.

[Visual Basic]
Overloads Public Sub New( _
ByVal text As String, _
ByVal width As Integer, _
ByVal alignment As HorizontalAlignment _
)
[C#]
public ColumnHeader(
string text,
int width,
HorizontalAlignment alignment
);

Parameters

text
The text to display in the column header.
width
The initial width of the column header. Set to -1 to autosize the column header to the size of the largest subitem text in the column or -2 to autosize the column header to the size of the text of the column header.
alignment
One of the HorizontalAlignment values.

See Also

ColumnHeader Class | Kixforms Namespace


ColumnHeader Properties

The properties of the ColumnHeader class are listed below. For a complete list of ColumnHeader class members, see the ColumnHeader Members topic.

Public Instance Properties

Index | Gets the location with the ListView control's ListView.ColumnHeaderCollection of this column.
Text | Gets or sets the text displayed in the column header.
TextAlign | Gets or sets the horizontal alignment of the text displayed in the ColumnHeader.
Width | Gets or sets the width of the column.

See Also

ColumnHeader Class | Kixforms Namespace


Index Property

KiXforms.NET Class Library

ColumnHeader.Index Property

Gets the location with the ListView control's ListView.ColumnHeaderCollection of this column.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}

See Also

ColumnHeader Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

ColumnHeader.Text Property

Gets or sets the text displayed in the column header.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

ColumnHeader Class | Kixforms Namespace


TextAlign Property

KiXforms.NET Class Library

ColumnHeader.TextAlign Property

Gets or sets the horizontal alignment of the text displayed in the ColumnHeader.

[Visual Basic]
Public Property TextAlign As HorizontalAlignment
[C#]
public HorizontalAlignment TextAlign {get; set;}

See Also

ColumnHeader Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

ColumnHeader.Width Property

Gets or sets the width of the column.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

ColumnHeader Class | Kixforms Namespace


ColumnHeaderStyle Enumeration

[Visual Basic]
Public Enum ColumnHeaderStyle
[C#]
public enum ColumnHeaderStyle

Members

Member Name | Description
Clickable |
Nonclickable |
None |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ComboBox Class

Represents a Windows combo box control.

For a list of all members of this type, see ComboBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ListControl
Kixforms.ComboBox

[Visual Basic]
Public Class ComboBox
Inherits ListControl
[C#]
public class ComboBox : ListControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ComboBox Members | Kixforms Namespace


ComboBox Members

ComboBox overview

Public Instance Constructors

ComboBox Constructor Initializes a new instance of the ComboBox class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl object.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
DropDownStyle | Gets or sets a value specifying the style of the combo box.
DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
ItemHeight | Gets or sets the height of an item in the combo box.
Items | Gets an object representing the collection of the items contained in this ComboBox.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.
MaxLength | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedIndex | Gets or sets the index specifying the currently selected item.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property has changed.
SelectedText | Gets or sets the text that is selected in the editable portion of a ComboBox.
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart | Gets or sets the starting index of text selected in the combo box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ComboBox Class | Kixforms Namespace


ComboBox Constructor

Initializes a new instance of the ComboBox class.

[Visual Basic]
Public Sub New()
[C#]
public ComboBox();

See Also

ComboBox Class | Kixforms Namespace


ComboBox Properties

The properties of the ComboBox class are listed below. For a complete list of ComboBox class members, see the ComboBox Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl object.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
DropDownStyle | Gets or sets a value specifying the style of the combo box.
DropDownWidth | Gets or sets the width of the of the drop-down portion of a combo box.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
ItemHeight | Gets or sets the height of an item in the combo box.
Items | Gets an object representing the collection of the items contained in this ComboBox.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxDropDownItems | Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.
MaxLength | Gets or sets the maximum number of characters allowed in the editable portion of a combo box.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height of the ComboBox.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedIndex | Gets or sets the index specifying the currently selected item.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property has changed.
SelectedText | Gets or sets the text that is selected in the editable portion of a ComboBox.
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionLength | Gets or sets the number of characters selected in the editable portion of the combo box.
SelectionStart | Gets or sets the starting index of text selected in the combo box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the items in the combo box are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ComboBox Class | Kixforms Namespace


DropDownStyle Property

KiXforms.NET Class Library

ComboBox.DropDownStyle Property

Gets or sets a value specifying the style of the combo box.

[Visual Basic]
Public Property DropDownStyle As ComboBoxStyle
[C#]
public ComboBoxStyle DropDownStyle {get; set;}

See Also

ComboBox Class | Kixforms Namespace


DropDownWidth Property

KiXforms.NET Class Library

ComboBox.DropDownWidth Property

Gets or sets the width of the of the drop-down portion of a combo box.

[Visual Basic]
Public Property DropDownWidth As Integer
[C#]
public int DropDownWidth {get; set;}

See Also

ComboBox Class | Kixforms Namespace


IntegralHeight Property

KiXforms.NET Class Library

ComboBox.IntegralHeight Property

Gets or sets a value indicating whether the control should resize to avoid showing partial items.

[Visual Basic]
Public Property IntegralHeight As Boolean
[C#]
public bool IntegralHeight {get; set;}

See Also

ComboBox Class | Kixforms Namespace


ItemHeight Property

KiXforms.NET Class Library

ComboBox.ItemHeight Property

Gets or sets the height of an item in the combo box.

[Visual Basic]
Public Property ItemHeight As Integer
[C#]
public int ItemHeight {get; set;}

See Also

ComboBox Class | Kixforms Namespace


Items Property

KiXforms.NET Class Library

ComboBox.Items Property

Gets an object representing the collection of the items contained in this ComboBox.

[Visual Basic]
Public ReadOnly Property Items As ComboBoxObjectCollection
[C#]
public ComboBoxObjectCollection Items {get;}

See Also

ComboBox Class | Kixforms Namespace


MaxDropDownItems Property

KiXforms.NET Class Library

ComboBox.MaxDropDownItems Property

Gets or sets the maximum number of items to be shown in the drop-down portion of the ComboBox.

[Visual Basic]
Public Property MaxDropDownItems As Integer
[C#]
public int MaxDropDownItems {get; set;}

See Also

ComboBox Class | Kixforms Namespace


MaxLength Property

KiXforms.NET Class Library

ComboBox.MaxLength Property

Gets or sets the maximum number of characters allowed in the editable portion of a combo box.

[Visual Basic]
Public Property MaxLength As Integer
[C#]
public int MaxLength {get; set;}

See Also

ComboBox Class | Kixforms Namespace


PreferredHeight Property

KiXforms.NET Class Library

ComboBox.PreferredHeight Property

Gets the preferred height of the ComboBox.

[Visual Basic]
Overridable Public ReadOnly Property PreferredHeight As Integer
[C#]
public virtual int PreferredHeight {get;}

Property Value

The preferred height, in pixels, of the item area of the combo box.

Remarks

The preferred height is a value based on the font height and an adjustment for the border.

See Also

ComboBox Class | Kixforms Namespace


SelectedIndex Property

KiXforms.NET Class Library

ComboBox.SelectedIndex Property

Gets or sets the index specifying the currently selected item.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}

See Also

ComboBox Class | Kixforms Namespace


SelectedIndexChanged Property

KiXforms.NET Class Library

ComboBox.SelectedIndexChanged Property

Gets or sets the code to execute when the SelectedIndex property has changed.

[Visual Basic]
Public Property SelectedIndexChanged As String
[C#]
public string SelectedIndexChanged {get; set;}

See Also

ComboBox Class | Kixforms Namespace


SelectedText Property

KiXforms.NET Class Library

ComboBox.SelectedText Property

Gets or sets the text that is selected in the editable portion of a ComboBox.

[Visual Basic]
Public Property SelectedText As String
[C#]
public string SelectedText {get; set;}

Property Value

A string that represents the currently selected text in the combo box. If DropDownStyle is set to ComboBoxStyle_DropDownList, the return is an empty string ("").

See Also

ComboBox Class | Kixforms Namespace


SelectionLength Property

KiXforms.NET Class Library

ComboBox.SelectionLength Property

Gets or sets the number of characters selected in the editable portion of the combo box.

[Visual Basic]
Public Property SelectionLength As Integer
[C#]
public int SelectionLength {get; set;}

Property Value

The number of characters selected in the combo box.

See Also

ComboBox Class | Kixforms Namespace


SelectionStart Property

KiXforms.NET Class Library

ComboBox.SelectionStart Property

Gets or sets the starting index of text selected in the combo box.

[Visual Basic]
Public Property SelectionStart As Integer
[C#]
public int SelectionStart {get; set;}

Property Value

The zero-based index of the first character in the string of the current text selection.

See Also

ComboBox Class | Kixforms Namespace


Sorted Property

KiXforms.NET Class Library

ComboBox.Sorted Property

Gets or sets a value indicating whether the items in the combo box are sorted.

[Visual Basic]
Public Property Sorted As Boolean
[C#]
public bool Sorted {get; set;}

See Also

ComboBox Class | Kixforms Namespace


ComboBoxObjectCollection Class

Represents the collection of items in a ComboBox.

For a list of all members of this type, see ComboBoxObjectCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ComboBoxObjectCollection

[Visual Basic]
Public Class ComboBoxObjectCollection
Inherits CollectionBase
[C#]
public class ComboBoxObjectCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ComboBoxObjectCollection Members | Kixforms Namespace


ComboBoxObjectCollection Members

ComboBoxObjectCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Retrieves the item at the specified index within the collection.

Public Instance Methods

Add | Adds an item to the list of items for a ComboBox.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an item into the collection at the specified index.
Remove | Removes the specified item from the ComboBox.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxObjectCollection Properties

The properties of the ComboBoxObjectCollection class are listed below. For a complete list of ComboBoxObjectCollection class members, see the ComboBoxObjectCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Retrieves the item at the specified index within the collection.

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ComboBoxObjectCollection.Item Property

Retrieves the item at the specified index within the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) _
Implements IList.Item
As Object _
Implements IList.Item
[C#]
new public object this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to retrieve.

Implements

IList.Item

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxObjectCollection Methods

The methods of the ComboBoxObjectCollection class are listed below. For a complete list of ComboBoxObjectCollection class members, see the ComboBoxObjectCollection Members topic.

Public Instance Methods

Add | Adds an item to the list of items for a ComboBox.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an item into the collection at the specified index.
Remove | Removes the specified item from the ComboBox.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxObjectCollection.Add Method

Adds an item to the list of items for a ComboBox.

[Visual Basic]
Public Function Add( _
ByVal item As Object _
) As Object
[C#]
new public object Add(
object item
);

Parameters

item
An object representing the item to add to the collection.

Return Value

The object that was added to the collection.

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxObjectCollection.Insert Method

Inserts an item into the collection at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal item As Object _
) As Object
[C#]
new public object Insert(
int index,
object item
);

Parameters

index
The zero-based index location where the item is inserted.
item
An object representing the item to insert.

Return Value

The object that was inserted into the collection.

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxObjectCollection.Remove Method

Removes the specified item from the ComboBox.

[Visual Basic]
Public Sub Remove( _
ByVal item As Object _
) _
Implements IList.Remove
[C#]
new public void Remove(
object item
);

Parameters

item
The Object to remove from the list.

Implements

IList.Remove

See Also

ComboBoxObjectCollection Class | Kixforms Namespace


ComboBoxStyle Enumeration

[Visual Basic]
Public Enum ComboBoxStyle
[C#]
public enum ComboBoxStyle

Members

Member Name | Description
DropDown |
DropDownList |
Simple |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


CommonDialog Class

Specifies the base class used for displaying dialog boxes on the screen.

For a list of all members of this type, see CommonDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FileDialog
Kixforms.FolderBrowserDialog
Kixforms.FontDialog

[Visual Basic]
Public Class CommonDialog
Inherits Component
[C#]
public class CommonDialog : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

CommonDialog Members | Kixforms Namespace


CommonDialog Members

CommonDialog overview

Public Instance Properties

Type (inherited from Component) Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
ShowDialog | Runs a common dialog box.

See Also

CommonDialog Class | Kixforms Namespace


CommonDialog Methods

The methods of the CommonDialog class are listed below. For a complete list of CommonDialog class members, see the CommonDialog Members topic.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
ShowDialog | Runs a common dialog box.

See Also

CommonDialog Class | Kixforms Namespace


CommonDialog.ShowDialog Method

Runs a common dialog box.

[Visual Basic]
Public Function ShowDialog() As DialogResult
[C#]
public DialogResult ShowDialog();

Return Value

DialogResult.OK if the user clicks OK in the dialog box; otherwise, DialogResult.Cancel .

See Also

CommonDialog Class | Kixforms Namespace


Component Class

Provides functionality required by all components.

For a list of all members of this type, see Component Members.

System.Object
Kixforms.Component
Derived types

[Visual Basic]
Public Class Component
[C#]
public class Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Component Members | Kixforms Namespace


Component Members

Component overview

Public Instance Properties

Type Gets the Type of the current instance.

Public Instance Methods

Dispose Releases the resources used by the Component.

See Also

Component Class | Kixforms Namespace


Component Properties

The properties of the Component class are listed below. For a complete list of Component class members, see the Component Members topic.

Public Instance Properties

Type Gets the Type of the current instance.

See Also

Component Class | Kixforms Namespace


Type Property

KiXforms.NET Class Library

Component.Type Property

Gets the Type of the current instance.

[Visual Basic]
Public ReadOnly Property Type As Type
[C#]
public Type Type {get;}

See Also

Component Class | Kixforms Namespace


Component Methods

The methods of the Component class are listed below. For a complete list of Component class members, see the Component Members topic.

Public Instance Methods

Dispose Releases the resources used by the Component.

See Also

Component Class | Kixforms Namespace


Component.Dispose Method

Releases the resources used by the Component.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

Component Class | Kixforms Namespace


ContainerControl Class

Provides focus management functionality for controls that can function as a container for other controls.

For a list of all members of this type, see ContainerControl Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.Form
Kixforms.PropertyGrid
Kixforms.UpDownBase
Kixforms.UserControl

[Visual Basic]
Public Class ContainerControl
Inherits ScrollableControl
[C#]
public class ContainerControl : ScrollableControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ContainerControl Members | Kixforms Namespace


ContainerControl Members

ContainerControl overview

Public Instance Properties

ActiveControl | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ContainerControl Class | Kixforms Namespace


ContainerControl Properties

The properties of the ContainerControl class are listed below. For a complete list of ContainerControl class members, see the ContainerControl Members topic.

Public Instance Properties

ActiveControl | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ContainerControl Class | Kixforms Namespace


ActiveControl Property

KiXforms.NET Class Library

ContainerControl.ActiveControl Property

Gets or sets the active control on the container control.

[Visual Basic]
Public Property ActiveControl As Control
[C#]
public Control ActiveControl {get; set;}

See Also

ContainerControl Class | Kixforms Namespace


ContentAlignment Enumeration

[Visual Basic]
Public Enum ContentAlignment
[C#]
public enum ContentAlignment

Members

Member Name | Description
BottomCenter | Content is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Content is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Content is vertically aligned at the bottom, and horizontally aligned on the right.
MiddleCenter | Content is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Content is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Content is vertically aligned in the middle, and horizontally aligned on the right.
TopCenter | Content is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Content is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Content is vertically aligned at the top, and horizontally aligned on the right.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ContextMenu Class

Represents a shortcut menu.

For a list of all members of this type, see ContextMenu Members.

System.Object
Kixforms.Menu
Kixforms.ContextMenu

[Visual Basic]
Public Class ContextMenu
Inherits Menu
[C#]
public class ContextMenu : Menu

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ContextMenu Members | Kixforms Namespace


ContextMenu Members

ContextMenu overview

Public Instance Constructors

ContextMenu Constructor Initializes a new instance of the ContextMenu class.

Public Instance Properties

MenuItems (inherited from Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
SourceControl | Gets the control that is displaying the shortcut menu.

Public Instance Methods

GetMainMenu (inherited from Menu) | Gets the MainMenu that contains this menu.
Show | Displays the shortcut menu at the specified position.

See Also

ContextMenu Class | Kixforms Namespace


ContextMenu Constructor

Initializes a new instance of the ContextMenu class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ContextMenu();

See Also

ContextMenu Class | Kixforms Namespace


ContextMenu Properties

The properties of the ContextMenu class are listed below. For a complete list of ContextMenu class members, see the ContextMenu Members topic.

Public Instance Properties

MenuItems (inherited from Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
SourceControl | Gets the control that is displaying the shortcut menu.

See Also

ContextMenu Class | Kixforms Namespace


SourceControl Property

KiXforms.NET Class Library

ContextMenu.SourceControl Property

Gets the control that is displaying the shortcut menu.

[Visual Basic]
Public ReadOnly Property SourceControl As Control
[C#]
public Control SourceControl {get;}

See Also

ContextMenu Class | Kixforms Namespace


ContextMenu Methods

The methods of the ContextMenu class are listed below. For a complete list of ContextMenu class members, see the ContextMenu Members topic.

Public Instance Methods

GetMainMenu (inherited from Menu) | Gets the MainMenu that contains this menu.
Show | Displays the shortcut menu at the specified position.

See Also

ContextMenu Class | Kixforms Namespace


ContextMenu.Show Method

Displays the shortcut menu at the specified position.

[Visual Basic]
Public Sub Show( _
ByVal control As Control, _
ByVal pos As Point _
)
[C#]
public void Show(
Control control,
Point pos
);

Parameters

control
A Control object that specifies the control with which this context menu is associated.
pos
A Point object that specifies the coordinates at which to display the menu. These coordinates are specified relative to the client coordinates of the control specified in the control parameter.

See Also

ContextMenu Class | Kixforms Namespace


Control Class

Defines the base class for controls, which are components with visual representation.

For a list of all members of this type, see Control Members.

System.Object
Kixforms.Component
Kixforms.Control
Derived types

[Visual Basic]
Public Class Control
Inherits Component
[C#]
public class Control : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Control Members | Kixforms Namespace


Control Members

Control overview

Public Instance Properties

Anchor | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor | Gets or sets a Color representing the background color for the control.
BackgroundImage | Gets or sets an Image representing the image to display in the background of the control.
Bottom | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds | Gets or sets a Rectangle representing the size and location of the control.
CanFocus | Gets or sets whether the control can receive focus.
Capture | Gets or sets whether the control has captured the mouse.
Click | Gets or sets the code to execute when the control is clicked.
ClientHeight | Gets or sets the height of the client area of the control.
ClientRectangle | Gets a Rectangle that represents the client area of the control.
ClientSize | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu | Gets or sets the ContextMenu associated with the control.
ControlAdded | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls | Gets a ControlCollection that represents all the controls contained within the control.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock | Gets or sets which edge of the parent container a control is docked to.
DoubleClick | Gets or sets the code to execute when the control is double-clicked.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Enter | Gets or sets the code to execute when the control is entered.
Focused | Gets a value indicating whether the control has input focus.
Font | Gets or sets the font of the text displayed by the control.
FontBold | Gets or sets whether the font used by the control is bold.
FontHeight | Gets the height (in pixels) of the font used by the control.
FontName | Gets or sets the face name of the font used by the control.
FontSize | Gets or sets the size (in points) of the font used by the control.
ForeColor | Gets or sets the foreground color of the control.
Height | Gets or sets the height of the control.
KeyDown | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp | Gets or sets the code to execute when a key is released while the control has focus.
Leave | Gets or sets the code to execute when input focus leaves the control.
Left | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged | Gets or sets the code to execute when the Location property value has changed.
MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition | Gets the position of the mouse cursor in screen coordinates.
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Move | Gets or sets the code to execute when the control is moved.
Name | Gets or sets the name of the control.
Paint | Gets or sets the code to execute when the control is redrawn.
Parent | Gets or sets the parent container of the control.
ProductName | Gets the product name of the assembly containing the control.
ProductVersion | Gets the version of the assembly containing the control.
Right | Gets the distance between the right edge of the control and the left edge of its container.
Size | Gets or sets the height and width of the control.
SizeChanged | Gets or sets the code to execute when the Size property value changes.
TabIndex | Gets or sets the tab order of the control within its container.
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag | Gets or sets the object that contains data about the control.
Text | Gets or sets the text associated with this control.
TextChanged | Gets or sets the code to execute when the Text property changes.
Top | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible | Gets or sets a value indicating whether the control is displayed.
Width | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront | Brings the control to the front of the z-order.
Center | Centers the control inside its container.
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl | Searches the ControlCollection for a control with the specified name.
FindForm | Retrieves the form that the control is on.
Focus | Sets input focus to the control.
GetChildAtPoint | Retrieves the child control that is located at the specified coordinates.
GetNextControl | Under development.
Hide | Conceals the control from the user.
Invalidate | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient | Computes the location of the specified screen point into client coordinates.
PointToScreen | Computes the location of the specified client point into screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage | Resets the BackgroundImage property to its default value.
ResumeLayout | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select | Activates a control.
SendToBack | Sends the control to the back of the z-order.
Show | Displays the control to the user.
SuspendLayout | Temporarily suspends the layout logic for the control.
Update | Causes the control to redraw the invalidated regions with its client area.

See Also

Control Class | Kixforms Namespace


Control Properties

The properties of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Properties

Anchor | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor | Gets or sets a Color representing the background color for the control.
BackgroundImage | Gets or sets an Image representing the image to display in the background of the control.
Bottom | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds | Gets or sets a Rectangle representing the size and location of the control.
CanFocus | Gets or sets whether the control can receive focus.
Capture | Gets or sets whether the control has captured the mouse.
Click | Gets or sets the code to execute when the control is clicked.
ClientHeight | Gets or sets the height of the client area of the control.
ClientRectangle | Gets a Rectangle that represents the client area of the control.
ClientSize | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu | Gets or sets the ContextMenu associated with the control.
ControlAdded | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls | Gets a ControlCollection that represents all the controls contained within the control.
Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock | Gets or sets which edge of the parent container a control is docked to.
DoubleClick | Gets or sets the code to execute when the control is double-clicked.
Enabled | Gets or sets a value indicating whether the control can respond to user interaction.
Enter | Gets or sets the code to execute when the control is entered.
Focused | Gets a value indicating whether the control has input focus.
Font | Gets or sets the font of the text displayed by the control.
FontBold | Gets or sets whether the font used by the control is bold.
FontHeight | Gets the height (in pixels) of the font used by the control.
FontName | Gets or sets the face name of the font used by the control.
FontSize | Gets or sets the size (in points) of the font used by the control.
ForeColor | Gets or sets the foreground color of the control.
Height | Gets or sets the height of the control.
KeyDown | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp | Gets or sets the code to execute when a key is released while the control has focus.
Leave | Gets or sets the code to execute when input focus leaves the control.
Left | Gets or sets the x-coordinate of a control's left edge in pixels.
Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged | Gets or sets the code to execute when the Location property value has changed.
MouseButtons | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition | Gets the position of the mouse cursor in screen coordinates.
MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released.
Move | Gets or sets the code to execute when the control is moved.
Name | Gets or sets the name of the control.
Paint | Gets or sets the code to execute when the control is redrawn.
Parent | Gets or sets the parent container of the control.
ProductName | Gets the product name of the assembly containing the control.
ProductVersion | Gets the version of the assembly containing the control.
Right | Gets the distance between the right edge of the control and the left edge of its container.
Size | Gets or sets the height and width of the control.
SizeChanged | Gets or sets the code to execute when the Size property value changes.
TabIndex | Gets or sets the tab order of the control within its container.
TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag | Gets or sets the object that contains data about the control.
Text | Gets or sets the text associated with this control.
TextChanged | Gets or sets the code to execute when the Text property changes.
Top | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible | Gets or sets a value indicating whether the control is displayed.
Width | Gets or sets the width of the control.

See Also

Control Class | Kixforms Namespace


Anchor Property

KiXforms.NET Class Library

Control.Anchor Property

Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.

[Visual Basic]
Public Property Anchor As AnchorStyles
[C#]
public AnchorStyles Anchor {get; set;}

See Also

Control Class | Kixforms Namespace


BackColor Property

KiXforms.NET Class Library

Control.BackColor Property

Gets or sets a Color representing the background color for the control.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}

See Also

Control Class | Kixforms Namespace


BackgroundImage Property

KiXforms.NET Class Library

Control.BackgroundImage Property

Gets or sets an Image representing the image to display in the background of the control.

[Visual Basic]
Public Property BackgroundImage As Image
[C#]
public Image BackgroundImage {get; set;}

See Also

Control Class | Kixforms Namespace


Bottom Property

KiXforms.NET Class Library

Control.Bottom Property

Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.

[Visual Basic]
Public ReadOnly Property Bottom As Integer
[C#]
public int Bottom {get;}

See Also

Control Class | Kixforms Namespace


Bounds Property

KiXforms.NET Class Library

Control.Bounds Property

Gets or sets a Rectangle representing the size and location of the control.

[Visual Basic]
Public Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get; set;}

See Also

Control Class | Kixforms Namespace


CanFocus Property

KiXforms.NET Class Library

Control.CanFocus Property

Gets or sets whether the control can receive focus.

[Visual Basic]
Public ReadOnly Property CanFocus As Boolean
[C#]
public bool CanFocus {get;}

See Also

Control Class | Kixforms Namespace


Capture Property

KiXforms.NET Class Library

Control.Capture Property

Gets or sets whether the control has captured the mouse.

[Visual Basic]
Public Property Capture As Boolean
[C#]
public bool Capture {get; set;}

See Also

Control Class | Kixforms Namespace


Click Property

KiXforms.NET Class Library

Control.Click Property

Gets or sets the code to execute when the control is clicked.

[Visual Basic]
Public Property Click As String
[C#]
public string Click {get; set;}

See Also

Control Class | Kixforms Namespace


ClientHeight Property

KiXforms.NET Class Library

Control.ClientHeight Property

Gets or sets the height of the client area of the control.

[Visual Basic]
Public Property ClientHeight As Integer
[C#]
public int ClientHeight {get; set;}

See Also

Control Class | Kixforms Namespace


ClientRectangle Property

KiXforms.NET Class Library

Control.ClientRectangle Property

Gets a Rectangle that represents the client area of the control.

[Visual Basic]
Public ReadOnly Property ClientRectangle As Rectangle
[C#]
public Rectangle ClientRectangle {get;}

See Also

Control Class | Kixforms Namespace


ClientSize Property

KiXforms.NET Class Library

Control.ClientSize Property

Gets or sets a Size representing the height and width of the client area of the control.

[Visual Basic]
Public Property ClientSize As Size
[C#]
public Size ClientSize {get; set;}

See Also

Control Class | Kixforms Namespace


ClientWidth Property

KiXforms.NET Class Library

Control.ClientWidth Property

Gets or sets the width (in pixels) of the client area of the control.

[Visual Basic]
Public Property ClientWidth As Integer
[C#]
public int ClientWidth {get; set;}

See Also

Control Class | Kixforms Namespace


ContextMenu Property

KiXforms.NET Class Library

Control.ContextMenu Property

Gets or sets the ContextMenu associated with the control.

[Visual Basic]
Public Property ContextMenu As ContextMenu
[C#]
public ContextMenu ContextMenu {get; set;}

See Also

Control Class | Kixforms Namespace


ControlAdded Property

KiXforms.NET Class Library

Control.ControlAdded Property

Gets or sets the code to execute when a new control is added to the ControlCollection.

[Visual Basic]
Public Property ControlAdded As String
[C#]
public string ControlAdded {get; set;}

Remarks

Use the System.Sender property to return the control that raised the event. Use the Event property to return a ControlEventArgs object containing data related to this event.

See Also

Control Class | Kixforms Namespace


ControlRemoved Property

KiXforms.NET Class Library

Control.ControlRemoved Property

Gets or sets the code to execute when a control is removed from the ControlCollection.

[Visual Basic]
Public Property ControlRemoved As String
[C#]
public string ControlRemoved {get; set;}

Remarks

The Event property receives a value of type ControlEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


Controls Property

KiXforms.NET Class Library

Control.Controls Property

Gets a ControlCollection that represents all the controls contained within the control.

[Visual Basic]
Public ReadOnly Property Controls As ControlCollection
[C#]
public ControlCollection Controls {get;}

See Also

Control Class | Kixforms Namespace


Cursor Property

KiXforms.NET Class Library

Control.Cursor Property

Gets or sets the cursor that is displayed when the mouse pointer is over the control.

[Visual Basic]
Public Property Cursor As Cursor
[C#]
public Cursor Cursor {get; set;}

See Also

Control Class | Kixforms Namespace


Dock Property

KiXforms.NET Class Library

Control.Dock Property

Gets or sets which edge of the parent container a control is docked to.

[Visual Basic]
Public Property Dock As DockStyle
[C#]
public DockStyle Dock {get; set;}

See Also

Control Class | Kixforms Namespace


DoubleClick Property

KiXforms.NET Class Library

Control.DoubleClick Property

Gets or sets the code to execute when the control is double-clicked.

[Visual Basic]
Public Property DoubleClick As String
[C#]
public string DoubleClick {get; set;}

See Also

Control Class | Kixforms Namespace


Enabled Property

KiXforms.NET Class Library

Control.Enabled Property

Gets or sets a value indicating whether the control can respond to user interaction.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}

See Also

Control Class | Kixforms Namespace


Enter Property

KiXforms.NET Class Library

Control.Enter Property

Gets or sets the code to execute when the control is entered.

[Visual Basic]
Public Property Enter As String
[C#]
public string Enter {get; set;}

See Also

Control Class | Kixforms Namespace


Focused Property

KiXforms.NET Class Library

Control.Focused Property

Gets a value indicating whether the control has input focus.

[Visual Basic]
Public ReadOnly Property Focused As Boolean
[C#]
public bool Focused {get;}

Property Value

True if the control has focus; otherwise, false.

See Also

Control Class | Kixforms Namespace


Font Property

KiXforms.NET Class Library

Control.Font Property

Gets or sets the font of the text displayed by the control.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}

See Also

Control Class | Kixforms Namespace


FontBold Property

KiXforms.NET Class Library

Control.FontBold Property

Gets or sets whether the font used by the control is bold.

[Visual Basic]
Public Property FontBold As Boolean
[C#]
public bool FontBold {get; set;}

See Also

Control Class | Kixforms Namespace


FontHeight Property

KiXforms.NET Class Library

Control.FontHeight Property

Gets the height (in pixels) of the font used by the control.

[Visual Basic]
Public ReadOnly Property FontHeight As Integer
[C#]
public int FontHeight {get;}

See Also

Control Class | Kixforms Namespace


FontName Property

KiXforms.NET Class Library

Control.FontName Property

Gets or sets the face name of the font used by the control.

[Visual Basic]
Public Property FontName As String
[C#]
public string FontName {get; set;}

See Also

Control Class | Kixforms Namespace


FontSize Property

KiXforms.NET Class Library

Control.FontSize Property

Gets or sets the size (in points) of the font used by the control.

[Visual Basic]
Public Property FontSize As Single
[C#]
public float FontSize {get; set;}

See Also

Control Class | Kixforms Namespace


ForeColor Property

KiXforms.NET Class Library

Control.ForeColor Property

Gets or sets the foreground color of the control.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}

See Also

Control Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Control.Height Property

Gets or sets the height of the control.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

See Also

Control Class | Kixforms Namespace


KeyDown Property

KiXforms.NET Class Library

Control.KeyDown Property

Gets or sets the code to execute when a key is pressed while the control has focus.

[Visual Basic]
Public Property KeyDown As String
[C#]
public string KeyDown {get; set;}

Remarks

The Event property receives a value of type KeyEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


KeyPress Property

KiXforms.NET Class Library

Control.KeyPress Property

Gets or sets the code to execute when a key is pressed while the control has focus.

[Visual Basic]
Public Property KeyPress As String
[C#]
public string KeyPress {get; set;}

Remarks

The Event property receives a value of type KeyPressEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


KeyUp Property

KiXforms.NET Class Library

Control.KeyUp Property

Gets or sets the code to execute when a key is released while the control has focus.

[Visual Basic]
Public Property KeyUp As String
[C#]
public string KeyUp {get; set;}

Remarks

The Event property receives a value of type KeyEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


Leave Property

KiXforms.NET Class Library

Control.Leave Property

Gets or sets the code to execute when input focus leaves the control.

[Visual Basic]
Public Property Leave As String
[C#]
public string Leave {get; set;}

See Also

Control Class | Kixforms Namespace


Left Property

KiXforms.NET Class Library

Control.Left Property

Gets or sets the x-coordinate of a control's left edge in pixels.

[Visual Basic]
Overridable Public Property Left As Integer
[C#]
public virtual int Left {get; set;}

See Also

Control Class | Kixforms Namespace


Location Property

KiXforms.NET Class Library

Control.Location Property

Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.

[Visual Basic]
Public Property Location As Point
[C#]
public Point Location {get; set;}

See Also

Control Class | Kixforms Namespace


LocationChanged Property

KiXforms.NET Class Library

Control.LocationChanged Property

Gets or sets the code to execute when the Location property value has changed.

[Visual Basic]
Public Property LocationChanged As String
[C#]
public string LocationChanged {get; set;}

See Also

Control Class | Kixforms Namespace


MouseButtons Property

KiXforms.NET Class Library

Control.MouseButtons Property

Gets a value indicating which of the mouse buttons is in a pressed state.

[Visual Basic]
Public ReadOnly Property MouseButtons As MouseButtons
[C#]
public MouseButtons MouseButtons {get;}

See Also

Control Class | Kixforms Namespace


MouseDown Property

KiXforms.NET Class Library

Control.MouseDown Property

Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.

[Visual Basic]
Public Property MouseDown As String
[C#]
public string MouseDown {get; set;}

Remarks

The Event property receives a value of type MouseEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


MouseEnter Property

KiXforms.NET Class Library

Control.MouseEnter Property

Gets or sets the code to execute when the mouse pointer enters the control.

[Visual Basic]
Public Property MouseEnter As String
[C#]
public string MouseEnter {get; set;}

See Also

Control Class | Kixforms Namespace


MouseHover Property

KiXforms.NET Class Library

Control.MouseHover Property

Gets or sets the code to execute when the mouse pointer hovers over the control.

[Visual Basic]
Public Property MouseHover As String
[C#]
public string MouseHover {get; set;}

See Also

Control Class | Kixforms Namespace


MouseLeave Property

KiXforms.NET Class Library

Control.MouseLeave Property

Gets or sets the code to execute when the mouse pointer leaves the control.

[Visual Basic]
Public Property MouseLeave As String
[C#]
public string MouseLeave {get; set;}

See Also

Control Class | Kixforms Namespace


MouseMove Property

KiXforms.NET Class Library

Control.MouseMove Property

Gets or sets the code to execute when the mouse pointer is moved over the control.

[Visual Basic]
Public Property MouseMove As String
[C#]
public string MouseMove {get; set;}

Remarks

The Event property receives a value of type MouseEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


MousePosition Property

KiXforms.NET Class Library

Control.MousePosition Property

Gets the position of the mouse cursor in screen coordinates.

[Visual Basic]
Public ReadOnly Property MousePosition As Point
[C#]
public Point MousePosition {get;}

See Also

Control Class | Kixforms Namespace


MouseUp Property

KiXforms.NET Class Library

Control.MouseUp Property

Occurs when the mouse pointer is over the control and a mouse button is released.

[Visual Basic]
Public Property MouseUp As String
[C#]
public string MouseUp {get; set;}

Remarks

The Event property receives a value of type MouseEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


Move Property

KiXforms.NET Class Library

Control.Move Property

Gets or sets the code to execute when the control is moved.

[Visual Basic]
Public Property Move As String
[C#]
public string Move {get; set;}

See Also

Control Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

Control.Name Property

Gets or sets the name of the control.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

See Also

Control Class | Kixforms Namespace


Paint Property

KiXforms.NET Class Library

Control.Paint Property

Gets or sets the code to execute when the control is redrawn.

[Visual Basic]
Public Property Paint As String
[C#]
public string Paint {get; set;}

Remarks

The Event property receives a value of type PaintEventArgs containing data related to this event.

See Also

Control Class | Kixforms Namespace


Parent Property

KiXforms.NET Class Library

Control.Parent Property

Gets or sets the parent container of the control.

[Visual Basic]
Overridable Public Property Parent As Object
[C#]
public virtual object Parent {get; set;}

See Also

Control Class | Kixforms Namespace


ProductName Property

KiXforms.NET Class Library

Control.ProductName Property

Gets the product name of the assembly containing the control.

[Visual Basic]
Public ReadOnly Property ProductName As String
[C#]
public string ProductName {get;}

See Also

Control Class | Kixforms Namespace


ProductVersion Property

KiXforms.NET Class Library

Control.ProductVersion Property

Gets the version of the assembly containing the control.

[Visual Basic]
Public ReadOnly Property ProductVersion As String
[C#]
public string ProductVersion {get;}

See Also

Control Class | Kixforms Namespace


Right Property

KiXforms.NET Class Library

Control.Right Property

Gets the distance between the right edge of the control and the left edge of its container.

[Visual Basic]
Public ReadOnly Property Right As Integer
[C#]
public int Right {get;}

See Also

Control Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Control.Size Property

Gets or sets the height and width of the control.

[Visual Basic]
Public Property Size As Size
[C#]
public Size Size {get; set;}

See Also

Control Class | Kixforms Namespace


SizeChanged Property

KiXforms.NET Class Library

Control.SizeChanged Property

Gets or sets the code to execute when the Size property value changes.

[Visual Basic]
Public Property SizeChanged As String
[C#]
public string SizeChanged {get; set;}

See Also

Control Class | Kixforms Namespace


TabIndex Property

KiXforms.NET Class Library

Control.TabIndex Property

Gets or sets the tab order of the control within its container.

[Visual Basic]
Public Property TabIndex As Integer
[C#]
public int TabIndex {get; set;}

See Also

Control Class | Kixforms Namespace


TabStop Property

KiXforms.NET Class Library

Control.TabStop Property

Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.

[Visual Basic]
Public Property TabStop As Boolean
[C#]
public bool TabStop {get; set;}

See Also

Control Class | Kixforms Namespace


Tag Property

KiXforms.NET Class Library

Control.Tag Property

Gets or sets the object that contains data about the control.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

Control Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

Control.Text Property

Gets or sets the text associated with this control.

[Visual Basic]
Overridable Public Property Text As String
[C#]
public virtual string Text {get; set;}

See Also

Control Class | Kixforms Namespace


TextChanged Property

KiXforms.NET Class Library

Control.TextChanged Property

Gets or sets the code to execute when the Text property changes.

[Visual Basic]
Public Property TextChanged As String
[C#]
public string TextChanged {get; set;}

See Also

Control Class | Kixforms Namespace


Top Property

KiXforms.NET Class Library

Control.Top Property

Gets or sets the y-coordinate of the control's top edge in pixels.

[Visual Basic]
Overridable Public Property Top As Integer
[C#]
public virtual int Top {get; set;}

See Also

Control Class | Kixforms Namespace


TopLevelControl Property

KiXforms.NET Class Library

Control.TopLevelControl Property

Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.

[Visual Basic]
Public ReadOnly Property TopLevelControl As Control
[C#]
public Control TopLevelControl {get;}

Property Value

The Control that represents the top-level control that contains the current control.

Remarks

The top-level control is defined as the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. For example, if the control is contained on an MDI child Form, then the top-level control is the Multiple Document Interface (MDI) parent Form.

See Also

Control Class | Kixforms Namespace


UseWaitCursor Property

KiXforms.NET Class Library

Control.UseWaitCursor Property

Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.

[Visual Basic]
Public Property UseWaitCursor As Boolean
[C#]
public bool UseWaitCursor {get; set;}

See Also

Control Class | Kixforms Namespace


Visible Property

KiXforms.NET Class Library

Control.Visible Property

Gets or sets a value indicating whether the control is displayed.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

Control Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

Control.Width Property

Gets or sets the width of the control.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

Control Class | Kixforms Namespace


Control Methods

The methods of the Control class are listed below. For a complete list of Control class members, see the Control Members topic.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront | Brings the control to the front of the z-order.
Center | Centers the control inside its container.
CreateControl | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl | Searches the ControlCollection for a control with the specified name.
FindForm | Retrieves the form that the control is on.
Focus | Sets input focus to the control.
GetChildAtPoint | Retrieves the child control that is located at the specified coordinates.
GetNextControl | Under development.
Hide | Conceals the control from the user.
Invalidate | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient | Computes the location of the specified screen point into client coordinates.
PointToScreen | Computes the location of the specified client point into screen coordinates.
Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage | Resets the BackgroundImage property to its default value.
ResumeLayout | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select | Activates a control.
SendToBack | Sends the control to the back of the z-order.
Show | Displays the control to the user.
SuspendLayout | Temporarily suspends the layout logic for the control.
Update | Causes the control to redraw the invalidated regions with its client area.

See Also

Control Class | Kixforms Namespace


Control.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

[Visual Basic]
Overridable Public Sub BeginUpdate()
[C#]
public virtual void BeginUpdate();

See Also

Control Class | Kixforms Namespace


Control.BringToFront Method

Brings the control to the front of the z-order.

[Visual Basic]
Public Sub BringToFront()
[C#]
public void BringToFront();

See Also

Control Class | Kixforms Namespace


Control.Center Method

Centers the control inside its container.

[Visual Basic]
Overridable Public Sub Center()
[C#]
public virtual void Center();

See Also

Control Class | Kixforms Namespace


Control.CreateControl Method

Forces the creation of the control, including the creation of the handle and any child controls.

[Visual Basic]
Public Sub CreateControl()
[C#]
public void CreateControl();

See Also

Control Class | Kixforms Namespace


Control.CreateGraphics Method

Creates the Graphics object for the control.

[Visual Basic]
Public Function CreateGraphics() As Graphics
[C#]
public Graphics CreateGraphics();

See Also

Control Class | Kixforms Namespace


Control.EndUpdate Method

Resumes drawing of the control after drawing is suspended by the BeginUpdate method.

[Visual Basic]
Overridable Public Sub EndUpdate()
[C#]
public virtual void EndUpdate();

See Also

Control Class | Kixforms Namespace


Control.FindControl Method

Searches the ControlCollection for a control with the specified name.

[Visual Basic]
Public Function FindControl( _
ByVal name As String _
) As Control
[C#]
public Control FindControl(
string name
);

Parameters

name
The name of the control.

See Also

Control Class | Kixforms Namespace


Control.FindForm Method

Retrieves the form that the control is on.

[Visual Basic]
Public Function FindForm() As Form
[C#]
public Form FindForm();

Return Value

The Form that the control is on.

See Also

Control Class | Kixforms Namespace


Control.Focus Method

Sets input focus to the control.

[Visual Basic]
Public Sub Focus()
[C#]
public void Focus();

See Also

Control Class | Kixforms Namespace


Control.GetChildAtPoint Method

Retrieves the child control that is located at the specified coordinates.

[Visual Basic]
Public Function GetChildAtPoint( _
ByVal pt As Point _
) As Control
[C#]
public Control GetChildAtPoint(
Point pt
);

Return Value

A Control that represents the control that is located at the specified point.

Remarks

If there is no child control at the specified point, the GetChildAtPoint method returns a null reference (Nothing in Visual Basic).

See Also

Control Class | Kixforms Namespace


Control.GetNextControl Method

Under development.

[Visual Basic]
Public Function GetNextControl( _
ByVal control As Control, _
ByVal forward As Boolean _
) As Control
[C#]
public Control GetNextControl(
Control control,
bool forward
);

See Also

Control Class | Kixforms Namespace


Control.Hide Method

Conceals the control from the user.

[Visual Basic]
Public Sub Hide()
[C#]
public void Hide();

See Also

Control Class | Kixforms Namespace


Control.Invalidate Method

Invalidates a specific region of the control and causes a paint message to be sent to the control.

[Visual Basic]
Public Sub Invalidate()
[C#]
public void Invalidate();

See Also

Control Class | Kixforms Namespace


Control.PointToClient Method

Computes the location of the specified screen point into client coordinates.

[Visual Basic]
Public Function PointToClient( _
ByVal p As Point _
) As Point
[C#]
public Point PointToClient(
Point p
);

Parameters

p
The screen coordinate Point to convert.

See Also

Control Class | Kixforms Namespace


Control.PointToScreen Method

Computes the location of the specified client point into screen coordinates.

[Visual Basic]
Public Function PointToScreen( _
ByVal p As Point _
) As Point
[C#]
public Point PointToScreen(
Point p
);

Parameters

p
The screen coordinate Point to convert.

See Also

Control Class | Kixforms Namespace


Control.Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

[Visual Basic]
Public Sub Refresh()
[C#]
public void Refresh();

See Also

Control Class | Kixforms Namespace


Control.ResetBackgroundImage Method

Resets the BackgroundImage property to its default value.

[Visual Basic]
Public Sub ResetBackgroundImage()
[C#]
public void ResetBackgroundImage();

See Also

Control Class | Kixforms Namespace


Control.ResumeLayout Method

Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.

[Visual Basic]
Public Sub ResumeLayout( _
Optional ByVal ResumeLayout As Boolean = False _
)
[C#]
public void ResumeLayout(
bool ResumeLayout
);

See Also

Control Class | Kixforms Namespace


Control.Select Method

Activates a control.

[Visual Basic]
Public Sub Select()
[C#]
public void Select();

See Also

Control Class | Kixforms Namespace


Control.SendToBack Method

Sends the control to the back of the z-order.

[Visual Basic]
Public Sub SendToBack()
[C#]
public void SendToBack();

See Also

Control Class | Kixforms Namespace


Control.Show Method

Displays the control to the user.

[Visual Basic]
Public Sub Show()
[C#]
public void Show();

See Also

Control Class | Kixforms Namespace


Control.SuspendLayout Method

Temporarily suspends the layout logic for the control.

[Visual Basic]
Public Sub SuspendLayout()
[C#]
public void SuspendLayout();

See Also

Control Class | Kixforms Namespace


Control.Update Method

Causes the control to redraw the invalidated regions with its client area.

[Visual Basic]
Public Sub Update()
[C#]
public void Update();

See Also

Control Class | Kixforms Namespace


ControlCollection Class

A collection of Control objects that represents all the controls contained within a control.

For a list of all members of this type, see ControlCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ControlCollection

[Visual Basic]
Public Class ControlCollection
Inherits CollectionBase
[C#]
public class ControlCollection : CollectionBase

Remarks

Use the Controls property to return the ControlCollection.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ControlCollection Members | Kixforms Namespace


ControlCollection Members

ControlCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the Control at the specified indexed location in the collection.

Public Instance Methods

Add | Adds the specified control to the control collection. Returns the control that was added to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines whether the specified control is a member of the collection.
Remove | Removes the specified control from the control collection.
RemoveAt | Removes a child control, at the specified index location, from the ControlCollection object.
SetChildIndex | Sets the index of the specified child control in the collection to the specified index value.

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection Properties

The properties of the ControlCollection class are listed below. For a complete list of ControlCollection class members, see the ControlCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the Control at the specified indexed location in the collection.

See Also

ControlCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ControlCollection.Item Property

Gets the Control at the specified indexed location in the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Control
[C#]
public Control this[
int index
] {get; set;}

Example

The following example sets the background color of the first control on $Form to blue.

$Form.Controls.Item(0).BackColor = $System.Color.Blue

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection Methods

The methods of the ControlCollection class are listed below. For a complete list of ControlCollection class members, see the ControlCollection Members topic.

Public Instance Methods

Add | Adds the specified control to the control collection. Returns the control that was added to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines whether the specified control is a member of the collection.
Remove | Removes the specified control from the control collection.
RemoveAt | Removes a child control, at the specified index location, from the ControlCollection object.
SetChildIndex | Sets the index of the specified child control in the collection to the specified index value.

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection.Add Method

Adds the specified control to the control collection. Returns the control that was added to the collection.

[Visual Basic]
Public Function Add( _
ByVal control As Control _
) As Control
[C#]
public Control Add(
Control control
);

Parameters

control
The control to add to the control collection.

Example

The following example adds a new button to $Form.

$Button = $Form.Controls.Add($System.Button())

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection.Contains Method

Determines whether the specified control is a member of the collection.

[Visual Basic]
Public Function Contains( _
ByVal control As Control _
) As Boolean
[C#]
public bool Contains(
Control control
);

Parameters

control
The Control to locate in the collection.

Return Value

True if the specified control exists in the collection; otherwise, false.

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection.Remove Method

Removes the specified control from the control collection.

[Visual Basic]
Public Sub Remove( _
ByVal control As Control _
)
[C#]
public void Remove(
Control control
);

Parameters

control

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection.RemoveAt Method

Removes a child control, at the specified index location, from the ControlCollection object.

[Visual Basic]
Overrides Public Sub RemoveAt( _
ByVal index As Integer _
) _
Implements IList.RemoveAt
[C#]
public override void RemoveAt(
int index
);

Parameters

index
The ordinal index of the server control to be removed from the collection.

Implements

IList.RemoveAt

See Also

ControlCollection Class | Kixforms Namespace


ControlCollection.SetChildIndex Method

Sets the index of the specified child control in the collection to the specified index value.

[Visual Basic]
Public Sub SetChildIndex( _
ByVal child As Control, _
ByVal index As Integer _
)
[C#]
public void SetChildIndex(
Control child,
int index
);

Parameters

child
The child Control to search for.
index
The new index value of the control.

See Also

ControlCollection Class | Kixforms Namespace


ControlEventArgs Class

Provides data for the ControlAdded and ControlRemoved events.

For a list of all members of this type, see ControlEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.ControlEventArgs

[Visual Basic]
Public Class ControlEventArgs
Inherits EventArgs
[C#]
public class ControlEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ControlEventArgs Members | Kixforms Namespace


ControlEventArgs Members

ControlEventArgs overview

Public Instance Properties

Control Gets the control object used by this event.

See Also

ControlEventArgs Class | Kixforms Namespace


ControlEventArgs Properties

The properties of the ControlEventArgs class are listed below. For a complete list of ControlEventArgs class members, see the ControlEventArgs Members topic.

Public Instance Properties

Control Gets the control object used by this event.

See Also

ControlEventArgs Class | Kixforms Namespace


Control Property

KiXforms.NET Class Library

ControlEventArgs.Control Property

Gets the control object used by this event.

[Visual Basic]
Public Property Control As Control
[C#]
public Control Control {get; set;}

See Also

ControlEventArgs Class | Kixforms Namespace


Cursor Class

Represents the image used to paint the mouse pointer.

For a list of all members of this type, see Cursor Members.

System.Object
Kixforms.Cursor

[Visual Basic]
Public Class Cursor
[C#]
public class Cursor

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Cursor Members | Kixforms Namespace


Cursor Members

Cursor overview

Public Instance Properties

Current | Gets or sets a cursor object that represents the mouse cursor.
Position | Gets or sets the cursor's position.
Size | Gets the size of the cursor object.

See Also

Cursor Class | Kixforms Namespace


Cursor Properties

The properties of the Cursor class are listed below. For a complete list of Cursor class members, see the Cursor Members topic.

Public Instance Properties

Current | Gets or sets a cursor object that represents the mouse cursor.
Position | Gets or sets the cursor's position.
Size | Gets the size of the cursor object.

See Also

Cursor Class | Kixforms Namespace


Current Property

KiXforms.NET Class Library

Cursor.Current Property

Gets or sets a cursor object that represents the mouse cursor.

[Visual Basic]
Public Property Current As Cursor
[C#]
public Cursor Current {get; set;}

See Also

Cursor Class | Kixforms Namespace


Position Property

KiXforms.NET Class Library

Cursor.Position Property

Gets or sets the cursor's position.

[Visual Basic]
Public Property Position As Point
[C#]
public Point Position {get; set;}

See Also

Cursor Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Cursor.Size Property

Gets the size of the cursor object.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}

Property Value

A Size object that represents the width and height of the Cursor.

See Also

Cursor Class | Kixforms Namespace


Cursors Class

Provides a collection of Cursor objects for use by a Windows Forms application.

For a list of all members of this type, see Cursors Members.

System.Object
Kixforms.Cursors

[Visual Basic]
Public Class Cursors
[C#]
public class Cursors

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Cursors Members | Kixforms Namespace


Cursors Members

Cursors overview

Public Instance Properties

AppStarting | Gets the cursor that appears when an application starts.
Arrow |
Cross |
Default |
Hand |
Help |
HSplit |
IBeam |
No |
NoMove2D |
NoMoveHoriz |
NoMoveVert |
PanEast |
PanNE |
PanNorth |
PanNW |
PanSE |
PanSouth |
PanSW |
PanWest |
SizeAll |
SizeNESW |
SizeNS |
SizeNWSE |
SizeWE |
UpArrow |
VSplit |
WaitCursor |

See Also

Cursors Class | Kixforms Namespace


Cursors Properties

The properties of the Cursors class are listed below. For a complete list of Cursors class members, see the Cursors Members topic.

Public Instance Properties

AppStarting | Gets the cursor that appears when an application starts.
Arrow |
Cross |
Default |
Hand |
Help |
HSplit |
IBeam |
No |
NoMove2D |
NoMoveHoriz |
NoMoveVert |
PanEast |
PanNE |
PanNorth |
PanNW |
PanSE |
PanSouth |
PanSW |
PanWest |
SizeAll |
SizeNESW |
SizeNS |
SizeNWSE |
SizeWE |
UpArrow |
VSplit |
WaitCursor |

See Also

Cursors Class | Kixforms Namespace


AppStarting Property

KiXforms.NET Class Library

Cursors.AppStarting Property

Gets the cursor that appears when an application starts.

[Visual Basic]
Public ReadOnly Property AppStarting As Cursor
[C#]
public Cursor AppStarting {get;}

See Also

Cursors Class | Kixforms Namespace


Arrow Property

KiXforms.NET Class Library

Cursors.Arrow Property

[Visual Basic]
Public ReadOnly Property Arrow As Cursor
[C#]
public Cursor Arrow {get;}

See Also

Cursors Class | Kixforms Namespace


Cross Property

KiXforms.NET Class Library

Cursors.Cross Property

[Visual Basic]
Public ReadOnly Property Cross As Cursor
[C#]
public Cursor Cross {get;}

See Also

Cursors Class | Kixforms Namespace


Default Property

KiXforms.NET Class Library

Cursors.Default Property

[Visual Basic]
Public ReadOnly Property Default As Cursor
[C#]
public Cursor Default {get;}

See Also

Cursors Class | Kixforms Namespace


Hand Property

KiXforms.NET Class Library

Cursors.Hand Property

[Visual Basic]
Public ReadOnly Property Hand As Cursor
[C#]
public Cursor Hand {get;}

See Also

Cursors Class | Kixforms Namespace


Help Property

KiXforms.NET Class Library

Cursors.Help Property

[Visual Basic]
Public ReadOnly Property Help As Cursor
[C#]
public Cursor Help {get;}

See Also

Cursors Class | Kixforms Namespace


HSplit Property

KiXforms.NET Class Library

Cursors.HSplit Property

[Visual Basic]
Public ReadOnly Property HSplit As Cursor
[C#]
public Cursor HSplit {get;}

See Also

Cursors Class | Kixforms Namespace


IBeam Property

KiXforms.NET Class Library

Cursors.IBeam Property

[Visual Basic]
Public ReadOnly Property IBeam As Cursor
[C#]
public Cursor IBeam {get;}

See Also

Cursors Class | Kixforms Namespace


No Property

KiXforms.NET Class Library

Cursors.No Property

[Visual Basic]
Public ReadOnly Property No As Cursor
[C#]
public Cursor No {get;}

See Also

Cursors Class | Kixforms Namespace


NoMove2D Property

KiXforms.NET Class Library

Cursors.NoMove2D Property

[Visual Basic]
Public ReadOnly Property NoMove2D As Cursor
[C#]
public Cursor NoMove2D {get;}

See Also

Cursors Class | Kixforms Namespace


NoMoveHoriz Property

KiXforms.NET Class Library

Cursors.NoMoveHoriz Property

[Visual Basic]
Public ReadOnly Property NoMoveHoriz As Cursor
[C#]
public Cursor NoMoveHoriz {get;}

See Also

Cursors Class | Kixforms Namespace


NoMoveVert Property

KiXforms.NET Class Library

Cursors.NoMoveVert Property

[Visual Basic]
Public ReadOnly Property NoMoveVert As Cursor
[C#]
public Cursor NoMoveVert {get;}

See Also

Cursors Class | Kixforms Namespace


PanEast Property

KiXforms.NET Class Library

Cursors.PanEast Property

[Visual Basic]
Public ReadOnly Property PanEast As Cursor
[C#]
public Cursor PanEast {get;}

See Also

Cursors Class | Kixforms Namespace


PanNE Property

KiXforms.NET Class Library

Cursors.PanNE Property

[Visual Basic]
Public ReadOnly Property PanNE As Cursor
[C#]
public Cursor PanNE {get;}

See Also

Cursors Class | Kixforms Namespace


PanNorth Property

KiXforms.NET Class Library

Cursors.PanNorth Property

[Visual Basic]
Public ReadOnly Property PanNorth As Cursor
[C#]
public Cursor PanNorth {get;}

See Also

Cursors Class | Kixforms Namespace


PanNW Property

KiXforms.NET Class Library

Cursors.PanNW Property

[Visual Basic]
Public ReadOnly Property PanNW As Cursor
[C#]
public Cursor PanNW {get;}

See Also

Cursors Class | Kixforms Namespace


PanSE Property

KiXforms.NET Class Library

Cursors.PanSE Property

[Visual Basic]
Public ReadOnly Property PanSE As Cursor
[C#]
public Cursor PanSE {get;}

See Also

Cursors Class | Kixforms Namespace


PanSouth Property

KiXforms.NET Class Library

Cursors.PanSouth Property

[Visual Basic]
Public ReadOnly Property PanSouth As Cursor
[C#]
public Cursor PanSouth {get;}

See Also

Cursors Class | Kixforms Namespace


PanSW Property

KiXforms.NET Class Library

Cursors.PanSW Property

[Visual Basic]
Public ReadOnly Property PanSW As Cursor
[C#]
public Cursor PanSW {get;}

See Also

Cursors Class | Kixforms Namespace


PanWest Property

KiXforms.NET Class Library

Cursors.PanWest Property

[Visual Basic]
Public ReadOnly Property PanWest As Cursor
[C#]
public Cursor PanWest {get;}

See Also

Cursors Class | Kixforms Namespace


SizeAll Property

KiXforms.NET Class Library

Cursors.SizeAll Property

[Visual Basic]
Public ReadOnly Property SizeAll As Cursor
[C#]
public Cursor SizeAll {get;}

See Also

Cursors Class | Kixforms Namespace


SizeNESW Property

KiXforms.NET Class Library

Cursors.SizeNESW Property

[Visual Basic]
Public ReadOnly Property SizeNESW As Cursor
[C#]
public Cursor SizeNESW {get;}

See Also

Cursors Class | Kixforms Namespace


SizeNS Property

KiXforms.NET Class Library

Cursors.SizeNS Property

[Visual Basic]
Public ReadOnly Property SizeNS As Cursor
[C#]
public Cursor SizeNS {get;}

See Also

Cursors Class | Kixforms Namespace


SizeNWSE Property

KiXforms.NET Class Library

Cursors.SizeNWSE Property

[Visual Basic]
Public ReadOnly Property SizeNWSE As Cursor
[C#]
public Cursor SizeNWSE {get;}

See Also

Cursors Class | Kixforms Namespace


SizeWE Property

KiXforms.NET Class Library

Cursors.SizeWE Property

[Visual Basic]
Public ReadOnly Property SizeWE As Cursor
[C#]
public Cursor SizeWE {get;}

See Also

Cursors Class | Kixforms Namespace


UpArrow Property

KiXforms.NET Class Library

Cursors.UpArrow Property

[Visual Basic]
Public ReadOnly Property UpArrow As Cursor
[C#]
public Cursor UpArrow {get;}

See Also

Cursors Class | Kixforms Namespace


VSplit Property

KiXforms.NET Class Library

Cursors.VSplit Property

[Visual Basic]
Public ReadOnly Property VSplit As Cursor
[C#]
public Cursor VSplit {get;}

See Also

Cursors Class | Kixforms Namespace


WaitCursor Property

KiXforms.NET Class Library

Cursors.WaitCursor Property

[Visual Basic]
Public ReadOnly Property WaitCursor As Cursor
[C#]
public Cursor WaitCursor {get;}

See Also

Cursors Class | Kixforms Namespace


DataCollectionBase Class

Under development.

For a list of all members of this type, see DataCollectionBase Members.

System.Object
Kixforms.DataCollectionBase

[Visual Basic]
Public Class DataCollectionBase
Implements ICollection, IEnumerable
[C#]
public class DataCollectionBase : ICollection, IEnumerable

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataCollectionBase Members | Kixforms Namespace


DataCollectionBase Members

DataCollectionBase overview

Public Instance Properties

Count | Gets the total number of elements in a collection.
IsSynchronized |

See Also

DataCollectionBase Class | Kixforms Namespace


DataCollectionBase Properties

The properties of the DataCollectionBase class are listed below. For a complete list of DataCollectionBase class members, see the DataCollectionBase Members topic.

Public Instance Properties

Count | Gets the total number of elements in a collection.
IsSynchronized |

See Also

DataCollectionBase Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

DataCollectionBase.Count Property

Gets the total number of elements in a collection.

[Visual Basic]
Overridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public virtual int Count {get;}

Implements

ICollection.Count

See Also

DataCollectionBase Class | Kixforms Namespace


IsSynchronized Property

KiXforms.NET Class Library

DataCollectionBase.IsSynchronized Property

[Visual Basic]
Overridable Public ReadOnly Property IsSynchronized As Boolean _
Implements ICollection.IsSynchronized
[C#]
public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

DataCollectionBase Class | Kixforms Namespace


DataColumn Class

Under development.

For a list of all members of this type, see DataColumn Members.

System.Object
Kixforms.DataColumn

[Visual Basic]
Public Class DataColumn
[C#]
public class DataColumn

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataColumn Members | Kixforms Namespace


DataColumn Members

DataColumn overview

Public Instance Constructors

DataColumn Constructor Initializes a new instance of the DataColumn class.

Public Instance Properties

AutoIncrement | Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.
Caption | Gets or sets the caption for the column.
ColumnName | Gets or sets the name of the column in the DataColumnCollection.
DataType | Gets or sets the type of data stored in the column.
DefaultValue | Gets or sets the default value for the column when creating new rows.
Ordinal | Gets the position of the column in the DataColumnCollection collection.
ReadOnly | Gets or sets a value indicating whether the column allows changes once a row has been added to the table.
Table | Gets the DataTable to which the column belongs to.

See Also

DataColumn Class | Kixforms Namespace


DataColumn Constructor

Initializes a new instance of the DataColumn class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal ColumnName As String = "Nothing", _
Optional ByVal DataType As String = "Nothing" _
)
[C#]
public DataColumn(
string ColumnName,
string DataType
);

See Also

DataColumn Class | Kixforms Namespace


DataColumn Properties

The properties of the DataColumn class are listed below. For a complete list of DataColumn class members, see the DataColumn Members topic.

Public Instance Properties

AutoIncrement | Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.
Caption | Gets or sets the caption for the column.
ColumnName | Gets or sets the name of the column in the DataColumnCollection.
DataType | Gets or sets the type of data stored in the column.
DefaultValue | Gets or sets the default value for the column when creating new rows.
Ordinal | Gets the position of the column in the DataColumnCollection collection.
ReadOnly | Gets or sets a value indicating whether the column allows changes once a row has been added to the table.
Table | Gets the DataTable to which the column belongs to.

See Also

DataColumn Class | Kixforms Namespace


AutoIncrement Property

KiXforms.NET Class Library

DataColumn.AutoIncrement Property

Gets or sets a value indicating whether the column automatically increments the value of the column for new rows added to the table.

[Visual Basic]
Public Property AutoIncrement As Boolean
[C#]
public bool AutoIncrement {get; set;}

Property Value

True if the value of the column increments automatically; otherwise, false. The default is false.

See Also

DataColumn Class | Kixforms Namespace


Caption Property

KiXforms.NET Class Library

DataColumn.Caption Property

Gets or sets the caption for the column.

[Visual Basic]
Public Property Caption As String
[C#]
public string Caption {get; set;}

Property Value

The caption of the column. If not set, returns the ColumnName value.

See Also

DataColumn Class | Kixforms Namespace


ColumnName Property

KiXforms.NET Class Library

DataColumn.ColumnName Property

Gets or sets the name of the column in the DataColumnCollection.

[Visual Basic]
Public Property ColumnName As String
[C#]
public string ColumnName {get; set;}

Property Value

The name of the column.

See Also

DataColumn Class | Kixforms Namespace


DataType Property

KiXforms.NET Class Library

DataColumn.DataType Property

Gets or sets the type of data stored in the column.

[Visual Basic]
Public Property DataType As String
[C#]
public string DataType {get; set;}

Property Value

A Type object that represents the column data type.

See Also

DataColumn Class | Kixforms Namespace


DefaultValue Property

KiXforms.NET Class Library

DataColumn.DefaultValue Property

Gets or sets the default value for the column when creating new rows.

[Visual Basic]
Public Property DefaultValue As Object
[C#]
public object DefaultValue {get; set;}

Property Value

A value appropriate to the column's DataType.

See Also

DataColumn Class | Kixforms Namespace


Ordinal Property

KiXforms.NET Class Library

DataColumn.Ordinal Property

Gets the position of the column in the DataColumnCollection collection.

[Visual Basic]
Public ReadOnly Property Ordinal As Integer
[C#]
public int Ordinal {get;}

Property Value

The position of the column. Gets -1 if the column is not a member of a collection.

See Also

DataColumn Class | Kixforms Namespace


ReadOnly Property

KiXforms.NET Class Library

DataColumn.ReadOnly Property

Gets or sets a value indicating whether the column allows changes once a row has been added to the table.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}

Property Value

True if the column is read only; otherwise, false. The default is false.

See Also

DataColumn Class | Kixforms Namespace


Table Property

KiXforms.NET Class Library

DataColumn.Table Property

Gets the DataTable to which the column belongs to.

[Visual Basic]
Public ReadOnly Property Table As DataTable
[C#]
public DataTable Table {get;}

Property Value

The DataTable that the DataColumn belongs to.

See Also

DataColumn Class | Kixforms Namespace


DataColumnCollection Class

Under development.

For a list of all members of this type, see DataColumnCollection Members.

System.Object
Kixforms.DataColumnCollection

[Visual Basic]
Public Class DataColumnCollection
Implements ICollection, IEnumerable, IEnumerator
[C#]
public class DataColumnCollection : ICollection, IEnumerable, IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataColumnCollection Members | Kixforms Namespace


DataColumnCollection Members

DataColumnCollection overview

Public Instance Properties

Count | Gets the total number of columns in a collection.
Item | Gets the specified DataColumn from the collection.

Public Instance Methods

Add | Creates and adds the specified DataColumn object to the DataColumnCollection.
AddItem | Creates and adds a DataColumn object with the specified name to the DataColumnCollection.
Clear | Clears the collection of any columns.
GetEnumerator |
Remove | Removes a DataColumn object from the collection.
RemoveAt | Removes the column at the specified index from the collection.

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection Properties

The properties of the DataColumnCollection class are listed below. For a complete list of DataColumnCollection class members, see the DataColumnCollection Members topic.

Public Instance Properties

Count | Gets the total number of columns in a collection.
Item | Gets the specified DataColumn from the collection.

See Also

DataColumnCollection Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

DataColumnCollection.Count Property

Gets the total number of columns in a collection.

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Property Value

The total number of columns in a collection.

Implements

ICollection.Count

See Also

DataColumnCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

DataColumnCollection.Item Property

Gets the specified DataColumn from the collection.

[Visual Basic]
Public Default Property Item( _
ByVal Index As Integer _
) As DataColumn
[C#]
public DataColumn this[
int Index
] {get; set;}

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection Methods

The methods of the DataColumnCollection class are listed below. For a complete list of DataColumnCollection class members, see the DataColumnCollection Members topic.

Public Instance Methods

Add | Creates and adds the specified DataColumn object to the DataColumnCollection.
AddItem | Creates and adds a DataColumn object with the specified name to the DataColumnCollection.
Clear | Clears the collection of any columns.
GetEnumerator |
Remove | Removes a DataColumn object from the collection.
RemoveAt | Removes the column at the specified index from the collection.

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.Add Method

Creates and adds the specified DataColumn object to the DataColumnCollection.

[Visual Basic]
Public Function Add( _
ByVal item As DataColumn _
) As DataColumn
[C#]
public DataColumn Add(
DataColumn item
);

Parameters

item
The DataColumn to add.

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.AddItem Method

Creates and adds a DataColumn object with the specified name to the DataColumnCollection.

[Visual Basic]
Public Function AddItem( _
ByVal name As String _
) As DataColumn
[C#]
public DataColumn AddItem(
string name
);

Parameters

name
The ColumnName to use when cretaing the column.

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.Clear Method

Clears the collection of any columns.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.Remove Method

Removes a DataColumn object from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal DataColumn As DataColumn _
)
[C#]
public void Remove(
DataColumn DataColumn
);

See Also

DataColumnCollection Class | Kixforms Namespace


DataColumnCollection.RemoveAt Method

Removes the column at the specified index from the collection.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
public void RemoveAt(
int index
);

Parameters

index
The index of the column to remove.

See Also

DataColumnCollection Class | Kixforms Namespace


DataGrid Class

Under development.

For a list of all members of this type, see DataGrid Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.DataGrid

[Visual Basic]
Public Class DataGrid
Inherits Control
[C#]
public class DataGrid : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataGrid Members | Kixforms Namespace


DataGrid Members

DataGrid overview

Public Instance Constructors

DataGrid Constructor Initializes a new instance of the DataGrid class.

Public Instance Properties

AllowSorting | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundColor | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CaptionBackColor | Gets or sets the background color of the caption area.
CaptionText | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
CurrentCell | Gets or sets which cell has the focus.
CurrentCellChanged |
CurrentRowIndex | Gets or sets index of the selected row.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataMember | Gets or sets the specific list in a DataSource for which the DataGrid control displays a grid.
DataSource | Gets or sets the data source that the grid is displaying data for.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is in read-only mode.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetCurrentCellBounds | Gets a Rectangle that specifies the four corners of the selected cell.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
IsSelected | Gets a value indicating whether a specified row is selected.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetDataBinding | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

DataGrid Class | Kixforms Namespace


DataGrid Constructor

Initializes a new instance of the DataGrid class.

[Visual Basic]
Public Sub New()
[C#]
public DataGrid();

See Also

DataGrid Class | Kixforms Namespace


DataGrid Properties

The properties of the DataGrid class are listed below. For a complete list of DataGrid class members, see the DataGrid Members topic.

Public Instance Properties

AllowSorting | Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundColor | Gets or sets the color of the non-row area of the grid.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CaptionBackColor | Gets or sets the background color of the caption area.
CaptionText | Gets or sets the text of the grid's window caption.
CaptionVisible | Gets or sets a value that indicates whether the grid's caption is visible.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
CurrentCell | Gets or sets which cell has the focus.
CurrentCellChanged |
CurrentRowIndex | Gets or sets index of the selected row.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataMember | Gets or sets the specific list in a DataSource for which the DataGrid control displays a grid.
DataSource | Gets or sets the data source that the grid is displaying data for.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the grid is in read-only mode.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TableStyles | Gets the collection of DataGridTableStyle objects for the grid.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

DataGrid Class | Kixforms Namespace


AllowSorting Property

KiXforms.NET Class Library

DataGrid.AllowSorting Property

Gets or sets a value indicating whether the grid can be resorted by clicking on a column header.

[Visual Basic]
Public Property AllowSorting As Boolean
[C#]
public bool AllowSorting {get; set;}

Property Value

True if columns can be sorted; otherwise, false.

See Also

DataGrid Class | Kixforms Namespace


BackgroundColor Property

KiXforms.NET Class Library

DataGrid.BackgroundColor Property

Gets or sets the color of the non-row area of the grid.

[Visual Basic]
Public Property BackgroundColor As Color
[C#]
public Color BackgroundColor {get; set;}

Property Value

A Color that represents the color of the grid's background. The default is the AppWorkspace color.

Remarks

The BackgroundColor determines the color of the nonrow area of the grid, which is only visible when no table is displayed by the DataGrid, or if the grid is scrolled to the bottom, or if only a few rows are contained in the grid.

See Also

DataGrid Class | Kixforms Namespace


CaptionBackColor Property

KiXforms.NET Class Library

DataGrid.CaptionBackColor Property

Gets or sets the background color of the caption area.

[Visual Basic]
Public Property CaptionBackColor As Color
[C#]
public Color CaptionBackColor {get; set;}

Property Value

A Color that represents the caption's background color. The default is ActiveCaption color.

See Also

DataGrid Class | Kixforms Namespace


CaptionText Property

KiXforms.NET Class Library

DataGrid.CaptionText Property

Gets or sets the text of the grid's window caption.

[Visual Basic]
Public Property CaptionText As String
[C#]
public string CaptionText {get; set;}

Property Value

A string to be displayed as the grid's window caption. The default is an empty string ("").

See Also

DataGrid Class | Kixforms Namespace


CaptionVisible Property

KiXforms.NET Class Library

DataGrid.CaptionVisible Property

Gets or sets a value that indicates whether the grid's caption is visible.

[Visual Basic]
Public Property CaptionVisible As Boolean
[C#]
public bool CaptionVisible {get; set;}

Property Value

True if the caption is visible; otherwise, false. The default is true.

Remarks

If CaptionVisible is false, the Back button, ParentRow button, and caption will not be seen. Because navigation is limited, links to child tables will also not be visible and AllowNavigation will be set to None.

See Also

DataGrid Class | Kixforms Namespace


CurrentCell Property

KiXforms.NET Class Library

DataGrid.CurrentCell Property

Gets or sets which cell has the focus.

[Visual Basic]
Public Property CurrentCell As DataGridCell
[C#]
public DataGridCell CurrentCell {get; set;}

Property Value

The DataGridCell with the focus.

See Also

DataGrid Class | Kixforms Namespace


CurrentCellChanged Property

KiXforms.NET Class Library

DataGrid.CurrentCellChanged Property

[Visual Basic]
Public Property CurrentCellChanged As String
[C#]
public string CurrentCellChanged {get; set;}

Property Value

See Also

DataGrid Class | Kixforms Namespace


CurrentRowIndex Property

KiXforms.NET Class Library

DataGrid.CurrentRowIndex Property

Gets or sets index of the selected row.

[Visual Basic]
Public Property CurrentRowIndex As Integer
[C#]
public int CurrentRowIndex {get; set;}

Property Value

The zero-based index of the selected row.

See Also

DataGrid Class | Kixforms Namespace


DataMember Property

KiXforms.NET Class Library

DataGrid.DataMember Property

Gets or sets the specific list in a DataSource for which the DataGrid control displays a grid.

[Visual Basic]
Public Property DataMember As String
[C#]
public string DataMember {get; set;}

Property Value

A list in a DataSource The default is an empty string ("").

See Also

DataGrid Class | Kixforms Namespace


DataSource Property

KiXforms.NET Class Library

DataGrid.DataSource Property

Gets or sets the data source that the grid is displaying data for.

[Visual Basic]
Public Property DataSource As Object
[C#]
public object DataSource {get; set;}

Property Value

An object that functions as a data source.

See Also

DataGrid Class | Kixforms Namespace


ReadOnly Property

KiXforms.NET Class Library

DataGrid.ReadOnly Property

Gets or sets a value indicating whether the grid is in read-only mode.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}

Property Value

True if the grid is in read-only mode; otherwise, false. The default is false.

See Also

DataGrid Class | Kixforms Namespace


TableStyles Property

KiXforms.NET Class Library

DataGrid.TableStyles Property

Gets the collection of DataGridTableStyle objects for the grid.

[Visual Basic]
Public ReadOnly Property TableStyles As GridTableStylesCollection
[C#]
public GridTableStylesCollection TableStyles {get;}

See Also

DataGrid Class | Kixforms Namespace


DataGrid Methods

The methods of the DataGrid class are listed below. For a complete list of DataGrid class members, see the DataGrid Members topic.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetCurrentCellBounds | Gets a Rectangle that specifies the four corners of the selected cell.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
IsSelected | Gets a value indicating whether a specified row is selected.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetDataBinding | Sets the DataSource and DataMember properties at run time.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

DataGrid Class | Kixforms Namespace


DataGrid.GetCurrentCellBounds Method

Gets a Rectangle that specifies the four corners of the selected cell.

[Visual Basic]
Public Function GetCurrentCellBounds() As Rectangle
[C#]
public Rectangle GetCurrentCellBounds();

Return Value

A Rectangle that defines the current cell's corners.

See Also

DataGrid Class | Kixforms Namespace


DataGrid.IsSelected Method

Gets a value indicating whether a specified row is selected.

[Visual Basic]
Public Function IsSelected( _
ByVal row As Integer _
) As Boolean
[C#]
public bool IsSelected(
int row
);

Parameters

row
The number of the row you interested in.

Return Value

True if the row is selected; otherwise, false.

See Also

DataGrid Class | Kixforms Namespace


DataGrid.SetDataBinding Method

Sets the DataSource and DataMember properties at run time.

[Visual Basic]
Public Function SetDataBinding( _
ByVal source As Object, _
Optional ByVal member As String = "Nothing" _
) As Object
[C#]
public object SetDataBinding(
object source,
string member
);

See Also

DataGrid Class | Kixforms Namespace


DataGridCell Class

Under development.

For a list of all members of this type, see DataGridCell Members.

System.Object
Kixforms.DataGridCell

[Visual Basic]
Public Class DataGridCell
[C#]
public class DataGridCell

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataGridCell Members | Kixforms Namespace


DataGridCell Members

DataGridCell overview

Public Instance Constructors

DataGridCell Constructor Initializes a new instance of the DataGridCell class.

Public Instance Properties

ColumnNumber | Gets or sets the number of a column in the DataGrid control.
RowNumber | Gets or sets the number of a row in the DataGrid control.

See Also

DataGridCell Class | Kixforms Namespace


DataGridCell Constructor

Initializes a new instance of the DataGridCell class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal RowNumber As Integer = 0, _
Optional ByVal ColumnNumber As Integer = 0 _
)
[C#]
public DataGridCell(
int RowNumber,
int ColumnNumber
);

See Also

DataGridCell Class | Kixforms Namespace


DataGridCell Properties

The properties of the DataGridCell class are listed below. For a complete list of DataGridCell class members, see the DataGridCell Members topic.

Public Instance Properties

ColumnNumber | Gets or sets the number of a column in the DataGrid control.
RowNumber | Gets or sets the number of a row in the DataGrid control.

See Also

DataGridCell Class | Kixforms Namespace


ColumnNumber Property

KiXforms.NET Class Library

DataGridCell.ColumnNumber Property

Gets or sets the number of a column in the DataGrid control.

[Visual Basic]
Public Property ColumnNumber As Integer
[C#]
public int ColumnNumber {get; set;}

Property Value

The number of the column.

See Also

DataGridCell Class | Kixforms Namespace


RowNumber Property

KiXforms.NET Class Library

DataGridCell.RowNumber Property

Gets or sets the number of a row in the DataGrid control.

[Visual Basic]
Public Property RowNumber As Integer
[C#]
public int RowNumber {get; set;}

Property Value

The number of the row.

See Also

DataGridCell Class | Kixforms Namespace


DataGridColumnStyle Class

Specifies the appearance and text formatting and behavior of a DataGrid control column. This class is abstract.

For a list of all members of this type, see DataGridColumnStyle Members.

System.Object
Kixforms.Component
Kixforms.DataGridColumnStyle

[Visual Basic]
Public Class DataGridColumnStyle
Inherits Component
[C#]
public class DataGridColumnStyle : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataGridColumnStyle Members | Kixforms Namespace


DataGridColumnStyle Members

DataGridColumnStyle overview

Public Instance Constructors

DataGridColumnStyle Constructor Initializes a new instance of the DataGridColumnStyle class.

Public Instance Properties

Alignment | Gets or sets the alignment of text in a column.
HeaderText | Gets or sets the text of the column header.
MappingName | Gets or sets the name used to map the column style to a data member.
Type (inherited from Component) | Gets the Type of the current instance.
Width | Gets or sets the width of the column.

Public Instance Methods

Dispose (inherited from Component) Releases the resources used by the Component.

See Also

DataGridColumnStyle Class | Kixforms Namespace


DataGridColumnStyle Constructor

Initializes a new instance of the DataGridColumnStyle class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataGridColumnStyle();

See Also

DataGridColumnStyle Class | Kixforms Namespace


DataGridColumnStyle Properties

The properties of the DataGridColumnStyle class are listed below. For a complete list of DataGridColumnStyle class members, see the DataGridColumnStyle Members topic.

Public Instance Properties

Alignment | Gets or sets the alignment of text in a column.
HeaderText | Gets or sets the text of the column header.
MappingName | Gets or sets the name used to map the column style to a data member.
Type (inherited from Component) | Gets the Type of the current instance.
Width | Gets or sets the width of the column.

See Also

DataGridColumnStyle Class | Kixforms Namespace


Alignment Property

KiXforms.NET Class Library

DataGridColumnStyle.Alignment Property

Gets or sets the alignment of text in a column.

[Visual Basic]
Public Property Alignment As HorizontalAlignment
[C#]
public HorizontalAlignment Alignment {get; set;}

Property Value

One of the HorizontalAlignment values. The default is Left.

See Also

DataGridColumnStyle Class | Kixforms Namespace


HeaderText Property

KiXforms.NET Class Library

DataGridColumnStyle.HeaderText Property

Gets or sets the text of the column header.

[Visual Basic]
Public Property HeaderText As String
[C#]
public string HeaderText {get; set;}

Property Value

A string that is displayed as the column header.

See Also

DataGridColumnStyle Class | Kixforms Namespace


MappingName Property

KiXforms.NET Class Library

DataGridColumnStyle.MappingName Property

Gets or sets the name used to map the column style to a data member.

[Visual Basic]
Public Property MappingName As String
[C#]
public string MappingName {get; set;}

Property Value

The name used to map the column style to a data member.

See Also

DataGridColumnStyle Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

DataGridColumnStyle.Width Property

Gets or sets the width of the column.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

Property Value

The width of the column in pixels.

See Also

DataGridColumnStyle Class | Kixforms Namespace


DataGridTableStyle Class

Represents the table drawn by the DataGrid control at run time.

For a list of all members of this type, see DataGridTableStyle Members.

System.Object
Kixforms.Component
Kixforms.DataGridTableStyle

[Visual Basic]
Public Class DataGridTableStyle
Inherits Component
[C#]
public class DataGridTableStyle : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataGridTableStyle Members | Kixforms Namespace


DataGridTableStyle Members

DataGridTableStyle overview

Public Instance Constructors

DataGridTableStyle Constructor Initializes a new instance of the DataGridTableStyle class.

Public Instance Properties

GridColumnStyles | Gets the collection of columns drawn for this table.
MappingName | Gets or sets the name used to map this table to a specific data source.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) Releases the resources used by the Component.

See Also

DataGridTableStyle Class | Kixforms Namespace


DataGridTableStyle Constructor

Initializes a new instance of the DataGridTableStyle class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataGridTableStyle();

See Also

DataGridTableStyle Class | Kixforms Namespace


DataGridTableStyle Properties

The properties of the DataGridTableStyle class are listed below. For a complete list of DataGridTableStyle class members, see the DataGridTableStyle Members topic.

Public Instance Properties

GridColumnStyles | Gets the collection of columns drawn for this table.
MappingName | Gets or sets the name used to map this table to a specific data source.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

DataGridTableStyle Class | Kixforms Namespace


GridColumnStyles Property

KiXforms.NET Class Library

DataGridTableStyle.GridColumnStyles Property

Gets the collection of columns drawn for this table.

[Visual Basic]
Public ReadOnly Property GridColumnStyles As GridColumnStylesCollection
[C#]
public GridColumnStylesCollection GridColumnStyles {get;}

Property Value

A GridColumnStylesCollection that contains all DataGridColumnStyle objects for the table.

See Also

DataGridTableStyle Class | Kixforms Namespace


MappingName Property

KiXforms.NET Class Library

DataGridTableStyle.MappingName Property

Gets or sets the name used to map this table to a specific data source.

[Visual Basic]
Public Property MappingName As String
[C#]
public string MappingName {get; set;}

Property Value

The name used to map this grid to a specific data source.

See Also

DataGridTableStyle Class | Kixforms Namespace


DataItem Class

Under development.

System.Object
Kixforms.DataItem

[Visual Basic]
Public Class DataItem
[C#]
public class DataItem

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


DataRow Class

Under development.

For a list of all members of this type, see DataRow Members.

System.Object
Kixforms.DataRow

[Visual Basic]
Public Class DataRow
[C#]
public class DataRow

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataRow Members | Kixforms Namespace


DataRow Members

DataRow overview

Public Instance Properties

Item

Public Instance Methods

AcceptChanges Commits all the changes made to this row since the last time AcceptChanges was called.

See Also

DataRow Class | Kixforms Namespace


DataRow Properties

The properties of the DataRow class are listed below. For a complete list of DataRow class members, see the DataRow Members topic.

Public Instance Properties

Item

See Also

DataRow Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

DataRow.Item Property

[Visual Basic]
Public Default Property Item( _
ByVal index As Object _
) As Object
[C#]
public object this[
object index
] {get; set;}

See Also

DataRow Class | Kixforms Namespace


DataRow Methods

The methods of the DataRow class are listed below. For a complete list of DataRow class members, see the DataRow Members topic.

Public Instance Methods

AcceptChanges Commits all the changes made to this row since the last time AcceptChanges was called.

See Also

DataRow Class | Kixforms Namespace


DataRow.AcceptChanges Method

Commits all the changes made to this row since the last time AcceptChanges was called.

[Visual Basic]
Public Sub AcceptChanges()
[C#]
public void AcceptChanges();

See Also

DataRow Class | Kixforms Namespace


DataRowCollection Class

Under development.

For a list of all members of this type, see DataRowCollection Members.

System.Object
Kixforms.DataRowCollection

[Visual Basic]
Public Class DataRowCollection
Implements ICollection, IEnumerable, IEnumerator
[C#]
public class DataRowCollection : ICollection, IEnumerable, IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataRowCollection Members | Kixforms Namespace


DataRowCollection Members

DataRowCollection overview

Public Instance Properties

Count |
Item | Gets the specified DataRow from the collection.

Public Instance Methods

Add | Creates and adds the specified DataRow object to the DataRowCollection.
Clear | Clears the collection of all rows.
GetEnumerator |
InsertAt | Inserts a new row into the collection at the specified location.
Remove | Removes a DataRow from the collection.
RemoveAt | Removes the row at the specified index from the collection.

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection Properties

The properties of the DataRowCollection class are listed below. For a complete list of DataRowCollection class members, see the DataRowCollection Members topic.

Public Instance Properties

Count |
Item | Gets the specified DataRow from the collection.

See Also

DataRowCollection Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

DataRowCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

DataRowCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

DataRowCollection.Item Property

Gets the specified DataRow from the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As DataRow
[C#]
public DataRow this[
int index
] {get; set;}

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection Methods

The methods of the DataRowCollection class are listed below. For a complete list of DataRowCollection class members, see the DataRowCollection Members topic.

Public Instance Methods

Add | Creates and adds the specified DataRow object to the DataRowCollection.
Clear | Clears the collection of all rows.
GetEnumerator |
InsertAt | Inserts a new row into the collection at the specified location.
Remove | Removes a DataRow from the collection.
RemoveAt | Removes the row at the specified index from the collection.

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.Add Method

Creates and adds the specified DataRow object to the DataRowCollection.

[Visual Basic]
Public Function Add( _
ByVal row As DataRow _
) As DataRow
[C#]
public DataRow Add(
DataRow row
);

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.Clear Method

Clears the collection of all rows.

[Visual Basic]
Public Sub Clear()
[C#]
public void Clear();

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.InsertAt Method

Inserts a new row into the collection at the specified location.

[Visual Basic]
Public Function InsertAt( _
ByVal row As DataRow, _
ByVal index As Integer _
) As DataRow
[C#]
public DataRow InsertAt(
DataRow row,
int index
);

Parameters

row
The DataRow to add.
index
The location in the collection where you want to add the DataRow.

Return Value

The DataRow that was inserted.

Remarks

If the value specified for the index parameter is greater than the number of rows in the collection, the new row is added to the end.

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.Remove Method

Removes a DataRow from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal row As DataRow _
)
[C#]
public void Remove(
DataRow row
);

See Also

DataRowCollection Class | Kixforms Namespace


DataRowCollection.RemoveAt Method

Removes the row at the specified index from the collection.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
public void RemoveAt(
int index
);

Parameters

index
The index of the row to remove.

See Also

DataRowCollection Class | Kixforms Namespace


DataRowView Class

Under development.

For a list of all members of this type, see DataRowView Members.

System.Object
Kixforms.DataRowView

[Visual Basic]
Public Class DataRowView
[C#]
public class DataRowView

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataRowView Members | Kixforms Namespace


DataRowView Members

DataRowView overview

Public Instance Constructors

DataRowView Constructor Initializes a new instance of the DataRowView class.

See Also

DataRowView Class | Kixforms Namespace


DataRowView Constructor

Initializes a new instance of the DataRowView class.

[Visual Basic]
Public Sub New()
[C#]
public DataRowView();

See Also

DataRowView Class | Kixforms Namespace


DataSet Class

Under development.

For a list of all members of this type, see DataSet Members.

System.Object
Kixforms.DataSet

[Visual Basic]
Public Class DataSet
[C#]
public class DataSet

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataSet Members | Kixforms Namespace


DataSet Members

DataSet overview

Public Instance Properties

DataSetName | Gets or sets the name of the current DataSet.
Tables | Gets the collection of tables contained in the DataSet.

Public Instance Methods

HasChanges | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
ReadXml | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.
WriteXml | Writes the current data, and optionally the schema, for the DataSet to the specified file.

See Also

DataSet Class | Kixforms Namespace


DataSet Properties

The properties of the DataSet class are listed below. For a complete list of DataSet class members, see the DataSet Members topic.

Public Instance Properties

DataSetName | Gets or sets the name of the current DataSet.
Tables | Gets the collection of tables contained in the DataSet.

See Also

DataSet Class | Kixforms Namespace


DataSetName Property

KiXforms.NET Class Library

DataSet.DataSetName Property

Gets or sets the name of the current DataSet.

[Visual Basic]
Public Property DataSetName As String
[C#]
public string DataSetName {get; set;}

See Also

DataSet Class | Kixforms Namespace


Tables Property

KiXforms.NET Class Library

DataSet.Tables Property

Gets the collection of tables contained in the DataSet.

[Visual Basic]
Public ReadOnly Property Tables As DataTableCollection
[C#]
public DataTableCollection Tables {get;}

Property Value

The DataTableCollection contained by this DataSet; otherwise a null value if no DataTable objects exist.

See Also

DataSet Class | Kixforms Namespace


DataSet Methods

The methods of the DataSet class are listed below. For a complete list of DataSet class members, see the DataSet Members topic.

Public Instance Methods

HasChanges | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
ReadXml | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.
WriteXml | Writes the current data, and optionally the schema, for the DataSet to the specified file.

See Also

DataSet Class | Kixforms Namespace


DataSet.HasChanges Method

Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.

[Visual Basic]
Public Function HasChanges() As Boolean
[C#]
public bool HasChanges();

Return Value

True, if the DataSet has changes; otherwise, false.

See Also

DataSet Class | Kixforms Namespace


DataSet.ReadXml Method

Reads XML schema and data into the DataSet using the specified file and XmlReadMode.

[Visual Basic]
Public Function ReadXml( _
ByVal filename As String, _
Optional ByVal mode As XmlReadMode = 2 _
) As XmlReadMode
[C#]
public XmlReadMode ReadXml(
string filename,
XmlReadMode mode
);

Parameters

filename
The file name (including the path) from which to read.
mode
One of the XmlReadMode values.

Return Value

The XmlReadMode used to read the data.

See Also

DataSet Class | Kixforms Namespace


DataSet.WriteXml Method

Writes the current data, and optionally the schema, for the DataSet to the specified file.

[Visual Basic]
Public Sub WriteXml( _
ByVal filename As String, _
Optional ByVal mode As XmlWriteMode = 1 _
)
[C#]
public void WriteXml(
string filename,
XmlWriteMode mode
);

Parameters

filename
The file name (including the path) to which to write.
mode
One of the XmlWriteMode values.

See Also

DataSet Class | Kixforms Namespace


DataTable Class

Under development.

For a list of all members of this type, see DataTable Members.

System.Object
Kixforms.DataTable

[Visual Basic]
Public Class DataTable
[C#]
public class DataTable

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataTable Members | Kixforms Namespace


DataTable Members

DataTable overview

Public Instance Constructors

DataTable Constructor Initializes a new instance of the DataTable class.

Public Instance Properties

Column | Gets the column at the specified index.
Columns | Gets the collection of columns that belong to this table.
DefaultView | Gets a customized view of the table which may include a filtered view, or a cursor position.
Rows | Gets the collection of rows that belong to this table.
TableName | Gets or sets the name of the the DataTable.

Public Instance Methods

AcceptChanges | Commits all the changes made to this table since the last time AcceptChanges was called.
Clone | Clones the structure of the DataTable, including all DataTable schemas and constraints.
Copy | Copies both the structure and data for this DataTable.
NewRow | Creates a new DataRow with the same schema as the table.
Select | Gets an array of all DataRow objects that match the filter criteria, in the the specified sort order.
Sort | Under development.

See Also

DataTable Class | Kixforms Namespace


DataTable Constructor

Initializes a new instance of the DataTable class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal tableName As String = "Nothing" _
)
[C#]
public DataTable(
string tableName
);

Parameters

tableName
The name to give the table. If a null reference (Nothing in Visual Basic) or an empty string, a default name will be given when added to the DataTableCollection.

See Also

DataTable Class | Kixforms Namespace


DataTable Properties

The properties of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public Instance Properties

Column | Gets the column at the specified index.
Columns | Gets the collection of columns that belong to this table.
DefaultView | Gets a customized view of the table which may include a filtered view, or a cursor position.
Rows | Gets the collection of rows that belong to this table.
TableName | Gets or sets the name of the the DataTable.

See Also

DataTable Class | Kixforms Namespace


Column Property

KiXforms.NET Class Library

DataTable.Column Property

Gets the column at the specified index.

[Visual Basic]
Public Default ReadOnly Property Column( _
ByVal index As Object _
) As DataColumn
[C#]
public DataColumn this[
object index
] {get;}

Property Value

See Also

DataTable Class | Kixforms Namespace


Columns Property

KiXforms.NET Class Library

DataTable.Columns Property

Gets the collection of columns that belong to this table.

[Visual Basic]
Public ReadOnly Property Columns As DataColumnCollection
[C#]
public DataColumnCollection Columns {get;}

Property Value

A DataColumnCollection that contains the collection of DataColumn objects for the table; otherwise a null value if no DataColumn objects exist.

See Also

DataTable Class | Kixforms Namespace


DefaultView Property

KiXforms.NET Class Library

DataTable.DefaultView Property

Gets a customized view of the table which may include a filtered view, or a cursor position.

[Visual Basic]
Public ReadOnly Property DefaultView As DataView
[C#]
public DataView DefaultView {get;}

Property Value

The DataView associated with the DataTable.

See Also

DataTable Class | Kixforms Namespace


Rows Property

KiXforms.NET Class Library

DataTable.Rows Property

Gets the collection of rows that belong to this table.

[Visual Basic]
Public ReadOnly Property Rows As DataRowCollection
[C#]
public DataRowCollection Rows {get;}

Property Value

A DataRowCollection that contains the collection of DataRow objects for the table; otherwise a null value if no DataRow objects exist.

See Also

DataTable Class | Kixforms Namespace


TableName Property

KiXforms.NET Class Library

DataTable.TableName Property

Gets or sets the name of the the DataTable.

[Visual Basic]
Public Property TableName As String
[C#]
public string TableName {get; set;}

Property Value

The name of the the DataTable.

See Also

DataTable Class | Kixforms Namespace


DataTable Methods

The methods of the DataTable class are listed below. For a complete list of DataTable class members, see the DataTable Members topic.

Public Instance Methods

AcceptChanges | Commits all the changes made to this table since the last time AcceptChanges was called.
Clone | Clones the structure of the DataTable, including all DataTable schemas and constraints.
Copy | Copies both the structure and data for this DataTable.
NewRow | Creates a new DataRow with the same schema as the table.
Select | Gets an array of all DataRow objects that match the filter criteria, in the the specified sort order.
Sort | Under development.

See Also

DataTable Class | Kixforms Namespace


DataTable.AcceptChanges Method

Commits all the changes made to this table since the last time AcceptChanges was called.

[Visual Basic]
Public Sub AcceptChanges()
[C#]
public void AcceptChanges();

See Also

DataTable Class | Kixforms Namespace


DataTable.Clone Method

Clones the structure of the DataTable, including all DataTable schemas and constraints.

[Visual Basic]
Public Function Clone() As DataTable
[C#]
public DataTable Clone();

Return Value

A new DataTable with the same schema as the current DataTable.

See Also

DataTable Class | Kixforms Namespace


DataTable.Copy Method

Copies both the structure and data for this DataTable.

[Visual Basic]
Public Function Copy() As DataTable
[C#]
public DataTable Copy();

Return Value

A new DataTable with the same structure (table schemas and constraints) and data as this DataTable.

See Also

DataTable Class | Kixforms Namespace


DataTable.NewRow Method

Creates a new DataRow with the same schema as the table.

[Visual Basic]
Public Function NewRow() As DataRow
[C#]
public DataRow NewRow();

Return Value

A DataRow with the same schema as the DataTable.

See Also

DataTable Class | Kixforms Namespace


DataTable.Select Method

Gets an array of all DataRow objects that match the filter criteria, in the the specified sort order.

[Visual Basic]
Public Function Select( _
ByVal filter As String _
) As Object()
[C#]
public object[] Select(
string filter
);

See Also

DataTable Class | Kixforms Namespace


DataTable.Sort Method

Under development.

[Visual Basic]
Public Sub Sort( _
ByVal expression As String _
)
[C#]
public void Sort(
string expression
);

See Also

DataTable Class | Kixforms Namespace


DataTableCollection Class

Under development.

For a list of all members of this type, see DataTableCollection Members.

System.Object
Kixforms.DataTableCollection

[Visual Basic]
Public Class DataTableCollection
Implements ICollection, IEnumerable, IEnumerator
[C#]
public class DataTableCollection : ICollection, IEnumerable, IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataTableCollection Members | Kixforms Namespace


DataTableCollection Members

DataTableCollection overview

Public Instance Properties

Count |
Item | Gets the specified DataTable from the collection.

Public Instance Methods

Add | Adds a DataTable to the collection.
GetEnumerator |
Remove | Removes a DataTable object from the collection.
RemoveAt | Removes the table at the specified index from the collection.

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection Properties

The properties of the DataTableCollection class are listed below. For a complete list of DataTableCollection class members, see the DataTableCollection Members topic.

Public Instance Properties

Count |
Item | Gets the specified DataTable from the collection.

See Also

DataTableCollection Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

DataTableCollection.Count Property

[Visual Basic]
NotOverridable Public ReadOnly Property Count As Integer _
Implements ICollection.Count
[C#]
public int Count {get;}

Implements

ICollection.Count

See Also

DataTableCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

DataTableCollection.Item Property

Gets the specified DataTable from the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As DataTable
[C#]
public DataTable this[
int index
] {get; set;}

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection Methods

The methods of the DataTableCollection class are listed below. For a complete list of DataTableCollection class members, see the DataTableCollection Members topic.

Public Instance Methods

Add | Adds a DataTable to the collection.
GetEnumerator |
Remove | Removes a DataTable object from the collection.
RemoveAt | Removes the table at the specified index from the collection.

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection.Add Method

Adds a DataTable to the collection.

[Visual Basic]
Public Function Add( _
Optional ByVal table As DataTable = Nothing _
) As DataTable
[C#]
public DataTable Add(
DataTable table
);

Parameters

table
Optional. The DataTable object to add.

Return Value

The DataTable that was added.

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection.GetEnumerator Method

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection.Remove Method

Removes a DataTable object from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal table As DataTable _
)
[C#]
public void Remove(
DataTable table
);

See Also

DataTableCollection Class | Kixforms Namespace


DataTableCollection.RemoveAt Method

Removes the table at the specified index from the collection.

[Visual Basic]
Public Sub RemoveAt( _
ByVal index As Integer _
)
[C#]
public void RemoveAt(
int index
);

Parameters

index
The index of the table to remove.

See Also

DataTableCollection Class | Kixforms Namespace


DataView Class

Under development.

For a list of all members of this type, see DataView Members.

System.Object
Kixforms.DataView

[Visual Basic]
Public Class DataView
Implements IEnumerable, IEnumerator
[C#]
public class DataView : IEnumerable, IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DataView Members | Kixforms Namespace


DataView Members

DataView overview

Public Instance Constructors

DataView Constructor Initializes a new instance of the DataView class.

Public Instance Properties

AllowEdit | Gets or sets a value indicating whether edits are allowed.
AllowNew | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort | Gets or sets a value indicating whether to use the default sort.
Count | Gets the total number of objects in the DataView.
Item | Gets a row of data from a specified table.
Sort | Gets or sets the sort column or columns, and sort order for the DataTable.
Table | Gets or sets the source DataTable.

Public Instance Methods

AddNew | Adds a new row to the DataView.
BeginInit |
EndInit | Ends the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
GetEnumerator | Gets an enumerator for this DataView.

See Also

DataView Class | Kixforms Namespace


DataView Constructor

Initializes a new instance of the DataView class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public DataView();

See Also

DataView Class | Kixforms Namespace


DataView Properties

The properties of the DataView class are listed below. For a complete list of DataView class members, see the DataView Members topic.

Public Instance Properties

AllowEdit | Gets or sets a value indicating whether edits are allowed.
AllowNew | Gets or sets a value indicating whether the new rows can be added using the AddNew method.
ApplyDefaultSort | Gets or sets a value indicating whether to use the default sort.
Count | Gets the total number of objects in the DataView.
Item | Gets a row of data from a specified table.
Sort | Gets or sets the sort column or columns, and sort order for the DataTable.
Table | Gets or sets the source DataTable.

See Also

DataView Class | Kixforms Namespace


AllowEdit Property

KiXforms.NET Class Library

DataView.AllowEdit Property

Gets or sets a value indicating whether edits are allowed.

[Visual Basic]
Public Property AllowEdit As Boolean
[C#]
public bool AllowEdit {get; set;}

Property Value

True, if edits are allowed; otherwise, false.

See Also

DataView Class | Kixforms Namespace


AllowNew Property

KiXforms.NET Class Library

DataView.AllowNew Property

Gets or sets a value indicating whether the new rows can be added using the AddNew method.

[Visual Basic]
Public Property AllowNew As Boolean
[C#]
public bool AllowNew {get; set;}

Property Value

True, if new rows can be added; otherwise, false.

See Also

DataView Class | Kixforms Namespace


ApplyDefaultSort Property

KiXforms.NET Class Library

DataView.ApplyDefaultSort Property

Gets or sets a value indicating whether to use the default sort.

[Visual Basic]
Public Property ApplyDefaultSort As Boolean
[C#]
public bool ApplyDefaultSort {get; set;}

Property Value

True, if the default sort is used; otherwise, false.

See Also

DataView Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

DataView.Count Property

Gets the total number of objects in the DataView.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

See Also

DataView Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

DataView.Item Property

Gets a row of data from a specified table.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) As Object
[C#]
public object this[
int index
] {get; set;}

See Also

DataView Class | Kixforms Namespace


Sort Property

KiXforms.NET Class Library

DataView.Sort Property

Gets or sets the sort column or columns, and sort order for the DataTable.

[Visual Basic]
Public Property Sort As String
[C#]
public string Sort {get; set;}

Property Value

A string containing the column name followed by "ASC" (ascending) or "DESC" (descending). Columns are sorted asending by default. Multiple columns can be separated by commas.

See Also

DataView Class | Kixforms Namespace


Table Property

KiXforms.NET Class Library

DataView.Table Property

Gets or sets the source DataTable.

[Visual Basic]
Public Property Table As DataTable
[C#]
public DataTable Table {get; set;}

Property Value

A DataTable that provides the data for this view.

See Also

DataView Class | Kixforms Namespace


DataView Methods

The methods of the DataView class are listed below. For a complete list of DataView class members, see the DataView Members topic.

Public Instance Methods

AddNew | Adds a new row to the DataView.
BeginInit |
EndInit | Ends the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.
GetEnumerator | Gets an enumerator for this DataView.

See Also

DataView Class | Kixforms Namespace


DataView.AddNew Method

Adds a new row to the DataView.

[Visual Basic]
Public Function AddNew() As Object
[C#]
public object AddNew();

See Also

DataView Class | Kixforms Namespace


DataView.BeginInit Method

[Visual Basic]
Public Sub BeginInit()
[C#]
public void BeginInit();

See Also

DataView Class | Kixforms Namespace


DataView.EndInit Method

Ends the initialization of a DataView that is used on a form or used by another component. The initialization occurs at runtime.

[Visual Basic]
Public Sub EndInit()
[C#]
public void EndInit();

See Also

DataView Class | Kixforms Namespace


DataView.GetEnumerator Method

Gets an enumerator for this DataView.

[Visual Basic]
NotOverridable Public Function GetEnumerator() As IEnumerator _
Implements IEnumerable.GetEnumerator
[C#]
public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

DataView Class | Kixforms Namespace


DialogResult Enumeration

[Visual Basic]
Public Enum DialogResult
[C#]
public enum DialogResult

Members

Member Name | Description
Abort |
Cancel |
Ignore |
No |
None |
OK |
Retry |
Yes |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


DictionaryEntry Class

Defines a dictionary key-and-value pair that can be set or retrieved.

For a list of all members of this type, see DictionaryEntry Members.

System.Object
Kixforms.DictionaryEntry

[Visual Basic]
Public Class DictionaryEntry
[C#]
public class DictionaryEntry

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DictionaryEntry Members | Kixforms Namespace


DictionaryEntry Members

DictionaryEntry overview

Public Instance Properties

Key | Gets or sets the key in the key-and-value pair.
Value | Gets or sets the value in the key-and-value pair.

See Also

DictionaryEntry Class | Kixforms Namespace


DictionaryEntry Properties

The properties of the DictionaryEntry class are listed below. For a complete list of DictionaryEntry class members, see the DictionaryEntry Members topic.

Public Instance Properties

Key | Gets or sets the key in the key-and-value pair.
Value | Gets or sets the value in the key-and-value pair.

See Also

DictionaryEntry Class | Kixforms Namespace


Key Property

KiXforms.NET Class Library

DictionaryEntry.Key Property

Gets or sets the key in the key-and-value pair.

[Visual Basic]
Public Property Key As Object
[C#]
public object Key {get; set;}

Property Value

The key in the key-and-value pair.

See Also

DictionaryEntry Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

DictionaryEntry.Value Property

Gets or sets the value in the key-and-value pair.

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}

Property Value

The value in the key-and-value pair.

See Also

DictionaryEntry Class | Kixforms Namespace


Dns Class

Provides simple domain name resolution functionality.

For a list of all members of this type, see Dns Members.

System.Object
Kixforms.Dns

[Visual Basic]
Public Class Dns
[C#]
public class Dns

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Dns Members | Kixforms Namespace


Dns Members

Dns overview

Public Instance Constructors

Dns Constructor Initializes a new instance of the Dns class.

Public Instance Methods

GetHostByAddress | Creates an IPHostEntry instance from an IP address.
GetHostByName | Gets the DNS information for the specified DNS host name.
GetHostName | Gets the host name of the local computer.
Resolve | Resolves a DNS host name or IP address to an IPHostEntry instance.

See Also

Dns Class | Kixforms Namespace


Dns Constructor

Initializes a new instance of the Dns class.

[Visual Basic]
Public Sub New()
[C#]
public Dns();

See Also

Dns Class | Kixforms Namespace


Dns Methods

The methods of the Dns class are listed below. For a complete list of Dns class members, see the Dns Members topic.

Public Instance Methods

GetHostByAddress | Creates an IPHostEntry instance from an IP address.
GetHostByName | Gets the DNS information for the specified DNS host name.
GetHostName | Gets the host name of the local computer.
Resolve | Resolves a DNS host name or IP address to an IPHostEntry instance.

See Also

Dns Class | Kixforms Namespace


Dns.GetHostByAddress Method

Creates an IPHostEntry instance from an IP address.

[Visual Basic]
Public Function GetHostByAddress( _
ByVal IP As String _
) As IpHostEntry
[C#]
public IpHostEntry GetHostByAddress(
string IP
);

Parameters

IP
A string that represents an IP address.

Return Value

An IPHostEntry instance.

See Also

Dns Class | Kixforms Namespace | GetHostByName | Resolve


Dns.GetHostByName Method

Gets the DNS information for the specified DNS host name.

[Visual Basic]
Public Function GetHostByName( _
ByVal HostName As String _
) As IpHostEntry
[C#]
public IpHostEntry GetHostByName(
string HostName
);

Parameters

HostName
A string that represents an IP address.

Return Value

An IPHostEntry instance.

See Also

Dns Class | Kixforms Namespace | GetHostByAddress | Resolve


Dns.GetHostName Method

Gets the host name of the local computer.

[Visual Basic]
Public Function GetHostName() As String
[C#]
public string GetHostName();

Return Value

A string containing the DNS host name of the local computer.

See Also

Dns Class | Kixforms Namespace


Dns.Resolve Method

Resolves a DNS host name or IP address to an IPHostEntry instance.

[Visual Basic]
Public Function Resolve( _
ByVal host As String _
) As IpHostEntry
[C#]
public IpHostEntry Resolve(
string host
);

Parameters

host
A DNS-style host name or IP address.

Return Value

An IPHostEntry instance.

Remarks

The Resolve method queries a DNS server for the IP address associated with a host name or IP address. When hostName is a DNS-style host name associated with multiple IP addresses, only the first IP address that resolves to that host name is returned.

Example

$dns = $system.dns
$resolvedEntry = $dns.resolve("www.kixforms.org") " " @serror ?
"hostname : " $resolvedEntry.hostname
"IpAddress: " $resolvedEntry.addresslist.item(0) ?

See Also

Dns Class | Kixforms Namespace | GetHostByName | GetHostByAddress


DockPaddingEdges Class

Determines the border padding for docked controls.

For a list of all members of this type, see DockPaddingEdges Members.

System.Object
Kixforms.DockPaddingEdges

[Visual Basic]
Public Class DockPaddingEdges
[C#]
public class DockPaddingEdges

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

DockPaddingEdges Members | Kixforms Namespace


DockPaddingEdges Members

DockPaddingEdges overview

Public Instance Properties

All | Gets or sets the padding width for all edges of a docked control.
Bottom | Gets or sets the padding width for the bottom edge of a docked control.
Left | Gets or sets the padding width for the left edge of a docked control.
Right | Gets or sets the padding width for the right edge of a docked control.
Top | Gets or sets the padding width for the top edge of a docked control.

See Also

DockPaddingEdges Class | Kixforms Namespace


DockPaddingEdges Properties

The properties of the DockPaddingEdges class are listed below. For a complete list of DockPaddingEdges class members, see the DockPaddingEdges Members topic.

Public Instance Properties

All | Gets or sets the padding width for all edges of a docked control.
Bottom | Gets or sets the padding width for the bottom edge of a docked control.
Left | Gets or sets the padding width for the left edge of a docked control.
Right | Gets or sets the padding width for the right edge of a docked control.
Top | Gets or sets the padding width for the top edge of a docked control.

See Also

DockPaddingEdges Class | Kixforms Namespace


All Property

KiXforms.NET Class Library

DockPaddingEdges.All Property

Gets or sets the padding width for all edges of a docked control.

[Visual Basic]
Public Property All As Integer
[C#]
public int All {get; set;}

See Also

DockPaddingEdges Class | Kixforms Namespace


Bottom Property

KiXforms.NET Class Library

DockPaddingEdges.Bottom Property

Gets or sets the padding width for the bottom edge of a docked control.

[Visual Basic]
Public Property Bottom As Integer
[C#]
public int Bottom {get; set;}

See Also

DockPaddingEdges Class | Kixforms Namespace


Left Property

KiXforms.NET Class Library

DockPaddingEdges.Left Property

Gets or sets the padding width for the left edge of a docked control.

[Visual Basic]
Public Property Left As Integer
[C#]
public int Left {get; set;}

See Also

DockPaddingEdges Class | Kixforms Namespace


Right Property

KiXforms.NET Class Library

DockPaddingEdges.Right Property

Gets or sets the padding width for the right edge of a docked control.

[Visual Basic]
Public Property Right As Integer
[C#]
public int Right {get; set;}

See Also

DockPaddingEdges Class | Kixforms Namespace


Top Property

KiXforms.NET Class Library

DockPaddingEdges.Top Property

Gets or sets the padding width for the top edge of a docked control.

[Visual Basic]
Public Property Top As Integer
[C#]
public int Top {get; set;}

See Also

DockPaddingEdges Class | Kixforms Namespace


DockStyle Enumeration

[Visual Basic]
Public Enum DockStyle
[C#]
public enum DockStyle

Members

Member Name | Description
Bottom |
Fill |
Left |
None |
Right |
Top |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Encoding Class

Represents a character encoding.

For a list of all members of this type, see Encoding Members.

System.Object
Kixforms.Encoding

[Visual Basic]
Public Class Encoding
[C#]
public class Encoding

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Encoding Members | Kixforms Namespace


Encoding Members

Encoding overview

Public Instance Constructors

Encoding Constructor Initializes a new instance of the Encoding class.

Public Instance Properties

ASCII | Gets an encoding for the ASCII (7 bit) character set.
BigEndianUnicode | Gets an encoding for the Unicode format in the big-endian byte order.
BodyName | Gets the name for this encoding that can be used with mail agent body tags.
Default | Gets an encoding for the system's current ANSI code page.
EncodingName | Gets the human-readable description of the encoding.
HeaderName | Gets the name for this encoding that can be used with mail agent header tags.
Unicode | Gets an encoding for the Unicode format in little-endian byte order.
UTF7 | Gets an encoding for the UTF-7 format.
UTF8 | Gets an encoding for the UTF-8 format.
WebName | Gets the name registered with the Internet Assigned Numbers Authority (IANA) for this encoding.
WindowsCodePage | Gets the Windows operating system code page that most closely corresponds to this encoding.

Public Instance Methods

Convert | Converts a byte array from one encoding to another.
GetByteCount | Calculates the number of bytes required to encode the specified String.
GetBytes | Encodes a specified String into an array of bytes.
GetString | Returns a string containing the decoded representation of the specified byte array.

See Also

Encoding Class | Kixforms Namespace


Encoding Constructor

Initializes a new instance of the Encoding class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Encoding();

Remarks

You can't directly use the encoding base class, but must get the encoding class via the properties, as example, default.

Example

The following example demonstrates the basic usage of the encoding class.

$enc = $system.encoding.default
$bytes = $enc.getbytes("some text here and there")
"length of the string: " 1+ubound($bytes) ?
"and the same string passed back:" ?
$enc.getstring($bytes) ?
well, it actually would but somehow, suddenly, ascii supports 256 chars. nah, the .net implementation just is broken

See Also

Encoding Class | Kixforms Namespace


Encoding Properties

The properties of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Instance Properties

ASCII | Gets an encoding for the ASCII (7 bit) character set.
BigEndianUnicode | Gets an encoding for the Unicode format in the big-endian byte order.
BodyName | Gets the name for this encoding that can be used with mail agent body tags.
Default | Gets an encoding for the system's current ANSI code page.
EncodingName | Gets the human-readable description of the encoding.
HeaderName | Gets the name for this encoding that can be used with mail agent header tags.
Unicode | Gets an encoding for the Unicode format in little-endian byte order.
UTF7 | Gets an encoding for the UTF-7 format.
UTF8 | Gets an encoding for the UTF-8 format.
WebName | Gets the name registered with the Internet Assigned Numbers Authority (IANA) for this encoding.
WindowsCodePage | Gets the Windows operating system code page that most closely corresponds to this encoding.

See Also

Encoding Class | Kixforms Namespace


ASCII Property

KiXforms.NET Class Library

Encoding.ASCII Property

Gets an encoding for the ASCII (7 bit) character set.

[Visual Basic]
Public ReadOnly Property ASCII As Encoding
[C#]
public Encoding ASCII {get;}

Property Value

An encoding for the ASCII (7 bit) character set.

Remarks

ASCII characters are limited to the lowest 128 Unicode characters, from U+0000 to U+007f.

See Also

Encoding Class | Kixforms Namespace


BigEndianUnicode Property

KiXforms.NET Class Library

Encoding.BigEndianUnicode Property

Gets an encoding for the Unicode format in the big-endian byte order.

[Visual Basic]
Public ReadOnly Property BigEndianUnicode As Encoding
[C#]
public Encoding BigEndianUnicode {get;}

Property Value

An encoding for the Unicode format in the big-endian byte order.

Remarks

Unicode characters can be stored in two different byte orders: big-endian and little-endian. On little-endian platforms such as Intel machines, it is generally more efficient to store Unicode characters in little-endian order. However, many other platforms can store Unicode characters in big-endian order.

See Also

Encoding Class | Kixforms Namespace


BodyName Property

KiXforms.NET Class Library

Encoding.BodyName Property

Gets the name for this encoding that can be used with mail agent body tags.

[Visual Basic]
Public ReadOnly Property BodyName As Integer
[C#]
public int BodyName {get;}

Property Value

The name for this encoding that can be used with mail agent body tags.

Remarks

For example, if this encoding is equivalent to UTF8Encoding, this property returns "utf-8".

If the encoding cannot be used, the property value is the empty string ("").

See Also

Encoding Class | Kixforms Namespace


Default Property

KiXforms.NET Class Library

Encoding.Default Property

Gets an encoding for the system's current ANSI code page.

[Visual Basic]
Public ReadOnly Property Default As Encoding
[C#]
public Encoding Default {get;}

Property Value

An encoding for the system's current ANSI code page.

See Also

Encoding Class | Kixforms Namespace


EncodingName Property

KiXforms.NET Class Library

Encoding.EncodingName Property

Gets the human-readable description of the encoding.

[Visual Basic]
Public ReadOnly Property EncodingName As Integer
[C#]
public int EncodingName {get;}

Property Value

The human-readable description of the encoding.

Remarks

An example of an EncodingName is "Hebrew (DOS) for code page 862".

See Also

Encoding Class | Kixforms Namespace


HeaderName Property

KiXforms.NET Class Library

Encoding.HeaderName Property

Gets the name for this encoding that can be used with mail agent header tags.

[Visual Basic]
Public ReadOnly Property HeaderName As Integer
[C#]
public int HeaderName {get;}

Property Value

The name for this encoding that can be used with mail agent header tags.

Remarks

For example, if this encoding is equivalent to UTF8Encoding, this property returns "utf-8".

If the encoding cannot be used, the property value is the empty string ("").

See Also

Encoding Class | Kixforms Namespace


Unicode Property

KiXforms.NET Class Library

Encoding.Unicode Property

Gets an encoding for the Unicode format in little-endian byte order.

[Visual Basic]
Public ReadOnly Property Unicode As Encoding
[C#]
public Encoding Unicode {get;}

Property Value

An encoding for the Unicode format in little-endian byte order.

See Also

Encoding Class | Kixforms Namespace


UTF7 Property

KiXforms.NET Class Library

Encoding.UTF7 Property

Gets an encoding for the UTF-7 format.

[Visual Basic]
Public ReadOnly Property UTF7 As Encoding
[C#]
public Encoding UTF7 {get;}

Property Value

An encoding for the UTF-7 format.

See Also

Encoding Class | Kixforms Namespace


UTF8 Property

KiXforms.NET Class Library

Encoding.UTF8 Property

Gets an encoding for the UTF-8 format.

[Visual Basic]
Public ReadOnly Property UTF8 As Encoding
[C#]
public Encoding UTF8 {get;}

Property Value

An encoding for the UTF-8 format.

See Also

Encoding Class | Kixforms Namespace


WebName Property

KiXforms.NET Class Library

Encoding.WebName Property

Gets the name registered with the Internet Assigned Numbers Authority (IANA) for this encoding.

[Visual Basic]
Public ReadOnly Property WebName As Integer
[C#]
public int WebName {get;}

Property Value

TThe IANA name for this encoding.

See Also

Encoding Class | Kixforms Namespace


WindowsCodePage Property

KiXforms.NET Class Library

Encoding.WindowsCodePage Property

Gets the Windows operating system code page that most closely corresponds to this encoding.

[Visual Basic]
Public ReadOnly Property WindowsCodePage As Integer
[C#]
public int WindowsCodePage {get;}

Property Value

The Windows operating system code page that most closely corresponds to this encoding.

See Also

Encoding Class | Kixforms Namespace


Encoding Methods

The methods of the Encoding class are listed below. For a complete list of Encoding class members, see the Encoding Members topic.

Public Instance Methods

Convert | Converts a byte array from one encoding to another.
GetByteCount | Calculates the number of bytes required to encode the specified String.
GetBytes | Encodes a specified String into an array of bytes.
GetString | Returns a string containing the decoded representation of the specified byte array.

See Also

Encoding Class | Kixforms Namespace


Encoding.Convert Method

Converts a byte array from one encoding to another.

[Visual Basic]
Public Function Convert( _
ByVal SrcEnc As Encoding, _
ByVal DstEnc As Encoding, _
ByVal ByteArr As Object() _
) As Object()
[C#]
public object[] Convert(
Encoding SrcEnc,
Encoding DstEnc,
object[] ByteArr
);

Parameters

SrcEnc
The encoding that ByteArr is in.
DstEnc
The encoding desired for the returned byte array.
ByteArr
The bytes to convert.

Return Value

An array of type Byte (remember, integers for kixtart) containing the result of the conversion.

Example

the following example shows how ascii is not same as ansi.

$ansi = $system.encoding.default
$bytes = $ansi.getbytes("some nice text and a © mark.")
$bytesOut = $system.encoding.convert($ansi, $system.encoding.ascii, $bytes)
$ansi.getString($bytesOut) ?

See Also

Encoding Class | Kixforms Namespace


Encoding.GetByteCount Method

Calculates the number of bytes required to encode the specified String.

[Visual Basic]
Public Function GetByteCount( _
ByVal sText As String _
) As Integer
[C#]
public int GetByteCount(
string sText
);

Parameters

sText
The string to calculate.

Return Value

The number of bytes required to encode sText.

Example

$unicode = $system.encoding.unicode
$unicode.getByteCount("how Should I know?")

See Also

Encoding Class | Kixforms Namespace


Encoding.GetBytes Method

Encodes a specified String into an array of bytes.

[Visual Basic]
Public Function GetBytes( _
ByVal sText As String _
) As Object()
[C#]
public object[] GetBytes(
string sText
);

Parameters

sText
The string to encode.

Return Value

A byte array containing the encoded representation of the specified string.

Remarks

as KiXtart has it's issues with byte arrays, the byte values are translated to integers. This is fully compliant with the way fileStream and NetworkStream expose and use the byte arrays.

See Also

Encoding Class | Kixforms Namespace


Encoding.GetString Method

Returns a string containing the decoded representation of the specified byte array.

[Visual Basic]
Public Function GetString( _
ByVal ByteArr As Object() _
) As String
[C#]
public string GetString(
object[] ByteArr
);

Parameters

ByteArr
The byte array to decode.

Return Value

A string containing the decoded representation of the specified byte array.

Remarks

as KiXtart has it's issues with byte arrays, you can use integers instead. This is fully compliant with the way fileStream and NetworkStream expose and use the byte arrays.

See Also

Encoding Class | Kixforms Namespace


Environment Class

Provides information about, and means to manipulate, the current environment and platform.

For a list of all members of this type, see Environment Members.

System.Object
Kixforms.Environment

[Visual Basic]
Public Class Environment
[C#]
public class Environment

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Environment Members | Kixforms Namespace


Environment Members

Environment overview

Public Instance Constructors

Environment Constructor Initializes a new instance of the Environment class.

Public Instance Properties

CommandLine | Gets the command line for this process.
Version | Gets a Version object that describes the major, minor, build, and revision numbers of the common language runtime.

See Also

Environment Class | Kixforms Namespace


Environment Constructor

Initializes a new instance of the Environment class.

[Visual Basic]
Public Sub New()
[C#]
public Environment();

See Also

Environment Class | Kixforms Namespace


Environment Properties

The properties of the Environment class are listed below. For a complete list of Environment class members, see the Environment Members topic.

Public Instance Properties

CommandLine | Gets the command line for this process.
Version | Gets a Version object that describes the major, minor, build, and revision numbers of the common language runtime.

See Also

Environment Class | Kixforms Namespace


CommandLine Property

KiXforms.NET Class Library

Environment.CommandLine Property

Gets the command line for this process.

[Visual Basic]
Public ReadOnly Property CommandLine As String
[C#]
public string CommandLine {get;}

Property Value

A string containing command line arguments.

See Also

Environment Class | Kixforms Namespace


Version Property

KiXforms.NET Class Library

Environment.Version Property

Gets a Version object that describes the major, minor, build, and revision numbers of the common language runtime.

[Visual Basic]
Public ReadOnly Property Version As Version
[C#]
public Version Version {get;}

Property Value

A Version object.

See Also

Environment Class | Kixforms Namespace


EventArgs Class

EventArgs is the base class for classes containing event data.

System.Object
Kixforms.EventArgs
Derived types

[Visual Basic]
Public Class EventArgs
[C#]
public class EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


File Class

Provides static methods for the creation, copying, deletion, moving, and opening of files, and aids in the creation of FileStream objects.

For a list of all members of this type, see File Members.

System.Object
Kixforms.File

[Visual Basic]
Public Class File
[C#]
public class File

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

File Members | Kixforms Namespace


File Members

File overview

Public Instance Methods

OpenRead | Opens an existing file for reading.
OpenText | Opens an existing UTF-8 encoded text file for reading.

See Also

File Class | Kixforms Namespace


File Methods

The methods of the File class are listed below. For a complete list of File class members, see the File Members topic.

Public Instance Methods

OpenRead | Opens an existing file for reading.
OpenText | Opens an existing UTF-8 encoded text file for reading.

See Also

File Class | Kixforms Namespace


File.OpenRead Method

Opens an existing file for reading.

[Visual Basic]
Public Function OpenRead( _
ByVal path As String _
) As FileStream
[C#]
public FileStream OpenRead(
string path
);

Parameters

path
The file to be opened for reading.

Return Value

A read-only FileStream on the specified path.

See Also

File Class | Kixforms Namespace


File.OpenText Method

Opens an existing UTF-8 encoded text file for reading.

[Visual Basic]
Public Function OpenText( _
ByVal path As String _
) As StreamReader
[C#]
public StreamReader OpenText(
string path
);

Parameters

path
The file to be opened for reading.

Return Value

A StreamReader on the specified path.

See Also

File Class | Kixforms Namespace


FileAccess Enumeration

[Visual Basic]
Public Enum FileAccess
[C#]
public enum FileAccess

Members

Member Name | Description
Read |
Write |
ReadWrite |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FileDialog Class

Displays a dialog window from which the user can select a file. FileDialog is an abstract class, and cannot be instantiated directly.

For a list of all members of this type, see FileDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FileDialog
Kixforms.OpenFileDialog
Kixforms.SaveFileDialog

[Visual Basic]
Public Class FileDialog
Inherits CommonDialog
[C#]
public class FileDialog : CommonDialog

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

FileDialog Members | Kixforms Namespace


FileDialog Members

FileDialog overview

Public Instance Properties

AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
DefaultExt | Gets or sets the default file name extension.
DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName | Gets or sets a string containing the file name selected in the file dialog box.
Filter | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Title | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

FileDialog Class | Kixforms Namespace


FileDialog Properties

The properties of the FileDialog class are listed below. For a complete list of FileDialog class members, see the FileDialog Members topic.

Public Instance Properties

AddExtension | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
DefaultExt | Gets or sets the default file name extension.
DereferenceLinks | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName | Gets or sets a string containing the file name selected in the file dialog box.
Filter | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory | Gets or sets the initial directory displayed by the file dialog box.
RestoreDirectory | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Title | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

FileDialog Class | Kixforms Namespace


AddExtension Property

KiXforms.NET Class Library

FileDialog.AddExtension Property

Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.

[Visual Basic]
Public Property AddExtension As Boolean
[C#]
public bool AddExtension {get; set;}

See Also

FileDialog Class | Kixforms Namespace


CheckFileExists Property

KiXforms.NET Class Library

FileDialog.CheckFileExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.

[Visual Basic]
Overridable Public Property CheckFileExists As Boolean
[C#]
public virtual bool CheckFileExists {get; set;}

See Also

FileDialog Class | Kixforms Namespace


CheckPathExists Property

KiXforms.NET Class Library

FileDialog.CheckPathExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.

[Visual Basic]
Public Property CheckPathExists As Boolean
[C#]
public bool CheckPathExists {get; set;}

See Also

FileDialog Class | Kixforms Namespace


DefaultExt Property

KiXforms.NET Class Library

FileDialog.DefaultExt Property

Gets or sets the default file name extension.

[Visual Basic]
Public Property DefaultExt As String
[C#]
public string DefaultExt {get; set;}

See Also

FileDialog Class | Kixforms Namespace


DereferenceLinks Property

KiXforms.NET Class Library

FileDialog.DereferenceLinks Property

Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).

[Visual Basic]
Public Property DereferenceLinks As Boolean
[C#]
public bool DereferenceLinks {get; set;}

See Also

FileDialog Class | Kixforms Namespace


FileName Property

KiXforms.NET Class Library

FileDialog.FileName Property

Gets or sets a string containing the file name selected in the file dialog box.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

See Also

FileDialog Class | Kixforms Namespace


Filter Property

KiXforms.NET Class Library

FileDialog.Filter Property

Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.

[Visual Basic]
Public Property Filter As String
[C#]
public string Filter {get; set;}

See Also

FileDialog Class | Kixforms Namespace


FilterIndex Property

KiXforms.NET Class Library

FileDialog.FilterIndex Property

Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.

[Visual Basic]
Public Property FilterIndex As Integer
[C#]
public int FilterIndex {get; set;}

See Also

FileDialog Class | Kixforms Namespace


InitialDirectory Property

KiXforms.NET Class Library

FileDialog.InitialDirectory Property

Gets or sets the initial directory displayed by the file dialog box.

[Visual Basic]
Public Property InitialDirectory As String
[C#]
public string InitialDirectory {get; set;}

See Also

FileDialog Class | Kixforms Namespace


RestoreDirectory Property

KiXforms.NET Class Library

FileDialog.RestoreDirectory Property

Gets or sets a value indicating whether the dialog box restores the current directory before closing.

[Visual Basic]
Public Property RestoreDirectory As Boolean
[C#]
public bool RestoreDirectory {get; set;}

See Also

FileDialog Class | Kixforms Namespace


Title Property

KiXforms.NET Class Library

FileDialog.Title Property

Gets or sets the file dialog box title.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

See Also

FileDialog Class | Kixforms Namespace


FileMode Enumeration

[Visual Basic]
Public Enum FileMode
[C#]
public enum FileMode

Members

Member Name | Description
Append |
Create |
CreateNew |
Open |
OpenOrCreate |
Truncate |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FileShare Enumeration

[Visual Basic]
Public Enum FileShare
[C#]
public enum FileShare

Members

Member Name | Description
None |
Read |
Write |
ReadWrite |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FileStream Class

Implements a FileStream that reads and or writes to a file.

For a list of all members of this type, see FileStream Members.

System.Object
Kixforms.Stream
Kixforms.FileStream

[Visual Basic]
Public Class FileStream
Inherits Stream
[C#]
public class FileStream : Stream

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

FileStream Members | Kixforms Namespace


FileStream Members

FileStream overview

Public Instance Constructors

FileStream Constructor

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Handle | Gets the operating system file handle for the file that the current FileStream object encapsulates.
IsAsync | Gets a value indicating whether the FileStream was opened asynchronously or synchronously.
Length | Gets the length of the stream in bytes.
Name | Gets the name of the FileStream that was passed to the constructor.
Position | Gets or sets the current position of this stream.

Public Instance Methods

Close | Closes the file and releases any resources associated with the current file stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Lock | Prevents other processes from changing the FileStream while permitting read access.
Read | Reads a block of bytes from the stream.
ReadByte | Reads a byte from the file and advances the read position one byte.
Seek | Sets the current position of this stream to the given value.
SetLength | Sets the length of this stream to the given value.
UnLock | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream.
WriteByte | Writes a byte to the current position in the file stream.

See Also

FileStream Class | Kixforms Namespace


FileStream Constructor

[Visual Basic]
Overloads Public Sub New( _
ByVal Path As String, _
ByVal FileOpenMode As FileMode, _
Optional ByVal FileAccessMode As FileAccess = 3, _
Optional ByVal FileShareMode As FileShare = 1 _
)
[C#]
public FileStream(
string Path,
FileMode FileOpenMode,
FileAccess FileAccessMode,
FileShare FileShareMode
);

Parameters

Path
A relative or absolute path for the file that the current FileStream object will encapsulate.
FileOpenMode
A FileMode constant that determines how to open or create the file.
FileAccessMode
Optional. A FileAccess constant that determines how the file can be accessed by the FileStream object. Defaults to FileAccess_ReadWrite.
FileShareMode
Optional. A FileShare constant that determines how the file will be shared by processes. Defaults to FileShare_Read

Return Value

The Opened filestream.

Remarks

The .NET Framework does not support direct access to physical disks through paths that are device names, such as "\\.\PHYSICALDRIVE0 ".

The path parameter can be a file name, including a file on a Universal Naming Convention (UNC) share.

path is not required to be a file stored on disk; it can be any part of a system that supports access through streams. For example, depending on the system, this class can access a physical device.

Example

 $File = $system.FileStream("%temp%\someTempFile.txt", $system.FileMode_Create)

See Also

FileStream Class | Kixforms Namespace


FileStream Properties

The properties of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Handle | Gets the operating system file handle for the file that the current FileStream object encapsulates.
IsAsync | Gets a value indicating whether the FileStream was opened asynchronously or synchronously.
Length | Gets the length of the stream in bytes.
Name | Gets the name of the FileStream that was passed to the constructor.
Position | Gets or sets the current position of this stream.

See Also

FileStream Class | Kixforms Namespace


CanRead Property

KiXforms.NET Class Library

FileStream.CanRead Property

Gets a value indicating whether the current stream supports reading.

[Visual Basic]
Overrides Public ReadOnly Property CanRead As Boolean
[C#]
public override bool CanRead {get;}

Property Value

true if the stream supports reading; false if the stream is closed or was opened with write-only access.

See Also

FileStream Class | Kixforms Namespace


CanSeek Property

KiXforms.NET Class Library

FileStream.CanSeek Property

Gets a value indicating whether the current stream supports seeking.

[Visual Basic]
Overrides Public ReadOnly Property CanSeek As Boolean
[C#]
public override bool CanSeek {get;}

Property Value

true if the stream supports seeking; false if the stream is closed or if the FileStream was constructed from an operating-system handle such as a pipe or output to the console.

See Also

FileStream Class | Kixforms Namespace


CanWrite Property

KiXforms.NET Class Library

FileStream.CanWrite Property

Gets a value indicating whether the current stream supports writing.

[Visual Basic]
Overrides Public ReadOnly Property CanWrite As Boolean
[C#]
public override bool CanWrite {get;}

Property Value

true if the stream supports writing; false if the stream is closed or was opened with read-only access.

See Also

FileStream Class | Kixforms Namespace


Handle Property

KiXforms.NET Class Library

FileStream.Handle Property

Gets the operating system file handle for the file that the current FileStream object encapsulates.

[Visual Basic]
Public ReadOnly Property Handle As IntPtr
[C#]
public System.IntPtr Handle {get;}

Property Value

The operating system file handle for the file encapsulated by this FileStream object, or -1 if the FileStream has been closed.

See Also

FileStream Class | Kixforms Namespace


IsAsync Property

KiXforms.NET Class Library

FileStream.IsAsync Property

Gets a value indicating whether the FileStream was opened asynchronously or synchronously.

[Visual Basic]
Public ReadOnly Property IsAsync As Boolean
[C#]
public bool IsAsync {get;}

Property Value

true if the FileStream was opened asynchronously; otherwise, false.

See Also

FileStream Class | Kixforms Namespace


Length Property

KiXforms.NET Class Library

FileStream.Length Property

Gets the length of the stream in bytes.

[Visual Basic]
Overrides Public ReadOnly Property Length As Integer
[C#]
public override int Length {get;}

Property Value

the length of the stream in bytes.

See Also

FileStream Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

FileStream.Name Property

Gets the name of the FileStream that was passed to the constructor.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

Property Value

A string that is the name of the FileStream.

See Also

FileStream Class | Kixforms Namespace


Position Property

KiXforms.NET Class Library

FileStream.Position Property

Gets or sets the current position of this stream.

[Visual Basic]
Overrides Public Property Position As Integer
[C#]
public override int Position {get; set;}

Property Value

The current position of this stream.

See Also

FileStream Class | Kixforms Namespace


FileStream Methods

The methods of the FileStream class are listed below. For a complete list of FileStream class members, see the FileStream Members topic.

Public Instance Methods

Close | Closes the file and releases any resources associated with the current file stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
Lock | Prevents other processes from changing the FileStream while permitting read access.
Read | Reads a block of bytes from the stream.
ReadByte | Reads a byte from the file and advances the read position one byte.
Seek | Sets the current position of this stream to the given value.
SetLength | Sets the length of this stream to the given value.
UnLock | Allows access by other processes to all or part of a file that was previously locked.
Write | Writes a block of bytes to this stream.
WriteByte | Writes a byte to the current position in the file stream.

See Also

FileStream Class | Kixforms Namespace


FileStream.Close Method

Closes the file and releases any resources associated with the current file stream.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();

Remarks

Any data previously written to the buffer is copied to the file before the file stream is closed, so it is not necessary to call Flush before invoking Close. Following a call to Close, any operations on the file stream might raise exceptions. After Close has been called once, it does nothing if called again.

See Also

FileStream Class | Kixforms Namespace


FileStream.Flush Method

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();

See Also

FileStream Class | Kixforms Namespace


FileStream.Lock Method

Prevents other processes from changing the FileStream while permitting read access.

[Visual Basic]
Public Sub Lock( _
ByVal position As Integer, _
ByVal length As Integer _
)
[C#]
public void Lock(
int position,
int length
);

Parameters

position
The beginning of the range to lock. The value of this parameter must be equal to or greater than zero (0).
length
The range to be locked.

See Also

FileStream Class | Kixforms Namespace


FileStream.Read Method

Reads a block of bytes from the stream.

[Visual Basic]
Public Function Read( _
ByVal offSet As Integer, _
ByVal Count As Integer _
) As Object()
[C#]
public object[] Read(
int offSet,
int Count
);

Parameters

offSet
Count

Return Value

the read bytes. The amount of read bytes might be less than the number of bytes requested if that number of bytes are not currently available, or none if the end of the stream is reached.

Remarks

If the read operation is successful, the current position of the stream is advanced by the number of bytes read. If an exception occurs, the current position of the stream is unchanged.

Example

$File1 = $system.FileStream("%temp%\someTempFile.txt", $system.FileMode_Open)
 "error of Open: " cError " - " @serror ?
if @error = 0 and $File1.CanRead
 $ReadArray=$File1.Read(0,$File1.Length)
endif

See Also

FileStream Class | Kixforms Namespace


FileStream.ReadByte Method

Reads a byte from the file and advances the read position one byte.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();

Return Value

The byte read.

Remarks

Example

"byte Read ->" $FileStream.ReadByte()

See Also

FileStream Class | Kixforms Namespace


FileStream.Seek Method

Sets the current position of this stream to the given value.

[Visual Basic]
Overrides Public Function Seek( _
ByVal offset As Integer, _
ByVal origin As SeekOrigin _
) As Integer
[C#]
public override int Seek(
int offset,
SeekOrigin origin
);

Parameters

offset
The point relative to origin from which to begin seeking.
origin
Specifies the beginning, the end, or the current position as a reference point for origin, using a value of type SeekOrigin.

Return Value

The new position in the stream.

Remarks

Seeking to any location beyond the length of the stream is supported.

Example

;Reading some 5 bytes of trash data from HD:
$File = $system.FileStream("%temp%\someTempFile.txt", $system.FileMode_Create)
if @error = 0 and $File.CanWrite and $File.CanSeek
 $pos = $File.Seek(0,$system.SeekOrigin_End)
 $File.SetLength = $pos + 5
 for each $byte in $File.Read(0,5)
  $byte " "
 next
endif

See Also

FileStream Class | Kixforms Namespace


FileStream.SetLength Method

Sets the length of this stream to the given value.

[Visual Basic]
Overrides Public Sub SetLength( _
ByVal val As Integer _
)
[C#]
public override void SetLength(
int val
);

Parameters

val
The new length of the stream.

Remarks

If the given value is less than the current length of the stream, the stream is truncated. If the given value is larger than the current length of the stream, the stream is expanded. If the stream is expanded, the contents of the stream between the old and the new length are undefined.

A stream must support both writing and seeking for SetLength to work.

Example

$File = $system.FileStream("%temp%\someTempFile.txt", $system.FileMode_Open)
 "error of Open: " cError " - " @serror ?
if @error = 0 and $File.CanWrite and $File.CanSeek
 $File.SetLength($File.Length/2) ;easy compression ;)
endif

See Also

FileStream Class | Kixforms Namespace


FileStream.UnLock Method

Allows access by other processes to all or part of a file that was previously locked.

[Visual Basic]
Public Sub UnLock( _
ByVal position As Integer, _
ByVal length As Integer _
)
[C#]
public void UnLock(
int position,
int length
);

Parameters

position
The beginning of the range to unlock.
length
The range to be unlocked.

See Also

FileStream Class | Kixforms Namespace


FileStream.Write Method

Writes a block of bytes to this stream.

[Visual Basic]
Overrides Public Sub Write( _
ByVal WriteArr As Object(), _
ByVal offSet As Integer, _
ByVal Count As Integer _
)
[C#]
public override void Write(
object[] WriteArr,
int offSet,
int Count
);

Parameters

WriteArr
The array whose bytes are written.
offSet
The byte offset in array at which to begin writing.
Count
The maximum number of bytes to write.

Remarks

The offset parameter gives the offset of the byte in array (the index) at which to begin writing, and the count parameter gives the maximum number of bytes that will be written to this stream. If the write operation is successful, the current position of the stream is advanced by the number of bytes written. If an exception occurs, the current position of the stream is unchanged.

Note Use the CanWrite property to determine whether the current instance supports writing. For additional information, see CanWrite.

Example

/*
 FileMode_Create - if file does not exist, it is created. if it does exist, it is truncated.
 FileAccess_ReadWrite - we can read and write to the file, as much as we please
 FileShare_none - no other filestream, in this process or in other can play with the file.
*/
$File1 = $system.FileStream("%temp%\someTempFile.txt", $system.FileMode_Create, $system.FileAccess_ReadWrite, $system.FileShare_none)
$arr=asc("K"),asc("i"),asc("X")
$File1.Write($arr,0,ubound($arr)+1)

See Also

FileStream Class | Kixforms Namespace


FileStream.WriteByte Method

Writes a byte to the current position in the file stream.

[Visual Basic]
Overrides Public Sub WriteByte( _
ByVal val As Byte _
)
[C#]
public override void WriteByte(
byte val
);

Parameters

val
The Byte to write

Remarks

In addition to type byte, you can use integer to descripe the value of byte to write.

Example

$File.WriteByte(asc("K"))
$File.WriteByte(asc("f"))
$File.WriteByte(asc(" "))
$File.WriteByte(asc("."))
$File.WriteByte(asc("N"))
$File.WriteByte(asc("e"))
$File.WriteByte(asc("t"))

See Also

FileStream Class | Kixforms Namespace


FlatStyle Enumeration

[Visual Basic]
Public Enum FlatStyle
[C#]
public enum FlatStyle

Members

Member Name | Description
Flat |
Popup |
Standard |
System |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FolderBrowserDialog Class

Represents a common dialog box that allows the user to choose a folder.

For a list of all members of this type, see FolderBrowserDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FolderBrowserDialog

[Visual Basic]
Public Class FolderBrowserDialog
Inherits CommonDialog
[C#]
public class FolderBrowserDialog : CommonDialog

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

FolderBrowserDialog Members | Kixforms Namespace


FolderBrowserDialog Members

FolderBrowserDialog overview

Public Instance Constructors

FolderBrowserDialog Constructor Initializes a new instance of the FolderBrowserDialog class.

Public Instance Properties

Description | Gets or sets the descriptive text displayed above the tree view control in the dialog box.
RootFolder | Gets or sets the root folder where the browsing starts from.
SelectedPath | Gets or sets the path selected by the user.
ShowNewFolderButton | Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets properties to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

FolderBrowserDialog Class | Kixforms Namespace


FolderBrowserDialog Constructor

Initializes a new instance of the FolderBrowserDialog class.

[Visual Basic]
Public Sub New()
[C#]
public FolderBrowserDialog();

See Also

FolderBrowserDialog Class | Kixforms Namespace


FolderBrowserDialog Properties

The properties of the FolderBrowserDialog class are listed below. For a complete list of FolderBrowserDialog class members, see the FolderBrowserDialog Members topic.

Public Instance Properties

Description | Gets or sets the descriptive text displayed above the tree view control in the dialog box.
RootFolder | Gets or sets the root folder where the browsing starts from.
SelectedPath | Gets or sets the path selected by the user.
ShowNewFolderButton | Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

FolderBrowserDialog Class | Kixforms Namespace


Description Property

KiXforms.NET Class Library

FolderBrowserDialog.Description Property

Gets or sets the descriptive text displayed above the tree view control in the dialog box.

[Visual Basic]
Public Property Description As String
[C#]
public string Description {get; set;}

See Also

FolderBrowserDialog Class | Kixforms Namespace


RootFolder Property

KiXforms.NET Class Library

FolderBrowserDialog.RootFolder Property

Gets or sets the root folder where the browsing starts from.

[Visual Basic]
Public Property RootFolder As SpecialFolder
[C#]
public SpecialFolder RootFolder {get; set;}

See Also

FolderBrowserDialog Class | Kixforms Namespace


SelectedPath Property

KiXforms.NET Class Library

FolderBrowserDialog.SelectedPath Property

Gets or sets the path selected by the user.

[Visual Basic]
Public Property SelectedPath As String
[C#]
public string SelectedPath {get; set;}

See Also

FolderBrowserDialog Class | Kixforms Namespace


ShowNewFolderButton Property

KiXforms.NET Class Library

FolderBrowserDialog.ShowNewFolderButton Property

Gets or sets a value indicating whether the New Folder button appears in the folder browser dialog box.

[Visual Basic]
Public Property ShowNewFolderButton As Boolean
[C#]
public bool ShowNewFolderButton {get; set;}

Remarks

This property is not functioning properly in the current release. Although it is enabled by default, the suggestion is to disable until further notice.

See Also

FolderBrowserDialog Class | Kixforms Namespace


FolderBrowserDialog Methods

The methods of the FolderBrowserDialog class are listed below. For a complete list of FolderBrowserDialog class members, see the FolderBrowserDialog Members topic.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets properties to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

FolderBrowserDialog Class | Kixforms Namespace


FolderBrowserDialog.Reset Method

Resets properties to their default values.

[Visual Basic]
Public Sub Reset()
[C#]
public void Reset();

See Also

FolderBrowserDialog Class | Kixforms Namespace


Font Class

Defines a particular format for text, including font face, size, and style attributes.

For a list of all members of this type, see Font Members.

System.Object
Kixforms.Font

[Visual Basic]
Public Class Font
[C#]
public class Font

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Font Members | Kixforms Namespace


Font Members

Font overview

Public Instance Constructors

Font Constructor Initializes a new instance of the Font class.

Public Instance Properties

Height | Gets the height of this Font object in current grpahics units.
Name | Gets the face name of this Font object.
Size | Gets the em-size of this Font object in design units.
Style | Gets style information for this Font object.

See Also

Font Class | Kixforms Namespace


Font Constructor

Initializes a new instance of the Font class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal name As String = "Nothing", _
Optional ByVal size As Single = 0, _
Optional ByVal style As FontStyle = 0 _
)
[C#]
public Font(
string name,
float size,
FontStyle style
);

See Also

Font Class | Kixforms Namespace


Font Properties

The properties of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Properties

Height | Gets the height of this Font object in current grpahics units.
Name | Gets the face name of this Font object.
Size | Gets the em-size of this Font object in design units.
Style | Gets style information for this Font object.

See Also

Font Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Font.Height Property

Gets the height of this Font object in current grpahics units.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}

See Also

Font Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

Font.Name Property

Gets the face name of this Font object.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

See Also

Font Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Font.Size Property

Gets the em-size of this Font object in design units.

[Visual Basic]
Public ReadOnly Property Size As Single
[C#]
public float Size {get;}

See Also

Font Class | Kixforms Namespace


Style Property

KiXforms.NET Class Library

Font.Style Property

Gets style information for this Font object.

[Visual Basic]
Public ReadOnly Property Style As FontStyle
[C#]
public FontStyle Style {get;}

See Also

Font Class | Kixforms Namespace


FontDialog Class

Represents a common dialog box that displays a list of fonts that are currently installed on the system.

For a list of all members of this type, see FontDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FontDialog

[Visual Basic]
Public Class FontDialog
Inherits CommonDialog
[C#]
public class FontDialog : CommonDialog

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

FontDialog Members | Kixforms Namespace


FontDialog Members

FontDialog overview

Public Instance Constructors

FontDialog Constructor Initializes a new instance of the FontDialog class.

Public Instance Properties

Font | Gets or sets the selected font.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

FontDialog Class | Kixforms Namespace


FontDialog Constructor

Initializes a new instance of the FontDialog class.

[Visual Basic]
Public Sub New()
[C#]
public FontDialog();

See Also

FontDialog Class | Kixforms Namespace


FontDialog Properties

The properties of the FontDialog class are listed below. For a complete list of FontDialog class members, see the FontDialog Members topic.

Public Instance Properties

Font | Gets or sets the selected font.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

FontDialog Class | Kixforms Namespace


Font Property

KiXforms.NET Class Library

FontDialog.Font Property

Gets or sets the selected font.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}

See Also

FontDialog Class | Kixforms Namespace


FontStyle Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum FontStyle
[C#]
public enum FontStyle

Members

Member Name | Description | Value
Bold |  | 1
Italic |  | 2
Regular |  | 0
Strikeout |  | 8
Underline |  | 4

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Form Class

Represents a window or dialog box that makes up an application's user interface.

For a list of all members of this type, see Form Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.Form

[Visual Basic]
Public Class Form
Inherits ContainerControl
[C#]
public class Form : ContainerControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Form Members | Kixforms Namespace


Form Members

Form overview

Public Static (Shared) Methods

SetParent

Public Instance Constructors

Form Constructor Initializes a new instance of the Form class.

Public Instance Properties

AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
Activated | Gets or sets the code to execute when the form is activated in code or by the user.
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveForm | Gets the currently active form for this application.
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
Closed | Gets or sets the code to execute when the form is closed.
Closing | Gets or sets the code to execute when a form is closing.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Deactivate | Gets or sets the code to execute when the form loses focus and is not the active form.
DialogResult | Gets or sets the dialog result for the form.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle | Gets or sets the border style of the form.
Height (inherited from Control) | Gets or sets the height of the control.
Icon | Gets or sets the icon for the form.
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left | Gets or sets the x-coordinate of the form's left edge in pixels.
Load | Gets or sets the code to execute before a form is displayed for the first time.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MdiChildActivate | Gets or sets the code to execute when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu | Gets or sets the MainMenu that is displayed in the form.
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Owner | Gets or sets the form that owns this form.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent | Gets or sets the form that owns this form.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
StartPosition | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top | Gets or sets the y-coordinate of the form's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey | Gets or sets the color that will represent transparent areas of the form.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState | Gets or sets the form's window state.

Public Instance Methods

Activate | Activates the form and gives it focus.
BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close | Closes the form.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
DoEvents | Processes all Windows messages currently in the message queue.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
ShowDialog | Shows the form as a modal dialog box.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Form Class | Kixforms Namespace


Form Constructor

Initializes a new instance of the Form class.

[Visual Basic]
Public Sub New()
[C#]
public Form();

See Also

Form Class | Kixforms Namespace


Form Properties

The properties of the Form class are listed below. For a complete list of Form class members, see the Form Members topic.

Public Instance Properties

AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key.
Activated | Gets or sets the code to execute when the form is activated in code or by the user.
ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
ActiveForm | Gets the currently active form for this application.
ActiveMdiChild | Gets the currently active multiple document interface (MDI) child window.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
Closed | Gets or sets the code to execute when the form is closed.
Closing | Gets or sets the code to execute when a form is closing.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Deactivate | Gets or sets the code to execute when the form loses focus and is not the active form.
DialogResult | Gets or sets the dialog result for the form.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FormBorderStyle | Gets or sets the border style of the form.
Height (inherited from Control) | Gets or sets the height of the control.
Icon | Gets or sets the icon for the form.
IsMdiChild | Gets a value indicating whether the form is a multiple document interface (MDI) child form.
IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left | Gets or sets the x-coordinate of the form's left edge in pixels.
Load | Gets or sets the code to execute before a form is displayed for the first time.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaximizeBox | Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.
MdiChildActivate | Gets or sets the code to execute when a multiple document interface (MDI) child form is activated or closed within an MDI application.
MdiChildren | Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.
MdiParent | Gets or sets the current multiple document interface (MDI) parent form of this form.
Menu | Gets or sets the MainMenu that is displayed in the form.
MinimizeBox | Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Owner | Gets or sets the form that owns this form.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent | Gets or sets the form that owns this form.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
StartPosition | Gets or sets the starting position of the form at run time.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top | Gets or sets the y-coordinate of the form's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
TopMost | Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.
TransparencyKey | Gets or sets the color that will represent transparent areas of the form.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowState | Gets or sets the form's window state.

See Also

Form Class | Kixforms Namespace


AcceptButton Property

KiXforms.NET Class Library

Form.AcceptButton Property

Gets or sets the button on the form that is clicked when the user presses the ENTER key.

[Visual Basic]
Public Property AcceptButton As Control
[C#]
public Control AcceptButton {get; set;}

See Also

Form Class | Kixforms Namespace


Activated Property

KiXforms.NET Class Library

Form.Activated Property

Gets or sets the code to execute when the form is activated in code or by the user.

[Visual Basic]
Public Property Activated As String
[C#]
public string Activated {get; set;}

See Also

Form Class | Kixforms Namespace


ActiveForm Property

KiXforms.NET Class Library

Form.ActiveForm Property

Gets the currently active form for this application.

[Visual Basic]
Public ReadOnly Property ActiveForm As Form
[C#]
public Form ActiveForm {get;}

See Also

Form Class | Kixforms Namespace


ActiveMdiChild Property

KiXforms.NET Class Library

Form.ActiveMdiChild Property

Gets the currently active multiple document interface (MDI) child window.

[Visual Basic]
Public ReadOnly Property ActiveMdiChild As Form
[C#]
public Form ActiveMdiChild {get;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


AutoScaleBaseSize Property

KiXforms.NET Class Library

Form.AutoScaleBaseSize Property

Gets or sets the base size used for autoscaling of the form.

[Visual Basic]
Public Property AutoScaleBaseSize As Size
[C#]
public Size AutoScaleBaseSize {get; set;}

See Also

Form Class | Kixforms Namespace


CancelButton Property

KiXforms.NET Class Library

Form.CancelButton Property

Gets or sets the button control that is clicked when the user presses the ESC key.

[Visual Basic]
Public Property CancelButton As Control
[C#]
public Control CancelButton {get; set;}

See Also

Form Class | Kixforms Namespace


Closed Property

KiXforms.NET Class Library

Form.Closed Property

Gets or sets the code to execute when the form is closed.

[Visual Basic]
Public Property Closed As String
[C#]
public string Closed {get; set;}

See Also

Form Class | Kixforms Namespace


Closing Property

KiXforms.NET Class Library

Form.Closing Property

Gets or sets the code to execute when a form is closing.

[Visual Basic]
Public Property Closing As String
[C#]
public string Closing {get; set;}

Remarks

The Event property receives a value of type CancelEventArgs containing data related to this event.

See Also

Form Class | Kixforms Namespace


ControlBox Property

KiXforms.NET Class Library

Form.ControlBox Property

Gets or sets a value indicating whether a control box is displayed in the caption bar of the form.

[Visual Basic]
Public Property ControlBox As Boolean
[C#]
public bool ControlBox {get; set;}

Remarks

This property is not functioning correctly in the current release.

See Also

Form Class | Kixforms Namespace


Deactivate Property

KiXforms.NET Class Library

Form.Deactivate Property

Gets or sets the code to execute when the form loses focus and is not the active form.

[Visual Basic]
Public Property Deactivate As String
[C#]
public string Deactivate {get; set;}

See Also

Form Class | Kixforms Namespace


DialogResult Property

KiXforms.NET Class Library

Form.DialogResult Property

Gets or sets the dialog result for the form.

[Visual Basic]
Public Property DialogResult As DialogResult
[C#]
public DialogResult DialogResult {get; set;}

See Also

Form Class | Kixforms Namespace


FormBorderStyle Property

KiXforms.NET Class Library

Form.FormBorderStyle Property

Gets or sets the border style of the form.

[Visual Basic]
Public Property FormBorderStyle As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle {get; set;}

See Also

Form Class | Kixforms Namespace


Icon Property

KiXforms.NET Class Library

Form.Icon Property

Gets or sets the icon for the form.

[Visual Basic]
Public Property Icon As Icon
[C#]
public Icon Icon {get; set;}

See Also

Form Class | Kixforms Namespace


IsMdiChild Property

KiXforms.NET Class Library

Form.IsMdiChild Property

Gets a value indicating whether the form is a multiple document interface (MDI) child form.

[Visual Basic]
Public ReadOnly Property IsMdiChild As Boolean
[C#]
public bool IsMdiChild {get;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


IsMdiContainer Property

KiXforms.NET Class Library

Form.IsMdiContainer Property

Gets or sets a value indicating whether the form is a container for multiple document interface (MDI) child forms.

[Visual Basic]
Public Property IsMdiContainer As Boolean
[C#]
public bool IsMdiContainer {get; set;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


KeyPreview Property

KiXforms.NET Class Library

Form.KeyPreview Property

Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus.

[Visual Basic]
Public Property KeyPreview As Boolean
[C#]
public bool KeyPreview {get; set;}

See Also

Form Class | Kixforms Namespace


Left Property

KiXforms.NET Class Library

Form.Left Property

Gets or sets the x-coordinate of the form's left edge in pixels.

[Visual Basic]
Overrides Public Property Left As Integer
[C#]
public override int Left {get; set;}

See Also

Form Class | Kixforms Namespace


Load Property

KiXforms.NET Class Library

Form.Load Property

Gets or sets the code to execute before a form is displayed for the first time.

[Visual Basic]
Public Property Load As String
[C#]
public string Load {get; set;}

See Also

Form Class | Kixforms Namespace


MaximizeBox Property

KiXforms.NET Class Library

Form.MaximizeBox Property

Gets or sets a value indicating whether the maximize button is displayed in the caption bar of the form.

[Visual Basic]
Public Property MaximizeBox As Boolean
[C#]
public bool MaximizeBox {get; set;}

See Also

Form Class | Kixforms Namespace


MdiChildActivate Property

KiXforms.NET Class Library

Form.MdiChildActivate Property

Gets or sets the code to execute when a multiple document interface (MDI) child form is activated or closed within an MDI application.

[Visual Basic]
Public Property MdiChildActivate As String
[C#]
public string MdiChildActivate {get; set;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


MdiChildren Property

KiXforms.NET Class Library

Form.MdiChildren Property

Gets an array of forms that represent the multiple document interface (MDI) child forms that are parented to this form.

[Visual Basic]
Public ReadOnly Property MdiChildren As Object()
[C#]
public object[] MdiChildren {get;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


MdiParent Property

KiXforms.NET Class Library

Form.MdiParent Property

Gets or sets the current multiple document interface (MDI) parent form of this form.

[Visual Basic]
Public Property MdiParent As Form
[C#]
public Form MdiParent {get; set;}

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


Menu Property

KiXforms.NET Class Library

Form.Menu Property

Gets or sets the MainMenu that is displayed in the form.

[Visual Basic]
Public Property Menu As MainMenu
[C#]
public MainMenu Menu {get; set;}

See Also

Form Class | Kixforms Namespace


MinimizeBox Property

KiXforms.NET Class Library

Form.MinimizeBox Property

Gets or sets a value indicating whether the minimize button is displayed in the caption bar of the form.

[Visual Basic]
Public Property MinimizeBox As Boolean
[C#]
public bool MinimizeBox {get; set;}

See Also

Form Class | Kixforms Namespace


Owner Property

KiXforms.NET Class Library

Form.Owner Property

Gets or sets the form that owns this form.

[Visual Basic]
Public Property Owner As Form
[C#]
public Form Owner {get; set;}

See Also

Form Class | Kixforms Namespace


Parent Property

KiXforms.NET Class Library

Form.Parent Property

Gets or sets the form that owns this form.

[Visual Basic]
Overrides Public Property Parent As Object
[C#]
public override object Parent {get; set;}

See Also

Form Class | Kixforms Namespace


ShowInTaskbar Property

KiXforms.NET Class Library

Form.ShowInTaskbar Property

Gets or sets a value indicating whether the form is displayed in the Windows taskbar.

[Visual Basic]
Public Property ShowInTaskbar As Boolean
[C#]
public bool ShowInTaskbar {get; set;}

See Also

Form Class | Kixforms Namespace


StartPosition Property

KiXforms.NET Class Library

Form.StartPosition Property

Gets or sets the starting position of the form at run time.

[Visual Basic]
Public Property StartPosition As FormStartPosition
[C#]
public FormStartPosition StartPosition {get; set;}

See Also

Form Class | Kixforms Namespace


Top Property

KiXforms.NET Class Library

Form.Top Property

Gets or sets the y-coordinate of the form's top edge in pixels.

[Visual Basic]
Overrides Public Property Top As Integer
[C#]
public override int Top {get; set;}

See Also

Form Class | Kixforms Namespace


TopMost Property

KiXforms.NET Class Library

Form.TopMost Property

Gets or sets a value indicating whether the form should be displayed as the top-most form of your application.

[Visual Basic]
Public Property TopMost As Boolean
[C#]
public bool TopMost {get; set;}

See Also

Form Class | Kixforms Namespace


TransparencyKey Property

KiXforms.NET Class Library

Form.TransparencyKey Property

Gets or sets the color that will represent transparent areas of the form.

[Visual Basic]
Public Property TransparencyKey As Color
[C#]
public Color TransparencyKey {get; set;}

Property Value

A Color that represents the color to display transparently on the form.

See Also

Form Class | Kixforms Namespace


WindowState Property

KiXforms.NET Class Library

Form.WindowState Property

Gets or sets the form's window state.

[Visual Basic]
Public Property WindowState As FormWindowState
[C#]
public FormWindowState WindowState {get; set;}

See Also

Form Class | Kixforms Namespace


Form Methods

The methods of the Form class are listed below. For a complete list of Form class members, see the Form Members topic.

Public Static (Shared) Methods

SetParent

Public Instance Methods

Activate | Activates the form and gives it focus.
BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Close | Closes the form.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
DoEvents | Processes all Windows messages currently in the message queue.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
LayoutMdi | Arranges the multiple document interface (MDI) child forms within the MDI parent form.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
ShowDialog | Shows the form as a modal dialog box.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Form Class | Kixforms Namespace


Form.Activate Method

Activates the form and gives it focus.

[Visual Basic]
Public Sub Activate()
[C#]
public void Activate();

See Also

Form Class | Kixforms Namespace


Form.Close Method

Closes the form.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

Form Class | Kixforms Namespace


Form.DoEvents Method

Processes all Windows messages currently in the message queue.

[Visual Basic]
Public Function DoEvents( _
Optional ByVal wait As Boolean = True _
) As String
[C#]
public string DoEvents(
bool wait
);

See Also

Form Class | Kixforms Namespace


Form.LayoutMdi Method

Arranges the multiple document interface (MDI) child forms within the MDI parent form.

[Visual Basic]
Public Sub LayoutMdi( _
ByVal value As MdiLayout _
)
[C#]
public void LayoutMdi(
MdiLayout value
);

Parameters

value
One of the MdiLayout values that defines the layout of MDI child forms.

Remarks

The Kixforms.Net MDI feature is still under development. Please do not use at this time.

See Also

Form Class | Kixforms Namespace


Form.SetParent Method

[Visual Basic]
Public Shared Function SetParent( _
ByVal hWndChild As IntPtr, _
ByVal hWndNewParent As IntPtr _
) As IntPtr
[C#]
public static IntPtr SetParent(
IntPtr hWndChild,
IntPtr hWndNewParent
);

See Also

Form Class | Kixforms Namespace


Form.ShowDialog Method

Shows the form as a modal dialog box.

[Visual Basic]
Public Function ShowDialog() As DialogResult
[C#]
public DialogResult ShowDialog();

See Also

Form Class | Kixforms Namespace


FormBorderStyle Enumeration

[Visual Basic]
Public Enum FormBorderStyle
[C#]
public enum FormBorderStyle

Members

Member Name | Description
Fixed3D |
FixedDialog |
FixedSingle |
FixedToolWindow |
None |
Sizable |
SizableToolWindow |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FormStartPosition Enumeration

[Visual Basic]
Public Enum FormStartPosition
[C#]
public enum FormStartPosition

Members

Member Name | Description
CenterParent |
CenterScreen |
Manual |
WindowsDefaultBounds |
WindowsDefaultLocation |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


FormWindowState Enumeration

[Visual Basic]
Public Enum FormWindowState
[C#]
public enum FormWindowState

Members

Member Name | Description
Maximized |
Minimized |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Graphics Class

Encapsulates a GDI+ drawing surface.

For a list of all members of this type, see Graphics Members.

System.Object
Kixforms.Graphics

[Visual Basic]
Public Class Graphics
[C#]
public class Graphics

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Graphics Members | Kixforms Namespace


Graphics Members

Graphics overview

Public Instance Methods

Clear | Clears the entire drawing surface and fills it with the specified background color.
DrawEllipse | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawImage | Draws the specified Image object at the specified location and with the specified size.
DrawLine | Draws a line connecting the two points specified by coordinate pairs.
DrawRectangle | Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawString | Draws the specified text string at the specified location with the specified Brush and Font objects.
FillRectangle | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FromImage | Creates a new Graphics object from the specified Image object.

See Also

Graphics Class | Kixforms Namespace


Graphics Methods

The methods of the Graphics class are listed below. For a complete list of Graphics class members, see the Graphics Members topic.

Public Instance Methods

Clear | Clears the entire drawing surface and fills it with the specified background color.
DrawEllipse | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
DrawImage | Draws the specified Image object at the specified location and with the specified size.
DrawLine | Draws a line connecting the two points specified by coordinate pairs.
DrawRectangle | Draws a rectangle specified by a coordinate pair, a width, and a height.
DrawString | Draws the specified text string at the specified location with the specified Brush and Font objects.
FillRectangle | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
FromImage | Creates a new Graphics object from the specified Image object.

See Also

Graphics Class | Kixforms Namespace


Graphics.Clear Method

Clears the entire drawing surface and fills it with the specified background color.

[Visual Basic]
Public Sub Clear( _
ByVal color As Color _
)
[C#]
public void Clear(
Color color
);

See Also

Graphics Class | Kixforms Namespace


Graphics.DrawEllipse Method

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

[Visual Basic]
Public Sub DrawEllipse( _
ByVal pen As Pen, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
)
[C#]
public void DrawEllipse(
Pen pen,
float x,
float y,
float width,
float height
);

Parameters

pen
Pen object that determines the color, width, and style of the ellipse.
x
x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
y
y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.
width
Width of the bounding rectangle that defines the ellipse.
height
Height of the bounding rectangle that defines the ellipse.

See Also

Graphics Class | Kixforms Namespace


Graphics.DrawImage Method

Draws the specified Image object at the specified location and with the specified size.

[Visual Basic]
Public Sub DrawImage( _
ByVal image As Image, _
ByVal dx As Single, _
ByVal dy As Single, _
ByVal dw As Single, _
ByVal dh As Single, _
Optional ByVal sx As Single = 0, _
Optional ByVal sy As Single = 0, _
Optional ByVal sw As Single = -1, _
Optional ByVal sh As Single = -1 _
)
[C#]
public void DrawImage(
Image image,
float dx,
float dy,
float dw,
float dh,
float sx,
float sy,
float sw,
float sh
);

Parameters

image
Image object to draw.
dx
x-coordinate of the upper-left corner of the drawn image.
dy
y-coordinate of the upper-left corner of the drawn image.
dw
Width of the drawn image.
dh
Height of the drawn image.
sx
x-coordinate of the upper-left corner of the source image.
sy
y-coordinate of the upper-left corner of the source image.
sw
Width of the source image.
sh
Height of the source image.

See Also

Graphics Class | Kixforms Namespace


Graphics.DrawLine Method

Draws a line connecting the two points specified by coordinate pairs.

[Visual Basic]
Public Sub DrawLine( _
ByVal pen As Pen, _
ByVal x1 As Single, _
ByVal y1 As Single, _
ByVal x2 As Single, _
ByVal y2 As Single _
)
[C#]
public void DrawLine(
Pen pen,
float x1,
float y1,
float x2,
float y2
);

Parameters

pen
Pen object that determines the color, width, and style of the line.
x1
x-coordinate of the first point.
y1
y-coordinate of the first point.
x2
x-coordinate of the second point.
y2
y-coordinate of the second point.

See Also

Graphics Class | Kixforms Namespace


Graphics.DrawRectangle Method

Draws a rectangle specified by a coordinate pair, a width, and a height.

[Visual Basic]
Public Sub DrawRectangle( _
ByVal pen As Pen, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
)
[C#]
public void DrawRectangle(
Pen pen,
float x,
float y,
float width,
float height
);

Parameters

pen
Pen object that determines the color, width, and style of the outlines of the rectangles.
x
x coordinate of the upper-left corner of the drawn rectangle.
y
y coordinate of the upper-left corner of the drawn rectangle.
width
width of the drawn rectangle.
height
height of the drawn rectangle.

See Also

Graphics Class | Kixforms Namespace


Graphics.DrawString Method

Draws the specified text string at the specified location with the specified Brush and Font objects.

[Visual Basic]
Public Sub DrawString( _
ByVal str As String, _
ByVal font As Font, _
ByVal brush As Brush, _
ByVal x As Single, _
ByVal y As Single _
)
[C#]
public void DrawString(
string str,
Font font,
Brush brush,
float x,
float y
);

Parameters

str
String to draw.
font
Font object that defines the text format of the string.
brush
Brush object that determines the color and texture of the drawn text.
x
x coordinate of the upper-left corner of the drawn text.
y
y coordinate of the upper-left corner of the drawn text.

See Also

Graphics Class | Kixforms Namespace


Graphics.FillRectangle Method

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

[Visual Basic]
Public Sub FillRectangle( _
ByVal brush As Brush, _
ByVal x As Single, _
ByVal y As Single, _
ByVal width As Single, _
ByVal height As Single _
)
[C#]
public void FillRectangle(
Brush brush,
float x,
float y,
float width,
float height
);

Parameters

brush
Brush object that determines the characteristics of the fill.
x
x coordinate of the upper-left corner of the rectangle to fill.
y
y coordinate of the upper-left corner of the rectangle to fill.
width
width of the rectangle to fill.
height
height of the rectangle to fill.

See Also

Graphics Class | Kixforms Namespace


Graphics.FromImage Method

Creates a new Graphics object from the specified Image object.

[Visual Basic]
Public Function FromImage( _
ByVal image As Image _
) As Graphics
[C#]
public Graphics FromImage(
Image image
);

Parameters

image
Image object from which to create the new Graphics object.

Return Value

This method returns a new Graphics for the specified Image object.

See Also

Graphics Class | Kixforms Namespace


GridColumnStylesCollection Class

Represents a collection of DataGridColumnStyle objects in the DataGrid control.

For a list of all members of this type, see GridColumnStylesCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.GridColumnStylesCollection

[Visual Basic]
Public Class GridColumnStylesCollection
Inherits CollectionBase
[C#]
public class GridColumnStylesCollection : CollectionBase

Remarks

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

GridColumnStylesCollection Members | Kixforms Namespace


GridColumnStylesCollection Members

GridColumnStylesCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the column style at a specified index.

Public Instance Methods

Add | Adds a column style to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

GridColumnStylesCollection Class | Kixforms Namespace


GridColumnStylesCollection Properties

The properties of the GridColumnStylesCollection class are listed below. For a complete list of GridColumnStylesCollection class members, see the GridColumnStylesCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the column style at a specified index.

See Also

GridColumnStylesCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

GridColumnStylesCollection.Item Property

Gets the column style at a specified index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DataGridColumnStyle
[C#]
new public DataGridColumnStyle this[
int index
] {get;}

Parameters

index
The zero-based index of the column style to return.

Property Value

The specified DataGridColumnStyle.

See Also

GridColumnStylesCollection Class | Kixforms Namespace


GridColumnStylesCollection Methods

The methods of the GridColumnStylesCollection class are listed below. For a complete list of GridColumnStylesCollection class members, see the GridColumnStylesCollection Members topic.

Public Instance Methods

Add | Adds a column style to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

GridColumnStylesCollection Class | Kixforms Namespace


GridColumnStylesCollection.Add Method

Adds a column style to the collection.

[Visual Basic]
Public Function Add( _
ByVal column As DataGridColumnStyle _
) As Integer
[C#]
public int Add(
DataGridColumnStyle column
);

Parameters

column
The DataGridColumnStyle to add to the collection.

Return Value

The index of the new DataGridColumnStyle object.

See Also

GridColumnStylesCollection Class | Kixforms Namespace


GridTableStylesCollection Class

Represents a collection of DataGridTableStyle objects in the DataGrid control.

For a list of all members of this type, see GridTableStylesCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.GridTableStylesCollection

[Visual Basic]
Public Class GridTableStylesCollection
Inherits CollectionBase
[C#]
public class GridTableStylesCollection : CollectionBase

Remarks

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

GridTableStylesCollection Members | Kixforms Namespace


GridTableStylesCollection Members

GridTableStylesCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the DataGridTableStyle specified by index.

Public Instance Methods

Add | Adds a table style to this collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

GridTableStylesCollection Class | Kixforms Namespace


GridTableStylesCollection Properties

The properties of the GridTableStylesCollection class are listed below. For a complete list of GridTableStylesCollection class members, see the GridTableStylesCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the DataGridTableStyle specified by index.

See Also

GridTableStylesCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

GridTableStylesCollection.Item Property

Gets the DataGridTableStyle specified by index.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As DataGridTableStyle
[C#]
new public DataGridTableStyle this[
int index
] {get;}

Parameters

index
The zero-based index of the DataGridTableStyle to return.

Property Value

The specified DataGridTableStyle.

See Also

GridTableStylesCollection Class | Kixforms Namespace


GridTableStylesCollection Methods

The methods of the GridTableStylesCollection class are listed below. For a complete list of GridTableStylesCollection class members, see the GridTableStylesCollection Members topic.

Public Instance Methods

Add | Adds a table style to this collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

GridTableStylesCollection Class | Kixforms Namespace


GridTableStylesCollection.Add Method

Adds a table style to this collection.

[Visual Basic]
Public Function Add( _
ByVal table As DataGridTableStyle _
) As Integer
[C#]
public int Add(
DataGridTableStyle table
);

Parameters

table
The DataGridTableStyle to add to the collection.

Return Value

The index of the newly added object.

See Also

GridTableStylesCollection Class | Kixforms Namespace


GroupBox Class

Represents a Windows group box.

For a list of all members of this type, see GroupBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.GroupBox

[Visual Basic]
Public Class GroupBox
Inherits Control
[C#]
public class GroupBox : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

GroupBox Members | Kixforms Namespace


GroupBox Members

GroupBox overview

Public Instance Constructors

GroupBox Constructor Initializes a new instance of the GroupBox class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

GroupBox Class | Kixforms Namespace


GroupBox Constructor

Initializes a new instance of the GroupBox class.

[Visual Basic]
Public Sub New()
[C#]
public GroupBox();

See Also

GroupBox Class | Kixforms Namespace


HatchBrush Class

Defines a rectangular brush with a hatch style, a foreground color, and a background color.

For a list of all members of this type, see HatchBrush Members.

System.Object
Kixforms.Brush
Kixforms.HatchBrush

[Visual Basic]
Public Class HatchBrush
Inherits Brush
[C#]
public class HatchBrush : Brush

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

HatchBrush Members | Kixforms Namespace


HatchBrush Members

HatchBrush overview

Public Instance Constructors

HatchBrush Constructor Initializes a new instance of the HatchBrush class.

See Also

HatchBrush Class | Kixforms Namespace


HatchBrush Constructor

Initializes a new instance of the HatchBrush class.

[Visual Basic]
Overloads Public Sub New( _
ByVal hatchStyle As HatchStyle, _
ByVal foreColor As Color, _
Optional ByVal backColor As Color = Nothing _
)
[C#]
public HatchBrush(
HatchStyle hatchStyle,
Color foreColor,
Color backColor
);

Parameters

hatchStyle
The HatchStyle enumeration that represents the pattern drawn by this HatchBrush.
foreColor
The Color structure that represents the color of lines drawn by this HatchBrush.
backColor
The Color structure that represents the color of spaces between the lines drawn by this HatchBrush.

Remarks

The background color is initialized to black.

See Also

HatchBrush Class | Kixforms Namespace


HatchStyle Enumeration

[Visual Basic]
Public Enum HatchStyle
[C#]
public enum HatchStyle

Members

Member Name | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal. This hatch pattern is not antialiased.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of HatchStyleHorizontal.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width, but the lines are not antialiased.
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points.
DashedVertical | Specifies dashed vertical lines.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
DiagonalCross | Specifies forward diagonal and backward diagonal lines that cross. The lines are antialiased.
Divot | Specifies a hatch that has the appearance of divots.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
LargeGrid | Specifies the hatch style Cross.
LightDownwardDiagonal |
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal, but they are not antialiased.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
Max | Specifies hatch style SolidDiamond.
Min | Specifies hatch style Horizonal.
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal (or 25 percent closer together than LightHorizontal).
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical (or 25 percent closer together than LightVertical).
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross but are not antialiased.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Shingle | Specifies a hatch that has the appearance of diagonally-layered shingles that slant to the right from top points to bottom points.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
Trellis | Specifies a hatch that has the appearance of a trellis.
Vertical | A pattern of vertical lines.
Wave | Specifies horizontal lines that are composed of tildes.
Weave | Specifies a hatch that has the appearance of a woven material.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width, but are not antialiased.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width, but are not antialiased.
ZigZag | Specifies horizontal lines that are composed of zigzags.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


HorizontalAlignment Enumeration

[Visual Basic]
Public Enum HorizontalAlignment
[C#]
public enum HorizontalAlignment

Members

Member Name | Description
Center |
Left |
Right |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Icon Class

Represents a Windows icon, which is a small bitmap image used to represent an object. Icons can be thought of as transparent bitmaps, although their size is determined by the system.

For a list of all members of this type, see Icon Members.

System.Object
Kixforms.Icon

[Visual Basic]
Public Class Icon
[C#]
public class Icon

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Icon Members | Kixforms Namespace


Icon Members

Icon overview

Public Instance Constructors

Icon Constructor Initializes a new instance of the Icon class from the specified file name.

Public Instance Properties

Height | Gets the height of this Icon object.
Size | Gets the size of this Icon object.
Width | Gets the width of this Icon object.

Public Instance Methods

FromBase64String | Converts the specified string representation of an icon consisting of base 64 digits to an equivalent icon.
FromBitmap | Converts the specified bitmap to an equivalent icon.
FromFile | Creates a Icon object from the specified file.
ToBitmap | Converts this Icon object to a GDI+ Bitmap object.

See Also

Icon Class | Kixforms Namespace


Icon Constructor

Initializes a new instance of the Icon class from the specified file name.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal filename As String = "Nothing" _
)
[C#]
public Icon(
string filename
);

See Also

Icon Class | Kixforms Namespace


Icon Properties

The properties of the Icon class are listed below. For a complete list of Icon class members, see the Icon Members topic.

Public Instance Properties

Height | Gets the height of this Icon object.
Size | Gets the size of this Icon object.
Width | Gets the width of this Icon object.

See Also

Icon Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Icon.Height Property

Gets the height of this Icon object.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}

See Also

Icon Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Icon.Size Property

Gets the size of this Icon object.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}

See Also

Icon Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

Icon.Width Property

Gets the width of this Icon object.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}

See Also

Icon Class | Kixforms Namespace


Icon Methods

The methods of the Icon class are listed below. For a complete list of Icon class members, see the Icon Members topic.

Public Instance Methods

FromBase64String | Converts the specified string representation of an icon consisting of base 64 digits to an equivalent icon.
FromBitmap | Converts the specified bitmap to an equivalent icon.
FromFile | Creates a Icon object from the specified file.
ToBitmap | Converts this Icon object to a GDI+ Bitmap object.

See Also

Icon Class | Kixforms Namespace


Icon.FromBase64String Method

Converts the specified string representation of an icon consisting of base 64 digits to an equivalent icon.

[Visual Basic]
Public Function FromBase64String( _
ByVal s As String _
) As Icon
[C#]
public Icon FromBase64String(
string s
);

Parameters

s
A String.

Return Value

An Icon object equivalent to s.

See Also

Icon Class | Kixforms Namespace


Icon.FromBitmap Method

Converts the specified bitmap to an equivalent icon.

[Visual Basic]
Public Function FromBitmap( _
ByVal bitmap As Bitmap _
) As Icon
[C#]
public Icon FromBitmap(
Bitmap bitmap
);

Parameters

bitmap
A Bitmap.

Return Value

The Icon object this method creates.

See Also

Icon Class | Kixforms Namespace


Icon.FromFile Method

Creates a Icon object from the specified file.

[Visual Basic]
Public Function FromFile( _
ByVal filename As String _
) As Icon
[C#]
public Icon FromFile(
string filename
);

See Also

Icon Class | Kixforms Namespace


Icon.ToBitmap Method

Converts this Icon object to a GDI+ Bitmap object.

[Visual Basic]
Public Function ToBitmap() As Bitmap
[C#]
public Bitmap ToBitmap();

Return Value

A Bitmap object representing the converted Icon object.

See Also

Icon Class | Kixforms Namespace


Image Class

An abstract base class that provides functionality for Bitmap, Icon and Metafile descended classes.

For a list of all members of this type, see Image Members.

System.Object
Kixforms.Image
Kixforms.Bitmap

[Visual Basic]
Public Class Image
[C#]
public class Image

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Image Members | Kixforms Namespace


Image Members

Image overview

Public Instance Constructors

Image Constructor Initializes a new instance of the Image class.

Public Instance Properties

Height | Gets the height of this Image object.
RawFormat | Gets the height of this Image object.
Size | Gets the width and height of this Image object.
Width | Gets the width of this Image object.

Public Instance Methods

Dispose | Releases all resources used by this Image object.
FromFile | Creates an Image object from the specified file.
FromStream | Creates an Image object from the specified data stream.
Save | Saves this Image object to the specified file in the specified format.

See Also

Image Class | Kixforms Namespace


Image Constructor

Initializes a new instance of the Image class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Image();

See Also

Image Class | Kixforms Namespace


Image Properties

The properties of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public Instance Properties

Height | Gets the height of this Image object.
RawFormat | Gets the height of this Image object.
Size | Gets the width and height of this Image object.
Width | Gets the width of this Image object.

See Also

Image Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Image.Height Property

Gets the height of this Image object.

[Visual Basic]
Public ReadOnly Property Height As Integer
[C#]
public int Height {get;}

See Also

Image Class | Kixforms Namespace


RawFormat Property

KiXforms.NET Class Library

Image.RawFormat Property

Gets the height of this Image object.

[Visual Basic]
Public ReadOnly Property RawFormat As Object
[C#]
public object RawFormat {get;}

See Also

Image Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Image.Size Property

Gets the width and height of this Image object.

[Visual Basic]
Public ReadOnly Property Size As Size
[C#]
public Size Size {get;}

See Also

Image Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

Image.Width Property

Gets the width of this Image object.

[Visual Basic]
Public ReadOnly Property Width As Integer
[C#]
public int Width {get;}

See Also

Image Class | Kixforms Namespace


Image Methods

The methods of the Image class are listed below. For a complete list of Image class members, see the Image Members topic.

Public Instance Methods

Dispose | Releases all resources used by this Image object.
FromFile | Creates an Image object from the specified file.
FromStream | Creates an Image object from the specified data stream.
Save | Saves this Image object to the specified file in the specified format.

See Also

Image Class | Kixforms Namespace


Image.Dispose Method

Releases all resources used by this Image object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

Image Class | Kixforms Namespace


Image.FromFile Method

Creates an Image object from the specified file.

[Visual Basic]
Public Function FromFile( _
ByVal filename As String _
) As Image
[C#]
public Image FromFile(
string filename
);

Parameters

filename
The name of the file.

See Also

Image Class | Kixforms Namespace


Image.FromStream Method

Creates an Image object from the specified data stream.

[Visual Basic]
Public Function FromStream( _
ByVal stream As Stream _
) As Image
[C#]
public Image FromStream(
Stream stream
);

Parameters

stream
A Stream object that contains the data for this Image object.

See Also

Image Class | Kixforms Namespace


Image.Save Method

Saves this Image object to the specified file in the specified format.

[Visual Basic]
Public Sub Save( _
ByVal filename As String, _
Optional ByVal format As ImageFormat = Nothing _
)
[C#]
public void Save(
string filename,
ImageFormat format
);

See Also

Image Class | Kixforms Namespace


ImageCollection Class

Encapsulates the collection of Image objects in an ImageList.

For a list of all members of this type, see ImageCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ImageCollection

[Visual Basic]
Public Class ImageCollection
Inherits CollectionBase
[C#]
public class ImageCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ImageCollection Members | Kixforms Namespace


ImageCollection Members

ImageCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets an Image in an existing ImageList.

Public Instance Methods

Add | Adds the specified image to the ImageList, using the specified color to generate the mask.
AddStrip | Adds an image strip to the specified image to the ImageList.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ImageCollection Class | Kixforms Namespace


ImageCollection Properties

The properties of the ImageCollection class are listed below. For a complete list of ImageCollection class members, see the ImageCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets an Image in an existing ImageList.

See Also

ImageCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ImageCollection.Item Property

Gets an Image in an existing ImageList.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As Image
[C#]
public Image this[
int index
] {get; set;}

See Also

ImageCollection Class | Kixforms Namespace


ImageCollection Methods

The methods of the ImageCollection class are listed below. For a complete list of ImageCollection class members, see the ImageCollection Members topic.

Public Instance Methods

Add | Adds the specified image to the ImageList, using the specified color to generate the mask.
AddStrip | Adds an image strip to the specified image to the ImageList.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ImageCollection Class | Kixforms Namespace


ImageCollection.Add Method

Adds the specified image to the ImageList, using the specified color to generate the mask.

[Visual Basic]
Public Function Add( _
ByVal image As Image, _
Optional ByVal color As Color = Nothing _
) As Integer
[C#]
public int Add(
Image image,
Color color
);

Parameters

image
A Bitmap of the image to add to the list.
color
Optional. The Color to mask this image.

Return Value

The index of the newly added image or -1 if the the image could not be added.

See Also

ImageCollection Class | Kixforms Namespace


ImageCollection.AddStrip Method

Adds an image strip to the specified image to the ImageList.

[Visual Basic]
Public Function AddStrip( _
ByVal image As Image _
) As Integer
[C#]
public int AddStrip(
Image image
);

Parameters

image
A Bitmap object with the image(s) to add.

Return Value

The index of the newly added image or -1 if the the image could not be added.

See Also

ImageCollection Class | Kixforms Namespace


ImageFormat Class

Specifies the format of the image.

For a list of all members of this type, see ImageFormat Members.

System.Object
Kixforms.ImageFormat

[Visual Basic]
Public Class ImageFormat
[C#]
public class ImageFormat

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ImageFormat Members | Kixforms Namespace


ImageFormat Members

ImageFormat overview

Public Instance Properties

Bmp | Gets the bitmap image format (BMP).
Gif | Gets the Graphics Interchange Format (GIF) image format.
Icon | Gets the Windows icon image format.
Jpeg | Gets the Joint Photographic Experts Group (JPEG) image format.
Png | Gets the W3C Portable Network Graphics (PNG) image format.

See Also

ImageFormat Class | Kixforms Namespace


ImageFormat Properties

The properties of the ImageFormat class are listed below. For a complete list of ImageFormat class members, see the ImageFormat Members topic.

Public Instance Properties

Bmp | Gets the bitmap image format (BMP).
Gif | Gets the Graphics Interchange Format (GIF) image format.
Icon | Gets the Windows icon image format.
Jpeg | Gets the Joint Photographic Experts Group (JPEG) image format.
Png | Gets the W3C Portable Network Graphics (PNG) image format.

See Also

ImageFormat Class | Kixforms Namespace


Bmp Property

KiXforms.NET Class Library

ImageFormat.Bmp Property

Gets the bitmap image format (BMP).

[Visual Basic]
Public ReadOnly Property Bmp As ImageFormat
[C#]
public ImageFormat Bmp {get;}

See Also

ImageFormat Class | Kixforms Namespace


Gif Property

KiXforms.NET Class Library

ImageFormat.Gif Property

Gets the Graphics Interchange Format (GIF) image format.

[Visual Basic]
Public ReadOnly Property Gif As ImageFormat
[C#]
public ImageFormat Gif {get;}

See Also

ImageFormat Class | Kixforms Namespace


Icon Property

KiXforms.NET Class Library

ImageFormat.Icon Property

Gets the Windows icon image format.

[Visual Basic]
Public ReadOnly Property Icon As ImageFormat
[C#]
public ImageFormat Icon {get;}

See Also

ImageFormat Class | Kixforms Namespace


Jpeg Property

KiXforms.NET Class Library

ImageFormat.Jpeg Property

Gets the Joint Photographic Experts Group (JPEG) image format.

[Visual Basic]
Public ReadOnly Property Jpeg As ImageFormat
[C#]
public ImageFormat Jpeg {get;}

See Also

ImageFormat Class | Kixforms Namespace


Png Property

KiXforms.NET Class Library

ImageFormat.Png Property

Gets the W3C Portable Network Graphics (PNG) image format.

[Visual Basic]
Public ReadOnly Property Png As ImageFormat
[C#]
public ImageFormat Png {get;}

See Also

ImageFormat Class | Kixforms Namespace


ImageList Class

Provides methods to manage a collection of Image objects.

For a list of all members of this type, see ImageList Members.

System.Object
Kixforms.ImageList

[Visual Basic]
Public Class ImageList
[C#]
public class ImageList

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ImageList Members | Kixforms Namespace


ImageList Members

ImageList overview

Public Instance Constructors

ImageList Constructor Initializes a new instance of the ImageList class.

Public Instance Properties

ColorDepth | Gets the color depth of the image list.
Images | Gets the ImageCollection for this image list. Use Images(index), where index the image index number, to return a specific image from the collection.
ImageSize | Gets or sets the size of the images in the image list.
TransparentColor | Gets or sets the color to treat as transparent.

See Also

ImageList Class | Kixforms Namespace


ImageList Constructor

Initializes a new instance of the ImageList class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ImageList();

See Also

ImageList Class | Kixforms Namespace


ImageList Properties

The properties of the ImageList class are listed below. For a complete list of ImageList class members, see the ImageList Members topic.

Public Instance Properties

ColorDepth | Gets the color depth of the image list.
Images | Gets the ImageCollection for this image list. Use Images(index), where index the image index number, to return a specific image from the collection.
ImageSize | Gets or sets the size of the images in the image list.
TransparentColor | Gets or sets the color to treat as transparent.

See Also

ImageList Class | Kixforms Namespace


ColorDepth Property

KiXforms.NET Class Library

ImageList.ColorDepth Property

Gets the color depth of the image list.

[Visual Basic]
Public Property ColorDepth As ColorDepth
[C#]
public ColorDepth ColorDepth {get; set;}

See Also

ImageList Class | Kixforms Namespace


Images Property

KiXforms.NET Class Library

ImageList.Images Property

Gets the ImageCollection for this image list. Use Images(index), where index the image index number, to return a specific image from the collection.

[Visual Basic]
Public ReadOnly Property Images As ImageCollection
[C#]
public ImageCollection Images {get;}

See Also

ImageList Class | Kixforms Namespace


ImageSize Property

KiXforms.NET Class Library

ImageList.ImageSize Property

Gets or sets the size of the images in the image list.

[Visual Basic]
Public Property ImageSize As Size
[C#]
public Size ImageSize {get; set;}

See Also

ImageList Class | Kixforms Namespace


TransparentColor Property

KiXforms.NET Class Library

ImageList.TransparentColor Property

Gets or sets the color to treat as transparent.

[Visual Basic]
Public Property TransparentColor As Color
[C#]
public Color TransparentColor {get; set;}

See Also

ImageList Class | Kixforms Namespace


InputBox Class

Displays a prompt in a dialog box, waits for the user to input text or click a button, and then returns a string containing the contents of the text box.

For a list of all members of this type, see InputBox Members.

System.Object
Kixforms.InputBox

[Visual Basic]
Public Class InputBox
[C#]
public class InputBox

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

InputBox Members | Kixforms Namespace


InputBox Members

InputBox overview

Public Instance Constructors

InputBox Constructor Initializes a new instance of the InputBox class.

Public Instance Methods

Show Displays an input box.

See Also

InputBox Class | Kixforms Namespace


InputBox Constructor

Initializes a new instance of the InputBox class.

[Visual Basic]
Public Sub New()
[C#]
public InputBox();

See Also

InputBox Class | Kixforms Namespace


InputBox Methods

The methods of the InputBox class are listed below. For a complete list of InputBox class members, see the InputBox Members topic.

Public Instance Methods

Show Displays an input box.

See Also

InputBox Class | Kixforms Namespace


InputBox.Show Method

Displays an input box.

[Visual Basic]
Public Function Show( _
ByVal prompt As String, _
Optional ByVal title As String = "", _
Optional ByVal default As String = "Nothing", _
Optional ByVal xpos As Integer = -1, _
Optional ByVal ypos As Integer = -1 _
) As String
[C#]
public string Show(
string prompt,
string title,
string default,
int xpos,
int ypos
);

Parameters

prompt
Required. String expression displayed as the message in the dialog box. The maximum length of Prompt is approximately 1024 characters, depending on the width of the characters used. If Prompt consists of more than one line, you can separate the lines using a carriage return character (Chr(13)), a linefeed character (Chr(10)), or a carriage return–linefeed character combination (Chr(13) and Chr(10)) between each line.
title
Optional. String expression displayed in the title bar of the dialog box. If you omit Title, the application name is placed in the title bar.
default
Optional. String expression displayed in the text box as the default response if no other input is provided. If you omit default, the displayed text box is empty.
xpos
Optional. Numeric expression that specifies, in pixels, the distance of the left edge of the dialog box from the left edge of the screen. If you omit XPos, the dialog box is centered horizontally.
ypos
Optional. Numeric expression that specifies, in pixels, the distance of the upper edge of the dialog box from the top of the screen. If you omit YPos, the dialog box is positioned vertically approximately one-third of the way down the screen.

Return Value

The contents of the text box.

See Also

InputBox Class | Kixforms Namespace


IpAddress Class

Provides an Internet Protocol (IP) address.

For a list of all members of this type, see IpAddress Members.

System.Object
Kixforms.IpAddress

[Visual Basic]
Public Class IpAddress
[C#]
public class IpAddress

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

IpAddress Members | Kixforms Namespace


IpAddress Members

IpAddress overview

Public Instance Constructors

IpAddress Constructor Initializes a new instance of the IpAddress class.

Public Instance Properties

Any | Provides an IP address indicating that the server should listen for client activity on all network interfaces. This field is read-only.
BroadCast | Provides the IP broadcast address. This field is read-only.
LoopBack | Provides the IP loopback address. This field is read-only.
None | Provides an IP address indicating that no network interface should be used. This field is read-only.

Public Instance Methods

Equals | Compares two IP addresses.
Parse | Converts an IP address string to an IPAddress instance.
ToString |

See Also

IpAddress Class | Kixforms Namespace


IpAddress Constructor

Initializes a new instance of the IpAddress class.

[Visual Basic]
Public Sub New()
[C#]
public IpAddress();

See Also

IpAddress Class | Kixforms Namespace


IpAddress Properties

The properties of the IpAddress class are listed below. For a complete list of IpAddress class members, see the IpAddress Members topic.

Public Instance Properties

Any | Provides an IP address indicating that the server should listen for client activity on all network interfaces. This field is read-only.
BroadCast | Provides the IP broadcast address. This field is read-only.
LoopBack | Provides the IP loopback address. This field is read-only.
None | Provides an IP address indicating that no network interface should be used. This field is read-only.

See Also

IpAddress Class | Kixforms Namespace


Any Property

KiXforms.NET Class Library

IpAddress.Any Property

Provides an IP address indicating that the server should listen for client activity on all network interfaces. This field is read-only.

[Visual Basic]
Public ReadOnly Property Any As IpAddress
[C#]
public IpAddress Any {get;}

Remarks

The Any field is equivalent to 0.0.0.0 in dotted-quad notation.

See Also

IpAddress Class | Kixforms Namespace


BroadCast Property

KiXforms.NET Class Library

IpAddress.BroadCast Property

Provides the IP broadcast address. This field is read-only.

[Visual Basic]
Public ReadOnly Property BroadCast As IpAddress
[C#]
public IpAddress BroadCast {get;}

Remarks

The Broadcast field is equivalent to 255.255.255.255 in dotted-quad notation.

See Also

IpAddress Class | Kixforms Namespace


LoopBack Property

KiXforms.NET Class Library

IpAddress.LoopBack Property

Provides the IP loopback address. This field is read-only.

[Visual Basic]
Public ReadOnly Property LoopBack As IpAddress
[C#]
public IpAddress LoopBack {get;}

Remarks

The Loopback field is equivalent to 127.0.0.1 in dotted-quad notation.

See Also

IpAddress Class | Kixforms Namespace


None Property

KiXforms.NET Class Library

IpAddress.None Property

Provides an IP address indicating that no network interface should be used. This field is read-only.

[Visual Basic]
Public ReadOnly Property None As IpAddress
[C#]
public IpAddress None {get;}

Remarks

The None field is equivalent to 255.255.255.255 in dotted-quad notation.

See Also

IpAddress Class | Kixforms Namespace


IpAddress Methods

The methods of the IpAddress class are listed below. For a complete list of IpAddress class members, see the IpAddress Members topic.

Public Instance Methods

Equals | Compares two IP addresses.
Parse | Converts an IP address string to an IPAddress instance.
ToString |

See Also

IpAddress Class | Kixforms Namespace


IpAddress.Equals Method

Compares two IP addresses.

[Visual Basic]
Public Function Equals( _
ByVal IPaddressObject As Object _
) As Boolean
[C#]
new public bool Equals(
object IPaddressObject
);

Parameters

IPaddressObject
An IPAddress instance to compare to the current instance.

Return Value

true if the two addresses are equal; otherwise, false.

Remarks

The Equals method compares the current IPAddress instance with the comparand parameter and returns true if the two instances contain the same IP address.

See Also

IpAddress Class | Kixforms Namespace


IpAddress.Parse Method

Converts an IP address string to an IPAddress instance.

[Visual Basic]
Public Function Parse( _
ByVal IPstring As String _
) As IpAddress
[C#]
public IpAddress Parse(
string IPstring
);

Parameters

IPstring
A string containing an IP address in dotted-quad notation in case of IPv4 and in colon-hexadecimal notation, in case of IPv6.

Return Value

An IPAddress instance.

Remarks

The static Parse method creates an IPAddress instance from an IP address expressed in dotted-quad notation in case of IPv4 and in colon-hexadecimal notation, in case of IPv6.

Example

;retrieve the ip addy of kixforms.org
$stringIP = $system.dns.resolve("www.kixforms.org").addresslist.item(0).toString
;and then make a ipAddress object out of it:
$IpAddy_kforg = $system.ipAddress.parse($stringIP)
now, that was one (silly) way of using it. the most powerful usage comes when you already know the ip you want to play with:
$IpAddy_localHost = $system.IpAddress.parse("127.0.0.1")

See Also

IpAddress Class | Kixforms Namespace


IpAddress.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

IpAddress Class | Kixforms Namespace


IpHostEntry Class

Provides a container class for Internet host address information.

For a list of all members of this type, see IpHostEntry Members.

System.Object
Kixforms.IpHostEntry

[Visual Basic]
Public Class IpHostEntry
[C#]
public class IpHostEntry

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

IpHostEntry Members | Kixforms Namespace


IpHostEntry Members

IpHostEntry overview

Public Instance Constructors

IpHostEntry Constructor Initializes a new instance of the IpHostEntry class.

Public Instance Properties

AddressList | ArrayList of ipAddress objects for the host.
Aliases | String array of DNS names for the host.
HostName | DNS Host name of the host.

Public Instance Methods

ToString

See Also

IpHostEntry Class | Kixforms Namespace


IpHostEntry Constructor

Initializes a new instance of the IpHostEntry class.

[Visual Basic]
Public Sub New()
[C#]
public IpHostEntry();

See Also

IpHostEntry Class | Kixforms Namespace


IpHostEntry Properties

The properties of the IpHostEntry class are listed below. For a complete list of IpHostEntry class members, see the IpHostEntry Members topic.

Public Instance Properties

AddressList | ArrayList of ipAddress objects for the host.
Aliases | String array of DNS names for the host.
HostName | DNS Host name of the host.

See Also

IpHostEntry Class | Kixforms Namespace


AddressList Property

KiXforms.NET Class Library

IpHostEntry.AddressList Property

ArrayList of ipAddress objects for the host.

[Visual Basic]
Public ReadOnly Property AddressList As Object
[C#]
public object AddressList {get;}

Example

"resolving: " $entry = $system.dns.resolve("www.kixtart.org") "    " @serror ?
"retrieve addies: " $list = $entry.addresslist "    " @serror ?
"count of addresses: " $list.count "    " @serror ?
"ipaddy0 is: " $list.item(0) "    " @serror ?
? " ???? " ?

;retrieve addresses with for each:
for each $addy in $list
  $addy.tostring ?
next
? "?????????????" ??

;or by going through the index:
for $c=0 to $list.count - 1
  $list.item($c).tostring ?
next
get $

See Also

IpHostEntry Class | Kixforms Namespace


Aliases Property

KiXforms.NET Class Library

IpHostEntry.Aliases Property

String array of DNS names for the host.

[Visual Basic]
Public ReadOnly Property Aliases As Object()
[C#]
public object[] Aliases {get;}

Example

aliases returns normal kixtart array consisting of strings

$aliases = $system.dns.resolve("www.kixforms.org").aliases
"default name:" $aliases[0] ? ?
"all possible aliases:" ?
for each $alias in $aliases
 $alias ?
next

See Also

IpHostEntry Class | Kixforms Namespace


HostName Property

KiXforms.NET Class Library

IpHostEntry.HostName Property

DNS Host name of the host.

[Visual Basic]
Public Property HostName As String
[C#]
public string HostName {get; set;}

See Also

IpHostEntry Class | Kixforms Namespace


IpHostEntry Methods

The methods of the IpHostEntry class are listed below. For a complete list of IpHostEntry class members, see the IpHostEntry Members topic.

Public Instance Methods

ToString

See Also

IpHostEntry Class | Kixforms Namespace


IpHostEntry.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

IpHostEntry Class | Kixforms Namespace


ItemActivation Enumeration

[Visual Basic]
Public Enum ItemActivation
[C#]
public enum ItemActivation

Members

Member Name | Description
OneClick |
Standard |
TwoClick |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ItemCheckEventArgs Class

Provides data for the ItemCheck event of the CheckedListBox and ListView controls.

For a list of all members of this type, see ItemCheckEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.ItemCheckEventArgs

[Visual Basic]
Public Class ItemCheckEventArgs
Inherits EventArgs
[C#]
public class ItemCheckEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ItemCheckEventArgs Members | Kixforms Namespace


ItemCheckEventArgs Members

ItemCheckEventArgs overview

Public Instance Properties

CurrentValue | Gets a value indicating the current state of the item's check box.
Index | Gets the zero-based index of the item to change.
NewValue | Gets or sets a value indicating whether to set the check box for the item to be checked, unchecked, or indeterminate.

See Also

ItemCheckEventArgs Class | Kixforms Namespace


ItemCheckEventArgs Properties

The properties of the ItemCheckEventArgs class are listed below. For a complete list of ItemCheckEventArgs class members, see the ItemCheckEventArgs Members topic.

Public Instance Properties

CurrentValue | Gets a value indicating the current state of the item's check box.
Index | Gets the zero-based index of the item to change.
NewValue | Gets or sets a value indicating whether to set the check box for the item to be checked, unchecked, or indeterminate.

See Also

ItemCheckEventArgs Class | Kixforms Namespace


CurrentValue Property

KiXforms.NET Class Library

ItemCheckEventArgs.CurrentValue Property

Gets a value indicating the current state of the item's check box.

[Visual Basic]
Public Property CurrentValue As CheckState
[C#]
public CheckState CurrentValue {get; set;}

Property Value

One of the CheckState values.

See Also

ItemCheckEventArgs Class | Kixforms Namespace


Index Property

KiXforms.NET Class Library

ItemCheckEventArgs.Index Property

Gets the zero-based index of the item to change.

[Visual Basic]
Public Property Index As Integer
[C#]
public int Index {get; set;}

Property Value

The zero-based index of the item to change.

See Also

ItemCheckEventArgs Class | Kixforms Namespace


NewValue Property

KiXforms.NET Class Library

ItemCheckEventArgs.NewValue Property

Gets or sets a value indicating whether to set the check box for the item to be checked, unchecked, or indeterminate.

[Visual Basic]
Public Property NewValue As CheckState
[C#]
public CheckState NewValue {get; set;}

Property Value

One of the CheckState values.

See Also

ItemCheckEventArgs Class | Kixforms Namespace


KeyEventArgs Class

Provides data for the KeyDown or KeyUp event.

For a list of all members of this type, see KeyEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.KeyEventArgs

[Visual Basic]
Public Class KeyEventArgs
Inherits EventArgs
[C#]
public class KeyEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

KeyEventArgs Members | Kixforms Namespace


KeyEventArgs Members

KeyEventArgs overview

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyDown or KeyUp event.
Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. This indicates which combination of modifier keys (CTRL, SHIFT, and ALT) were pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.

See Also

KeyEventArgs Class | Kixforms Namespace


KeyEventArgs Properties

The properties of the KeyEventArgs class are listed below. For a complete list of KeyEventArgs class members, see the KeyEventArgs Members topic.

Public Instance Properties

Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
KeyCode | Gets the keyboard code for a KeyDown or KeyUp event.
Modifiers | Gets the modifier flags for a KeyDown or KeyUp event. This indicates which combination of modifier keys (CTRL, SHIFT, and ALT) were pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.

See Also

KeyEventArgs Class | Kixforms Namespace


Alt Property

KiXforms.NET Class Library

KeyEventArgs.Alt Property

Gets a value indicating whether the ALT key was pressed.

[Visual Basic]
Public Property Alt As Boolean
[C#]
public bool Alt {get; set;}

Property Value

True if the ALT key was pressed; otherwise, false.

See Also

KeyEventArgs Class | Kixforms Namespace


Control Property

KiXforms.NET Class Library

KeyEventArgs.Control Property

Gets a value indicating whether the CTRL key was pressed.

[Visual Basic]
Public Property Control As Boolean
[C#]
public bool Control {get; set;}

Property Value

True if the CTRL key was pressed; otherwise, false.

See Also

KeyEventArgs Class | Kixforms Namespace


KeyCode Property

KiXforms.NET Class Library

KeyEventArgs.KeyCode Property

Gets the keyboard code for a KeyDown or KeyUp event.

[Visual Basic]
Public Property KeyCode As Keys
[C#]
public Keys KeyCode {get; set;}

See Also

KeyEventArgs Class | Kixforms Namespace


Modifiers Property

KiXforms.NET Class Library

KeyEventArgs.Modifiers Property

Gets the modifier flags for a KeyDown or KeyUp event. This indicates which combination of modifier keys (CTRL, SHIFT, and ALT) were pressed.

[Visual Basic]
Public Property Modifiers As Keys
[C#]
public Keys Modifiers {get; set;}

Property Value

One or more modifier flags, as defined in Keys.

See Also

KeyEventArgs Class | Kixforms Namespace


Shift Property

KiXforms.NET Class Library

KeyEventArgs.Shift Property

Gets a value indicating whether the SHIFT key was pressed.

[Visual Basic]
Public Property Shift As Boolean
[C#]
public bool Shift {get; set;}

Property Value

True if the SHIFT key was pressed; otherwise, false.

See Also

KeyEventArgs Class | Kixforms Namespace


KeyPressEventArgs Class

Provides data for the KeyPress event.

For a list of all members of this type, see KeyPressEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.KeyPressEventArgs

[Visual Basic]
Public Class KeyPressEventArgs
Inherits EventArgs
[C#]
public class KeyPressEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

KeyPressEventArgs Members | Kixforms Namespace


KeyPressEventArgs Members

KeyPressEventArgs overview

Public Instance Properties

KeyChar Gets the character corresponding to the key pressed.

See Also

KeyPressEventArgs Class | Kixforms Namespace


KeyPressEventArgs Properties

The properties of the KeyPressEventArgs class are listed below. For a complete list of KeyPressEventArgs class members, see the KeyPressEventArgs Members topic.

Public Instance Properties

KeyChar Gets the character corresponding to the key pressed.

See Also

KeyPressEventArgs Class | Kixforms Namespace


KeyChar Property

KiXforms.NET Class Library

KeyPressEventArgs.KeyChar Property

Gets the character corresponding to the key pressed.

[Visual Basic]
Public Property KeyChar As String
[C#]
public string KeyChar {get; set;}

See Also

KeyPressEventArgs Class | Kixforms Namespace


Keys Enumeration

Specifies key codes and modifiers.

[Visual Basic]
Public Enum Keys
[C#]
public enum Keys

Members

Member Name | Description
A | The A key.
Add | The Add key.
Alt | The ALT modifier key.
Apps | The Application key (Microsoft Natural Keyboard).
Attn | The ATTN key.
B | The B key.
Back | The BACKSPACE key.
BrowserBack | The Browser Back key (Windows 2000 or later).
BrowserFavorites | The Browser Favorites key (Windows 2000 or later).
BrowserForward | The Browser Forward key (Windows 2000 or later).
BrowserHome | The Browser Home key (Windows 2000 or later).
BrowserRefresh | The Browser Refresh key (Windows 2000 or later).
BrowserSearch | The Browser Search key (Windows 2000 or later).
BrowserStop | The Browser Stop key (Windows 2000 or later).
C | The C key.
Cancel | The CANCEL key.
Capital | The CAPS LOCK key.
CapsLock | The CAPS LOCK key.
Clear | The CLEAR key.
Control | The CTRL modifier key.
ControlKey | The CTRL key.
Crsel | The CRSEL key.
D | The D key.
D0 | The 0 key.
D1 | The 1 key.
D2 | The 2 key.
D3 | The 3 key.
D4 | The 4 key.
D5 | The 5 key.
D6 | The 6 key.
D7 | The 7 key.
D8 | The 8 key.
D9 | The 9 key.
Decimal | The Decimal key.
Delete | The DEL key.
Divide | The Divide key.
Down | The DOWN ARROW key.
E | The E key.
End | The END key.
Enter | The ENTER key.
EraseEof | The ERASE EOF key.
Escape | The ESC key.
Execute | The EXECUTE key.
Exsel | The EXSEL key.
F | The F key.
F1 | The F1 key.
F10 | The F10 key.
F11 | The F11 key.
F12 | The F12 key.
F13 | The F13 key.
F14 | The F14 key.
F15 | The F15 key.
F16 | The F16 key.
F17 | The F17 key.
F18 | The F18 key.
F19 | The F19 key.
F2 | The F2 key.
F20 | The F20 key.
F21 | The F21 key.
F22 | The F22 key.
F23 | The F23 key.
F24 | The F24 key.
F3 | The F3 key.
F4 | The F4 key.
F5 | The F5 key.
F6 | The F6 key.
F7 | The F7 key.
F8 | The F8 key.
F9 | The F9 key.
FinalMode | The IME final mode key.
G | The G key.
H | The H key.
HanguelMode | The IME Hanguel mode key. (maintained for compatibility; use HangulMode)
HangulMode | The IME Hangul mode key.
HanjaMode | The IME Hanja mode key.
Help | The HELP key.
Home | The HOME key.
I | The I key.
IMEAceept | The IME Accept key.
IMEConvert | The IME Convert key.
IMEModeChange | The IME Mode Change key.
IMENonconvert | The IME Nonconvert key.
Insert | The INS key.
J | The J key.
JunjaMode | The IME Junja mode key.
K | The K key.
KanaMode | The IME Kana mode key.
KanjiMode | The IME Kanji mode key.
KeyCode | The bitmask to extract a key code from a key value.
L | The L key.
LaunchApplication1 | The Start Application one key (Windows 2000 or later).
LaunchApplication2 | The Start Application two key (Windows 2000 or later).
LaunchMail | The Launch Mail key (Windows 2000 or later).
LButton | The left mouse button.
LControlKey | The left CTRL key.
Left | The LEFT ARROW key.
LineFeed | The LINEFEED key.
LMenu | The left ALT key.
LShiftKey | The left SHIFT key.
LWin | The left Windows logo key (Microsoft Natural Keyboard).
M | The M key.
MButton | The middle mouse button (three-button mouse).
MediaNextTrack | The Media Next Track key (Windows 2000 or later).
MediaPlayPause | The Media Play Pause key (Windows 2000 or later).
MediaPreviousTrack | The Media Previous Track key (Windows 2000 or later).
MediaStop | The Media Stop key (Windows 2000 or later).
Menu | The ALT key.
Modifiers | The bitmask to extract modifiers from a key value.
Multiply | The Multiply key.
N | The N key.
Next | The PAGE DOWN key.
NoName | A constant reserved for future use.
None | No key pressed.
NumLock | The NUM LOCK key.
NumPad0 | The 0 key on the numeric keypad.
NumPad1 | The 1 key on the numeric keypad.
NumPad2 | The 2 key on the numeric keypad.
NumPad3 | The 3 key on the numeric keypad.
NumPad4 | The 4 key on the numeric keypad.
NumPad5 | The 5 key on the numeric keypad.
NumPad6 | The 6 key on the numeric keypad.
NumPad7 | The 7 key on the numeric keypad.
NumPad8 | The 8 key on the numeric keypad.
NumPad9 | The 9 key on the numeric keypad.
O | The O key.
Oem8 | OEM specific.
OemBackslash | The OEM Angle bracket or Backslash key on the RT 102 key keboard (Windows 2000 or later).
OemClear | The CLEAR key.
OemCloseBrackets | The OEM Close Bracket key on a US standard keyboard (Windows 2000 or later).
Oemcomma | The OEM Comma key on any country/region keyboard (Windows 2000 or later).
OemMinus | The OEM Minus key on any country/region keyboard (Windows 2000 or later).
OemOpenBrackets | The OEM OpenBracket key on a US standard keyboard (Windows 2000 or later).
OemPeriod | The OEM Period key on any country/region keyboard (Windows 2000 or later).
OemPipe | The OEM Pipe key on a US standard keyboard (Windows 2000 or later).
Oemplus | The OEM Plus key on any country/region keyboard (Windows 2000 or later).
OemQuestion | The OEM Question Mark key on a US standard keyboard (Windows 2000 or later).
OemQuotes | The OEM Singled/Double quote key on a US standard keyboard (Windows 2000 or later).
OemSemicolon | The OEM Semicolon key on a US standard keyboard (Windows 2000 or later).
Oemtilde | The OEM tilde key on a US standard keyboard (Windows 2000 or later).
P | The P key.
Pa1 | The PA1 key.
PageDown | The PAGE DOWN key.
PageUp | The PAGE UP key.
Pause | The PAUSE key.
Play | The PLAY key.
Print | The PRINT key.
PrintScreen | The PRINT SCREEN key.
Prior | The PAGE UP key.
ProcessKey | The PROCESS KEY key.
Q | The Q key.
R | The R key.
RButton | The right mouse button.
RControlKey | The right CTRL key.
Return | The RETURN key.
Right | The RIGHT ARROW key.
RMenu | The right ALT key.
RShiftKey | The right SHIFT key.
RWin | The right Windows logo key (Microsoft Natural Keyboard).
S | The S key.
Scroll | The SCROLL LOCK key.
Select | The SELECT key.
SelectMedia | The Select Media key (Windows 2000 or later).
Separator | The Separator key.
Shift | The SHIFT modifier key.
ShiftKey | The SHIFT key.
Snapshot | The PRINT SCREEN key.
Space | The SPACEBAR key.
Subtract | The Subtract key.
T | The T key.
Tab | The TAB key.
U | The U key.
Up | The UP ARROW key.
V | The V key.
VolumeDown | The Volume Down key (Windows 2000 or later).
VolumeMute | The Volume Mute key (Windows 2000 or later).
VolumeUp | The Volume Up key (Windows 2000 or later).
W | The W key.
X | The X key.
XButton1 | The first x mouse button (five-button mouse).
XButton2 | The second x mouse button (five-button mouse).
Y | The Y key.
Z | The Z key.
Zoom | The ZOOM key.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Label Class

Represents a Windows Label control.

For a list of all members of this type, see Label Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.Label

[Visual Basic]
Public Class Label
Inherits Control
[C#]
public class Label : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Label Members | Kixforms Namespace


Label Members

Label overview

Public Instance Constructors

Label Constructor Initializes a new instance of the Label class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that is displayed on a Label.
ImageAlign | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex | Gets or sets the index value of the image displayed on the Label.
ImageList | Gets or sets the ImageList that contains the images to display in the Label control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height of the control.
PreferredWidth | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of text in the label.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Label Class | Kixforms Namespace


Label Constructor

Initializes a new instance of the Label class.

[Visual Basic]
Public Sub New()
[C#]
public Label();

See Also

Label Class | Kixforms Namespace


Label Properties

The properties of the Label class are listed below. For a complete list of Label class members, see the Label Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize | Gets or sets a value indicating whether the control is automatically resized to display its entire contents.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that is displayed on a Label.
ImageAlign | Gets or sets the alignment of an image that is displayed in the control.
ImageIndex | Gets or sets the index value of the image displayed on the Label.
ImageList | Gets or sets the ImageList that contains the images to display in the Label control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height of the control.
PreferredWidth | Gets the preferred width of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of text in the label.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

Label Class | Kixforms Namespace


AutoSize Property

KiXforms.NET Class Library

Label.AutoSize Property

Gets or sets a value indicating whether the control is automatically resized to display its entire contents.

[Visual Basic]
Public Property AutoSize As Boolean
[C#]
public bool AutoSize {get; set;}

See Also

Label Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

Label.BorderStyle Property

Indicates the border style for the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

Label Class | Kixforms Namespace


Image Property

KiXforms.NET Class Library

Label.Image Property

Gets or sets the image that is displayed on a Label.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image {get; set;}

See Also

Label Class | Kixforms Namespace


ImageAlign Property

KiXforms.NET Class Library

Label.ImageAlign Property

Gets or sets the alignment of an image that is displayed in the control.

[Visual Basic]
Public Property ImageAlign As ContentAlignment
[C#]
public ContentAlignment ImageAlign {get; set;}

See Also

Label Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

Label.ImageIndex Property

Gets or sets the index value of the image displayed on the Label.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

Label Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

Label.ImageList Property

Gets or sets the ImageList that contains the images to display in the Label control.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}

See Also

Label Class | Kixforms Namespace


PreferredHeight Property

KiXforms.NET Class Library

Label.PreferredHeight Property

Gets the preferred height of the control.

[Visual Basic]
Public ReadOnly Property PreferredHeight As Integer
[C#]
public int PreferredHeight {get;}

Property Value

The height of the control (in pixels), assuming a single line of text is displayed.

See Also

Label Class | Kixforms Namespace


PreferredWidth Property

KiXforms.NET Class Library

Label.PreferredWidth Property

Gets the preferred width of the control.

[Visual Basic]
Public ReadOnly Property PreferredWidth As Integer
[C#]
public int PreferredWidth {get;}

Property Value

The width of the control (in pixels), assuming a single line of text is displayed.

See Also

Label Class | Kixforms Namespace


TextAlign Property

KiXforms.NET Class Library

Label.TextAlign Property

Gets or sets the alignment of text in the label.

[Visual Basic]
Public Property TextAlign As ContentAlignment
[C#]
public ContentAlignment TextAlign {get; set;}

See Also

Label Class | Kixforms Namespace


LinkClickedEventArgs Class

Provides data for the LinkClicked event.

For a list of all members of this type, see LinkClickedEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.LinkClickedEventArgs

[Visual Basic]
Public Class LinkClickedEventArgs
Inherits EventArgs
[C#]
public class LinkClickedEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

LinkClickedEventArgs Members | Kixforms Namespace


LinkClickedEventArgs Members

LinkClickedEventArgs overview

Public Instance Properties

LinkText Gets the text of the link being clicked.

See Also

LinkClickedEventArgs Class | Kixforms Namespace


LinkClickedEventArgs Properties

The properties of the LinkClickedEventArgs class are listed below. For a complete list of LinkClickedEventArgs class members, see the LinkClickedEventArgs Members topic.

Public Instance Properties

LinkText Gets the text of the link being clicked.

See Also

LinkClickedEventArgs Class | Kixforms Namespace


LinkText Property

KiXforms.NET Class Library

LinkClickedEventArgs.LinkText Property

Gets the text of the link being clicked.

[Visual Basic]
Public Property LinkText As String
[C#]
public string LinkText {get; set;}

See Also

LinkClickedEventArgs Class | Kixforms Namespace


ListBox Class

Represents a Windows list box control.

For a list of all members of this type, see ListBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ListControl
Kixforms.ListBox

[Visual Basic]
Public Class ListBox
Inherits ListControl
[C#]
public class ListBox : ListControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListBox Members | Kixforms Namespace


ListBox Members

ListBox overview

Public Instance Constructors

ListBox Constructor Creates a new instance of the ListBox class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the ListBox.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl object.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
ItemHeight | Gets or sets the height of an item in the ListBox.
Items | Gets the items of the ListBox.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property has changed.
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem | Gets or sets the currently selected item in the ListBox.
SelectedItems | Gets a collection containing the currently selected items in the ListBox.
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode | Gets or sets the method in which items are selected in the ListBox.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex | Gets or sets the index of the first visible item in the ListBox.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
GetSelected | Returns a value indicating whether the specified item is selected.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetSelected | Selects or clears the selection for the specified item in a ListBox.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ListBox Class | Kixforms Namespace


ListBox Constructor

Creates a new instance of the ListBox class.

[Visual Basic]
Public Sub New()
[C#]
public ListBox();

See Also

ListBox Class | Kixforms Namespace


ListBox Properties

The properties of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the ListBox.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ColumnWidth | Gets or sets the width of columns in a multicolumn ListBox.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource (inherited from ListControl) | Gets or sets the data source for this ListControl object.
DisplayMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalExtent | Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.
HorizontalScrollbar | Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.
IntegralHeight | Gets or sets a value indicating whether the control should resize to avoid showing partial items.
ItemHeight | Gets or sets the height of an item in the ListBox.
Items | Gets the items of the ListBox.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiColumn | Gets or sets a value indicating whether the ListBox supports multiple columns.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ScrollAlwaysVisible | Gets or sets a value indicating whether the vertical scroll bar is shown at all times.
SelectedIndex | Gets or sets the zero-based index of the currently selected item in a ListBox.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property has changed.
SelectedIndices | Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.
SelectedItem | Gets or sets the currently selected item in the ListBox.
SelectedItems | Gets a collection containing the currently selected items in the ListBox.
SelectedValue (inherited from ListControl) | Gets or sets the value of the member property specified by the ValueMember property.
SelectionMode | Gets or sets the method in which items are selected in the ListBox.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopIndex | Gets or sets the index of the first visible item in the ListBox.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseTabStops | Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember (inherited from ListControl) | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ListBox Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

ListBox.BorderStyle Property

Indicates the border style for the ListBox.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

ListBox Class | Kixforms Namespace


ColumnWidth Property

KiXforms.NET Class Library

ListBox.ColumnWidth Property

Gets or sets the width of columns in a multicolumn ListBox.

[Visual Basic]
Public Property ColumnWidth As Integer
[C#]
public int ColumnWidth {get; set;}

See Also

ListBox Class | Kixforms Namespace


HorizontalExtent Property

KiXforms.NET Class Library

ListBox.HorizontalExtent Property

Gets or sets the width by which the horizontal scroll bar of a ListBox can scroll.

[Visual Basic]
Public Property HorizontalExtent As Integer
[C#]
public int HorizontalExtent {get; set;}

See Also

ListBox Class | Kixforms Namespace


HorizontalScrollbar Property

KiXforms.NET Class Library

ListBox.HorizontalScrollbar Property

Gets or sets a value indicating whether a horizontal scroll bar is displayed in the control.

[Visual Basic]
Public Property HorizontalScrollbar As Boolean
[C#]
public bool HorizontalScrollbar {get; set;}

See Also

ListBox Class | Kixforms Namespace


IntegralHeight Property

KiXforms.NET Class Library

ListBox.IntegralHeight Property

Gets or sets a value indicating whether the control should resize to avoid showing partial items.

[Visual Basic]
Public Property IntegralHeight As Boolean
[C#]
public bool IntegralHeight {get; set;}

See Also

ListBox Class | Kixforms Namespace


ItemHeight Property

KiXforms.NET Class Library

ListBox.ItemHeight Property

Gets or sets the height of an item in the ListBox.

[Visual Basic]
Public Property ItemHeight As Integer
[C#]
public int ItemHeight {get; set;}

See Also

ListBox Class | Kixforms Namespace


Items Property

KiXforms.NET Class Library

ListBox.Items Property

Gets the items of the ListBox.

[Visual Basic]
Public ReadOnly Property Items As ListBoxObjectCollection
[C#]
public ListBoxObjectCollection Items {get;}

See Also

ListBox Class | Kixforms Namespace


MultiColumn Property

KiXforms.NET Class Library

ListBox.MultiColumn Property

Gets or sets a value indicating whether the ListBox supports multiple columns.

[Visual Basic]
Public Property MultiColumn As Boolean
[C#]
public bool MultiColumn {get; set;}

See Also

ListBox Class | Kixforms Namespace


ScrollAlwaysVisible Property

KiXforms.NET Class Library

ListBox.ScrollAlwaysVisible Property

Gets or sets a value indicating whether the vertical scroll bar is shown at all times.

[Visual Basic]
Public Property ScrollAlwaysVisible As Boolean
[C#]
public bool ScrollAlwaysVisible {get; set;}

See Also

ListBox Class | Kixforms Namespace


SelectedIndex Property

KiXforms.NET Class Library

ListBox.SelectedIndex Property

Gets or sets the zero-based index of the currently selected item in a ListBox.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}

See Also

ListBox Class | Kixforms Namespace


SelectedIndexChanged Property

KiXforms.NET Class Library

ListBox.SelectedIndexChanged Property

Gets or sets the code to execute when the SelectedIndex property has changed.

[Visual Basic]
Public Property SelectedIndexChanged As String
[C#]
public string SelectedIndexChanged {get; set;}

See Also

ListBox Class | Kixforms Namespace


SelectedIndices Property

KiXforms.NET Class Library

ListBox.SelectedIndices Property

Gets a collection that contains the zero-based indexes of all currently selected items in the ListBox.

[Visual Basic]
Public ReadOnly Property SelectedIndices As ListBoxSelectedIndexCollection
[C#]
public ListBoxSelectedIndexCollection SelectedIndices {get;}

Property Value

A ListBoxSelectedIndexCollection containing the indexes of the currently selected items in the control. If no items are currently selected, an empty ListBoxSelectedIndexCollection is returned.

Remarks

For a multiple-selection ListBox, this property returns a collection containing the indexes to all items that are selected in the ListBox. For a single-selection ListBox, this property returns a collection containing a single element containing the index of the only selected item in the ListBox. For more information on how to manipulate the items of the collection, see ListBoxSelectedIndexCollection.

See Also

ListBox Class | Kixforms Namespace


SelectedItem Property

KiXforms.NET Class Library

ListBox.SelectedItem Property

Gets or sets the currently selected item in the ListBox.

[Visual Basic]
Public Property SelectedItem As Object
[C#]
public object SelectedItem {get; set;}

Property Value

An object that represents the current selection in the control.

See Also

ListBox Class | Kixforms Namespace


SelectedItems Property

KiXforms.NET Class Library

ListBox.SelectedItems Property

Gets a collection containing the currently selected items in the ListBox.

[Visual Basic]
Public ReadOnly Property SelectedItems As ListBoxSelectedObjectCollection
[C#]
public ListBoxSelectedObjectCollection SelectedItems {get;}

Property Value

A ListBoxSelectedObjectCollection containing the currently selected items in the control.

See Also

ListBox Class | Kixforms Namespace


SelectionMode Property

KiXforms.NET Class Library

ListBox.SelectionMode Property

Gets or sets the method in which items are selected in the ListBox.

[Visual Basic]
Public Property SelectionMode As SelectionMode
[C#]
public SelectionMode SelectionMode {get; set;}

See Also

ListBox Class | Kixforms Namespace


Sorted Property

KiXforms.NET Class Library

ListBox.Sorted Property

Gets or sets a value indicating whether the items in the ListBox are sorted alphabetically.

[Visual Basic]
Public Property Sorted As Boolean
[C#]
public bool Sorted {get; set;}

See Also

ListBox Class | Kixforms Namespace


TopIndex Property

KiXforms.NET Class Library

ListBox.TopIndex Property

Gets or sets the index of the first visible item in the ListBox.

[Visual Basic]
Public Property TopIndex As Integer
[C#]
public int TopIndex {get; set;}

See Also

ListBox Class | Kixforms Namespace


UseTabStops Property

KiXforms.NET Class Library

ListBox.UseTabStops Property

Gets or sets a value indicating whether the ListBox can recognize and expand tab characters when drawing its strings.

[Visual Basic]
Public Property UseTabStops As Boolean
[C#]
public bool UseTabStops {get; set;}

See Also

ListBox Class | Kixforms Namespace


ListBox Methods

The methods of the ListBox class are listed below. For a complete list of ListBox class members, see the ListBox Members topic.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
GetSelected | Returns a value indicating whether the specified item is selected.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetSelected | Selects or clears the selection for the specified item in a ListBox.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ListBox Class | Kixforms Namespace


ListBox.GetSelected Method

Returns a value indicating whether the specified item is selected.

[Visual Basic]
Public Function GetSelected( _
ByVal index As Integer _
) As Boolean
[C#]
public bool GetSelected(
int index
);

Parameters

index
The zero-based index of the item that determines whether it is selected.

Return Value

True if the specified item is currently selected in the ListBox; otherwise, false.

See Also

ListBox Class | Kixforms Namespace


ListBox.SetSelected Method

Selects or clears the selection for the specified item in a ListBox.

[Visual Basic]
Public Sub SetSelected( _
ByVal index As Integer, _
ByVal value As Boolean _
)
[C#]
public void SetSelected(
int index,
bool value
);

Parameters

index
The zero-based index of the item in a ListBox to select or clear the selection for.
value
True to select the specified item; otherwise, false.

Remarks

You can use this property to set the selection of items in a multiple-selection ListBox. To select an item in a single-selection ListBox, use the SelectedIndex property.

See Also

ListBox Class | Kixforms Namespace


ListBoxObjectCollection Class

Represents the collection of items in a ListBox.

For a list of all members of this type, see ListBoxObjectCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListBoxObjectCollection

[Visual Basic]
Public Class ListBoxObjectCollection
Inherits CollectionBase
[C#]
public class ListBoxObjectCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListBoxObjectCollection Members | Kixforms Namespace


ListBoxObjectCollection Members

ListBoxObjectCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the item at the specified index within the collection.

Public Instance Methods

Add | Adds an item to the list of items for a ListBox.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an item into the list box at the specified index.
Remove | Removes the specified object from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxObjectCollection Properties

The properties of the ListBoxObjectCollection class are listed below. For a complete list of ListBoxObjectCollection class members, see the ListBoxObjectCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the item at the specified index within the collection.

See Also

ListBoxObjectCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListBoxObjectCollection.Item Property

Gets or sets the item at the specified index within the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) _
Implements IList.Item
As Object _
Implements IList.Item
[C#]
new public object this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to get or set.

Implements

IList.Item

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxObjectCollection Methods

The methods of the ListBoxObjectCollection class are listed below. For a complete list of ListBoxObjectCollection class members, see the ListBoxObjectCollection Members topic.

Public Instance Methods

Add | Adds an item to the list of items for a ListBox.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an item into the list box at the specified index.
Remove | Removes the specified object from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxObjectCollection.Add Method

Adds an item to the list of items for a ListBox.

[Visual Basic]
Public Function Add( _
ByVal item As Object _
) As Object
[C#]
new public object Add(
object item
);

Parameters

item
An object representing the item to add to the collection.

Return Value

The zero-based index of the item in the collection.

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxObjectCollection.Insert Method

Inserts an item into the list box at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal item As Object _
) As Object
[C#]
new public object Insert(
int index,
object item
);

Parameters

index
The zero-based index location where the item is inserted.
item
An object representing the item to insert.

Return Value

The object that was inserted into the collection.

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxObjectCollection.Remove Method

Removes the specified object from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As Object _
) _
Implements IList.Remove
[C#]
new public void Remove(
object item
);

Parameters

item
An object representing the item to remove from the collection.

Implements

IList.Remove

See Also

ListBoxObjectCollection Class | Kixforms Namespace


ListBoxSelectedIndexCollection Class

Represents the collection containing the indexes to the selected items in a ListBox.

For a list of all members of this type, see ListBoxSelectedIndexCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListBoxSelectedIndexCollection

[Visual Basic]
Public Class ListBoxSelectedIndexCollection
Inherits CollectionBase
[C#]
public class ListBoxSelectedIndexCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListBoxSelectedIndexCollection Members | Kixforms Namespace


ListBoxSelectedIndexCollection Members

ListBoxSelectedIndexCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the index value at the specified index within this collection.

Public Instance Methods

Contains | Determines whether the specified index is located within the collection.
IndexOf | Returns the index within the collection of the specified index from the ListBoxObjectCollection of the ListBox.

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


ListBoxSelectedIndexCollection Properties

The properties of the ListBoxSelectedIndexCollection class are listed below. For a complete list of ListBoxSelectedIndexCollection class members, see the ListBoxSelectedIndexCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the index value at the specified index within this collection.

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListBoxSelectedIndexCollection.Item Property

Gets the index value at the specified index within this collection.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As Integer
[C#]
new public int this[
int index
] {get;}

Parameters

index
The index of the item in the collection to get.

Property Value

The index value from the ListBoxObjectCollection that is stored at the specified location.

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


ListBoxSelectedIndexCollection Methods

The methods of the ListBoxSelectedIndexCollection class are listed below. For a complete list of ListBoxSelectedIndexCollection class members, see the ListBoxSelectedIndexCollection Members topic.

Public Instance Methods

Contains | Determines whether the specified index is located within the collection.
IndexOf | Returns the index within the collection of the specified index from the ListBoxObjectCollection of the ListBox.

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


ListBoxSelectedIndexCollection.Contains Method

Determines whether the specified index is located within the collection.

[Visual Basic]
Overrides Public Function Contains( _
ByVal value As Object _
) As Boolean _
Implements IList.Contains
[C#]
public override bool Contains(
object value
);

Parameters

value
The index to locate in the collection.

Return Value

True if the specified index from the ListBoxObjectCollection for the ListBox is an item in this collection; otherwise, false.

Implements

IList.Contains

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


ListBoxSelectedIndexCollection.IndexOf Method

Returns the index within the collection of the specified index from the ListBoxObjectCollection of the ListBox.

[Visual Basic]
Overrides Public Function IndexOf( _
ByVal value As Object _
) As Integer _
Implements IList.IndexOf
[C#]
public override int IndexOf(
object value
);

Parameters

value
The zero-based index from the ListBoxObjectCollection to locate in this collection.

Return Value

The zero-based index in the collection where the specified index of the ListBoxObjectCollection was located within collection; otherwise, negative one (-1).

Implements

IList.IndexOf

See Also

ListBoxSelectedIndexCollection Class | Kixforms Namespace


ListBoxSelectedObjectCollection Class

Represents the collection of selected items in the ListBox.

For a list of all members of this type, see ListBoxSelectedObjectCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListBoxSelectedObjectCollection

[Visual Basic]
Public Class ListBoxSelectedObjectCollection
Inherits CollectionBase
[C#]
public class ListBoxSelectedObjectCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListBoxSelectedObjectCollection Members | Kixforms Namespace


ListBoxSelectedObjectCollection Members

ListBoxSelectedObjectCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Gets the item at the specified index within the collection.

Public Instance Methods

Contains | Determines whether the specified item is located within the collection.
IndexOf | Returns the index within the collection of the specified item.

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


ListBoxSelectedObjectCollection Properties

The properties of the ListBoxSelectedObjectCollection class are listed below. For a complete list of ListBoxSelectedObjectCollection class members, see the ListBoxSelectedObjectCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Gets the item at the specified index within the collection.

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListBoxSelectedObjectCollection.Item Property

Gets the item at the specified index within the collection.

[Visual Basic]
Public Default Property Item( _
ByVal index As Integer _
) _
Implements IList.Item
As Object _
Implements IList.Item
[C#]
new public object this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to retrieve.

Property Value

An object representing the item located at the specified index within the collection.

Implements

IList.Item

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


ListBoxSelectedObjectCollection Methods

The methods of the ListBoxSelectedObjectCollection class are listed below. For a complete list of ListBoxSelectedObjectCollection class members, see the ListBoxSelectedObjectCollection Members topic.

Public Instance Methods

Contains | Determines whether the specified item is located within the collection.
IndexOf | Returns the index within the collection of the specified item.

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


ListBoxSelectedObjectCollection.Contains Method

Determines whether the specified item is located within the collection.

[Visual Basic]
Overrides Public Function Contains( _
ByVal value As Object _
) As Boolean _
Implements IList.Contains
[C#]
public override bool Contains(
object value
);

Parameters

value
An object representing the item to locate in the collection.

Return Value

True if the specified item is located in the collection; otherwise, false.

Implements

IList.Contains

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


ListBoxSelectedObjectCollection.IndexOf Method

Returns the index within the collection of the specified item.

[Visual Basic]
Overrides Public Function IndexOf( _
ByVal value As Object _
) As Integer _
Implements IList.IndexOf
[C#]
public override int IndexOf(
object value
);

Parameters

value
An object representing the item to locate in the collection.

Return Value

The zero-based index of the item in the collection; otherwise, -1.

Implements

IList.IndexOf

See Also

ListBoxSelectedObjectCollection Class | Kixforms Namespace


ListControl Class

Provides a common implementation of members for the ListBox and ComboBox classes.

For a list of all members of this type, see ListControl Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ListControl
Kixforms.ComboBox
Kixforms.ListBox

[Visual Basic]
Public Class ListControl
Inherits Control
[C#]
public class ListControl : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListControl Members | Kixforms Namespace


ListControl Members

ListControl overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource | Gets or sets the data source for this ListControl object.
DisplayMember | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedValue | Gets or sets the value of the member property specified by the ValueMember property.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ListControl Class | Kixforms Namespace


ListControl Properties

The properties of the ListControl class are listed below. For a complete list of ListControl class members, see the ListControl Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataSource | Gets or sets the data source for this ListControl object.
DisplayMember | Gets or sets a string that specifies the property of the data source whose contents you want to display.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedValue | Gets or sets the value of the member property specified by the ValueMember property.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
ValueMember | Gets or sets a string that specifies the property of the data source from which to draw the value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ListControl Class | Kixforms Namespace


DataSource Property

KiXforms.NET Class Library

ListControl.DataSource Property

Gets or sets the data source for this ListControl object.

[Visual Basic]
Public Property DataSource As Object
[C#]
public object DataSource {get; set;}

Property Value

An object that implements the IList interface, such as a DataSet object or an Array object. The default is an empty reference.

See Also

ListControl Class | Kixforms Namespace


DisplayMember Property

KiXforms.NET Class Library

ListControl.DisplayMember Property

Gets or sets a string that specifies the property of the data source whose contents you want to display.

[Visual Basic]
Public Property DisplayMember As String
[C#]
public string DisplayMember {get; set;}

Property Value

A String specifying the name of a property of the object specified by the DataSource property. The default is an empty string ("").

See Also

ListControl Class | Kixforms Namespace


SelectedValue Property

KiXforms.NET Class Library

ListControl.SelectedValue Property

Gets or sets the value of the member property specified by the ValueMember property.

[Visual Basic]
Public Property SelectedValue As Object
[C#]
public object SelectedValue {get; set;}

Property Value

An object containing the value of the member of the data source specified by the ValueMember property.

See Also

ListControl Class | Kixforms Namespace


ValueMember Property

KiXforms.NET Class Library

ListControl.ValueMember Property

Gets or sets a string that specifies the property of the data source from which to draw the value.

[Visual Basic]
Public Property ValueMember As String
[C#]
public string ValueMember {get; set;}

Property Value

A String specifying the name of a property of the object specified by the DataSource property. The default is an empty string ("").

See Also

ListControl Class | Kixforms Namespace


ListItem Class

Represents a data item in a data-bound list control.

For a list of all members of this type, see ListItem Members.

System.Object
Kixforms.ListItem

[Visual Basic]
Public Class ListItem
[C#]
public class ListItem

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListItem Members | Kixforms Namespace


ListItem Members

ListItem overview

Public Instance Constructors

ListItem Constructor Initializes a new instance of the ListItem class.

Public Instance Properties

ForeColor | Gets or sets the value associated with the ListItem.
Text | Gets or sets the text displayed in a list control for the item represented by the ListItem.
Value | Gets or sets the value associated with the ListItem.

Public Instance Methods

ToString

See Also

ListItem Class | Kixforms Namespace


ListItem Constructor

Initializes a new instance of the ListItem class.

[Visual Basic]
Public Sub New( _
Optional ByVal text As String = "Nothing", _
Optional ByVal value As Object = Nothing _
)
[C#]
public ListItem(
string text,
object value
);

Parameters

text
Optional. The text to display in the list control for the item represented by the ListItem.
value
Optional. The value associated with the ListItem.

See Also

ListItem Class | Kixforms Namespace


ListItem Properties

The properties of the ListItem class are listed below. For a complete list of ListItem class members, see the ListItem Members topic.

Public Instance Properties

ForeColor | Gets or sets the value associated with the ListItem.
Text | Gets or sets the text displayed in a list control for the item represented by the ListItem.
Value | Gets or sets the value associated with the ListItem.

See Also

ListItem Class | Kixforms Namespace


ForeColor Property

KiXforms.NET Class Library

ListItem.ForeColor Property

Gets or sets the value associated with the ListItem.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}

See Also

ListItem Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

ListItem.Text Property

Gets or sets the text displayed in a list control for the item represented by the ListItem.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

Property Value

The text displayed in a list control for the item represented by the ListItem control. The default value is an empty string.

See Also

ListItem Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

ListItem.Value Property

Gets or sets the value associated with the ListItem.

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}

See Also

ListItem Class | Kixforms Namespace


ListItem Methods

The methods of the ListItem class are listed below. For a complete list of ListItem class members, see the ListItem Members topic.

Public Instance Methods

ToString

See Also

ListItem Class | Kixforms Namespace


ListItem.ToString Method

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

ListItem Class | Kixforms Namespace


ListView Class

Represents a Windows ListView Control.

For a list of all members of this type, see ListView Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ListView

[Visual Basic]
Public Class ListView
Inherits Control
[C#]
public class ListView : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListView Members | Kixforms Namespace


ListView Members

ListView overview

Public Instance Constructors

ListView Constructor Initializes a new instance of the ListView class.

Public Instance Properties

Activation | Gets or sets the type of action the user must take to activate an item.
Alignment | Gets or sets the alignment of items in the control.
AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoArrange | Gets or sets whether icons are automatically kept arranged.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style of the list view control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control.
CheckedItems | Gets the currently checked items in the control.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ColumnClick | Gets or sets the code to execute when when the user clicks a column header within the list view control.
Columns | Gets the collection of all column headers that appear in the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
FocusedItem | Gets the item in the control that currently has focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems.
GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control.
HeaderStyle | Gets or sets the column header style.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus.
HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds.
ItemCheck | Gets or sets the code to execute when the check state of an item changes.
ItemCheckEventArgs | Provides data for the ItemCheck event.
Items | Gets a collection containing all items in the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control.
LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons.
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiSelect | Gets or sets a value indicating whether multiple items can be selected.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.
SelectedIndexChanged | Gets or sets the code to execute when the index of the selected item in the list view control changes.
SelectedItems | Gets the items that are selected in the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Sorting | Gets or sets the sort order for items in the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
View | Gets or sets how items are displayed in the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate method.
EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemAt | Retrieves the item at the specified location.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ListView Class | Kixforms Namespace


ListView Constructor

Initializes a new instance of the ListView class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ListView();

See Also

ListView Class | Kixforms Namespace


ListView Properties

The properties of the ListView class are listed below. For a complete list of ListView class members, see the ListView Members topic.

Public Instance Properties

Activation | Gets or sets the type of action the user must take to activate an item.
Alignment | Gets or sets the alignment of items in the control.
AllowColumnReorder | Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoArrange | Gets or sets whether icons are automatically kept arranged.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style of the list view control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckBoxes | Gets or sets a value indicating whether a check box appears next to each item in the control.
CheckedItems | Gets the currently checked items in the control.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ColumnClick | Gets or sets the code to execute when when the user clicks a column header within the list view control.
Columns | Gets the collection of all column headers that appear in the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
FocusedItem | Gets the item in the control that currently has focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRowSelect | Gets or sets a value indicating whether clicking an item selects all its subitems.
GridLines | Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control.
HeaderStyle | Gets or sets the column header style.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus.
HoverSelection | Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds.
ItemCheck | Gets or sets the code to execute when the check state of an item changes.
ItemCheckEventArgs | Provides data for the ItemCheck event.
Items | Gets a collection containing all items in the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LabelEdit | Gets or sets a value indicating whether the user can edit the labels of items in the control.
LabelWrap | Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons.
LargeImageList | Gets or sets the ImageList to use when displaying items as large icons in the control.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiSelect | Gets or sets a value indicating whether multiple items can be selected.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Scrollable | Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.
SelectedIndexChanged | Gets or sets the code to execute when the index of the selected item in the list view control changes.
SelectedItems | Gets the items that are selected in the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SmallImageList | Gets or sets the ImageList to use when displaying items as small icons in the control.
Sorting | Gets or sets the sort order for items in the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
View | Gets or sets how items are displayed in the control.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ListView Class | Kixforms Namespace


Activation Property

KiXforms.NET Class Library

ListView.Activation Property

Gets or sets the type of action the user must take to activate an item.

[Visual Basic]
Public Property Activation As ItemActivation
[C#]
public ItemActivation Activation {get; set;}

See Also

ListView Class | Kixforms Namespace


Alignment Property

KiXforms.NET Class Library

ListView.Alignment Property

Gets or sets the alignment of items in the control.

[Visual Basic]
Public Property Alignment As ListViewAlignment
[C#]
public ListViewAlignment Alignment {get; set;}

See Also

ListView Class | Kixforms Namespace


AllowColumnReorder Property

KiXforms.NET Class Library

ListView.AllowColumnReorder Property

Gets or sets a value indicating whether the user can drag column headers to reorder columns in the control.

[Visual Basic]
Public Property AllowColumnReorder As Boolean
[C#]
public bool AllowColumnReorder {get; set;}

See Also

ListView Class | Kixforms Namespace


AutoArrange Property

KiXforms.NET Class Library

ListView.AutoArrange Property

Gets or sets whether icons are automatically kept arranged.

[Visual Basic]
Public Property AutoArrange As Boolean
[C#]
public bool AutoArrange {get; set;}

See Also

ListView Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

ListView.BorderStyle Property

Gets or sets the border style of the list view control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

ListView Class | Kixforms Namespace


CheckBoxes Property

KiXforms.NET Class Library

ListView.CheckBoxes Property

Gets or sets a value indicating whether a check box appears next to each item in the control.

[Visual Basic]
Public Property CheckBoxes As Boolean
[C#]
public bool CheckBoxes {get; set;}

See Also

ListView Class | Kixforms Namespace


CheckedItems Property

KiXforms.NET Class Library

ListView.CheckedItems Property

Gets the currently checked items in the control.

[Visual Basic]
Public ReadOnly Property CheckedItems As ListViewCheckedItemCollection
[C#]
public ListViewCheckedItemCollection CheckedItems {get;}

See Also

ListView Class | Kixforms Namespace


ColumnClick Property

KiXforms.NET Class Library

ListView.ColumnClick Property

Gets or sets the code to execute when when the user clicks a column header within the list view control.

[Visual Basic]
Public Property ColumnClick As String
[C#]
public string ColumnClick {get; set;}

Remarks

Use the System.EventArgs property to return a value of type ColumnClickEventArgs containing data related to this event.

Example

$ListView.ColumnClick = "ListView_ColumnClick()"

See Also

ListView Class | Kixforms Namespace


Columns Property

KiXforms.NET Class Library

ListView.Columns Property

Gets the collection of all column headers that appear in the control.

[Visual Basic]
Public ReadOnly Property Columns As ListViewColumnHeaderCollection
[C#]
public ListViewColumnHeaderCollection Columns {get;}

See Also

ListView Class | Kixforms Namespace


FocusedItem Property

KiXforms.NET Class Library

ListView.FocusedItem Property

Gets the item in the control that currently has focus.

[Visual Basic]
Public ReadOnly Property FocusedItem As ListViewItem
[C#]
public ListViewItem FocusedItem {get;}

See Also

ListView Class | Kixforms Namespace


FullRowSelect Property

KiXforms.NET Class Library

ListView.FullRowSelect Property

Gets or sets a value indicating whether clicking an item selects all its subitems.

[Visual Basic]
Public Property FullRowSelect As Boolean
[C#]
public bool FullRowSelect {get; set;}

See Also

ListView Class | Kixforms Namespace


GridLines Property

KiXforms.NET Class Library

ListView.GridLines Property

Gets or sets a value indicating whether grid lines appear between the rows and columns containing the items and subitems in the control.

[Visual Basic]
Public Property GridLines As Boolean
[C#]
public bool GridLines {get; set;}

See Also

ListView Class | Kixforms Namespace


HeaderStyle Property

KiXforms.NET Class Library

ListView.HeaderStyle Property

Gets or sets the column header style.

[Visual Basic]
Public Property HeaderStyle As ColumnHeaderStyle
[C#]
public ColumnHeaderStyle HeaderStyle {get; set;}

See Also

ListView Class | Kixforms Namespace


HideSelection Property

KiXforms.NET Class Library

ListView.HideSelection Property

Gets or sets a value indicating whether the selected item in the control remains highlighted when the control loses focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection {get; set;}

See Also

ListView Class | Kixforms Namespace


HoverSelection Property

KiXforms.NET Class Library

ListView.HoverSelection Property

Gets or sets a value indicating whether an item is automatically selected when the mouse pointer remains over the item for a few seconds.

[Visual Basic]
Public Property HoverSelection As Boolean
[C#]
public bool HoverSelection {get; set;}

See Also

ListView Class | Kixforms Namespace


ItemCheck Property

KiXforms.NET Class Library

ListView.ItemCheck Property

Gets or sets the code to execute when the check state of an item changes.

[Visual Basic]
Public Property ItemCheck As String
[C#]
public string ItemCheck {get; set;}

Remarks

Use the ItemCheckEventArgs property to return data related to this event.

The ItemCheck event occurs when the check state of an item changes. The CheckBoxes property must be set to true in order for check boxes to be displayed next to each item in the ListView control. You can create an event handler for the ItemCheck event to perform tasks such as changing the state of an item's icon or another application-specific task each time an item is checked in the ListView control.

See Also

ListView Class | Kixforms Namespace


ItemCheckEventArgs Property

KiXforms.NET Class Library

ListView.ItemCheckEventArgs Property

Provides data for the ItemCheck event.

[Visual Basic]
Public Property ItemCheckEventArgs As ItemCheckEventArgs
[C#]
public ItemCheckEventArgs ItemCheckEventArgs {get; set;}

See Also

ListView Class | Kixforms Namespace


Items Property

KiXforms.NET Class Library

ListView.Items Property

Gets a collection containing all items in the control.

[Visual Basic]
Public ReadOnly Property Items As ListViewItemCollection
[C#]
public ListViewItemCollection Items {get;}

See Also

ListView Class | Kixforms Namespace


LabelEdit Property

KiXforms.NET Class Library

ListView.LabelEdit Property

Gets or sets a value indicating whether the user can edit the labels of items in the control.

[Visual Basic]
Public Property LabelEdit As Boolean
[C#]
public bool LabelEdit {get; set;}

See Also

ListView Class | Kixforms Namespace


LabelWrap Property

KiXforms.NET Class Library

ListView.LabelWrap Property

Gets or sets a value indicating whether item labels wrap when items are displayed in the control as icons.

[Visual Basic]
Public Property LabelWrap As Boolean
[C#]
public bool LabelWrap {get; set;}

See Also

ListView Class | Kixforms Namespace


LargeImageList Property

KiXforms.NET Class Library

ListView.LargeImageList Property

Gets or sets the ImageList to use when displaying items as large icons in the control.

[Visual Basic]
Public Property LargeImageList As ImageList
[C#]
public ImageList LargeImageList {get; set;}

See Also

ListView Class | Kixforms Namespace


MultiSelect Property

KiXforms.NET Class Library

ListView.MultiSelect Property

Gets or sets a value indicating whether multiple items can be selected.

[Visual Basic]
Public Property MultiSelect As Boolean
[C#]
public bool MultiSelect {get; set;}

See Also

ListView Class | Kixforms Namespace


Scrollable Property

KiXforms.NET Class Library

ListView.Scrollable Property

Gets or sets a value indicating whether a scroll bar is added to the control when there is not enough room to display all items.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}

See Also

ListView Class | Kixforms Namespace


SelectedIndexChanged Property

KiXforms.NET Class Library

ListView.SelectedIndexChanged Property

Gets or sets the code to execute when the index of the selected item in the list view control changes.

[Visual Basic]
Public Property SelectedIndexChanged As String
[C#]
public string SelectedIndexChanged {get; set;}

See Also

ListView Class | Kixforms Namespace


SelectedItems Property

KiXforms.NET Class Library

ListView.SelectedItems Property

Gets the items that are selected in the control.

[Visual Basic]
Public ReadOnly Property SelectedItems As ListViewSelectedItemCollection
[C#]
public ListViewSelectedItemCollection SelectedItems {get;}

Property Value

A ListViewSelectedItemCollection that contains the items that are selected in the control. If no items are currently selected, an empty collection is returned.

Remarks

When the MultiSelect property is set to true, this property returns a collection containing the items that are selected in the ListView. For a single-selection ListView, this property returns a collection containing the only selected item in the ListView.

See Also

ListView Class | Kixforms Namespace


SmallImageList Property

KiXforms.NET Class Library

ListView.SmallImageList Property

Gets or sets the ImageList to use when displaying items as small icons in the control.

[Visual Basic]
Public Property SmallImageList As ImageList
[C#]
public ImageList SmallImageList {get; set;}

See Also

ListView Class | Kixforms Namespace


Sorting Property

KiXforms.NET Class Library

ListView.Sorting Property

Gets or sets the sort order for items in the control.

[Visual Basic]
Public Property Sorting As SortOrder
[C#]
public SortOrder Sorting {get; set;}

See Also

ListView Class | Kixforms Namespace


View Property

KiXforms.NET Class Library

ListView.View Property

Gets or sets how items are displayed in the control.

[Visual Basic]
Public Property View As View
[C#]
public View View {get; set;}

See Also

ListView Class | Kixforms Namespace


ListView Methods

The methods of the ListView class are listed below. For a complete list of ListView class members, see the ListView Members topic.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the list view control after drawing is suspended by the BeginUpdate method.
EnsureVisible | Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetItemAt | Retrieves the item at the specified location.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ListView Class | Kixforms Namespace


ListView.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

[Visual Basic]
Overrides Public Sub BeginUpdate()
[C#]
public override void BeginUpdate();

See Also

ListView Class | Kixforms Namespace


ListView.EndUpdate Method

Resumes drawing of the list view control after drawing is suspended by the BeginUpdate method.

[Visual Basic]
Overrides Public Sub EndUpdate()
[C#]
public override void EndUpdate();

See Also

ListView Class | Kixforms Namespace


ListView.EnsureVisible Method

Ensures that the specified item is visible within the control, scrolling the contents of the control if necessary.

[Visual Basic]
Public Sub EnsureVisible( _
ByVal index As Integer _
)
[C#]
public void EnsureVisible(
int index
);

Parameters

index
The zero-based index of the item to scroll into view.

See Also

ListView Class | Kixforms Namespace


ListView.GetItemAt Method

Retrieves the item at the specified location.

[Visual Basic]
Public Function GetItemAt( _
ByVal x As Integer, _
ByVal y As Integer _
) As ListViewItem
[C#]
public ListViewItem GetItemAt(
int x,
int y
);

Parameters

x
The x-coordinate of the location to search for an item (expressed in client coordinates).
y
The y-coordinate of the location to search for an item (expressed in client coordinates).

Return Value

A ListViewItem that represents the item at the specified position. If there is no item at the specified location, the method returns a null reference (Nothing in Visual Basic).

See Also

ListView Class | Kixforms Namespace


ListViewAlignment Enumeration

Specifies how items align in the ListView.

[Visual Basic]
Public Enum ListViewAlignment
[C#]
public enum ListViewAlignment

Members

Member Name | Description
Default | When the user moves an item, it remains where it is dropped.
Left | Items are aligned to the left of the ListView control.
SnapToGrid | Items are aligned to an invisible grid in the control. When the user moves an item, it moves to the closest juncture in the grid.
Top | Items are aligned to the top of the ListView control.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ListViewCheckedItemCollection Class

Represents the collection of checked items in a list view control.

For a list of all members of this type, see ListViewCheckedItemCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListViewCheckedItemCollection

[Visual Basic]
Public Class ListViewCheckedItemCollection
Inherits CollectionBase
[C#]
public class ListViewCheckedItemCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewCheckedItemCollection Members | Kixforms Namespace


ListViewCheckedItemCollection Members

ListViewCheckedItemCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewCheckedItemCollection Class | Kixforms Namespace


ListViewCheckedItemCollection Properties

The properties of the ListViewCheckedItemCollection class are listed below. For a complete list of ListViewCheckedItemCollection class members, see the ListViewCheckedItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

See Also

ListViewCheckedItemCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListViewCheckedItemCollection.Item Property

Gets the item at the specified index within the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ListViewItem
[C#]
public ListViewItem this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to get.

See Also

ListViewCheckedItemCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection Class

Represents the collection of column headers in a ListView control.

For a list of all members of this type, see ListViewColumnHeaderCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListViewColumnHeaderCollection

[Visual Basic]
Public Class ListViewColumnHeaderCollection
Inherits CollectionBase
[C#]
public class ListViewColumnHeaderCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewColumnHeaderCollection Members | Kixforms Namespace


ListViewColumnHeaderCollection Members

ListViewColumnHeaderCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the column header at the specified index within the collection.

Public Instance Methods

Add | Adds a column header to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a column header into the collection at the specified index.
Remove | Removes the specified column header from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection Properties

The properties of the ListViewColumnHeaderCollection class are listed below. For a complete list of ListViewColumnHeaderCollection class members, see the ListViewColumnHeaderCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the column header at the specified index within the collection.

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListViewColumnHeaderCollection.Item Property

Gets the column header at the specified index within the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ColumnHeader
[C#]
public ColumnHeader this[
int index
] {get; set;}

Parameters

index
The index of the column header in the collection to get.

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection Methods

The methods of the ListViewColumnHeaderCollection class are listed below. For a complete list of ListViewColumnHeaderCollection class members, see the ListViewColumnHeaderCollection Members topic.

Public Instance Methods

Add | Adds a column header to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a column header into the collection at the specified index.
Remove | Removes the specified column header from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection.Add Method

Adds a column header to the collection.

[Visual Basic]
Public Function Add( _
ByVal column As ColumnHeader _
) As ColumnHeader
[C#]
public ColumnHeader Add(
ColumnHeader column
);

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection.Insert Method

Inserts a column header into the collection at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal column As ColumnHeader _
) As ColumnHeader
[C#]
public ColumnHeader Insert(
int index,
ColumnHeader column
);

Parameters

index
The zero-based index location where the column header is inserted.
column
The ColumnHeader to insert into the collection.

Return Value

The ColumnHeader that was inserted into the collection

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewColumnHeaderCollection.Remove Method

Removes the specified column header from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal column As ColumnHeader _
)
[C#]
public void Remove(
ColumnHeader column
);

Parameters

column
A ColumnHeader representing the column header to remove from the collection.

See Also

ListViewColumnHeaderCollection Class | Kixforms Namespace


ListViewItem Class

Represents an item in a ListView control.

For a list of all members of this type, see ListViewItem Members.

System.Object
Kixforms.ListViewItem

[Visual Basic]
Public Class ListViewItem
[C#]
public class ListViewItem

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewItem Members | Kixforms Namespace


ListViewItem Members

ListViewItem overview

Public Instance Constructors

ListViewItem Constructor Initializes a new instance of the ListViewItem class with specified item text and the image index position of the item's icon.

Public Instance Properties

BackColor | Gets or sets the background color of the item's text.
Bounds | Gets the bounding rectangle of the item, including subitems.
Checked | Gets or sets a value indicating whether the item is checked.
Focused | Gets or sets a value indicating whether the item has focus within the list view control.
Font | Gets or sets the font of the text displayed by the item.
ForeColor | Gets or sets the foreground color of the item's text.
ImageIndex | Gets or sets the index of the image that is displayed for the item.
ImageList | Gets the ImageList that contains the image displayed with the item.
Index | Gets the zero-based index of the item within the list view control.
Selected | Gets or sets a value indicating whether the item is selected.
SubItems | Gets a collection containing all subitems of the item.
Tag | Gets or sets an object that contains data to associate with the item.
Text | Gets or sets the text of the item.
UseItemStyleForSubItems | Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all of its subitems.

Public Instance Methods

BeginEdit | Places the item text into edit mode.
Remove | Removes the item from its associated list view control.

See Also

ListViewItem Class | Kixforms Namespace


ListViewItem Constructor

Initializes a new instance of the ListViewItem class with specified item text and the image index position of the item's icon.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal text As String = "Nothing", _
Optional ByVal imageIndex As Integer = 0 _
)
[C#]
public ListViewItem(
string text,
int imageIndex
);

See Also

ListViewItem Class | Kixforms Namespace


ListViewItem Properties

The properties of the ListViewItem class are listed below. For a complete list of ListViewItem class members, see the ListViewItem Members topic.

Public Instance Properties

BackColor | Gets or sets the background color of the item's text.
Bounds | Gets the bounding rectangle of the item, including subitems.
Checked | Gets or sets a value indicating whether the item is checked.
Focused | Gets or sets a value indicating whether the item has focus within the list view control.
Font | Gets or sets the font of the text displayed by the item.
ForeColor | Gets or sets the foreground color of the item's text.
ImageIndex | Gets or sets the index of the image that is displayed for the item.
ImageList | Gets the ImageList that contains the image displayed with the item.
Index | Gets the zero-based index of the item within the list view control.
Selected | Gets or sets a value indicating whether the item is selected.
SubItems | Gets a collection containing all subitems of the item.
Tag | Gets or sets an object that contains data to associate with the item.
Text | Gets or sets the text of the item.
UseItemStyleForSubItems | Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all of its subitems.

See Also

ListViewItem Class | Kixforms Namespace


BackColor Property

KiXforms.NET Class Library

ListViewItem.BackColor Property

Gets or sets the background color of the item's text.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


Bounds Property

KiXforms.NET Class Library

ListViewItem.Bounds Property

Gets the bounding rectangle of the item, including subitems.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}

See Also

ListViewItem Class | Kixforms Namespace


Checked Property

KiXforms.NET Class Library

ListViewItem.Checked Property

Gets or sets a value indicating whether the item is checked.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


Focused Property

KiXforms.NET Class Library

ListViewItem.Focused Property

Gets or sets a value indicating whether the item has focus within the list view control.

[Visual Basic]
Public Property Focused As Boolean
[C#]
public bool Focused {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


Font Property

KiXforms.NET Class Library

ListViewItem.Font Property

Gets or sets the font of the text displayed by the item.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


ForeColor Property

KiXforms.NET Class Library

ListViewItem.ForeColor Property

Gets or sets the foreground color of the item's text.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

ListViewItem.ImageIndex Property

Gets or sets the index of the image that is displayed for the item.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

ListViewItem.ImageList Property

Gets the ImageList that contains the image displayed with the item.

[Visual Basic]
Public ReadOnly Property ImageList As ImageList
[C#]
public ImageList ImageList {get;}

See Also

ListViewItem Class | Kixforms Namespace


Index Property

KiXforms.NET Class Library

ListViewItem.Index Property

Gets the zero-based index of the item within the list view control.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}

See Also

ListViewItem Class | Kixforms Namespace


Selected Property

KiXforms.NET Class Library

ListViewItem.Selected Property

Gets or sets a value indicating whether the item is selected.

[Visual Basic]
Public Property Selected As Boolean
[C#]
public bool Selected {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


SubItems Property

KiXforms.NET Class Library

ListViewItem.SubItems Property

Gets a collection containing all subitems of the item.

[Visual Basic]
Public ReadOnly Property SubItems As ListViewSubItemCollection
[C#]
public ListViewSubItemCollection SubItems {get;}

See Also

ListViewItem Class | Kixforms Namespace


Tag Property

KiXforms.NET Class Library

ListViewItem.Tag Property

Gets or sets an object that contains data to associate with the item.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

ListViewItem.Text Property

Gets or sets the text of the item.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


UseItemStyleForSubItems Property

KiXforms.NET Class Library

ListViewItem.UseItemStyleForSubItems Property

Gets or sets a value indicating whether the Font, ForeColor, and BackColor properties for the item are used for all of its subitems.

[Visual Basic]
Public Property UseItemStyleForSubItems As Boolean
[C#]
public bool UseItemStyleForSubItems {get; set;}

See Also

ListViewItem Class | Kixforms Namespace


ListViewItem Methods

The methods of the ListViewItem class are listed below. For a complete list of ListViewItem class members, see the ListViewItem Members topic.

Public Instance Methods

BeginEdit | Places the item text into edit mode.
Remove | Removes the item from its associated list view control.

See Also

ListViewItem Class | Kixforms Namespace


ListViewItem.BeginEdit Method

Places the item text into edit mode.

[Visual Basic]
Public Sub BeginEdit()
[C#]
public void BeginEdit();

Remarks

This property is only effective if the LabelEdit property of the ListView control that contains the item is set to true. You can use this method at run time to force the item's text to display in edit mode. For example, if you are validating the item text edited by the user, and an item fails validation, you could select the item in the ListView control and call the BeginEdit method to force the user to change the text that failed validation.

See Also

ListViewItem Class | Kixforms Namespace


ListViewItem.Remove Method

Removes the item from its associated list view control.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();

See Also

ListViewItem Class | Kixforms Namespace


ListViewItemCollection Class

Represents the collection of items in a ListView control.

For a list of all members of this type, see ListViewItemCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListViewItemCollection

[Visual Basic]
Public Class ListViewItemCollection
Inherits CollectionBase
[C#]
public class ListViewItemCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewItemCollection Members | Kixforms Namespace


ListViewItemCollection Members

ListViewItemCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

Public Instance Methods

Add | Adds a ListViewItem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an existing ListViewItem into the collection at the specified index.
Remove | Removes the specified item from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewItemCollection Properties

The properties of the ListViewItemCollection class are listed below. For a complete list of ListViewItemCollection class members, see the ListViewItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListViewItemCollection.Item Property

Gets the item at the specified index within the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ListViewItem
[C#]
public ListViewItem this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to get.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewItemCollection Methods

The methods of the ListViewItemCollection class are listed below. For a complete list of ListViewItemCollection class members, see the ListViewItemCollection Members topic.

Public Instance Methods

Add | Adds a ListViewItem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an existing ListViewItem into the collection at the specified index.
Remove | Removes the specified item from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewItemCollection.Add Method

Adds a ListViewItem to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ListViewItem _
) As ListViewItem
[C#]
public ListViewItem Add(
ListViewItem item
);

Parameters

item
The ListViewItem to add to the collection.

Return Value

The ListViewItem that was added to the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewItemCollection.Insert Method

Inserts an existing ListViewItem into the collection at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal item As ListViewItem _
) As ListViewItem
[C#]
public ListViewItem Insert(
int index,
ListViewItem item
);

Parameters

index
The zero-based index location where the item is inserted.
item
The ListViewItem that represents the item to insert.

Return Value

The ListViewItem that was inserted into the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewItemCollection.Remove Method

Removes the specified item from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal item As ListViewItem _
)
[C#]
public void Remove(
ListViewItem item
);

Parameters

item
A ListViewItem representing the item to remove from the collection.

See Also

ListViewItemCollection Class | Kixforms Namespace


ListViewSelectedItemCollection Class

Represents the collection of selected items in a list view control.

For a list of all members of this type, see ListViewSelectedItemCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListViewSelectedItemCollection

[Visual Basic]
Public Class ListViewSelectedItemCollection
Inherits CollectionBase
[C#]
public class ListViewSelectedItemCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewSelectedItemCollection Members | Kixforms Namespace


ListViewSelectedItemCollection Members

ListViewSelectedItemCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines whether the specified item is located in the collection.

See Also

ListViewSelectedItemCollection Class | Kixforms Namespace


ListViewSelectedItemCollection Properties

The properties of the ListViewSelectedItemCollection class are listed below. For a complete list of ListViewSelectedItemCollection class members, see the ListViewSelectedItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets the item at the specified index within the collection.

See Also

ListViewSelectedItemCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListViewSelectedItemCollection.Item Property

Gets the item at the specified index within the collection.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As ListViewItem
[C#]
new public ListViewItem this[
int index
] {get;}

Parameters

index
The index of the item in the collection to retrieve.

See Also

ListViewSelectedItemCollection Class | Kixforms Namespace


ListViewSelectedItemCollection Methods

The methods of the ListViewSelectedItemCollection class are listed below. For a complete list of ListViewSelectedItemCollection class members, see the ListViewSelectedItemCollection Members topic.

Public Instance Methods

Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines whether the specified item is located in the collection.

See Also

ListViewSelectedItemCollection Class | Kixforms Namespace


ListViewSelectedItemCollection.Contains Method

Determines whether the specified item is located in the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As ListViewItem _
) As Boolean
[C#]
public bool Contains(
ListViewItem item
);

Parameters

item
A ListViewItem representing the item to locate in the collection.

Return Value

True if the specified item is located in the collection; otherwise, false.

See Also

ListViewSelectedItemCollection Class | Kixforms Namespace


ListViewSubItem Class

Represents a subitem of a ListViewItem.

For a list of all members of this type, see ListViewSubItem Members.

System.Object
Kixforms.ListViewSubItem

[Visual Basic]
Public Class ListViewSubItem
[C#]
public class ListViewSubItem

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewSubItem Members | Kixforms Namespace


ListViewSubItem Members

ListViewSubItem overview

Public Instance Constructors

ListViewSubItem Constructor Initializes a new instance of the ListViewSubItem class with the specified text.

Public Instance Properties

BackColor | Gets or sets the background color of the subitem's text.
Font | Gets or sets the font of the text displayed by the subitem.
ForeColor | Gets or sets the foreground color of the subitem's text.
Text | Gets or sets the text of the subitem.

See Also

ListViewSubItem Class | Kixforms Namespace


ListViewSubItem Constructor

Initializes a new instance of the ListViewSubItem class with the specified text.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal text As String = "Nothing" _
)
[C#]
public ListViewSubItem(
string text
);

Parameters

text
The text to display for the subitem.

See Also

ListViewSubItem Class | Kixforms Namespace


ListViewSubItem Properties

The properties of the ListViewSubItem class are listed below. For a complete list of ListViewSubItem class members, see the ListViewSubItem Members topic.

Public Instance Properties

BackColor | Gets or sets the background color of the subitem's text.
Font | Gets or sets the font of the text displayed by the subitem.
ForeColor | Gets or sets the foreground color of the subitem's text.
Text | Gets or sets the text of the subitem.

See Also

ListViewSubItem Class | Kixforms Namespace


BackColor Property

KiXforms.NET Class Library

ListViewSubItem.BackColor Property

Gets or sets the background color of the subitem's text.

[Visual Basic]
Public Property BackColor As Color
[C#]
public Color BackColor {get; set;}

See Also

ListViewSubItem Class | Kixforms Namespace


Font Property

KiXforms.NET Class Library

ListViewSubItem.Font Property

Gets or sets the font of the text displayed by the subitem.

[Visual Basic]
Public Property Font As Font
[C#]
public Font Font {get; set;}

See Also

ListViewSubItem Class | Kixforms Namespace


ForeColor Property

KiXforms.NET Class Library

ListViewSubItem.ForeColor Property

Gets or sets the foreground color of the subitem's text.

[Visual Basic]
Public Property ForeColor As Color
[C#]
public Color ForeColor {get; set;}

See Also

ListViewSubItem Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

ListViewSubItem.Text Property

Gets or sets the text of the subitem.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

ListViewSubItem Class | Kixforms Namespace


ListViewSubItemCollection Class

Represents a collection of ListViewSubItem objects stored in a ListViewItem.

For a list of all members of this type, see ListViewSubItemCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ListViewSubItemCollection

[Visual Basic]
Public Class ListViewSubItemCollection
Inherits CollectionBase
[C#]
public class ListViewSubItemCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ListViewSubItemCollection Members | Kixforms Namespace


ListViewSubItemCollection Members

ListViewSubItemCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the subitem at the specified index within the collection.

Public Instance Methods

Add | Adds an existing subitem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a subitem into the collection at the specified index.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


ListViewSubItemCollection Properties

The properties of the ListViewSubItemCollection class are listed below. For a complete list of ListViewSubItemCollection class members, see the ListViewSubItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the subitem at the specified index within the collection.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ListViewSubItemCollection.Item Property

Gets or sets the subitem at the specified index within the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As ListViewSubItem
[C#]
public ListViewSubItem this[
int index
] {get; set;}

Parameters

index
The index of the item in the collection to retrieve.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


ListViewSubItemCollection Methods

The methods of the ListViewSubItemCollection class are listed below. For a complete list of ListViewSubItemCollection class members, see the ListViewSubItemCollection Members topic.

Public Instance Methods

Add | Adds an existing subitem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a subitem into the collection at the specified index.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


ListViewSubItemCollection.Add Method

Adds an existing subitem to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As ListViewSubItem _
) As ListViewSubItem
[C#]
public ListViewSubItem Add(
ListViewSubItem item
);

Parameters

item

Return Value

The subitem that was added to the collection.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


ListViewSubItemCollection.Insert Method

Inserts a subitem into the collection at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal item As ListViewSubItem _
) As ListViewSubItem
[C#]
public ListViewSubItem Insert(
int index,
ListViewSubItem item
);

Parameters

index
The zero-based index location where the item is inserted.
item
A ListViewSubItem representing the subitem to insert into the collection.

Return Value

The subitem that was inserted to the collection.

See Also

ListViewSubItemCollection Class | Kixforms Namespace


MainMenu Class

Represents the menu structure of a form.

For a list of all members of this type, see MainMenu Members.

System.Object
Kixforms.Menu
Kixforms.MainMenu

[Visual Basic]
Public Class MainMenu
Inherits Menu
[C#]
public class MainMenu : Menu

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MainMenu Members | Kixforms Namespace


MainMenu Members

MainMenu overview

Public Instance Constructors

MainMenu Constructor Initializes a new instance of the MainMenu class.

Public Instance Properties

MenuItems (inherited from Menu) Gets a value indicating the collection of MenuItem objects associated with the menu.

Public Instance Methods

GetForm | Gets the Form that contains this control.
GetMainMenu (inherited from Menu) | Gets the MainMenu that contains this menu.

See Also

MainMenu Class | Kixforms Namespace


MainMenu Constructor

Initializes a new instance of the MainMenu class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public MainMenu();

See Also

MainMenu Class | Kixforms Namespace


MainMenu Methods

The methods of the MainMenu class are listed below. For a complete list of MainMenu class members, see the MainMenu Members topic.

Public Instance Methods

GetForm | Gets the Form that contains this control.
GetMainMenu (inherited from Menu) | Gets the MainMenu that contains this menu.

See Also

MainMenu Class | Kixforms Namespace


MainMenu.GetForm Method

Gets the Form that contains this control.

[Visual Basic]
Public Function GetForm() As Form
[C#]
public Form GetForm();

See Also

MainMenu Class | Kixforms Namespace


Math Class

Provides constants and static methods for trigonometric, logarithmic, and other common mathematical functions.

For a list of all members of this type, see Math Members.

System.Object
Kixforms.Math

[Visual Basic]
Public Class Math
[C#]
public class Math

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Math Members | Kixforms Namespace


Math Members

Math overview

Public Instance Properties

E | Represents the natural logarithmic base, specified by the constant, e.
PI | Represents the ratio of the circumference of a circle to its diameter, specified by the constant, p.

Public Instance Methods

Acos | Returns the angle whose cosine is the specified number.
Asin | Returns the angle whose sine is the specified number.
Atan | Returns the angle whose tangent is the specified number.
Atan2 | Returns the angle whose tangent is the quotient of two specified numbers.
Ceiling | Returns the smallest whole number greater than or equal to the specified number.
Cos | Returns the cosine of the specified angle.
Cosh | Returns the hyperbolic cosine of the specified angle.
Exp | Returns e raised to the specified power.
Floor | Returns the largest whole number less than or equal to the specified number.
Log | Returns the logarithm of a specified number.
Log10 | Returns the base 10 logarithm of a specified number.
Pow | Returns a specified number raised to the specified power.
Random | Returns a pseudorandom number between 0 and 1.
Round | Returns the whole number nearest the specified value.
Sin | Returns the sine of the specified angle.
Sinh | Returns the hyperbolic sine of the specified angle.
Sqrt | Returns the square root of a specified number.
Tan | Returns the tangent of the specified angle.
Tanh | Returns the hyperbolic tangent of the specified angle.

See Also

Math Class | Kixforms Namespace


Math Properties

The properties of the Math class are listed below. For a complete list of Math class members, see the Math Members topic.

Public Instance Properties

E | Represents the natural logarithmic base, specified by the constant, e.
PI | Represents the ratio of the circumference of a circle to its diameter, specified by the constant, p.

See Also

Math Class | Kixforms Namespace


E Property

KiXforms.NET Class Library

Math.E Property

Represents the natural logarithmic base, specified by the constant, e.

[Visual Basic]
Public ReadOnly Property E As Double
[C#]
public double E {get;}

See Also

Math Class | Kixforms Namespace


PI Property

KiXforms.NET Class Library

Math.PI Property

Represents the ratio of the circumference of a circle to its diameter, specified by the constant, p.

[Visual Basic]
Public ReadOnly Property PI As Double
[C#]
public double PI {get;}

See Also

Math Class | Kixforms Namespace


Math Methods

The methods of the Math class are listed below. For a complete list of Math class members, see the Math Members topic.

Public Instance Methods

Acos | Returns the angle whose cosine is the specified number.
Asin | Returns the angle whose sine is the specified number.
Atan | Returns the angle whose tangent is the specified number.
Atan2 | Returns the angle whose tangent is the quotient of two specified numbers.
Ceiling | Returns the smallest whole number greater than or equal to the specified number.
Cos | Returns the cosine of the specified angle.
Cosh | Returns the hyperbolic cosine of the specified angle.
Exp | Returns e raised to the specified power.
Floor | Returns the largest whole number less than or equal to the specified number.
Log | Returns the logarithm of a specified number.
Log10 | Returns the base 10 logarithm of a specified number.
Pow | Returns a specified number raised to the specified power.
Random | Returns a pseudorandom number between 0 and 1.
Round | Returns the whole number nearest the specified value.
Sin | Returns the sine of the specified angle.
Sinh | Returns the hyperbolic sine of the specified angle.
Sqrt | Returns the square root of a specified number.
Tan | Returns the tangent of the specified angle.
Tanh | Returns the hyperbolic tangent of the specified angle.

See Also

Math Class | Kixforms Namespace


Math.Acos Method

Returns the angle whose cosine is the specified number.

[Visual Basic]
Public Function Acos( _
ByVal d As Double _
) As Double
[C#]
public double Acos(
double d
);

Parameters

d
A number representing a cosine.

Return Value

An angle, q, measured in radians.

See Also

Math Class | Kixforms Namespace


Math.Asin Method

Returns the angle whose sine is the specified number.

[Visual Basic]
Public Function Asin( _
ByVal d As Double _
) As Double
[C#]
public double Asin(
double d
);

Parameters

d
A number representing a sine.

Return Value

An angle, q, measured in radians.

See Also

Math Class | Kixforms Namespace


Math.Atan Method

Returns the angle whose tangent is the specified number.

[Visual Basic]
Public Function Atan( _
ByVal d As Double _
) As Double
[C#]
public double Atan(
double d
);

Parameters

d
A number representing a tangent.

Return Value

An angle, q, measured in radians.

See Also

Math Class | Kixforms Namespace


Math.Atan2 Method

Returns the angle whose tangent is the quotient of two specified numbers.

[Visual Basic]
Public Function Atan2( _
ByVal y As Double, _
ByVal x As Double _
) As Double
[C#]
public double Atan2(
double y,
double x
);

Parameters

y
The y coordinate of a point.
x
The x coordinate of a point.

Return Value

An angle, q, measured in radians.

See Also

Math Class | Kixforms Namespace


Math.Ceiling Method

Returns the smallest whole number greater than or equal to the specified number.

[Visual Basic]
Public Function Ceiling( _
ByVal d As Double _
) As Double
[C#]
public double Ceiling(
double d
);

Parameters

d
A number.

Return Value

The smallest whole number greater than or equal to d.

See Also

Math Class | Kixforms Namespace


Math.Cos Method

Returns the cosine of the specified angle.

[Visual Basic]
Public Function Cos( _
ByVal a As Double _
) As Double
[C#]
public double Cos(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The cosine of a.

See Also

Math Class | Kixforms Namespace


Math.Cosh Method

Returns the hyperbolic cosine of the specified angle.

[Visual Basic]
Public Function Cosh( _
ByVal a As Double _
) As Double
[C#]
public double Cosh(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The hyperbolic cosine of a.

See Also

Math Class | Kixforms Namespace


Math.Exp Method

Returns e raised to the specified power.

[Visual Basic]
Public Function Exp( _
ByVal d As Double _
) As Double
[C#]
public double Exp(
double d
);

Parameters

d
A number specifying a power.

Return Value

The number e raised to the power d.

See Also

Math Class | Kixforms Namespace


Math.Floor Method

Returns the largest whole number less than or equal to the specified number.

[Visual Basic]
Public Function Floor( _
ByVal d As Double _
) As Double
[C#]
public double Floor(
double d
);

Parameters

d
A number.

Return Value

The largest whole number less than or equal to d.

See Also

Math Class | Kixforms Namespace


Math.Log Method

Returns the logarithm of a specified number.

[Visual Basic]
Public Function Log( _
ByVal d As Double _
) As Double
[C#]
public double Log(
double d
);

Parameters

d
A number.

Return Value

The natural logarithm of d.

See Also

Math Class | Kixforms Namespace


Math.Log10 Method

Returns the base 10 logarithm of a specified number.

[Visual Basic]
Public Function Log10( _
ByVal d As Double _
) As Double
[C#]
public double Log10(
double d
);

Parameters

d
A number whose logarithm is to be found.

Return Value

The base 10 log of d.

See Also

Math Class | Kixforms Namespace


Math.Pow Method

Returns a specified number raised to the specified power.

[Visual Basic]
Public Function Pow( _
ByVal x As Double, _
ByVal y As Double _
) As Double
[C#]
public double Pow(
double x,
double y
);

Parameters

x
A number to be raised to a power.
y
A number that specifies a power.

Return Value

The number x raised to the power y.

See Also

Math Class | Kixforms Namespace


Math.Random Method

Returns a pseudorandom number between 0 and 1.

[Visual Basic]
Public Function Random() As Double
[C#]
public double Random();

Return Value

A pseudorandom number between 0 and 1.

See Also

Math Class | Kixforms Namespace


Math.Round Method

Returns the whole number nearest the specified value.

[Visual Basic]
Public Function Round( _
ByVal a As Double _
) As Double
[C#]
public double Round(
double a
);

Parameters

a
A double-precision floating-point number to be rounded.

Return Value

The whole number nearest a. If a is halfway between two whole numbers, one of which by definition is even and the other odd, then the even number is returned.

See Also

Math Class | Kixforms Namespace


Math.Sin Method

Returns the sine of the specified angle.

[Visual Basic]
Public Function Sin( _
ByVal a As Double _
) As Double
[C#]
public double Sin(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The sine of a.

See Also

Math Class | Kixforms Namespace


Math.Sinh Method

Returns the hyperbolic sine of the specified angle.

[Visual Basic]
Public Function Sinh( _
ByVal a As Double _
) As Double
[C#]
public double Sinh(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The hyperbolic sine of a.

See Also

Math Class | Kixforms Namespace


Math.Sqrt Method

Returns the square root of a specified number.

[Visual Basic]
Public Function Sqrt( _
ByVal d As Double _
) As Double
[C#]
public double Sqrt(
double d
);

Parameters

d
A number whose square root is to be found.

Return Value

The square root of d.

See Also

Math Class | Kixforms Namespace


Math.Tan Method

Returns the tangent of the specified angle.

[Visual Basic]
Public Function Tan( _
ByVal a As Double _
) As Double
[C#]
public double Tan(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The tangent of a.

See Also

Math Class | Kixforms Namespace


Math.Tanh Method

Returns the hyperbolic tangent of the specified angle.

[Visual Basic]
Public Function Tanh( _
ByVal a As Double _
) As Double
[C#]
public double Tanh(
double a
);

Parameters

a
An angle, measured in radians.

Return Value

The hyperbolic tangent of a.

See Also

Math Class | Kixforms Namespace


MdiLayout Enumeration

[Visual Basic]
Public Enum MdiLayout
[C#]
public enum MdiLayout

Members

Member Name | Description
ArrangeIcons |
Cascade |
TileHorizontal |
TileVertical |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


MemoryStream Class

Creates a stream whose backing store is memory.

For a list of all members of this type, see MemoryStream Members.

System.Object
Kixforms.Stream
Kixforms.MemoryStream

[Visual Basic]
Public Class MemoryStream
Inherits Stream
[C#]
public class MemoryStream : Stream

Remarks

Use the System.Memory method to initialize a new instance of the MemoryStream class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MemoryStream Members | Kixforms Namespace


MemoryStream Members

MemoryStream overview

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Capacity | Gets or sets the number of bytes allocated for this stream.
Length | Gets the length of the stream in bytes.
Position | Gets or sets the current position within the stream.

Public Instance Methods

Close | Closes the stream for reading and writing.
Flush | Overrides Stream.Flush so that no action is performed.
FromByteArray | Initializes a new non-resizable instance of the MemoryStream class based on the specified byte array.
ReadByte | Reads a byte from the current stream.
Seek | Sets the position within the current stream to the specified value.
SetLength | Sets the length of the current stream to the specified value.
Write | Writes a block of bytes to the current stream using data read from buffer.
WriteByte | Writes a byte to the current stream at the current position.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream Properties

The properties of the MemoryStream class are listed below. For a complete list of MemoryStream class members, see the MemoryStream Members topic.

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Capacity | Gets or sets the number of bytes allocated for this stream.
Length | Gets the length of the stream in bytes.
Position | Gets or sets the current position within the stream.

See Also

MemoryStream Class | Kixforms Namespace


CanRead Property

KiXforms.NET Class Library

MemoryStream.CanRead Property

Gets a value indicating whether the current stream supports reading.

[Visual Basic]
Overrides Public ReadOnly Property CanRead As Boolean
[C#]
public override bool CanRead {get;}

Property Value

True if the stream supports reading; otherwise, false.

See Also

MemoryStream Class | Kixforms Namespace


CanSeek Property

KiXforms.NET Class Library

MemoryStream.CanSeek Property

Gets a value indicating whether the current stream supports seeking.

[Visual Basic]
Overrides Public ReadOnly Property CanSeek As Boolean
[C#]
public override bool CanSeek {get;}

Property Value

True if the stream supports seeking.

See Also

MemoryStream Class | Kixforms Namespace


CanWrite Property

KiXforms.NET Class Library

MemoryStream.CanWrite Property

Gets a value indicating whether the current stream supports writing.

[Visual Basic]
Overrides Public ReadOnly Property CanWrite As Boolean
[C#]
public override bool CanWrite {get;}

Property Value

True if the stream supports writing; otherwise, false.

See Also

MemoryStream Class | Kixforms Namespace


Capacity Property

KiXforms.NET Class Library

MemoryStream.Capacity Property

Gets or sets the number of bytes allocated for this stream.

[Visual Basic]
Overridable Public Property Capacity As Integer
[C#]
public virtual int Capacity {get; set;}

Property Value

The length of the usable portion of the buffer for the stream.

See Also

MemoryStream Class | Kixforms Namespace


Length Property

KiXforms.NET Class Library

MemoryStream.Length Property

Gets the length of the stream in bytes.

[Visual Basic]
Overrides Public ReadOnly Property Length As Integer
[C#]
public override int Length {get;}

Property Value

The length of the stream in bytes.

See Also

MemoryStream Class | Kixforms Namespace


Position Property

KiXforms.NET Class Library

MemoryStream.Position Property

Gets or sets the current position within the stream.

[Visual Basic]
Overrides Public Property Position As Integer
[C#]
public override int Position {get; set;}

Property Value

The current position within the stream.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream Methods

The methods of the MemoryStream class are listed below. For a complete list of MemoryStream class members, see the MemoryStream Members topic.

Public Instance Methods

Close | Closes the stream for reading and writing.
Flush | Overrides Stream.Flush so that no action is performed.
FromByteArray | Initializes a new non-resizable instance of the MemoryStream class based on the specified byte array.
ReadByte | Reads a byte from the current stream.
Seek | Sets the position within the current stream to the specified value.
SetLength | Sets the length of the current stream to the specified value.
Write | Writes a block of bytes to the current stream using data read from buffer.
WriteByte | Writes a byte to the current stream at the current position.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.Close Method

Closes the stream for reading and writing.

[Visual Basic]
Overrides Public Sub Close()
[C#]
public override void Close();

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.Flush Method

Overrides Stream.Flush so that no action is performed.

[Visual Basic]
Overrides Public Sub Flush()
[C#]
public override void Flush();

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.FromByteArray Method

Initializes a new non-resizable instance of the MemoryStream class based on the specified byte array.

[Visual Basic]
Public Function FromByteArray( _
ByVal array As Object() _
) As MemoryStream
[C#]
public MemoryStream FromByteArray(
object[] array
);

Parameters

array
The array of unsigned bytes from which to create the stream.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.ReadByte Method

Reads a byte from the current stream.

[Visual Basic]
Overrides Public Function ReadByte() As Integer
[C#]
public override int ReadByte();

Return Value

The byte cast to a Integer, or -1 if the end of the stream has been reached.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.Seek Method

Sets the position within the current stream to the specified value.

[Visual Basic]
Overrides Public Function Seek( _
ByVal offset As Integer, _
ByVal origin As SeekOrigin _
) As Integer
[C#]
public override int Seek(
int offset,
SeekOrigin origin
);

Parameters

offset
The new position within the stream. This is relative to the loc parameter, and may be positive or negative.
origin
A value of type SeekOrigin, which acts as the seek reference point.

Return Value

The new position within the stream, calculated by combining the initial reference point and the offset.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.SetLength Method

Sets the length of the current stream to the specified value.

[Visual Basic]
Overrides Public Sub SetLength( _
ByVal value As Integer _
)
[C#]
public override void SetLength(
int value
);

Parameters

value
The value at which to set the length.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.Write Method

Writes a block of bytes to the current stream using data read from buffer.

[Visual Basic]
Overrides Public Sub Write( _
ByVal buffer As Object(), _
ByVal offset As Integer, _
ByVal count As Integer _
)
[C#]
public override void Write(
object[] buffer,
int offset,
int count
);

Parameters

buffer
The buffer to write data to.
offset
The byte offset in buffer at which to begin writing.
count
The maximum number of bytes to write.

See Also

MemoryStream Class | Kixforms Namespace


MemoryStream.WriteByte Method

Writes a byte to the current stream at the current position.

[Visual Basic]
Overrides Public Sub WriteByte( _
ByVal value As Byte _
)
[C#]
public override void WriteByte(
byte value
);

Parameters

value
The byte to write.

See Also

MemoryStream Class | Kixforms Namespace


Menu Class

Represents the base functionality for all menus.

For a list of all members of this type, see Menu Members.

System.Object
Kixforms.Menu
Kixforms.ContextMenu
Kixforms.MainMenu
Kixforms.MenuItem

[Visual Basic]
Public Class Menu
[C#]
public class Menu

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Menu Members | Kixforms Namespace


Menu Members

Menu overview

Public Instance Properties

MenuItems Gets a value indicating the collection of MenuItem objects associated with the menu.

Public Instance Methods

GetMainMenu Gets the MainMenu that contains this menu.

See Also

Menu Class | Kixforms Namespace


Menu Properties

The properties of the Menu class are listed below. For a complete list of Menu class members, see the Menu Members topic.

Public Instance Properties

MenuItems Gets a value indicating the collection of MenuItem objects associated with the menu.

See Also

Menu Class | Kixforms Namespace


MenuItems Property

KiXforms.NET Class Library

Menu.MenuItems Property

Gets a value indicating the collection of MenuItem objects associated with the menu.

[Visual Basic]
Public ReadOnly Property MenuItems As MenuItemCollection
[C#]
public MenuItemCollection MenuItems {get;}

See Also

Menu Class | Kixforms Namespace


Menu Methods

The methods of the Menu class are listed below. For a complete list of Menu class members, see the Menu Members topic.

Public Instance Methods

GetMainMenu Gets the MainMenu that contains this menu.

See Also

Menu Class | Kixforms Namespace


Menu.GetMainMenu Method

Gets the MainMenu that contains this menu.

[Visual Basic]
Public Function GetMainMenu() As MainMenu
[C#]
public MainMenu GetMainMenu();

See Also

Menu Class | Kixforms Namespace


MenuItem Class

Represents an individual item that is displayed within a MainMenu or ContextMenu.

For a list of all members of this type, see MenuItem Members.

System.Object
Kixforms.Menu
Kixforms.MenuItem

[Visual Basic]
Public Class MenuItem
Inherits Menu
[C#]
public class MenuItem : Menu

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MenuItem Members | Kixforms Namespace


MenuItem Members

MenuItem overview

Public Instance Constructors

MenuItem Constructor Initializes a new instance of the MenuItem class.

Public Instance Properties

Checked | Gets or sets a value indicating whether a check mark appears next to the text of the menu item.
Click | Gets or sets the code to execute when the menu item is clicked or selected using a shortcut key or access key defined for the menu item.
Enabled | Gets or sets a value indicating whether the menu item is enabled.
Index | Gets or sets a value indicating the position of the menu item in its parent menu.
MdiList | Gets or sets a value indicating whether the menu item will be populated with a list of the Multiple Document Interface (MDI) child windows that are displayed within the associated form.
MenuItems (inherited from Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
MergeOrder | Gets or sets a value indicating the relative position of the menu item when it is merged with another.
MergeType | Gets or sets a value indicating the relative position of the menu item when it is merged with another.
Name | Gets or sets the name of the menu item.
RadioCheck | Gets or sets a value indicating whether the MenuItem, if checked, displays a radio-button instead of a check mark.
Shortcut | Gets or sets a value indicating the shortcut key associated with the menu item.
Text | Gets or sets a value indicating the caption of the menu item.
Visible | Gets or sets a value indicating whether the menu item is visible.

Public Instance Methods

GetMainMenu (inherited from Menu) Gets the MainMenu that contains this menu.

See Also

MenuItem Class | Kixforms Namespace


MenuItem Constructor

Initializes a new instance of the MenuItem class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal text As String = "Nothing", _
Optional ByVal click As String = "Nothing", _
Optional ByVal shortcut As Shortcut = 0 _
)
[C#]
public MenuItem(
string text,
string click,
Shortcut shortcut
);

Parameters

text
The caption for the menu item.
click
The event handler that handles the Click event for this menu item.
shortcut
One of the Shortcut values.

See Also

MenuItem Class | Kixforms Namespace


MenuItem Properties

The properties of the MenuItem class are listed below. For a complete list of MenuItem class members, see the MenuItem Members topic.

Public Instance Properties

Checked | Gets or sets a value indicating whether a check mark appears next to the text of the menu item.
Click | Gets or sets the code to execute when the menu item is clicked or selected using a shortcut key or access key defined for the menu item.
Enabled | Gets or sets a value indicating whether the menu item is enabled.
Index | Gets or sets a value indicating the position of the menu item in its parent menu.
MdiList | Gets or sets a value indicating whether the menu item will be populated with a list of the Multiple Document Interface (MDI) child windows that are displayed within the associated form.
MenuItems (inherited from Menu) | Gets a value indicating the collection of MenuItem objects associated with the menu.
MergeOrder | Gets or sets a value indicating the relative position of the menu item when it is merged with another.
MergeType | Gets or sets a value indicating the relative position of the menu item when it is merged with another.
Name | Gets or sets the name of the menu item.
RadioCheck | Gets or sets a value indicating whether the MenuItem, if checked, displays a radio-button instead of a check mark.
Shortcut | Gets or sets a value indicating the shortcut key associated with the menu item.
Text | Gets or sets a value indicating the caption of the menu item.
Visible | Gets or sets a value indicating whether the menu item is visible.

See Also

MenuItem Class | Kixforms Namespace


Checked Property

KiXforms.NET Class Library

MenuItem.Checked Property

Gets or sets a value indicating whether a check mark appears next to the text of the menu item.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Click Property

KiXforms.NET Class Library

MenuItem.Click Property

Gets or sets the code to execute when the menu item is clicked or selected using a shortcut key or access key defined for the menu item.

[Visual Basic]
Public Property Click As String
[C#]
public string Click {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Enabled Property

KiXforms.NET Class Library

MenuItem.Enabled Property

Gets or sets a value indicating whether the menu item is enabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Index Property

KiXforms.NET Class Library

MenuItem.Index Property

Gets or sets a value indicating the position of the menu item in its parent menu.

[Visual Basic]
Public Property Index As Integer
[C#]
public int Index {get; set;}

Property Value

The zero-based index representing the position of the menu item in its parent menu.

See Also

MenuItem Class | Kixforms Namespace


MdiList Property

KiXforms.NET Class Library

MenuItem.MdiList Property

Gets or sets a value indicating whether the menu item will be populated with a list of the Multiple Document Interface (MDI) child windows that are displayed within the associated form.

[Visual Basic]
Public Property MdiList As Boolean
[C#]
public bool MdiList {get; set;}

See Also

MenuItem Class | Kixforms Namespace


MergeOrder Property

KiXforms.NET Class Library

MenuItem.MergeOrder Property

Gets or sets a value indicating the relative position of the menu item when it is merged with another.

[Visual Basic]
Public Property MergeOrder As Integer
[C#]
public int MergeOrder {get; set;}

See Also

MenuItem Class | Kixforms Namespace


MergeType Property

KiXforms.NET Class Library

MenuItem.MergeType Property

Gets or sets a value indicating the relative position of the menu item when it is merged with another.

[Visual Basic]
Public Property MergeType As MenuMerge
[C#]
public MenuMerge MergeType {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

MenuItem.Name Property

Gets or sets the name of the menu item.

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

The name of the menu item. The default is an empty string ("").

See Also

MenuItem Class | Kixforms Namespace


RadioCheck Property

KiXforms.NET Class Library

MenuItem.RadioCheck Property

Gets or sets a value indicating whether the MenuItem, if checked, displays a radio-button instead of a check mark.

[Visual Basic]
Public Property RadioCheck As Boolean
[C#]
public bool RadioCheck {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Shortcut Property

KiXforms.NET Class Library

MenuItem.Shortcut Property

Gets or sets a value indicating the shortcut key associated with the menu item.

[Visual Basic]
Public Property Shortcut As Shortcut
[C#]
public Shortcut Shortcut {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

MenuItem.Text Property

Gets or sets a value indicating the caption of the menu item.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

MenuItem Class | Kixforms Namespace


Visible Property

KiXforms.NET Class Library

MenuItem.Visible Property

Gets or sets a value indicating whether the menu item is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

Property Value

True if the menu item will be made visible on the menu; otherwise, false. The default is true.

See Also

MenuItem Class | Kixforms Namespace


MenuItemCollection Class

Represents a collection of MenuItem objects.

For a list of all members of this type, see MenuItemCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.MenuItemCollection

[Visual Basic]
Public Class MenuItemCollection
Inherits CollectionBase
[C#]
public class MenuItemCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MenuItemCollection Members | Kixforms Namespace


MenuItemCollection Members

MenuItemCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Retrieves the MenuItem at the specified indexed location in the collection.

Public Instance Methods

Add | Adds a MenuItem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines if the specified MenuItem is a member of the collection.
IndexOf | Retrieves the index of a specific item in the collection.
Remove | Removes a MenuItem from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection Properties

The properties of the MenuItemCollection class are listed below. For a complete list of MenuItemCollection class members, see the MenuItemCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Retrieves the MenuItem at the specified indexed location in the collection.

See Also

MenuItemCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

MenuItemCollection.Item Property

Retrieves the MenuItem at the specified indexed location in the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As MenuItem
[C#]
public MenuItem this[
int index
] {get; set;}

Parameters

index
The indexed location of the MenuItem in the collection.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection Methods

The methods of the MenuItemCollection class are listed below. For a complete list of MenuItemCollection class members, see the MenuItemCollection Members topic.

Public Instance Methods

Add | Adds a MenuItem to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Contains | Determines if the specified MenuItem is a member of the collection.
IndexOf | Retrieves the index of a specific item in the collection.
Remove | Removes a MenuItem from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection.Add Method

Adds a MenuItem to the collection.

[Visual Basic]
Public Function Add( _
ByVal item As MenuItem _
) As MenuItem
[C#]
public MenuItem Add(
MenuItem item
);

Parameters

item
The MenuItem to add.

Return Value

The MenuItem that was added to the collection.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection.Contains Method

Determines if the specified MenuItem is a member of the collection.

[Visual Basic]
Public Function Contains( _
ByVal item As MenuItem _
) As Boolean
[C#]
public bool Contains(
MenuItem item
);

Parameters

item
The MenuItem to locate in the collection.

Return Value

True if the MenuItem is a member of the collection; otherwise, false.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection.IndexOf Method

Retrieves the index of a specific item in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal item As MenuItem _
) As Integer
[C#]
public int IndexOf(
MenuItem item
);

Parameters

item
The MenuItem to locate in the collection.

Return Value

The zero-based index of the item found in the collection; otherwise, -1.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuItemCollection.Remove Method

Removes a MenuItem from the collection.

[Visual Basic]
Public Function Remove( _
ByVal item As MenuItem _
) As Object
[C#]
public object Remove(
MenuItem item
);

Parameters

item
The MenuItem to remove.

See Also

MenuItemCollection Class | Kixforms Namespace


MenuMerge Enumeration

[Visual Basic]
Public Enum MenuMerge
[C#]
public enum MenuMerge

Members

Member Name | Description
Add |
MergeItems |
Remove |
Replace |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


MessageBox Class

Displays a message box that can contain text, buttons, and symbols that inform and instruct the user.

For a list of all members of this type, see MessageBox Members.

System.Object
Kixforms.MessageBox

[Visual Basic]
Public Class MessageBox
[C#]
public class MessageBox

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MessageBox Members | Kixforms Namespace


MessageBox Members

MessageBox overview

Public Instance Constructors

MessageBox Constructor Initializes a new instance of the MessageBox class.

Public Instance Properties

Buttons | Gets or sets one of the MessageBoxButtons values that specifies which buttons to display in the message box.
Icon | Gets or sets one of the MessageBoxIcon values that specifies which icon to display in the message box.
Text | Gets or sets the text to display in the message box.
Title | Gets or sets the text to display in the title bar of the message box.

Public Instance Methods

Show Displays a message box.

See Also

MessageBox Class | Kixforms Namespace


MessageBox Constructor

Initializes a new instance of the MessageBox class.

[Visual Basic]
Public Sub New()
[C#]
public MessageBox();

See Also

MessageBox Class | Kixforms Namespace


MessageBox Properties

The properties of the MessageBox class are listed below. For a complete list of MessageBox class members, see the MessageBox Members topic.

Public Instance Properties

Buttons | Gets or sets one of the MessageBoxButtons values that specifies which buttons to display in the message box.
Icon | Gets or sets one of the MessageBoxIcon values that specifies which icon to display in the message box.
Text | Gets or sets the text to display in the message box.
Title | Gets or sets the text to display in the title bar of the message box.

See Also

MessageBox Class | Kixforms Namespace


Buttons Property

KiXforms.NET Class Library

MessageBox.Buttons Property

Gets or sets one of the MessageBoxButtons values that specifies which buttons to display in the message box.

[Visual Basic]
Public Property Buttons As MessageBoxButtons
[C#]
public MessageBoxButtons Buttons {get; set;}

Property Value

One of the MessageBoxButtons values.

See Also

MessageBox Class | Kixforms Namespace


Icon Property

KiXforms.NET Class Library

MessageBox.Icon Property

Gets or sets one of the MessageBoxIcon values that specifies which icon to display in the message box.

[Visual Basic]
Public Property Icon As MessageBoxIcon
[C#]
public MessageBoxIcon Icon {get; set;}

Property Value

One of the MessageBoxIcon values.

See Also

MessageBox Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

MessageBox.Text Property

Gets or sets the text to display in the message box.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

Property Value

The text to display in the message box.

See Also

MessageBox Class | Kixforms Namespace


Title Property

KiXforms.NET Class Library

MessageBox.Title Property

Gets or sets the text to display in the title bar of the message box.

[Visual Basic]
Public Property Title As String
[C#]
public string Title {get; set;}

Property Value

The text to display in the title bar of the message box.

See Also

MessageBox Class | Kixforms Namespace


MessageBox Methods

The methods of the MessageBox class are listed below. For a complete list of MessageBox class members, see the MessageBox Members topic.

Public Instance Methods

Show Displays a message box.

See Also

MessageBox Class | Kixforms Namespace


MessageBox.Show Method

Displays a message box.

[Visual Basic]
Public Function Show( _
Optional ByVal text As String = "Nothing", _
Optional ByVal title As String = "Nothing", _
Optional ByVal buttons As MessageBoxButtons = 0, _
Optional ByVal icon As MessageBoxIcon = 0 _
) As DialogResult
[C#]
public DialogResult Show(
string text,
string title,
MessageBoxButtons buttons,
MessageBoxIcon icon
);

Parameters

text
The text to display in the message box.
title
The text to display in the title bar of the message box.
buttons
One of the MessageBoxButtons that specifies which buttons to display in the message box.
icon
One of the MessageBoxIcon; values that specifies which icon to display in the message box.

Return Value

One of the DialogResult values.

See Also

MessageBox Class | Kixforms Namespace


MessageBoxButtons Enumeration

[Visual Basic]
Public Enum MessageBoxButtons
[C#]
public enum MessageBoxButtons

Members

Member Name | Description
AbortRetryIgnore |
OK |
OKCancel |
RetryCancel |
YesNo |
YesNoCancel |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


MessageBoxIcon Enumeration

[Visual Basic]
Public Enum MessageBoxIcon
[C#]
public enum MessageBoxIcon

Members

Member Name | Description
Asterisk |
Error |
Exclamation |
Hand |
Information |
None |
Question |
Stop |
Warning |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


MouseButtons Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

[Visual Basic]
Public Enum MouseButtons
[C#]
public enum MouseButtons

Members

Member Name | Description | Value
None |  | 0
Right |  | 2097152
Left |  | 1048576
Middle |  | 4194304
XButton1 |  | 8388608
XButton2 |  | 16777216

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


MouseEventArgs Class

Provides data for the MouseUp, MouseDown, and MouseMove events.

For a list of all members of this type, see MouseEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.MouseEventArgs

[Visual Basic]
Public Class MouseEventArgs
Inherits EventArgs
[C#]
public class MouseEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

MouseEventArgs Members | Kixforms Namespace


MouseEventArgs Members

MouseEventArgs overview

Public Instance Properties

Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
X | Gets the x-coordinate of a mouse click.
Y | Gets the y-coordinate of a mouse click.

See Also

MouseEventArgs Class | Kixforms Namespace


MouseEventArgs Properties

The properties of the MouseEventArgs class are listed below. For a complete list of MouseEventArgs class members, see the MouseEventArgs Members topic.

Public Instance Properties

Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
X | Gets the x-coordinate of a mouse click.
Y | Gets the y-coordinate of a mouse click.

See Also

MouseEventArgs Class | Kixforms Namespace


Button Property

KiXforms.NET Class Library

MouseEventArgs.Button Property

Gets which mouse button was pressed.

[Visual Basic]
Public Property Button As MouseButtons
[C#]
public MouseButtons Button {get; set;}

See Also

MouseEventArgs Class | Kixforms Namespace


Clicks Property

KiXforms.NET Class Library

MouseEventArgs.Clicks Property

Gets the number of times the mouse button was pressed and released.

[Visual Basic]
Public Property Clicks As Integer
[C#]
public int Clicks {get; set;}

See Also

MouseEventArgs Class | Kixforms Namespace


X Property

KiXforms.NET Class Library

MouseEventArgs.X Property

Gets the x-coordinate of a mouse click.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}

See Also

MouseEventArgs Class | Kixforms Namespace


Y Property

KiXforms.NET Class Library

MouseEventArgs.Y Property

Gets the y-coordinate of a mouse click.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}

See Also

MouseEventArgs Class | Kixforms Namespace


NetworkStream Class

Provides the underlying stream of data for network access.

For a list of all members of this type, see NetworkStream Members.

System.Object
Kixforms.NetworkStream

[Visual Basic]
Public Class NetworkStream
[C#]
public class NetworkStream

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

NetworkStream Members | Kixforms Namespace


NetworkStream Members

NetworkStream overview

Public Instance Properties

CanRead | Gets a value indicating whether the NetworkStream supports reading.
CanWrite | Gets a value indicating whether the NetworkStream supports writing.
DataAvailable | Gets a value indicating whether data is available on the NetworkStream to be read.

Public Instance Methods

Close | Closes the NetworkStream.
Read | Reads data from the NetworkStream.
Write | Writes data to the NetworkStream.

See Also

NetworkStream Class | Kixforms Namespace


NetworkStream Properties

The properties of the NetworkStream class are listed below. For a complete list of NetworkStream class members, see the NetworkStream Members topic.

Public Instance Properties

CanRead | Gets a value indicating whether the NetworkStream supports reading.
CanWrite | Gets a value indicating whether the NetworkStream supports writing.
DataAvailable | Gets a value indicating whether data is available on the NetworkStream to be read.

See Also

NetworkStream Class | Kixforms Namespace


CanRead Property

KiXforms.NET Class Library

NetworkStream.CanRead Property

Gets a value indicating whether the NetworkStream supports reading.

[Visual Basic]
Public ReadOnly Property CanRead As Boolean
[C#]
public bool CanRead {get;}

Property Value

true if data can be read from the stream; otherwise, false. The default value is true.

See Also

NetworkStream Class | Kixforms Namespace


CanWrite Property

KiXforms.NET Class Library

NetworkStream.CanWrite Property

Gets a value indicating whether the NetworkStream supports writing.

[Visual Basic]
Public ReadOnly Property CanWrite As Boolean
[C#]
public bool CanWrite {get;}

Property Value

true if data can be written to the stream; otherwise, false. The default value is true.

See Also

NetworkStream Class | Kixforms Namespace


DataAvailable Property

KiXforms.NET Class Library

NetworkStream.DataAvailable Property

Gets a value indicating whether data is available on the NetworkStream to be read.

[Visual Basic]
Public ReadOnly Property DataAvailable As Boolean
[C#]
public bool DataAvailable {get;}

Property Value

true if data is available on the stream to be read; otherwise, false.

Remarks

The Read method blocks execution until data is received from the remote host and queued in the network buffer for reading. If you want to avoid blocking, use the DataAvailable method to determine if this data is available. If DataAvailable is true, a call to Read will return immediately.

See Also

NetworkStream Class | Kixforms Namespace


NetworkStream Methods

The methods of the NetworkStream class are listed below. For a complete list of NetworkStream class members, see the NetworkStream Members topic.

Public Instance Methods

Close | Closes the NetworkStream.
Read | Reads data from the NetworkStream.
Write | Writes data to the NetworkStream.

See Also

NetworkStream Class | Kixforms Namespace


NetworkStream.Close Method

Closes the NetworkStream.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

NetworkStream Class | Kixforms Namespace


NetworkStream.Read Method

Reads data from the NetworkStream.

[Visual Basic]
Public Function Read( _
ByVal offSet As Integer, _
ByVal Count As Integer _
) As Object()
[C#]
public object[] Read(
int offSet,
int Count
);

Parameters

offSet
Count
The number of bytes to read from the NetworkStream.

Return Value

byteArray holding the bytes read.

Note as kixtart currently doesn't support byteArrays (weird, I know) the values are actually integers.

Remarks

This method returns bytes successfully read. If no data is available for reading, the NetworkStream.Read method will block until data is available. To avoid blocking, you can use the DataAvailable property to determine if data is queued in the incoming network buffer for reading. If DataAvailable returns true, the Read operation will complete immediately. The Read operation will read as much data as is available, up to the number of bytes specified by the Count parameter. If the remote host shuts down the connection, and all available data has been received, the Read method will complete immediately and return zero bytes.

See Also

NetworkStream Class | Kixforms Namespace


NetworkStream.Write Method

Writes data to the NetworkStream.

[Visual Basic]
Public Sub Write( _
ByVal WriteArr As Object(), _
ByVal offSet As Integer, _
ByVal Count As Integer _
)
[C#]
public void Write(
object[] WriteArr,
int offSet,
int Count
);

Parameters

WriteArr
An array of type Byte that contains the data to write to the NetworkStream.
offSet
The location in buffer from which to start writing data.
Count
The number of bytes to write to the NetworkStream.

Remarks

The Write method starts at the specified offSet and sends Count bytes from the contents of buffer to the network. The Write method blocks until the requested number of bytes are sent or error is raised.

Note as KiXtart has limited support for bytes and many other basic types, you can use integers to represent the byte values in the array.

to easily translate strings or other types to byte arrays, use the Encoding.GetBytes method.

See Also

NetworkStream Class | Kixforms Namespace


NodeLabelEditEventArgs Class

Provides data for the BeforeLabelEdit and AfterLabelEdit events.

For a list of all members of this type, see NodeLabelEditEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.NodeLabelEditEventArgs

[Visual Basic]
Public Class NodeLabelEditEventArgs
Inherits EventArgs
[C#]
public class NodeLabelEditEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

NodeLabelEditEventArgs Members | Kixforms Namespace


NodeLabelEditEventArgs Members

NodeLabelEditEventArgs overview

Public Instance Properties

CancelEdit | Gets or sets a value indicating whether the edit has been canceled.
Label | Gets the new text to associate with the tree node.
Node | Gets the tree node containing the text to edit.

See Also

NodeLabelEditEventArgs Class | Kixforms Namespace


NodeLabelEditEventArgs Properties

The properties of the NodeLabelEditEventArgs class are listed below. For a complete list of NodeLabelEditEventArgs class members, see the NodeLabelEditEventArgs Members topic.

Public Instance Properties

CancelEdit | Gets or sets a value indicating whether the edit has been canceled.
Label | Gets the new text to associate with the tree node.
Node | Gets the tree node containing the text to edit.

See Also

NodeLabelEditEventArgs Class | Kixforms Namespace


CancelEdit Property

KiXforms.NET Class Library

NodeLabelEditEventArgs.CancelEdit Property

Gets or sets a value indicating whether the edit has been canceled.

[Visual Basic]
Public Property CancelEdit As Boolean
[C#]
public bool CancelEdit {get; set;}

Remarks

True if the edit has been canceled; otherwise, false.

See Also

NodeLabelEditEventArgs Class | Kixforms Namespace


Label Property

KiXforms.NET Class Library

NodeLabelEditEventArgs.Label Property

Gets the new text to associate with the tree node.

[Visual Basic]
Public Property Label As String
[C#]
public string Label {get; set;}

Remarks

The string value that represents the TreeNode label.

See Also

NodeLabelEditEventArgs Class | Kixforms Namespace


Node Property

KiXforms.NET Class Library

NodeLabelEditEventArgs.Node Property

Gets the tree node containing the text to edit.

[Visual Basic]
Public Property Node As TreeNode
[C#]
public TreeNode Node {get; set;}

Remarks

A TreeNode that represents the tree node containing the text to edit.

See Also

NodeLabelEditEventArgs Class | Kixforms Namespace


NotifyIcon Class

Specifies a component that creates an icon in the status area.

For a list of all members of this type, see NotifyIcon Members.

System.Object
Kixforms.Component
Kixforms.NotifyIcon

[Visual Basic]
Public Class NotifyIcon
Inherits Component
[C#]
public class NotifyIcon : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

NotifyIcon Members | Kixforms Namespace


NotifyIcon Members

NotifyIcon overview

Public Instance Constructors

NotifyIcon Constructor Initializes a new instance of the NotifyIcon class.

Public Instance Properties

Click | Gets or sets the code to execute when the user clicks the icon in the status area.
ContextMenu | Gets or sets the context menu for the icon.
DoubleClick | Gets or sets the code to execute when the user double-clicks the icon in the status notification area of the taskbar.
Icon | Gets or sets the current icon.
MouseDown | Gets or sets the code to execute when the user presses the mouse button while the pointer is over the icon in the status notification area of the taskbar.
MouseDownEventArgs | Gets the data for the MouseDown event.
MouseMove | Gets or sets the code to execute when the user moves the mouse while the pointer is over the icon in the status notification area of the taskbar.
MouseMoveEventArgs | Gets the data for the MouseMove event.
MouseUp | Gets or sets the code to execute when the user releases the mouse button while the pointer is over the icon in the status notification area of the taskbar.
MouseUpEventArgs | Gets the data for the MouseUp event.
Text | Gets or sets the ToolTip text displayed when the mouse hovers over a status area icon.
Type (inherited from Component) | Gets the Type of the current instance.
Visible | Gets or sets a value indicating whether the icon is visible in the status notification area of the taskbar.

Public Instance Methods

Dispose (inherited from Component) Releases the resources used by the Component.

See Also

NotifyIcon Class | Kixforms Namespace


NotifyIcon Constructor

Initializes a new instance of the NotifyIcon class.

[Visual Basic]
Public Sub New()
[C#]
public NotifyIcon();

See Also

NotifyIcon Class | Kixforms Namespace


NotifyIcon Properties

The properties of the NotifyIcon class are listed below. For a complete list of NotifyIcon class members, see the NotifyIcon Members topic.

Public Instance Properties

Click | Gets or sets the code to execute when the user clicks the icon in the status area.
ContextMenu | Gets or sets the context menu for the icon.
DoubleClick | Gets or sets the code to execute when the user double-clicks the icon in the status notification area of the taskbar.
Icon | Gets or sets the current icon.
MouseDown | Gets or sets the code to execute when the user presses the mouse button while the pointer is over the icon in the status notification area of the taskbar.
MouseDownEventArgs | Gets the data for the MouseDown event.
MouseMove | Gets or sets the code to execute when the user moves the mouse while the pointer is over the icon in the status notification area of the taskbar.
MouseMoveEventArgs | Gets the data for the MouseMove event.
MouseUp | Gets or sets the code to execute when the user releases the mouse button while the pointer is over the icon in the status notification area of the taskbar.
MouseUpEventArgs | Gets the data for the MouseUp event.
Text | Gets or sets the ToolTip text displayed when the mouse hovers over a status area icon.
Type (inherited from Component) | Gets the Type of the current instance.
Visible | Gets or sets a value indicating whether the icon is visible in the status notification area of the taskbar.

See Also

NotifyIcon Class | Kixforms Namespace


Click Property

KiXforms.NET Class Library

NotifyIcon.Click Property

Gets or sets the code to execute when the user clicks the icon in the status area.

[Visual Basic]
Public Property Click As String
[C#]
public string Click {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


ContextMenu Property

KiXforms.NET Class Library

NotifyIcon.ContextMenu Property

Gets or sets the context menu for the icon.

[Visual Basic]
Public Property ContextMenu As ContextMenu
[C#]
public ContextMenu ContextMenu {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


DoubleClick Property

KiXforms.NET Class Library

NotifyIcon.DoubleClick Property

Gets or sets the code to execute when the user double-clicks the icon in the status notification area of the taskbar.

[Visual Basic]
Public Property DoubleClick As String
[C#]
public string DoubleClick {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


Icon Property

KiXforms.NET Class Library

NotifyIcon.Icon Property

Gets or sets the current icon.

[Visual Basic]
Public Property Icon As Icon
[C#]
public Icon Icon {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseDown Property

KiXforms.NET Class Library

NotifyIcon.MouseDown Property

Gets or sets the code to execute when the user presses the mouse button while the pointer is over the icon in the status notification area of the taskbar.

[Visual Basic]
Public Property MouseDown As String
[C#]
public string MouseDown {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseDownEventArgs Property

KiXforms.NET Class Library

NotifyIcon.MouseDownEventArgs Property

Gets the data for the MouseDown event.

[Visual Basic]
Public Property MouseDownEventArgs As MouseEventArgs
[C#]
public MouseEventArgs MouseDownEventArgs {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseMove Property

KiXforms.NET Class Library

NotifyIcon.MouseMove Property

Gets or sets the code to execute when the user moves the mouse while the pointer is over the icon in the status notification area of the taskbar.

[Visual Basic]
Public Property MouseMove As String
[C#]
public string MouseMove {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseMoveEventArgs Property

KiXforms.NET Class Library

NotifyIcon.MouseMoveEventArgs Property

Gets the data for the MouseMove event.

[Visual Basic]
Public Property MouseMoveEventArgs As MouseEventArgs
[C#]
public MouseEventArgs MouseMoveEventArgs {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseUp Property

KiXforms.NET Class Library

NotifyIcon.MouseUp Property

Gets or sets the code to execute when the user releases the mouse button while the pointer is over the icon in the status notification area of the taskbar.

[Visual Basic]
Public Property MouseUp As String
[C#]
public string MouseUp {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


MouseUpEventArgs Property

KiXforms.NET Class Library

NotifyIcon.MouseUpEventArgs Property

Gets the data for the MouseUp event.

[Visual Basic]
Public Property MouseUpEventArgs As MouseEventArgs
[C#]
public MouseEventArgs MouseUpEventArgs {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

NotifyIcon.Text Property

Gets or sets the ToolTip text displayed when the mouse hovers over a status area icon.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


Visible Property

KiXforms.NET Class Library

NotifyIcon.Visible Property

Gets or sets a value indicating whether the icon is visible in the status notification area of the taskbar.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

NotifyIcon Class | Kixforms Namespace


NumericUpDown Class

Represents a Windows up-down control that displays numeric values.

For a list of all members of this type, see NumericUpDown Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.UpDownBase
Kixforms.NumericUpDown

[Visual Basic]
Public Class NumericUpDown
Inherits UpDownBase
[C#]
public class NumericUpDown : UpDownBase

Remarks

Use the System.NumericUpDown method to create a new instance of the NumericUpDown class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

NumericUpDown Members | Kixforms Namespace


NumericUpDown Members

NumericUpDown overview

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from UpDownBase) | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DecimalPlaces | Gets or sets the number of decimal places to display in the up-down control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Increment | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the maximum value for the up-down control.
Minimum | Gets or sets the minimum allowed value for the up-down control.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from UpDownBase) | Gets or sets a value indicating whether the text may be changed by the use of the up or down buttons only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets the value assigned to the up-down control.
ValueChanged | Gets or sets the code to execute when the Value property has been changed in some way.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

NumericUpDown Class | Kixforms Namespace


NumericUpDown Properties

The properties of the NumericUpDown class are listed below. For a complete list of NumericUpDown class members, see the NumericUpDown Members topic.

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from UpDownBase) | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DecimalPlaces | Gets or sets the number of decimal places to display in the up-down control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Increment | Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the maximum value for the up-down control.
Minimum | Gets or sets the minimum allowed value for the up-down control.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from UpDownBase) | Gets or sets a value indicating whether the text may be changed by the use of the up or down buttons only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets the value assigned to the up-down control.
ValueChanged | Gets or sets the code to execute when the Value property has been changed in some way.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

NumericUpDown Class | Kixforms Namespace


DecimalPlaces Property

KiXforms.NET Class Library

NumericUpDown.DecimalPlaces Property

Gets or sets the number of decimal places to display in the up-down control.

[Visual Basic]
Public Property DecimalPlaces As Integer
[C#]
public int DecimalPlaces {get; set;}

Property Value

The number of decimal places to display in the up-down control. The default value is zero.

See Also

NumericUpDown Class | Kixforms Namespace


Increment Property

KiXforms.NET Class Library

NumericUpDown.Increment Property

Gets or sets the value to increment or decrement the up-down control when the up or down buttons are clicked.

[Visual Basic]
Public Property Increment As Decimal
[C#]
public decimal Increment {get; set;}

Property Value

The value to increment or decrement the Value property when the up or down buttons are clicked on the up-down control. The default value is 1.

See Also

NumericUpDown Class | Kixforms Namespace


Maximum Property

KiXforms.NET Class Library

NumericUpDown.Maximum Property

Gets or sets the maximum value for the up-down control.

[Visual Basic]
Public Property Maximum As Decimal
[C#]
public decimal Maximum {get; set;}

Property Value

The maximum value for the up-down control. The default value is 100.

See Also

NumericUpDown Class | Kixforms Namespace


Minimum Property

KiXforms.NET Class Library

NumericUpDown.Minimum Property

Gets or sets the minimum allowed value for the up-down control.

[Visual Basic]
Public Property Minimum As Decimal
[C#]
public decimal Minimum {get; set;}

Property Value

The minimum allowed value for the up-down control. The default value is zero.

See Also

NumericUpDown Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

NumericUpDown.Value Property

Gets or sets the value assigned to the up-down control.

[Visual Basic]
Public Property Value As Decimal
[C#]
public decimal Value {get; set;}

Property Value

The numeric value of the control.

See Also

NumericUpDown Class | Kixforms Namespace


ValueChanged Property

KiXforms.NET Class Library

NumericUpDown.ValueChanged Property

Gets or sets the code to execute when the Value property has been changed in some way.

[Visual Basic]
Public Property ValueChanged As String
[C#]
public string ValueChanged {get; set;}

Property Value

The code to execute when the Value property has been changed in some way.

See Also

NumericUpDown Class | Kixforms Namespace


OpenFileDialog Class

Represents a common dialog box that displays the control that allows the user to open a file.

For a list of all members of this type, see OpenFileDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FileDialog
Kixforms.OpenFileDialog

[Visual Basic]
Public Class OpenFileDialog
Inherits FileDialog
[C#]
public class OpenFileDialog : FileDialog

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

OpenFileDialog Members | Kixforms Namespace


OpenFileDialog Members

OpenFileDialog overview

Public Instance Constructors

OpenFileDialog Constructor Initializes a new instance of the OpenFileDialog class.

Public Instance Properties

AddExtension (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
DefaultExt (inherited from FileDialog) | Gets or sets the default file name extension.
DereferenceLinks (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName (inherited from FileDialog) | Gets or sets a string containing the file name selected in the file dialog box.
Filter (inherited from FileDialog) | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex (inherited from FileDialog) | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory (inherited from FileDialog) | Gets or sets the initial directory displayed by the file dialog box.
ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
RestoreDirectory (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
ShowReadOnly | Gets or sets a value indicating whether the dialog contains a read-only check box.
Title (inherited from FileDialog) | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets all dialog box options to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

OpenFileDialog Class | Kixforms Namespace


OpenFileDialog Constructor

Initializes a new instance of the OpenFileDialog class.

[Visual Basic]
Public Sub New()
[C#]
public OpenFileDialog();

See Also

OpenFileDialog Class | Kixforms Namespace


OpenFileDialog Properties

The properties of the OpenFileDialog class are listed below. For a complete list of OpenFileDialog class members, see the OpenFileDialog Members topic.

Public Instance Properties

AddExtension (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
DefaultExt (inherited from FileDialog) | Gets or sets the default file name extension.
DereferenceLinks (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName (inherited from FileDialog) | Gets or sets a string containing the file name selected in the file dialog box.
Filter (inherited from FileDialog) | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex (inherited from FileDialog) | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory (inherited from FileDialog) | Gets or sets the initial directory displayed by the file dialog box.
ReadOnlyChecked | Gets or sets a value indicating whether the read-only check box is selected.
RestoreDirectory (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
ShowReadOnly | Gets or sets a value indicating whether the dialog contains a read-only check box.
Title (inherited from FileDialog) | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

OpenFileDialog Class | Kixforms Namespace


CheckFileExists Property

KiXforms.NET Class Library

OpenFileDialog.CheckFileExists Property

Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.

[Visual Basic]
Overrides Public Property CheckFileExists As Boolean
[C#]
public override bool CheckFileExists {get; set;}

See Also

OpenFileDialog Class | Kixforms Namespace


ReadOnlyChecked Property

KiXforms.NET Class Library

OpenFileDialog.ReadOnlyChecked Property

Gets or sets a value indicating whether the read-only check box is selected.

[Visual Basic]
Public Property ReadOnlyChecked As Boolean
[C#]
public bool ReadOnlyChecked {get; set;}

See Also

OpenFileDialog Class | Kixforms Namespace


ShowReadOnly Property

KiXforms.NET Class Library

OpenFileDialog.ShowReadOnly Property

Gets or sets a value indicating whether the dialog contains a read-only check box.

[Visual Basic]
Public Property ShowReadOnly As Boolean
[C#]
public bool ShowReadOnly {get; set;}

See Also

OpenFileDialog Class | Kixforms Namespace


OpenFileDialog Methods

The methods of the OpenFileDialog class are listed below. For a complete list of OpenFileDialog class members, see the OpenFileDialog Members topic.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets all dialog box options to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

OpenFileDialog Class | Kixforms Namespace


OpenFileDialog.Reset Method

Resets all dialog box options to their default values.

[Visual Basic]
Public Function Reset() As Object
[C#]
public object Reset();

See Also

OpenFileDialog Class | Kixforms Namespace


PaintEventArgs Class

Provides data for the Paint event.

For a list of all members of this type, see PaintEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.PaintEventArgs

[Visual Basic]
Public Class PaintEventArgs
Inherits EventArgs
[C#]
public class PaintEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

PaintEventArgs Members | Kixforms Namespace


PaintEventArgs Members

PaintEventArgs overview

Public Instance Properties

ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the Graphics object used to paint

See Also

PaintEventArgs Class | Kixforms Namespace


PaintEventArgs Properties

The properties of the PaintEventArgs class are listed below. For a complete list of PaintEventArgs class members, see the PaintEventArgs Members topic.

Public Instance Properties

ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the Graphics object used to paint

See Also

PaintEventArgs Class | Kixforms Namespace


ClipRectangle Property

KiXforms.NET Class Library

PaintEventArgs.ClipRectangle Property

Gets the rectangle in which to paint.

[Visual Basic]
Public Property ClipRectangle As Rectangle
[C#]
public Rectangle ClipRectangle {get; set;}

See Also

PaintEventArgs Class | Kixforms Namespace


Graphics Property

KiXforms.NET Class Library

PaintEventArgs.Graphics Property

Gets the Graphics object used to paint

[Visual Basic]
Public Property Graphics As Graphics
[C#]
public Graphics Graphics {get; set;}

See Also

PaintEventArgs Class | Kixforms Namespace


Panel Class

Represents a Windows Panel control.

For a list of all members of this type, see Panel Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.Panel
Kixforms.TabPage

[Visual Basic]
Public Class Panel
Inherits ScrollableControl
[C#]
public class Panel : ScrollableControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Panel Members | Kixforms Namespace


Panel Members

Panel overview

Public Instance Constructors

Panel Constructor Initializes a new instance of the Panel class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Panel Class | Kixforms Namespace


Panel Constructor

Initializes a new instance of the Panel class.

[Visual Basic]
Public Sub New()
[C#]
public Panel();

See Also

Panel Class | Kixforms Namespace


Panel Properties

The properties of the Panel class are listed below. For a complete list of Panel class members, see the Panel Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

Panel Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

Panel.BorderStyle Property

Indicates the border style for the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

Panel Class | Kixforms Namespace


Pen Class

Defines an object used to draw lines and curves.

For a list of all members of this type, see Pen Members.

System.Object
Kixforms.Pen

[Visual Basic]
Public Class Pen
[C#]
public class Pen

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Pen Members | Kixforms Namespace


Pen Members

Pen overview

Public Instance Constructors

Pen Constructor Initializes a new instance of the Pen class.

Public Instance Methods

Dispose Releases all resources used by this Pen object.

See Also

Pen Class | Kixforms Namespace


Pen Constructor

Initializes a new instance of the Pen class.

[Visual Basic]
Overloads Public Sub New( _
ByVal color As Color, _
Optional ByVal width As Single = 1 _
)
[C#]
public Pen(
Color color,
float width
);

Parameters

color
A Color structure that indicates the color of this Pen object.
width
The width of the new Pen object. The default is 1.

See Also

Pen Class | Kixforms Namespace


Pen Methods

The methods of the Pen class are listed below. For a complete list of Pen class members, see the Pen Members topic.

Public Instance Methods

Dispose Releases all resources used by this Pen object.

See Also

Pen Class | Kixforms Namespace


Pen.Dispose Method

Releases all resources used by this Pen object.

[Visual Basic]
Public Sub Dispose()
[C#]
public void Dispose();

See Also

Pen Class | Kixforms Namespace


PictureBox Class

Represents a Windows picture box control for displaying an image.

For a list of all members of this type, see PictureBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.PictureBox

[Visual Basic]
Public Class PictureBox
Inherits Control
[C#]
public class PictureBox : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

PictureBox Members | Kixforms Namespace


PictureBox Members

PictureBox overview

Public Instance Constructors

PictureBox Constructor Initializes a new instance of the PictureBox class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that the PictureBox displays.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizeMode | Indicates how the image is displayed.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

PictureBox Class | Kixforms Namespace


PictureBox Constructor

Initializes a new instance of the PictureBox class.

[Visual Basic]
Public Sub New()
[C#]
public PictureBox();

See Also

PictureBox Class | Kixforms Namespace


PictureBox Properties

The properties of the PictureBox class are listed below. For a complete list of PictureBox class members, see the PictureBox Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image | Gets or sets the image that the PictureBox displays.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizeMode | Indicates how the image is displayed.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

PictureBox Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

PictureBox.BorderStyle Property

Indicates the border style for the control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

PictureBox Class | Kixforms Namespace


Image Property

KiXforms.NET Class Library

PictureBox.Image Property

Gets or sets the image that the PictureBox displays.

[Visual Basic]
Public Property Image As Image
[C#]
public Image Image {get; set;}

See Also

PictureBox Class | Kixforms Namespace


SizeMode Property

KiXforms.NET Class Library

PictureBox.SizeMode Property

Indicates how the image is displayed.

[Visual Basic]
Public Property SizeMode As PictureBoxSizeMode
[C#]
public PictureBoxSizeMode SizeMode {get; set;}

See Also

PictureBox Class | Kixforms Namespace


PictureBoxSizeMode Enumeration

[Visual Basic]
Public Enum PictureBoxSizeMode
[C#]
public enum PictureBoxSizeMode

Members

Member Name | Description
AutoSize |
CenterImage |
Normal |
StretchImage |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Point Class

Represents an ordered pair of integer x- and y-coordinates that defines a point in a two-dimensional plane.

For a list of all members of this type, see Point Members.

System.Object
Kixforms.Point

[Visual Basic]
Public Class Point
[C#]
public class Point

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Point Members | Kixforms Namespace


Point Members

Point overview

Public Instance Constructors

Point Constructor Initializes a new instance of the Point class.

Public Instance Properties

X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.

See Also

Point Class | Kixforms Namespace


Point Constructor

Initializes a new instance of the Point class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal x As Integer = 0, _
Optional ByVal y As Integer = 0 _
)
[C#]
public Point(
int x,
int y
);

Parameters

x
The horizontal position of the point.
y
The vertical position of the point.

See Also

Point Class | Kixforms Namespace


Point Properties

The properties of the Point class are listed below. For a complete list of Point class members, see the Point Members topic.

Public Instance Properties

X | Gets or sets the x-coordinate of this Point.
Y | Gets or sets the y-coordinate of this Point.

See Also

Point Class | Kixforms Namespace


X Property

KiXforms.NET Class Library

Point.X Property

Gets or sets the x-coordinate of this Point.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}

See Also

Point Class | Kixforms Namespace


Y Property

KiXforms.NET Class Library

Point.Y Property

Gets or sets the y-coordinate of this Point.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}

See Also

Point Class | Kixforms Namespace


Process Class

Provides access to local and remote processes and enables you to start and stop local system processes.

For a list of all members of this type, see Process Members.

System.Object
Kixforms.Process

[Visual Basic]
Public Class Process
[C#]
public class Process

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Process Members | Kixforms Namespace


Process Members

Process overview

Public Instance Properties

HasExited | Gets a value indicating whether the associated process has been terminated. the process.
StandardOutput | Gets a StreamReader through which the application can read output from the process.
StartInfo | Gets or sets the properties to pass to the Start method of the Process.

Public Instance Methods

Start Starts a process resource and associates it with a Process component.

See Also

Process Class | Kixforms Namespace


Process Properties

The properties of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public Instance Properties

HasExited | Gets a value indicating whether the associated process has been terminated. the process.
StandardOutput | Gets a StreamReader through which the application can read output from the process.
StartInfo | Gets or sets the properties to pass to the Start method of the Process.

See Also

Process Class | Kixforms Namespace


HasExited Property

KiXforms.NET Class Library

Process.HasExited Property

Gets a value indicating whether the associated process has been terminated. the process.

[Visual Basic]
Public ReadOnly Property HasExited As Boolean
[C#]
public bool HasExited {get;}

Property Value

True if the operating system process referenced by the Process component has terminated; otherwise, false.

See Also

Process Class | Kixforms Namespace


StandardOutput Property

KiXforms.NET Class Library

Process.StandardOutput Property

Gets a StreamReader through which the application can read output from the process.

[Visual Basic]
Public ReadOnly Property StandardOutput As StreamReader
[C#]
public StreamReader StandardOutput {get;}

See Also

Process Class | Kixforms Namespace


StartInfo Property

KiXforms.NET Class Library

Process.StartInfo Property

Gets or sets the properties to pass to the Start method of the Process.

[Visual Basic]
Public Property StartInfo As ProcessStartInfo
[C#]
public ProcessStartInfo StartInfo {get; set;}

See Also

Process Class | Kixforms Namespace


Process Methods

The methods of the Process class are listed below. For a complete list of Process class members, see the Process Members topic.

Public Instance Methods

Start Starts a process resource and associates it with a Process component.

See Also

Process Class | Kixforms Namespace


Process.Start Method

Starts a process resource and associates it with a Process component.

[Visual Basic]
Public Function Start() As Process
[C#]
public Process Start();

Return Value

A new Process component that is associated with the process, or a reference to this process if no process resource is started (for example, if an existing process is reused).

See Also

Process Class | Kixforms Namespace


ProcessStartInfo Class

Specifies a set of values used when starting a process.

For a list of all members of this type, see ProcessStartInfo Members.

System.Object
Kixforms.ProcessStartInfo

[Visual Basic]
Public Class ProcessStartInfo
[C#]
public class ProcessStartInfo

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ProcessStartInfo Members | Kixforms Namespace


ProcessStartInfo Members

ProcessStartInfo overview

Public Instance Constructors

ProcessStartInfo Constructor Initializes a new instance of the ProcessStartInfo class.

Public Instance Properties

Arguments | Gets or sets the set of command line arguments to use when starting the application.
CreateNoWindow | Gets or sets a value indicating whether to start the process in a new window.
FileName | Gets or sets the application or document to start.
RedirectStandardOutput | Gets or sets a value indicating whether the process output is written to the Process instance's StandardOutput member, enabling you to write to a destination other than the standard output stream (usually the monitor screen). Used to write data to a file, for example.
UseShellExecute | Gets or sets a value indicating whether to use the operating system shell to start the process.
WindowStyle | Specified how a new window should appear when the system starts a process.

See Also

ProcessStartInfo Class | Kixforms Namespace


ProcessStartInfo Constructor

Initializes a new instance of the ProcessStartInfo class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal filename As String = "Nothing", _
Optional ByVal arguments As String = "Nothing" _
)
[C#]
public ProcessStartInfo(
string filename,
string arguments
);

Parameters

filename
An application with which to start a process.
arguments
Command line arguments to pass to the application when the process starts.

See Also

ProcessStartInfo Class | Kixforms Namespace


ProcessStartInfo Properties

The properties of the ProcessStartInfo class are listed below. For a complete list of ProcessStartInfo class members, see the ProcessStartInfo Members topic.

Public Instance Properties

Arguments | Gets or sets the set of command line arguments to use when starting the application.
CreateNoWindow | Gets or sets a value indicating whether to start the process in a new window.
FileName | Gets or sets the application or document to start.
RedirectStandardOutput | Gets or sets a value indicating whether the process output is written to the Process instance's StandardOutput member, enabling you to write to a destination other than the standard output stream (usually the monitor screen). Used to write data to a file, for example.
UseShellExecute | Gets or sets a value indicating whether to use the operating system shell to start the process.
WindowStyle | Specified how a new window should appear when the system starts a process.

See Also

ProcessStartInfo Class | Kixforms Namespace


Arguments Property

KiXforms.NET Class Library

ProcessStartInfo.Arguments Property

Gets or sets the set of command line arguments to use when starting the application.

[Visual Basic]
Public Property Arguments As String
[C#]
public string Arguments {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


CreateNoWindow Property

KiXforms.NET Class Library

ProcessStartInfo.CreateNoWindow Property

Gets or sets a value indicating whether to start the process in a new window.

[Visual Basic]
Public Property CreateNoWindow As Boolean
[C#]
public bool CreateNoWindow {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


FileName Property

KiXforms.NET Class Library

ProcessStartInfo.FileName Property

Gets or sets the application or document to start.

[Visual Basic]
Public Property FileName As String
[C#]
public string FileName {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


RedirectStandardOutput Property

KiXforms.NET Class Library

ProcessStartInfo.RedirectStandardOutput Property

Gets or sets a value indicating whether the process output is written to the Process instance's StandardOutput member, enabling you to write to a destination other than the standard output stream (usually the monitor screen). Used to write data to a file, for example.

[Visual Basic]
Public Property RedirectStandardOutput As Boolean
[C#]
public bool RedirectStandardOutput {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


UseShellExecute Property

KiXforms.NET Class Library

ProcessStartInfo.UseShellExecute Property

Gets or sets a value indicating whether to use the operating system shell to start the process.

[Visual Basic]
Public Property UseShellExecute As Boolean
[C#]
public bool UseShellExecute {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


WindowStyle Property

KiXforms.NET Class Library

ProcessStartInfo.WindowStyle Property

Specified how a new window should appear when the system starts a process.

[Visual Basic]
Public Property WindowStyle As ProcessWindowStyle
[C#]
public ProcessWindowStyle WindowStyle {get; set;}

See Also

ProcessStartInfo Class | Kixforms Namespace


ProcessWindowStyle Enumeration

[Visual Basic]
Public Enum ProcessWindowStyle
[C#]
public enum ProcessWindowStyle

Members

Member Name | Description
Hidden |
Maximized |
Minimized |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ProgressBar Class

Represents a Windows progress bar control.

For a list of all members of this type, see ProgressBar Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ProgressBar

[Visual Basic]
Public Class ProgressBar
Inherits Control
[C#]
public class ProgressBar : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ProgressBar Members | Kixforms Namespace


ProgressBar Members

ProgressBar overview

Public Instance Constructors

ProgressBar Constructor Initializes a new instance of the ProgressBar class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the maximum value of the range of the control.
Minimum | Gets or sets the minimum value of the range of the control.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets the current position of the progress bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ProgressBar Class | Kixforms Namespace


ProgressBar Constructor

Initializes a new instance of the ProgressBar class.

[Visual Basic]
Public Sub New()
[C#]
public ProgressBar();

See Also

ProgressBar Class | Kixforms Namespace


ProgressBar Properties

The properties of the ProgressBar class are listed below. For a complete list of ProgressBar class members, see the ProgressBar Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the maximum value of the range of the control.
Minimum | Gets or sets the minimum value of the range of the control.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets the current position of the progress bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ProgressBar Class | Kixforms Namespace


Maximum Property

KiXforms.NET Class Library

ProgressBar.Maximum Property

Gets or sets the maximum value of the range of the control.

[Visual Basic]
Public Property Maximum As Integer
[C#]
public int Maximum {get; set;}

Property Value

The maximum value of the range. The default is 100.

See Also

ProgressBar Class | Kixforms Namespace


Minimum Property

KiXforms.NET Class Library

ProgressBar.Minimum Property

Gets or sets the minimum value of the range of the control.

[Visual Basic]
Public Property Minimum As Integer
[C#]
public int Minimum {get; set;}

Property Value

The minimum value of the range. The default is 0.

See Also

ProgressBar Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

ProgressBar.Value Property

Gets or sets the current position of the progress bar.

[Visual Basic]
Public Property Value As Integer
[C#]
public int Value {get; set;}

Property Value

The position within the range of the progress bar. The default is 0.

See Also

ProgressBar Class | Kixforms Namespace


PropertyGrid Class

Provides a user interface for browsing the properties of an object.

For a list of all members of this type, see PropertyGrid Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.PropertyGrid

[Visual Basic]
Public Class PropertyGrid
Inherits ContainerControl
[C#]
public class PropertyGrid : ContainerControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

PropertyGrid Members | Kixforms Namespace


PropertyGrid Members

PropertyGrid overview

Public Instance Constructors

PropertyGrid Constructor Initializes a new instance of the PropertyGrid class.

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties.
PropertyValueChanged | Gets or sets the code to execute when when a property value changes.
PropertyValueChangedEventArgs | Provides data for the PropertyValueChanged event.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedObject | Gets or sets the object for which the grid displays properties.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

PropertyGrid Class | Kixforms Namespace


PropertyGrid Constructor

Initializes a new instance of the PropertyGrid class.

[Visual Basic]
Public Sub New()
[C#]
public PropertyGrid();

See Also

PropertyGrid Class | Kixforms Namespace


PropertyGrid Properties

The properties of the PropertyGrid class are listed below. For a complete list of PropertyGrid class members, see the PropertyGrid Members topic.

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
PropertySort | Gets or sets the type of sorting the PropertyGrid uses to display properties.
PropertyValueChanged | Gets or sets the code to execute when when a property value changes.
PropertyValueChangedEventArgs | Provides data for the PropertyValueChanged event.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedObject | Gets or sets the object for which the grid displays properties.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
ToolbarVisible | Gets or sets a value indicating whether the toolbar is visible.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

PropertyGrid Class | Kixforms Namespace


PropertySort Property

KiXforms.NET Class Library

PropertyGrid.PropertySort Property

Gets or sets the type of sorting the PropertyGrid uses to display properties.

[Visual Basic]
Public Property PropertySort As PropertySort
[C#]
public PropertySort PropertySort {get; set;}

See Also

PropertyGrid Class | Kixforms Namespace


PropertyValueChanged Property

KiXforms.NET Class Library

PropertyGrid.PropertyValueChanged Property

Gets or sets the code to execute when when a property value changes.

[Visual Basic]
Public Property PropertyValueChanged As String
[C#]
public string PropertyValueChanged {get; set;}

See Also

PropertyGrid Class | Kixforms Namespace


PropertyValueChangedEventArgs Property

KiXforms.NET Class Library

PropertyGrid.PropertyValueChangedEventArgs Property

Provides data for the PropertyValueChanged event.

[Visual Basic]
Public ReadOnly Property PropertyValueChangedEventArgs As PropertyValueChangedEventArgs
[C#]
public PropertyValueChangedEventArgs PropertyValueChangedEventArgs {get;}

See Also

PropertyGrid Class | Kixforms Namespace


SelectedObject Property

KiXforms.NET Class Library

PropertyGrid.SelectedObject Property

Gets or sets the object for which the grid displays properties.

[Visual Basic]
Public Property SelectedObject As Object
[C#]
public object SelectedObject {get; set;}

See Also

PropertyGrid Class | Kixforms Namespace


ToolbarVisible Property

KiXforms.NET Class Library

PropertyGrid.ToolbarVisible Property

Gets or sets a value indicating whether the toolbar is visible.

[Visual Basic]
Public Property ToolbarVisible As Boolean
[C#]
public bool ToolbarVisible {get; set;}

Property Value

True if the toolbar is visible; otherwise, false. The default is true.

See Also

PropertyGrid Class | Kixforms Namespace


PropertySort Enumeration

[Visual Basic]
Public Enum PropertySort
[C#]
public enum PropertySort

Members

Member Name | Description
Alphabetical |
Categorized |
CategorizedAlphabetical |
NoSort |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


PropertyValueChangedEventArgs Class

Provides data for the PropertyValueChanged event of a PropertyGrid.

For a list of all members of this type, see PropertyValueChangedEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.PropertyValueChangedEventArgs

[Visual Basic]
Public Class PropertyValueChangedEventArgs
Inherits EventArgs
[C#]
public class PropertyValueChangedEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

PropertyValueChangedEventArgs Members | Kixforms Namespace


PropertyValueChangedEventArgs Members

PropertyValueChangedEventArgs overview

Public Instance Properties

OldValue The value of the grid item before it was changed.

See Also

PropertyValueChangedEventArgs Class | Kixforms Namespace


PropertyValueChangedEventArgs Properties

The properties of the PropertyValueChangedEventArgs class are listed below. For a complete list of PropertyValueChangedEventArgs class members, see the PropertyValueChangedEventArgs Members topic.

Public Instance Properties

OldValue The value of the grid item before it was changed.

See Also

PropertyValueChangedEventArgs Class | Kixforms Namespace


OldValue Property

KiXforms.NET Class Library

PropertyValueChangedEventArgs.OldValue Property

The value of the grid item before it was changed.

[Visual Basic]
Public Property OldValue As Object
[C#]
public object OldValue {get; set;}

Property Value

A object representing the old value of the property.

See Also

PropertyValueChangedEventArgs Class | Kixforms Namespace


RadioButton Class

Represents a Windows radio button.

For a list of all members of this type, see RadioButton Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ButtonBase
Kixforms.RadioButton

[Visual Basic]
Public Class RadioButton
Inherits ButtonBase
[C#]
public class RadioButton : ButtonBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

RadioButton Members | Kixforms Namespace


RadioButton Members

RadioButton overview

Public Instance Constructors

RadioButton Constructor Initializes a new instance of the RadioButton class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or set the value that determines the appearance of the radio button control.
AutoCheck | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckAlign | Gets or sets the location of the check box portion of the radio button control.
CheckChanged | Gets or sets the code to execute when the value of the Checked property changes.
Checked | Gets or sets a value indicating whether the control is checked.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

RadioButton Class | Kixforms Namespace


RadioButton Constructor

Initializes a new instance of the RadioButton class.

[Visual Basic]
Public Sub New()
[C#]
public RadioButton();

See Also

RadioButton Class | Kixforms Namespace


RadioButton Properties

The properties of the RadioButton class are listed below. For a complete list of RadioButton class members, see the RadioButton Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or set the value that determines the appearance of the radio button control.
AutoCheck | Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckAlign | Gets or sets the location of the check box portion of the radio button control.
CheckChanged | Gets or sets the code to execute when the value of the Checked property changes.
Checked | Gets or sets a value indicating whether the control is checked.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
FlatStyle (inherited from ButtonBase) | Gets or sets the flat style appearance of the button control.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
Image (inherited from ButtonBase) | Gets or sets the image that is displayed on a button control.
ImageAlign (inherited from ButtonBase) | Gets or sets the alignment of the image on the button control.
ImageIndex (inherited from ButtonBase) | Gets or sets the image list index value of the image displayed on the button control.
ImageList (inherited from ButtonBase) | Gets or sets the ImageList that contains the Image displayed on a button control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign (inherited from ButtonBase) | Gets or sets the alignment of the text on the button control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

RadioButton Class | Kixforms Namespace


Appearance Property

KiXforms.NET Class Library

RadioButton.Appearance Property

Gets or set the value that determines the appearance of the radio button control.

[Visual Basic]
Public Property Appearance As Appearance
[C#]
public Appearance Appearance {get; set;}

See Also

RadioButton Class | Kixforms Namespace


AutoCheck Property

KiXforms.NET Class Library

RadioButton.AutoCheck Property

Gets or sets a value indicating whether the Checked value and the appearance of the control automatically change when the control is clicked.

[Visual Basic]
Public Property AutoCheck As Boolean
[C#]
public bool AutoCheck {get; set;}

See Also

RadioButton Class | Kixforms Namespace


CheckAlign Property

KiXforms.NET Class Library

RadioButton.CheckAlign Property

Gets or sets the location of the check box portion of the radio button control.

[Visual Basic]
Public Property CheckAlign As ContentAlignment
[C#]
public ContentAlignment CheckAlign {get; set;}

See Also

RadioButton Class | Kixforms Namespace


CheckChanged Property

KiXforms.NET Class Library

RadioButton.CheckChanged Property

Gets or sets the code to execute when the value of the Checked property changes.

[Visual Basic]
Public Property CheckChanged As String
[C#]
public string CheckChanged {get; set;}

See Also

RadioButton Class | Kixforms Namespace


Checked Property

KiXforms.NET Class Library

RadioButton.Checked Property

Gets or sets a value indicating whether the control is checked.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

RadioButton Class | Kixforms Namespace


Rectangle Class

Stores the location and size of a rectangular region.

For a list of all members of this type, see Rectangle Members.

System.Object
Kixforms.Rectangle

[Visual Basic]
Public Class Rectangle
[C#]
public class Rectangle

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Rectangle Members | Kixforms Namespace


Rectangle Members

Rectangle overview

Public Instance Constructors

Rectangle Constructor Initializes a new instance of the Rectangle class.

Public Instance Properties

Bottom | Gets the y-coordinate of the bottom edge of this Rectangle structure.
Height | Gets or sets the height of this Rectangle structure.
Left | Gets the x-coordinate of the left edge of this Rectangle structure.
Location | Gets or sets the coordinates of the upper-left corner of this Rectangle structure.
Right | Gets the x-coordinate of the right edge of this Rectangle structure.
Size | Gets or sets the size of this Rectangle.
Top | Gets the y-coordinate of the top edge of this Rectangle structure.
Width | Gets or sets the width of this Rectangle structure.
X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

Public Instance Methods

FromSize Creates a Rectangle structure from the specified Size.

See Also

Rectangle Class | Kixforms Namespace


Rectangle Constructor

Initializes a new instance of the Rectangle class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal x As Integer = 0, _
Optional ByVal y As Integer = 0, _
Optional ByVal width As Integer = 0, _
Optional ByVal height As Integer = 0 _
)
[C#]
public Rectangle(
int x,
int y,
int width,
int height
);

See Also

Rectangle Class | Kixforms Namespace


Rectangle Properties

The properties of the Rectangle class are listed below. For a complete list of Rectangle class members, see the Rectangle Members topic.

Public Instance Properties

Bottom | Gets the y-coordinate of the bottom edge of this Rectangle structure.
Height | Gets or sets the height of this Rectangle structure.
Left | Gets the x-coordinate of the left edge of this Rectangle structure.
Location | Gets or sets the coordinates of the upper-left corner of this Rectangle structure.
Right | Gets the x-coordinate of the right edge of this Rectangle structure.
Size | Gets or sets the size of this Rectangle.
Top | Gets the y-coordinate of the top edge of this Rectangle structure.
Width | Gets or sets the width of this Rectangle structure.
X | Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

See Also

Rectangle Class | Kixforms Namespace


Bottom Property

KiXforms.NET Class Library

Rectangle.Bottom Property

Gets the y-coordinate of the bottom edge of this Rectangle structure.

[Visual Basic]
Public ReadOnly Property Bottom As Integer
[C#]
public int Bottom {get;}

See Also

Rectangle Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Rectangle.Height Property

Gets or sets the height of this Rectangle structure.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

See Also

Rectangle Class | Kixforms Namespace


Left Property

KiXforms.NET Class Library

Rectangle.Left Property

Gets the x-coordinate of the left edge of this Rectangle structure.

[Visual Basic]
Public ReadOnly Property Left As Integer
[C#]
public int Left {get;}

See Also

Rectangle Class | Kixforms Namespace


Location Property

KiXforms.NET Class Library

Rectangle.Location Property

Gets or sets the coordinates of the upper-left corner of this Rectangle structure.

[Visual Basic]
Public Property Location As Point
[C#]
public Point Location {get; set;}

See Also

Rectangle Class | Kixforms Namespace


Right Property

KiXforms.NET Class Library

Rectangle.Right Property

Gets the x-coordinate of the right edge of this Rectangle structure.

[Visual Basic]
Public ReadOnly Property Right As Integer
[C#]
public int Right {get;}

See Also

Rectangle Class | Kixforms Namespace


Size Property

KiXforms.NET Class Library

Rectangle.Size Property

Gets or sets the size of this Rectangle.

[Visual Basic]
Public Property Size As Size
[C#]
public Size Size {get; set;}

See Also

Rectangle Class | Kixforms Namespace


Top Property

KiXforms.NET Class Library

Rectangle.Top Property

Gets the y-coordinate of the top edge of this Rectangle structure.

[Visual Basic]
Public ReadOnly Property Top As Integer
[C#]
public int Top {get;}

See Also

Rectangle Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

Rectangle.Width Property

Gets or sets the width of this Rectangle structure.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

Rectangle Class | Kixforms Namespace


X Property

KiXforms.NET Class Library

Rectangle.X Property

Gets or sets the x-coordinate of the upper-left corner of this Rectangle structure.

[Visual Basic]
Public Property X As Integer
[C#]
public int X {get; set;}

See Also

Rectangle Class | Kixforms Namespace


Y Property

KiXforms.NET Class Library

Rectangle.Y Property

Gets or sets the y-coordinate of the upper-left corner of this Rectangle structure.

[Visual Basic]
Public Property Y As Integer
[C#]
public int Y {get; set;}

See Also

Rectangle Class | Kixforms Namespace


Rectangle Methods

The methods of the Rectangle class are listed below. For a complete list of Rectangle class members, see the Rectangle Members topic.

Public Instance Methods

FromSize Creates a Rectangle structure from the specified Size.

See Also

Rectangle Class | Kixforms Namespace


Rectangle.FromSize Method

Creates a Rectangle structure from the specified Size.

[Visual Basic]
Public Function FromSize( _
ByVal Size As Size _
) As Rectangle
[C#]
public Rectangle FromSize(
Size Size
);

See Also

Rectangle Class | Kixforms Namespace


RichTextBox Class

Represents a Windows rich text box control.

For a list of all members of this type, see RichTextBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.TextBoxBase
Kixforms.RichTextBox

[Visual Basic]
Public Class RichTextBox
Inherits TextBoxBase
[C#]
public class RichTextBox : TextBoxBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

RichTextBox Members | Kixforms Namespace


RichTextBox Members

RichTextBox overview

Public Instance Constructors

RichTextBox Constructor Initializes a new instance of the RichTextBox class.

Public Instance Properties

AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkClicked | Gets or sets the code to execute when the user clicks on a link within the text of the control.
LinkClickedEventArgs | Gets data for the LinkClicked event.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightMargin | Gets or sets the size of a single line of text within the RichTextBox control.
Rtf | Gets or sets the text of the RichTextBox control, including all Rich Text Format (RTF) codes.
ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionChanged | Occurs when the selection of text within the control has changed.
SelectionColor | Gets or sets the text color of the current text selection or insertion point.
SelectionFont | Gets or sets the font of the current text selection or insertion point.
SelectionIndent | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point.
SelectionLength (inherited from TextBoxBase) | Gets or sets the number of characters selected in the text box.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
ZoomFactor | Gets or sets the current zoom level of the RichTextBox.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CanPaste | Determines whether you can paste information from the Clipboard in the specified data format.
Center (inherited from Control) | Centers the control inside its container.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.
Find | Searches the text in a RichTextBox control for a string.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetCharIndexFromPosition | Gets the index of the character nearest to the specified location.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLineFromCharIndex | Gets the line number from the specified character position within the text of the RichTextBox control.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
LoadFile | Loads a specific type of file into the RichTextBox control.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Redo | Reapplies the last operation that was undone in the control.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
SaveFile | Saves the contents of the RichTextBox to a specific type of file.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from Control) | Activates a control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox Constructor

Initializes a new instance of the RichTextBox class.

[Visual Basic]
Public Sub New()
[C#]
public RichTextBox();

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox Properties

The properties of the RichTextBox class are listed below. For a complete list of RichTextBox class members, see the RichTextBox Members topic.

Public Instance Properties

AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
AutoWordSelection | Gets or sets a value indicating whether automatic word selection is enabled.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
BulletIndent | Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanRedo | Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DetectUrls | Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
LinkClicked | Gets or sets the code to execute when the user clicks on a link within the text of the control.
LinkClickedEventArgs | Gets data for the LinkClicked event.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
RightMargin | Gets or sets the size of a single line of text within the RichTextBox control.
Rtf | Gets or sets the text of the RichTextBox control, including all Rich Text Format (RTF) codes.
ScrollBars | Gets or sets the type of scroll bars to display in the RichTextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionChanged | Occurs when the selection of text within the control has changed.
SelectionColor | Gets or sets the text color of the current text selection or insertion point.
SelectionFont | Gets or sets the font of the current text selection or insertion point.
SelectionIndent | Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point.
SelectionLength (inherited from TextBoxBase) | Gets or sets the number of characters selected in the text box.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.
ZoomFactor | Gets or sets the current zoom level of the RichTextBox.

See Also

RichTextBox Class | Kixforms Namespace


AutoWordSelection Property

KiXforms.NET Class Library

RichTextBox.AutoWordSelection Property

Gets or sets a value indicating whether automatic word selection is enabled.

[Visual Basic]
Public Property AutoWordSelection As Boolean
[C#]
public bool AutoWordSelection {get; set;}

Property Value

True if automatic word selection is enabled; otherwise, false. The default is false.

See Also

RichTextBox Class | Kixforms Namespace


BulletIndent Property

KiXforms.NET Class Library

RichTextBox.BulletIndent Property

Gets or sets the indentation used in the RichTextBox control when the bullet style is applied to the text.

[Visual Basic]
Public Property BulletIndent As Integer
[C#]
public int BulletIndent {get; set;}

Property Value

The number of pixels inserted as the indentation after a bullet. The default is zero.

See Also

RichTextBox Class | Kixforms Namespace


CanRedo Property

KiXforms.NET Class Library

RichTextBox.CanRedo Property

Gets a value indicating whether there are actions that have occurred within the RichTextBox that can be reapplied.

[Visual Basic]
Public ReadOnly Property CanRedo As Boolean
[C#]
public bool CanRedo {get;}

Property Value

True if there are operations that have been undone that can be reapplied to the content of the control; otherwise, false.

See Also

RichTextBox Class | Kixforms Namespace


DetectUrls Property

KiXforms.NET Class Library

RichTextBox.DetectUrls Property

Gets or sets a value indicating whether or not the RichTextBox will automatically format a Uniform Resource Locator (URL) when it is typed into the control.

[Visual Basic]
Public Property DetectUrls As Boolean
[C#]
public bool DetectUrls {get; set;}

Property Value

True if the RichTextBox will automatically format URLs that are typed into the control as a link; otherwise, false. The default is true.

Remarks

If this property is set to true, any text entered into the control that is determined by the RichTextBox to be a URL is automatically formatted as a link. You can create an event handler for the LinkClicked event to handle all links clicked in the control. The LinkClickedEventArgs that is provided to the event handler for the LinkClicked event provides data that enables you to determine which link was clicked in the control in order to process the link.

See Also

RichTextBox Class | Kixforms Namespace


LinkClicked Property

KiXforms.NET Class Library

RichTextBox.LinkClicked Property

Gets or sets the code to execute when the user clicks on a link within the text of the control.

[Visual Basic]
Public Property LinkClicked As String
[C#]
public string LinkClicked {get; set;}

Remarks

Use the LinkClickedEventArgs property to return data related to this event

See Also

RichTextBox Class | Kixforms Namespace


LinkClickedEventArgs Property

KiXforms.NET Class Library

RichTextBox.LinkClickedEventArgs Property

Gets data for the LinkClicked event.

[Visual Basic]
Public Property LinkClickedEventArgs As LinkClickedEventArgs
[C#]
public LinkClickedEventArgs LinkClickedEventArgs {get; set;}

See Also

RichTextBox Class | Kixforms Namespace


RightMargin Property

KiXforms.NET Class Library

RichTextBox.RightMargin Property

Gets or sets the size of a single line of text within the RichTextBox control.

[Visual Basic]
Public Property RightMargin As Integer
[C#]
public int RightMargin {get; set;}

See Also

RichTextBox Class | Kixforms Namespace


Rtf Property

KiXforms.NET Class Library

RichTextBox.Rtf Property

Gets or sets the text of the RichTextBox control, including all Rich Text Format (RTF) codes.

[Visual Basic]
Public Property Rtf As String
[C#]
public string Rtf {get; set;}

See Also

RichTextBox Class | Kixforms Namespace


ScrollBars Property

KiXforms.NET Class Library

RichTextBox.ScrollBars Property

Gets or sets the type of scroll bars to display in the RichTextBox control.

[Visual Basic]
Public Property ScrollBars As ScrollBars
[C#]
public ScrollBars ScrollBars {get; set;}

See Also

RichTextBox Class | Kixforms Namespace


SelectionChanged Property

KiXforms.NET Class Library

RichTextBox.SelectionChanged Property

Occurs when the selection of text within the control has changed.

[Visual Basic]
Public Property SelectionChanged As String
[C#]
public string SelectionChanged {get; set;}

Property Value

The code to execute when the selection of text within the control has changed.

See Also

RichTextBox Class | Kixforms Namespace


SelectionColor Property

KiXforms.NET Class Library

RichTextBox.SelectionColor Property

Gets or sets the text color of the current text selection or insertion point.

[Visual Basic]
Public Property SelectionColor As Color
[C#]
public Color SelectionColor {get; set;}

Property Value

A Color that represents the color to apply to the current text selection or to text entered after the insertion point.

See Also

RichTextBox Class | Kixforms Namespace


SelectionFont Property

KiXforms.NET Class Library

RichTextBox.SelectionFont Property

Gets or sets the font of the current text selection or insertion point.

[Visual Basic]
Public Property SelectionFont As Font
[C#]
public Font SelectionFont {get; set;}

Property Value

A Font that represents the font to apply to the current text selection or to text entered after the insertion point.

See Also

RichTextBox Class | Kixforms Namespace


SelectionIndent Property

KiXforms.NET Class Library

RichTextBox.SelectionIndent Property

Gets or sets the distance in pixels between the left edge of the RichTextBox and the left edge of the current text selection or text added after the insertion point.

[Visual Basic]
Public Property SelectionIndent As Integer
[C#]
public int SelectionIndent {get; set;}

Property Value

The current distance, in pixels, of the indentation applied to the left of the current text selection or the insertion point.

See Also

RichTextBox Class | Kixforms Namespace


ZoomFactor Property

KiXforms.NET Class Library

RichTextBox.ZoomFactor Property

Gets or sets the current zoom level of the RichTextBox.

[Visual Basic]
Public Property ZoomFactor As Single
[C#]
public float ZoomFactor {get; set;}

Property Value

The factor by which the contents of the control is zoomed.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox Methods

The methods of the RichTextBox class are listed below. For a complete list of RichTextBox class members, see the RichTextBox Members topic.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
CanPaste | Determines whether you can paste information from the Clipboard in the specified data format.
Center (inherited from Control) | Centers the control inside its container.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.
Find | Searches the text in a RichTextBox control for a string.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetCharIndexFromPosition | Gets the index of the character nearest to the specified location.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetLineFromCharIndex | Gets the line number from the specified character position within the text of the RichTextBox control.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
LoadFile | Loads a specific type of file into the RichTextBox control.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Redo | Reapplies the last operation that was undone in the control.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
SaveFile | Saves the contents of the RichTextBox to a specific type of file.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from Control) | Activates a control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

[Visual Basic]
Overrides Public Sub BeginUpdate()
[C#]
public override void BeginUpdate();

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.CanPaste Method

Determines whether you can paste information from the Clipboard in the specified data format.

[Visual Basic]
Public Function CanPaste() As Boolean
[C#]
public bool CanPaste();

Return Value

True if you can paste data from the Clipboard in the specified data format; otherwise, false.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.EndUpdate Method

Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.

[Visual Basic]
Overrides Public Sub EndUpdate()
[C#]
public override void EndUpdate();

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.Find Method

Searches the text in a RichTextBox control for a string.

[Visual Basic]
Public Function Find( _
ByVal str As String, _
Optional ByVal start As Integer = 0, _
Optional ByVal options As RichTextBoxFinds = 0 _
) As Integer
[C#]
public int Find(
string str,
int start,
RichTextBoxFinds options
);

Parameters

str
The text to locate in the control.
start
The location within the control's text at which to begin searching.
options

Return Value

The location within the control where the search text was found or a negative one (-1) if the search string is not found or an empty search string is specified in the str parameter.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.GetCharIndexFromPosition Method

Gets the index of the character nearest to the specified location.

[Visual Basic]
Public Function GetCharIndexFromPosition( _
ByVal pt As Point _
) As Integer
[C#]
public int GetCharIndexFromPosition(
Point pt
);

Parameters

pt
The location to search.

Return Value

The zero-based character index at the specified location.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.GetLineFromCharIndex Method

Gets the line number from the specified character position within the text of the RichTextBox control.

[Visual Basic]
Public Function GetLineFromCharIndex( _
ByVal index As Integer _
) As Integer
[C#]
public int GetLineFromCharIndex(
int index
);

Parameters

index
The character index position to search.

Return Value

The zero-based line number where the character index is located in.

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.LoadFile Method

Loads a specific type of file into the RichTextBox control.

[Visual Basic]
Public Sub LoadFile( _
ByVal path As String, _
Optional ByVal fileType As RichTextBoxStreamType = 0 _
)
[C#]
public void LoadFile(
string path,
RichTextBoxStreamType fileType
);

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.Redo Method

Reapplies the last operation that was undone in the control.

[Visual Basic]
Public Sub Redo()
[C#]
public void Redo();

See Also

RichTextBox Class | Kixforms Namespace


RichTextBox.SaveFile Method

Saves the contents of the RichTextBox to a specific type of file.

[Visual Basic]
Public Sub SaveFile( _
ByVal path As String, _
Optional ByVal fileType As RichTextBoxStreamType = 0 _
)
[C#]
public void SaveFile(
string path,
RichTextBoxStreamType fileType
);

See Also

RichTextBox Class | Kixforms Namespace


RichTextBoxFinds Enumeration

[Visual Basic]
Public Enum RichTextBoxFinds
[C#]
public enum RichTextBoxFinds

Members

Member Name | Description
MatchCase |
NoHighlight |
None |
Reverse |
WholeWord |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


RichTextBoxStreamType Enumeration

[Visual Basic]
Public Enum RichTextBoxStreamType
[C#]
public enum RichTextBoxStreamType

Members

Member Name | Description
PlainText |
RichNoOleObjs |
RichText |
TextTextOleObjs |
UnicodePlainText |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


SaveFileDialog Class

Represents a common dialog box that allows the user to specify options for saving a file.

For a list of all members of this type, see SaveFileDialog Members.

System.Object
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FileDialog
Kixforms.SaveFileDialog

[Visual Basic]
Public Class SaveFileDialog
Inherits FileDialog
[C#]
public class SaveFileDialog : FileDialog

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

SaveFileDialog Members | Kixforms Namespace


SaveFileDialog Members

SaveFileDialog overview

Public Instance Constructors

SaveFileDialog Constructor Initializes a new instance of the SaveFileDialog class.

Public Instance Properties

AddExtension (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
CreatePrompt | Gets or sets a value indicating whether the dialog box prompts the user for permission to create a file if the user specifies a file that does not exist.
DefaultExt (inherited from FileDialog) | Gets or sets the default file name extension.
DereferenceLinks (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName (inherited from FileDialog) | Gets or sets a string containing the file name selected in the file dialog box.
Filter (inherited from FileDialog) | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex (inherited from FileDialog) | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory (inherited from FileDialog) | Gets or sets the initial directory displayed by the file dialog box.
OverwritePrompt | Gets or sets a value indicating whether the Save As dialog box displays a warning if the user specifies a file name that already exists.
RestoreDirectory (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Title (inherited from FileDialog) | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets all dialog box options to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

SaveFileDialog Class | Kixforms Namespace


SaveFileDialog Constructor

Initializes a new instance of the SaveFileDialog class.

[Visual Basic]
Public Sub New()
[C#]
public SaveFileDialog();

See Also

SaveFileDialog Class | Kixforms Namespace


SaveFileDialog Properties

The properties of the SaveFileDialog class are listed below. For a complete list of SaveFileDialog class members, see the SaveFileDialog Members topic.

Public Instance Properties

AddExtension (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box automatically adds an extension to a file name if the user omits the extension.
CheckFileExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a file name that does not exist.
CheckPathExists (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box displays a warning if the user specifies a path that does not exist.
CreatePrompt | Gets or sets a value indicating whether the dialog box prompts the user for permission to create a file if the user specifies a file that does not exist.
DefaultExt (inherited from FileDialog) | Gets or sets the default file name extension.
DereferenceLinks (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box returns the location of the file referenced by the shortcut or whether it returns the location of the shortcut (.lnk).
FileName (inherited from FileDialog) | Gets or sets a string containing the file name selected in the file dialog box.
Filter (inherited from FileDialog) | Gets or sets the current file name filter string, which determines the choices that appear in the 'Save as file type' or 'Files of type' box in t he dialog box.
FilterIndex (inherited from FileDialog) | Gets or sets the index of the filter currently selected in the file dialog box. The first filter is at index one. The default value is one.
InitialDirectory (inherited from FileDialog) | Gets or sets the initial directory displayed by the file dialog box.
OverwritePrompt | Gets or sets a value indicating whether the Save As dialog box displays a warning if the user specifies a file name that already exists.
RestoreDirectory (inherited from FileDialog) | Gets or sets a value indicating whether the dialog box restores the current directory before closing.
Title (inherited from FileDialog) | Gets or sets the file dialog box title.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

SaveFileDialog Class | Kixforms Namespace


CreatePrompt Property

KiXforms.NET Class Library

SaveFileDialog.CreatePrompt Property

Gets or sets a value indicating whether the dialog box prompts the user for permission to create a file if the user specifies a file that does not exist.

[Visual Basic]
Public Property CreatePrompt As Boolean
[C#]
public bool CreatePrompt {get; set;}

See Also

SaveFileDialog Class | Kixforms Namespace


OverwritePrompt Property

KiXforms.NET Class Library

SaveFileDialog.OverwritePrompt Property

Gets or sets a value indicating whether the Save As dialog box displays a warning if the user specifies a file name that already exists.

[Visual Basic]
Public Property OverwritePrompt As Boolean
[C#]
public bool OverwritePrompt {get; set;}

See Also

SaveFileDialog Class | Kixforms Namespace


SaveFileDialog Methods

The methods of the SaveFileDialog class are listed below. For a complete list of SaveFileDialog class members, see the SaveFileDialog Members topic.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Reset | Resets all dialog box options to their default values.
ShowDialog (inherited from CommonDialog) | Runs a common dialog box.

See Also

SaveFileDialog Class | Kixforms Namespace


SaveFileDialog.Reset Method

Resets all dialog box options to their default values.

[Visual Basic]
Public Function Reset() As Object
[C#]
public object Reset();

See Also

SaveFileDialog Class | Kixforms Namespace


Screen Class

Represents a display device or multiple display devices on a single system.

For a list of all members of this type, see Screen Members.

System.Object
Kixforms.Screen

[Visual Basic]
Public Class Screen
[C#]
public class Screen

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Screen Members | Kixforms Namespace


Screen Members

Screen overview

Public Instance Constructors

Screen Constructor Initializes a new instance of the Screen class.

Public Instance Properties

Bounds | Gets the bounds of the display.
PrimaryScreen | Gets the primary display.
WorkingArea | Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

See Also

Screen Class | Kixforms Namespace


Screen Constructor

Initializes a new instance of the Screen class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public Screen();

See Also

Screen Class | Kixforms Namespace


Screen Properties

The properties of the Screen class are listed below. For a complete list of Screen class members, see the Screen Members topic.

Public Instance Properties

Bounds | Gets the bounds of the display.
PrimaryScreen | Gets the primary display.
WorkingArea | Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

See Also

Screen Class | Kixforms Namespace


Bounds Property

KiXforms.NET Class Library

Screen.Bounds Property

Gets the bounds of the display.

[Visual Basic]
Public ReadOnly Property Bounds As Rectangle
[C#]
public Rectangle Bounds {get;}

See Also

Screen Class | Kixforms Namespace


PrimaryScreen Property

KiXforms.NET Class Library

Screen.PrimaryScreen Property

Gets the primary display.

[Visual Basic]
Public ReadOnly Property PrimaryScreen As Screen
[C#]
public Screen PrimaryScreen {get;}

See Also

Screen Class | Kixforms Namespace


WorkingArea Property

KiXforms.NET Class Library

Screen.WorkingArea Property

Gets the working area of the display. The working area is the desktop area of the display, excluding taskbars, docked windows, and docked tool bars.

[Visual Basic]
Public ReadOnly Property WorkingArea As Rectangle
[C#]
public Rectangle WorkingArea {get;}

See Also

Screen Class | Kixforms Namespace


ScrollableControl Class

Defines a base class for controls that support auto-scrolling behavior.

For a list of all members of this type, see ScrollableControl Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.Panel

[Visual Basic]
Public Class ScrollableControl
Inherits Control
[C#]
public class ScrollableControl : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ScrollableControl Members | Kixforms Namespace


ScrollableControl Members

ScrollableControl overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ScrollableControl Class | Kixforms Namespace


ScrollableControl Properties

The properties of the ScrollableControl class are listed below. For a complete list of ScrollableControl class members, see the ScrollableControl Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ScrollableControl Class | Kixforms Namespace


AutoScroll Property

KiXforms.NET Class Library

ScrollableControl.AutoScroll Property

Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.

[Visual Basic]
Public Property AutoScroll As Boolean
[C#]
public bool AutoScroll {get; set;}

See Also

ScrollableControl Class | Kixforms Namespace


AutoScrollMargin Property

KiXforms.NET Class Library

ScrollableControl.AutoScrollMargin Property

Gets or sets the size of the auto-scroll margin.

[Visual Basic]
Public Property AutoScrollMargin As Size
[C#]
public Size AutoScrollMargin {get; set;}

See Also

ScrollableControl Class | Kixforms Namespace


DockPadding Property

KiXforms.NET Class Library

ScrollableControl.DockPadding Property

Gets the dock padding settings for all edges of the control.

[Visual Basic]
Public ReadOnly Property DockPadding As DockPaddingEdges
[C#]
public DockPaddingEdges DockPadding {get;}

See Also

ScrollableControl Class | Kixforms Namespace


ScrollBar Class

Implements the basic functionality of a scroll bar control.

For a list of all members of this type, see ScrollBar Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollBar
Kixforms.VScrollBar

[Visual Basic]
Public Class ScrollBar
Inherits Control
[C#]
public class ScrollBar : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ScrollBar Members | Kixforms Namespace


ScrollBar Members

ScrollBar overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LargeChange | Gets or sets a value to be added to or subtracted from to the Value property when the scroll box is moved a large distance.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the upper limit of values of the scrollable range.
Minimum | Gets or sets the lower limit of values of the scrollable range.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SmallChange | Gets or sets the value to be added to or subtracted from to the Value property when the scroll box is moved a small distance.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets a numeric value that represents the current position of the scroll box on the scroll bar control.
ValueChanged | Occurs when the Value property has changed, either by a Scroll event or programatically.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ScrollBar Class | Kixforms Namespace


ScrollBar Properties

The properties of the ScrollBar class are listed below. For a complete list of ScrollBar class members, see the ScrollBar Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LargeChange | Gets or sets a value to be added to or subtracted from to the Value property when the scroll box is moved a large distance.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum | Gets or sets the upper limit of values of the scrollable range.
Minimum | Gets or sets the lower limit of values of the scrollable range.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SmallChange | Gets or sets the value to be added to or subtracted from to the Value property when the scroll box is moved a small distance.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | Gets or sets a numeric value that represents the current position of the scroll box on the scroll bar control.
ValueChanged | Occurs when the Value property has changed, either by a Scroll event or programatically.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

ScrollBar Class | Kixforms Namespace


LargeChange Property

KiXforms.NET Class Library

ScrollBar.LargeChange Property

Gets or sets a value to be added to or subtracted from to the Value property when the scroll box is moved a large distance.

[Visual Basic]
Public Property LargeChange As Integer
[C#]
public int LargeChange {get; set;}

Property Value

A numeric value. The default value is 10.

See Also

ScrollBar Class | Kixforms Namespace


Maximum Property

KiXforms.NET Class Library

ScrollBar.Maximum Property

Gets or sets the upper limit of values of the scrollable range.

[Visual Basic]
Public Property Maximum As Integer
[C#]
public int Maximum {get; set;}

Property Value

A numeric value. The default value is 100.

See Also

ScrollBar Class | Kixforms Namespace


Minimum Property

KiXforms.NET Class Library

ScrollBar.Minimum Property

Gets or sets the lower limit of values of the scrollable range.

[Visual Basic]
Public Property Minimum As Integer
[C#]
public int Minimum {get; set;}

Property Value

A numeric value. The default value is 0.

See Also

ScrollBar Class | Kixforms Namespace


SmallChange Property

KiXforms.NET Class Library

ScrollBar.SmallChange Property

Gets or sets the value to be added to or subtracted from to the Value property when the scroll box is moved a small distance.

[Visual Basic]
Public Property SmallChange As Integer
[C#]
public int SmallChange {get; set;}

Property Value

A numeric value. The default value is 1.

See Also

ScrollBar Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

ScrollBar.Value Property

Gets or sets a numeric value that represents the current position of the scroll box on the scroll bar control.

[Visual Basic]
Public Property Value As Integer
[C#]
public int Value {get; set;}

Property Value

A numeric value that is within the Minimum and Maximum range. The default value is zero.

See Also

ScrollBar Class | Kixforms Namespace


ValueChanged Property

KiXforms.NET Class Library

ScrollBar.ValueChanged Property

Occurs when the Value property has changed, either by a Scroll event or programatically.

[Visual Basic]
Public Property ValueChanged As String
[C#]
public string ValueChanged {get; set;}

Property Value

The code to execute when the Value property has changed.

Remarks

The System.EventArgs property a value of type EventArgs containing data related to this event.

See Also

ScrollBar Class | Kixforms Namespace


ScrollBars Enumeration

[Visual Basic]
Public Enum ScrollBars
[C#]
public enum ScrollBars

Members

Member Name | Description
Both |
Horizontal |
None |
Vertical |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


SeekOrigin Enumeration

[Visual Basic]
Public Enum SeekOrigin
[C#]
public enum SeekOrigin

Members

Member Name | Description
Begin |
Current |
End |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


SelectionMode Enumeration

Specifies the selection behavior of a list box.

[Visual Basic]
Public Enum SelectionMode
[C#]
public enum SelectionMode

Members

Member Name | Description
MultiExtended | Multiple items can be selected, and the user can use the SHIFT, CTRL, and arrow keys to make selections.
MultiSimple | Multiple items can be selected.
None | No items can be selected.
One | Only one item can be selected.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Shortcut Enumeration

[Visual Basic]
Public Enum Shortcut
[C#]
public enum Shortcut

Members

Member Name | Description
Alt0 | The shortcut keys ALT+0.
Alt1 | The shortcut keys ALT+1.
Alt2 | The shortcut keys ALT+2.
Alt3 | The shortcut keys ALT+3.
Alt4 | The shortcut keys ALT+4.
Alt5 | The shortcut keys ALT+5.
Alt6 | The shortcut keys ALT+6.
Alt7 | The shortcut keys ALT+7.
Alt8 | The shortcut keys ALT+8.
Alt9 | The shortcut keys ALT+9.
AltBksp | The shortcut keys ALT+BACKSPACE.
AltF1 | The shortcut keys ALT+F1.
AltF10 | The shortcut keys ALT+F10.
AltF11 | The shortcut keys ALT+F11.
AltF12 | The shortcut keys ALT+F12.
AltF2 | The shortcut keys ALT+F2.
AltF3 | The shortcut keys ALT+F3.
AltF4 | The shortcut keys ALT+F4.
AltF5 | The shortcut keys ALT+F5.
AltF6 | The shortcut keys ALT+F6.
AltF7 | The shortcut keys ALT+F7.
AltF8 | The shortcut keys ALT+F8.
AltF9 | The shortcut keys ALT+F9.
Ctrl0 | The shortcut keys CTRL+0.
Ctrl1 | The shortcut keys CTRL+1.
Ctrl2 | The shortcut keys CTRL+2.
Ctrl3 | The shortcut keys CTRL+3.
Ctrl4 | The shortcut keys CTRL+4.
Ctrl5 | The shortcut keys CTRL+5.
Ctrl6 | The shortcut keys CTRL+6.
Ctrl7 | The shortcut keys CTRL+7.
Ctrl8 | The shortcut keys CTRL+8.
Ctrl9 | The shortcut keys CTRL+9.
CtrlA | The shortcut keys CTRL+A.
CtrlB | The shortcut keys CTRL+B.
CtrlC | The shortcut keys CTRL+C.
CtrlD | The shortcut keys CTRL+D.
CtrlDel | The shortcut keys CTRL+DELETE.
CtrlE | The shortcut keys CTRL+E.
CtrlF | The shortcut keys CTRL+F.
CtrlF1 | The shortcut keys CTRL+F1.
CtrlF10 | The shortcut keys CTRL+F10.
CtrlF11 | The shortcut keys CTRL+F11.
CtrlF12 | The shortcut keys CTRL+F12.
CtrlF2 | The shortcut keys CTRL+F2.
CtrlF3 | The shortcut keys CTRL+F3.
CtrlF4 | The shortcut keys CTRL+F4.
CtrlF5 | The shortcut keys CTRL+F5.
CtrlF6 | The shortcut keys CTRL+F6.
CtrlF7 | The shortcut keys CTRL+F7.
CtrlF8 | The shortcut keys CTRL+F8.
CtrlF9 | The shortcut keys CTRL+F9.
CtrlG | The shortcut keys CTRL+G.
CtrlH | The shortcut keys CTRL+H.
CtrlI | The shortcut keys CTRL+I.
CtrlIns | The shortcut keys CTRL+INSERT.
CtrlJ | The shortcut keys CTRL+J.
CtrlK | The shortcut keys CTRL+K.
CtrlL | The shortcut keys CTRL+L.
CtrlM | The shortcut keys CTRL+M.
CtrlN | The shortcut keys CTRL+N.
CtrlO | The shortcut keys CTRL+O.
CtrlP | The shortcut keys CTRL+P.
CtrlQ | The shortcut keys CTRL+Q.
CtrlR | The shortcut keys CTRL+R.
CtrlS | The shortcut keys CTRL+S.
CtrlShift0 | The shortcut keys CTRL+SHIFT+0.
CtrlShift1 | The shortcut keys CTRL+SHIFT+1.
CtrlShift2 | The shortcut keys CTRL+SHIFT+2.
CtrlShift3 | The shortcut keys CTRL+SHIFT+3.
CtrlShift4 | The shortcut keys CTRL+SHIFT+4.
CtrlShift5 | The shortcut keys CTRL+SHIFT+5.
CtrlShift6 | The shortcut keys CTRL+SHIFT+6.
CtrlShift7 | The shortcut keys CTRL+SHIFT+7.
CtrlShift8 | The shortcut keys CTRL+SHIFT+8.
CtrlShift9 | The shortcut keys CTRL+SHIFT+9.
CtrlShiftA | The shortcut keys CTRL+SHIFT+A.
CtrlShiftB | The shortcut keys CTRL+SHIFT+B.
CtrlShiftC | The shortcut keys CTRL+SHIFT+C.
CtrlShiftD | The shortcut keys CTRL+SHIFT+D.
CtrlShiftE | The shortcut keys CTRL+SHIFT+E.
CtrlShiftF | The shortcut keys CTRL+SHIFT+F.
CtrlShiftF1 | The shortcut keys CTRL+SHIFT+F1.
CtrlShiftF10 | The shortcut keys CTRL+SHIFT+F10.
CtrlShiftF11 | The shortcut keys CTRL+SHIFT+F11.
CtrlShiftF12 | The shortcut keys CTRL+SHIFT+F12.
CtrlShiftF2 | The shortcut keys CTRL+SHIFT+F2.
CtrlShiftF3 | The shortcut keys CTRL+SHIFT+F3.
CtrlShiftF4 | The shortcut keys CTRL+SHIFT+F4.
CtrlShiftF5 | The shortcut keys CTRL+SHIFT+F5.
CtrlShiftF6 | The shortcut keys CTRL+SHIFT+F6.
CtrlShiftF7 | The shortcut keys CTRL+SHIFT+F7.
CtrlShiftF8 | The shortcut keys CTRL+SHIFT+F8.
CtrlShiftF9 | The shortcut keys CTRL+SHIFT+F9.
CtrlShiftG | The shortcut keys CTRL+SHIFT+G.
CtrlShiftH | The shortcut keys CTRL+SHIFT+H.
CtrlShiftI | The shortcut keys CTRL+SHIFT+I.
CtrlShiftJ | The shortcut keys CTRL+SHIFT+J.
CtrlShiftK | The shortcut keys CTRL+SHIFT+K.
CtrlShiftL | The shortcut keys CTRL+SHIFT+L.
CtrlShiftM | The shortcut keys CTRL+SHIFT+M.
CtrlShiftN | The shortcut keys CTRL+SHIFT+N.
CtrlShiftO | The shortcut keys CTRL+SHIFT+O.
CtrlShiftP | The shortcut keys CTRL+SHIFT+P.
CtrlShiftQ | The shortcut keys CTRL+SHIFT+Q.
CtrlShiftR | The shortcut keys CTRL+SHIFT+R.
CtrlShiftS | The shortcut keys CTRL+SHIFT+S.
CtrlShiftT | The shortcut keys CTRL+SHIFT+T.
CtrlShiftU | The shortcut keys CTRL+SHIFT+U.
CtrlShiftV | The shortcut keys CTRL+SHIFT+V.
CtrlShiftW | The shortcut keys CTRL+SHIFT+W.
CtrlShiftX | The shortcut keys CTRL+SHIFT+X.
CtrlShiftY | The shortcut keys CTRL+SHIFT+Y.
CtrlShiftZ | The shortcut keys CTRL+SHIFT+Z.
CtrlT | The shortcut keys CTRL+T.
CtrlU | The shortcut keys CTRL+U
CtrlV | The shortcut keys CTRL+V.
CtrlW | The shortcut keys CTRL+W.
CtrlX | The shortcut keys CTRL+X.
CtrlY | The shortcut keys CTRL+Y.
CtrlZ | The shortcut keys CTRL+Z.
Del | The shortcut key DELETE.
F1 | The shortcut key F1.
F10 | The shortcut key F10.
F11 | The shortcut key F11.
F12 | The shortcut key F12.
F2 | The shortcut key F2.
F3 | The shortcut key F3.
F4 | The shortcut key F4.
F5 | The shortcut key F5.
F6 | The shortcut key F6.
F7 | The shortcut key F7.
F8 | The shortcut key F8.
F9 | The shortcut key F9.
Ins | The shortcut key INSERT.
None | No shortcut key is associated with the menu item.
ShiftDel | The shortcut keys SHIFT+DELETE.
ShiftF1 | The shortcut keys SHIFT+F1.
ShiftF10 | The shortcut keys SHIFT+F10.
ShiftF11 | The shortcut keys SHIFT+F11.
ShiftF12 | The shortcut keys SHIFT+F12.
ShiftF2 | The shortcut keys SHIFT+F2.
ShiftF3 | The shortcut keys SHIFT+F3.
ShiftF4 | The shortcut keys SHIFT+F4.
ShiftF5 | The shortcut keys SHIFT+F5.
ShiftF6 | The shortcut keys SHIFT+F6.
ShiftF7 | The shortcut keys SHIFT+F7.
ShiftF8 | The shortcut keys SHIFT+F8.
ShiftF9 | The shortcut keys SHIFT+F9.
ShiftIns | The shortcut keys SHIFT+INSERT.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Size Class

Represents the size of a rectangular region with an ordered pair of width and height.

For a list of all members of this type, see Size Members.

System.Object
Kixforms.Size

[Visual Basic]
Public Class Size
[C#]
public class Size

Remarks

Use System.Size to initialize a new instance of the Size class.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Size Members | Kixforms Namespace


Size Members

Size overview

Public Instance Properties

Height | Gets or sets the vertical component of this Size.
Width | Gets or sets the horizontal component of this Size.

See Also

Size Class | Kixforms Namespace


Size Properties

The properties of the Size class are listed below. For a complete list of Size class members, see the Size Members topic.

Public Instance Properties

Height | Gets or sets the vertical component of this Size.
Width | Gets or sets the horizontal component of this Size.

See Also

Size Class | Kixforms Namespace


Height Property

KiXforms.NET Class Library

Size.Height Property

Gets or sets the vertical component of this Size.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

See Also

Size Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

Size.Width Property

Gets or sets the horizontal component of this Size.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

See Also

Size Class | Kixforms Namespace


SolidBrush Class

Defines a brush of a single color. Brushes are used to fill graphics shapes, such as rectangles, ellipses, pies, polygons, and paths.

For a list of all members of this type, see SolidBrush Members.

System.Object
Kixforms.Brush
Kixforms.SolidBrush

[Visual Basic]
Public Class SolidBrush
Inherits Brush
[C#]
public class SolidBrush : Brush

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

SolidBrush Members | Kixforms Namespace


SolidBrush Members

SolidBrush overview

Public Instance Constructors

SolidBrush Constructor Initializes a new instance of the SolidBrush class.

See Also

SolidBrush Class | Kixforms Namespace


SolidBrush Constructor

Initializes a new instance of the SolidBrush class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal clr As Color = Nothing _
)
[C#]
public SolidBrush(
Color clr
);

See Also

SolidBrush Class | Kixforms Namespace


SortedList Class

Represents a collection of key-and-value pairs that are sorted by the keys and are accessible by key and by index.

For a list of all members of this type, see SortedList Members.

System.Object
Kixforms.SortedList

[Visual Basic]
Public Class SortedList
Implements IEnumerator
[C#]
public class SortedList : IEnumerator

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

SortedList Members | Kixforms Namespace


SortedList Members

SortedList overview

Public Instance Constructors

SortedList Constructor Initializses a new instance of the SortedList class.

Public Instance Properties

Count | Gets the number of elements contained in the SortedList.
Item | Gets the value associated with a specific key in the SortedList.

Public Instance Methods

Add | Adds an element with the specified key and value to the SortedList.
GetByIndex | Gets the value at the specified index of the SortedList.
Remove | Removes the element with the specified key from SortedList.

See Also

SortedList Class | Kixforms Namespace


SortedList Constructor

Initializses a new instance of the SortedList class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public SortedList();

See Also

SortedList Class | Kixforms Namespace


SortedList Properties

The properties of the SortedList class are listed below. For a complete list of SortedList class members, see the SortedList Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the SortedList.
Item | Gets the value associated with a specific key in the SortedList.

See Also

SortedList Class | Kixforms Namespace


Count Property

KiXforms.NET Class Library

SortedList.Count Property

Gets the number of elements contained in the SortedList.

[Visual Basic]
Public ReadOnly Property Count As Integer
[C#]
public int Count {get;}

Property Value

The number of elements contained in the SortedList.

See Also

SortedList Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

SortedList.Item Property

Gets the value associated with a specific key in the SortedList.

[Visual Basic]
Public Default ReadOnly Property Item( _
ByVal key As Object _
) As DictionaryEntry
[C#]
public DictionaryEntry this[
object key
] {get;}

Parameters

key
The key associated with the value to get

Property Value

A DictionaryEntry representing the value with the specific key.

See Also

SortedList Class | Kixforms Namespace


SortedList Methods

The methods of the SortedList class are listed below. For a complete list of SortedList class members, see the SortedList Members topic.

Public Instance Methods

Add | Adds an element with the specified key and value to the SortedList.
GetByIndex | Gets the value at the specified index of the SortedList.
Remove | Removes the element with the specified key from SortedList.

See Also

SortedList Class | Kixforms Namespace


SortedList.Add Method

Adds an element with the specified key and value to the SortedList.

[Visual Basic]
Public Sub Add( _
ByVal key As Object, _
ByVal value As Object _
)
[C#]
public void Add(
object key,
object value
);

Parameters

key
The key of the element to add.
value
The value of the element to add.

See Also

SortedList Class | Kixforms Namespace


SortedList.GetByIndex Method

Gets the value at the specified index of the SortedList.

[Visual Basic]
Public Function GetByIndex( _
ByVal index As Integer _
) As Object
[C#]
public object GetByIndex(
int index
);

Parameters

index
The zero-based index of the value to get.

Return Value

The value at the specified index of the SortedList.

See Also

SortedList Class | Kixforms Namespace


SortedList.Remove Method

Removes the element with the specified key from SortedList.

[Visual Basic]
Public Sub Remove( _
ByVal key As Object _
)
[C#]
public void Remove(
object key
);

Parameters

key
The key of the element to remove.

See Also

SortedList Class | Kixforms Namespace


SortOrder Enumeration

[Visual Basic]
Public Enum SortOrder
[C#]
public enum SortOrder

Members

Member Name | Description
Ascending |
Descending |
None |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Sound Class

Under Development.

For a list of all members of this type, see Sound Members.

System.Object
Kixforms.Sound

[Visual Basic]
Public Class Sound
[C#]
public class Sound

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Sound Members | Kixforms Namespace


Sound Members

Sound overview

Public Static (Shared) Fields

SND_ALIAS
SND_ASYNC
SND_FILENAME
SND_MEMORY
SND_NODEFAULT
SND_RESOURCE
SND_SYNC

Public Static (Shared) Methods

PlaySound Overloaded.

Public Instance Constructors

Sound Constructor Initializes a new instance of the Sound class.

Public Instance Methods

Play
PlayResource
PlaySystem

See Also

Sound Class | Kixforms Namespace


Sound Constructor

Initializes a new instance of the Sound class.

[Visual Basic]
Public Sub New()
[C#]
public Sound();

See Also

Sound Class | Kixforms Namespace


Sound Fields

The fields of the Sound class are listed below. For a complete list of Sound class members, see the Sound Members topic.

Public Static (Shared) Fields

SND_ALIAS
SND_ASYNC
SND_FILENAME
SND_MEMORY
SND_NODEFAULT
SND_RESOURCE
SND_SYNC

See Also

Sound Class | Kixforms Namespace


Sound.SND_ALIAS Field

[Visual Basic]
Public Const SND_ALIAS As Integer = 65536
[C#]
public const int SND_ALIAS = 65536;

See Also

Sound Class | Kixforms Namespace


Sound.SND_ASYNC Field

[Visual Basic]
Public Const SND_ASYNC As Integer = 1
[C#]
public const int SND_ASYNC = 1;

See Also

Sound Class | Kixforms Namespace


Sound.SND_FILENAME Field

[Visual Basic]
Public Const SND_FILENAME As Integer = 131072
[C#]
public const int SND_FILENAME = 131072;

See Also

Sound Class | Kixforms Namespace


Sound.SND_MEMORY Field

[Visual Basic]
Public Const SND_MEMORY As Integer = 4
[C#]
public const int SND_MEMORY = 4;

See Also

Sound Class | Kixforms Namespace


Sound.SND_NODEFAULT Field

[Visual Basic]
Public Const SND_NODEFAULT As Integer = 2
[C#]
public const int SND_NODEFAULT = 2;

See Also

Sound Class | Kixforms Namespace


Sound.SND_RESOURCE Field

[Visual Basic]
Public Const SND_RESOURCE As Integer = 262148
[C#]
public const int SND_RESOURCE = 262148;

See Also

Sound Class | Kixforms Namespace


Sound.SND_SYNC Field

[Visual Basic]
Public Const SND_SYNC As Integer = 0
[C#]
public const int SND_SYNC = 0;

See Also

Sound Class | Kixforms Namespace


Sound Methods

The methods of the Sound class are listed below. For a complete list of Sound class members, see the Sound Members topic.

Public Static (Shared) Methods

PlaySound Overloaded.

Public Instance Methods

Play
PlayResource
PlaySystem

See Also

Sound Class | Kixforms Namespace


Sound.Play Method

[Visual Basic]
Public Sub Play( _
ByVal filename As String _
)
[C#]
public void Play(
string filename
);

See Also

Sound Class | Kixforms Namespace


Sound.PlayResource Method

[Visual Basic]
Public Sub PlayResource( _
ByVal resource As String _
)
[C#]
public void PlayResource(
string resource
);

See Also

Sound Class | Kixforms Namespace


PlaySound Method

KiXforms.NET Class Library

Sound.PlaySound Method

Overload List

public static int PlaySound(byte[],int,int);

public static int PlaySound(ref string,int,int);

See Also

Sound Class | Kixforms Namespace


Sound.PlaySound Method (Byte[], Int32, Int32)

[Visual Basic]
Overloads Public Shared Function PlaySound( _
ByVal name As Byte(), _
ByVal hmod As Integer, _
ByVal flags As Integer _
) As Integer
[C#]
public static int PlaySound(
byte[] name,
int hmod,
int flags
);

See Also

Sound Class | Kixforms Namespace | Sound.PlaySound Overload List


Sound.PlaySound Method (String, Int32, Int32)

[Visual Basic]
Overloads Public Shared Function PlaySound( _
ByRef name As String, _
ByVal hmod As Integer, _
ByVal flags As Integer _
) As Integer
[C#]
public static int PlaySound(
ref string name,
int hmod,
int flags
);

See Also

Sound Class | Kixforms Namespace | Sound.PlaySound Overload List


Sound.PlaySystem Method

[Visual Basic]
Public Sub PlaySystem( _
ByVal name As String _
)
[C#]
public void PlaySystem(
string name
);

See Also

Sound Class | Kixforms Namespace


SpecialFolder Enumeration

[Visual Basic]
Public Enum SpecialFolder
[C#]
public enum SpecialFolder

Members

Member Name | Description
ApplicationData | The directory that serves as a common repository for application-specific data for the current roaming user. A roaming user works on more than one computer on a network. A roaming user's profile is kept on a server on the network and is loaded onto a system when the user logs on.
CommonApplicationData | The directory that serves as a common repository for application-specific data that is used by all users.
CommonProgramFiles | The directory for components that are shared across applications.
Cookies | The directory that serves as a common repository for Internet cookies.
Desktop |
DesktopDirectory | The directory used to physically store file objects on the desktop. Do not confuse this directory with the desktop folder itself, which is a virtual folder.
Favorites | The directory that serves as a common repository for the user's favorite items.
History | The directory that serves as a common repository for Internet history items.
InternetCache | The directory that serves as a common repository for temporary Internet files.
LocalApplicationData | The directory that serves as a common repository for application-specific data that is used by the current, non-roaming user.
MyComputer |
MyMusic |
MyPictures |
Personal | The directory that serves as a common repository for documents.
ProgramFiles | The program files directory.
Programs | The directory that contains the user's program groups.
Recent | The directory that contains the user's most recently used documents.
SendTo | The directory that contains the Send To menu items.
StartMenu | The directory that contains the Start menu items.
Startup | The directory that corresponds to the user's Startup program group. The system starts these programs whenever a user logs on or starts Windows NT or later, or starts Windows 98.
System | The System directory.
Templates | The directory that serves as a common repository for document templates.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


Splitter Class

Represents a splitter control that allows the user to resize docked controls.

For a list of all members of this type, see Splitter Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.Splitter

[Visual Basic]
Public Class Splitter
Inherits Control
[C#]
public class Splitter : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Splitter Members | Kixforms Namespace


Splitter Members

Splitter overview

Public Instance Constructors

Splitter Constructor Initializes a new instance of the Splitter class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MinExtra | Gets or sets the minimum distance that must remain between the splitter control and the edge of the opposite side of the container (or the closest control docked to that side).
MinSize | Gets or sets the minimum distance that must remain between the splitter control and the container edge that the control is docked to.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SplitPosition | Gets or sets the distance between the splitter control and the container edge that the control is docked to.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

Splitter Class | Kixforms Namespace


Splitter Constructor

Initializes a new instance of the Splitter class.

[Visual Basic]
Public Sub New()
[C#]
public Splitter();

See Also

Splitter Class | Kixforms Namespace


Splitter Properties

The properties of the Splitter class are listed below. For a complete list of Splitter class members, see the Splitter Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MinExtra | Gets or sets the minimum distance that must remain between the splitter control and the edge of the opposite side of the container (or the closest control docked to that side).
MinSize | Gets or sets the minimum distance that must remain between the splitter control and the container edge that the control is docked to.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SplitPosition | Gets or sets the distance between the splitter control and the container edge that the control is docked to.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

Splitter Class | Kixforms Namespace


MinExtra Property

KiXforms.NET Class Library

Splitter.MinExtra Property

Gets or sets the minimum distance that must remain between the splitter control and the edge of the opposite side of the container (or the closest control docked to that side).

[Visual Basic]
Public Property MinExtra As Integer
[C#]
public int MinExtra {get; set;}

See Also

Splitter Class | Kixforms Namespace


MinSize Property

KiXforms.NET Class Library

Splitter.MinSize Property

Gets or sets the minimum distance that must remain between the splitter control and the container edge that the control is docked to.

[Visual Basic]
Public Property MinSize As Integer
[C#]
public int MinSize {get; set;}

See Also

Splitter Class | Kixforms Namespace


SplitPosition Property

KiXforms.NET Class Library

Splitter.SplitPosition Property

Gets or sets the distance between the splitter control and the container edge that the control is docked to.

[Visual Basic]
Public Property SplitPosition As Integer
[C#]
public int SplitPosition {get; set;}

See Also

Splitter Class | Kixforms Namespace


StatusBar Class

Represents a Windows status bar control.

For a list of all members of this type, see StatusBar Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.StatusBar

[Visual Basic]
Public Class StatusBar
Inherits Control
[C#]
public class StatusBar : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

StatusBar Members | Kixforms Namespace


StatusBar Members

StatusBar overview

Public Instance Constructors

StatusBar Constructor Initializes a new instance of the StatusBar class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Panels | Gets the collection of StatusBar panels contained within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowPanels | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizingGrip | Gets or sets a value indicating whether a sizing grip is displayed in the lower-right corner of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

StatusBar Class | Kixforms Namespace


StatusBar Constructor

Initializes a new instance of the StatusBar class.

[Visual Basic]
Public Sub New()
[C#]
public StatusBar();

See Also

StatusBar Class | Kixforms Namespace


StatusBar Properties

The properties of the StatusBar class are listed below. For a complete list of StatusBar class members, see the StatusBar Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Panels | Gets the collection of StatusBar panels contained within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowPanels | Gets or sets a value indicating whether any panels that have been added to the control are displayed.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizingGrip | Gets or sets a value indicating whether a sizing grip is displayed in the lower-right corner of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

StatusBar Class | Kixforms Namespace


Panels Property

KiXforms.NET Class Library

StatusBar.Panels Property

Gets the collection of StatusBar panels contained within the control.

[Visual Basic]
Public ReadOnly Property Panels As StatusBarPanelCollection
[C#]
public StatusBarPanelCollection Panels {get;}

See Also

StatusBar Class | Kixforms Namespace


ShowPanels Property

KiXforms.NET Class Library

StatusBar.ShowPanels Property

Gets or sets a value indicating whether any panels that have been added to the control are displayed.

[Visual Basic]
Public Property ShowPanels As Boolean
[C#]
public bool ShowPanels {get; set;}

See Also

StatusBar Class | Kixforms Namespace


SizingGrip Property

KiXforms.NET Class Library

StatusBar.SizingGrip Property

Gets or sets a value indicating whether a sizing grip is displayed in the lower-right corner of the control.

[Visual Basic]
Public Property SizingGrip As Boolean
[C#]
public bool SizingGrip {get; set;}

See Also

StatusBar Class | Kixforms Namespace


StatusBarPanel Class

Represents a panel in a StatusBar control.

For a list of all members of this type, see StatusBarPanel Members.

System.Object
Kixforms.Component
Kixforms.StatusBarPanel

[Visual Basic]
Public Class StatusBarPanel
Inherits Component
[C#]
public class StatusBarPanel : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

StatusBarPanel Members | Kixforms Namespace


StatusBarPanel Members

StatusBarPanel overview

Public Instance Constructors

StatusBarPanel Constructor Initializes a new instance of the StatusBarPanel class.

Public Instance Properties

AutoSize | Gets or sets a value indicating whether the status bar panel is autosized.
BorderStyle | Gets or sets the border style of the status bar panel.
Icon | Gets or sets the icon to display within the status bar panel.
MinWidth | Gets or sets the minimum allowed width of the status bar panel within the StatusBar control.
Text | Gets or sets the text of the status bar panel.
Type (inherited from Component) | Gets the Type of the current instance.
Width | Gets or sets the width of the status bar panel within the StatusBar control.

Public Instance Methods

Dispose (inherited from Component) Releases the resources used by the Component.

See Also

StatusBarPanel Class | Kixforms Namespace


StatusBarPanel Constructor

Initializes a new instance of the StatusBarPanel class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal text As String = "Nothing" _
)
[C#]
public StatusBarPanel(
string text
);

See Also

StatusBarPanel Class | Kixforms Namespace


StatusBarPanel Properties

The properties of the StatusBarPanel class are listed below. For a complete list of StatusBarPanel class members, see the StatusBarPanel Members topic.

Public Instance Properties

AutoSize | Gets or sets a value indicating whether the status bar panel is autosized.
BorderStyle | Gets or sets the border style of the status bar panel.
Icon | Gets or sets the icon to display within the status bar panel.
MinWidth | Gets or sets the minimum allowed width of the status bar panel within the StatusBar control.
Text | Gets or sets the text of the status bar panel.
Type (inherited from Component) | Gets the Type of the current instance.
Width | Gets or sets the width of the status bar panel within the StatusBar control.

See Also

StatusBarPanel Class | Kixforms Namespace


AutoSize Property

KiXforms.NET Class Library

StatusBarPanel.AutoSize Property

Gets or sets a value indicating whether the status bar panel is autosized.

[Visual Basic]
Public Property AutoSize As StatusBarPanelAutoSize
[C#]
public StatusBarPanelAutoSize AutoSize {get; set;}

See Also

StatusBarPanel Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

StatusBarPanel.BorderStyle Property

Gets or sets the border style of the status bar panel.

[Visual Basic]
Public Property BorderStyle As StatusBarPanelBorderStyle
[C#]
public StatusBarPanelBorderStyle BorderStyle {get; set;}

Property Value

One of the StatusBarPanelBorderStyle values. The default is Sunken.

See Also

StatusBarPanel Class | Kixforms Namespace


Icon Property

KiXforms.NET Class Library

StatusBarPanel.Icon Property

Gets or sets the icon to display within the status bar panel.

[Visual Basic]
Public Property Icon As Icon
[C#]
public Icon Icon {get; set;}

Property Value

An Icon that represents the icon to display in the panel.

See Also

StatusBarPanel Class | Kixforms Namespace


MinWidth Property

KiXforms.NET Class Library

StatusBarPanel.MinWidth Property

Gets or sets the minimum allowed width of the status bar panel within the StatusBar control.

[Visual Basic]
Public Property MinWidth As Integer
[C#]
public int MinWidth {get; set;}

Property Value

The minimum width (in pixels) of the StatusBarPanel.

See Also

StatusBarPanel Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

StatusBarPanel.Text Property

Gets or sets the text of the status bar panel.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

Property Value

The text displayed in the panel.

See Also

StatusBarPanel Class | Kixforms Namespace


Width Property

KiXforms.NET Class Library

StatusBarPanel.Width Property

Gets or sets the width of the status bar panel within the StatusBar control.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

Property Value

The width (in pixels) of the StatusBarPanel.

See Also

StatusBarPanel Class | Kixforms Namespace


StatusBarPanelAutoSize Enumeration

[Visual Basic]
Public Enum StatusBarPanelAutoSize
[C#]
public enum StatusBarPanelAutoSize

Members

Member Name | Description
Contents |
None |
Spring |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


StatusBarPanelBorderStyle Enumeration

[Visual Basic]
Public Enum StatusBarPanelBorderStyle
[C#]
public enum StatusBarPanelBorderStyle

Members

Member Name | Description
None | No border is displayed.
Raised | The StatusBarPanel is displayed with a three-dimensional raised border.
Sunken | The StatusBarPanel is displayed with a three-dimensional sunken border.

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


StatusBarPanelCollection Class

Represents the collection of panels in a StatusBar control.

For a list of all members of this type, see StatusBarPanelCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.StatusBarPanelCollection

[Visual Basic]
Public Class StatusBarPanelCollection
Inherits CollectionBase
[C#]
public class StatusBarPanelCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

StatusBarPanelCollection Members | Kixforms Namespace


StatusBarPanelCollection Members

StatusBarPanelCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the StatusBarPanel at the specified index.

Public Instance Methods

Add | Adds a StatusBarPanel with the specified text to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts the specified StatusBarPanel into the collection at the specified index.
Remove | Removes the specified StatusBarPanel from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


StatusBarPanelCollection Properties

The properties of the StatusBarPanelCollection class are listed below. For a complete list of StatusBarPanelCollection class members, see the StatusBarPanelCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the StatusBarPanel at the specified index.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

StatusBarPanelCollection.Item Property

Gets or sets the StatusBarPanel at the specified index.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal Index As Integer _
) As StatusBarPanel
[C#]
public StatusBarPanel this[
int Index
] {get; set;}

Parameters

Index

Property Value

A StatusBarPanel representing the panel located at the specified index within the collection.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


StatusBarPanelCollection Methods

The methods of the StatusBarPanelCollection class are listed below. For a complete list of StatusBarPanelCollection class members, see the StatusBarPanelCollection Members topic.

Public Instance Methods

Add | Adds a StatusBarPanel with the specified text to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts the specified StatusBarPanel into the collection at the specified index.
Remove | Removes the specified StatusBarPanel from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


StatusBarPanelCollection.Add Method

Adds a StatusBarPanel with the specified text to the collection.

[Visual Basic]
Public Function Add( _
ByVal value As StatusBarPanel _
) As StatusBarPanel
[C#]
public StatusBarPanel Add(
StatusBarPanel value
);

Parameters

value
A StatusBarPanel that represents the panel to add to the collection.

Return Value

The StatusBarPanel that was added to the collection.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


StatusBarPanelCollection.Insert Method

Inserts the specified StatusBarPanel into the collection at the specified index.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal value As StatusBarPanel _
) As StatusBarPanel
[C#]
public StatusBarPanel Insert(
int index,
StatusBarPanel value
);

Parameters

index
The zero-based index location where the panel is inserted.
value
A StatusBarPanel representing the panel to insert.

Return Value

The StatusBarPanel that was inserted to the collection.

See Also

StatusBarPanelCollection Class | Kixforms Namespace


StatusBarPanelCollection.Remove Method

Removes the specified StatusBarPanel from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal StatusBarPanel As StatusBarPanel _
)
[C#]
public void Remove(
StatusBarPanel StatusBarPanel
);

Parameters

StatusBarPanel

See Also

StatusBarPanelCollection Class | Kixforms Namespace


Stream Class

Provides a generic view of a sequence of bytes.

For a list of all members of this type, see Stream Members.

System.Object
Kixforms.Stream
Kixforms.FileStream
Kixforms.MemoryStream

[Visual Basic]
Public Class Stream
[C#]
public class Stream

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Stream Members | Kixforms Namespace


Stream Members

Stream overview

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets the length in bytes of the stream.
Position | Gets or sets the position within the current stream.

Public Instance Methods

Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.

See Also

Stream Class | Kixforms Namespace


Stream Properties

The properties of the Stream class are listed below. For a complete list of Stream class members, see the Stream Members topic.

Public Instance Properties

CanRead | Gets a value indicating whether the current stream supports reading.
CanSeek | Gets a value indicating whether the current stream supports seeking.
CanWrite | Gets a value indicating whether the current stream supports writing.
Length | Gets the length in bytes of the stream.
Position | Gets or sets the position within the current stream.

See Also

Stream Class | Kixforms Namespace


CanRead Property

KiXforms.NET Class Library

Stream.CanRead Property

Gets a value indicating whether the current stream supports reading.

[Visual Basic]
Overridable Public ReadOnly Property CanRead As Boolean
[C#]
public virtual bool CanRead {get;}

Property Value

True if the stream supports reading; otherwise, false.

See Also

Stream Class | Kixforms Namespace


CanSeek Property

KiXforms.NET Class Library

Stream.CanSeek Property

Gets a value indicating whether the current stream supports seeking.

[Visual Basic]
Overridable Public ReadOnly Property CanSeek As Boolean
[C#]
public virtual bool CanSeek {get;}

Property Value

True if the stream supports seeking; otherwise, false.

See Also

Stream Class | Kixforms Namespace


CanWrite Property

KiXforms.NET Class Library

Stream.CanWrite Property

Gets a value indicating whether the current stream supports writing.

[Visual Basic]
Overridable Public ReadOnly Property CanWrite As Boolean
[C#]
public virtual bool CanWrite {get;}

Property Value

True if the stream supports writing; otherwise, false.

See Also

Stream Class | Kixforms Namespace


Length Property

KiXforms.NET Class Library

Stream.Length Property

Gets the length in bytes of the stream.

[Visual Basic]
Overridable Public ReadOnly Property Length As Integer
[C#]
public virtual int Length {get;}

Property Value

The length of the stream in bytes.

See Also

Stream Class | Kixforms Namespace


Position Property

KiXforms.NET Class Library

Stream.Position Property

Gets or sets the position within the current stream.

[Visual Basic]
Overridable Public Property Position As Integer
[C#]
public virtual int Position {get; set;}

Property Value

The current position within the stream.

Remarks

The position must not be more than one byte beyond the end of the stream.

See Also

Stream Class | Kixforms Namespace


Stream Methods

The methods of the Stream class are listed below. For a complete list of Stream class members, see the Stream Members topic.

Public Instance Methods

Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device.
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.
Seek | Sets the position within the current stream.
SetLength | Sets the length of the current stream.
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte.

See Also

Stream Class | Kixforms Namespace


Stream.Close Method

Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream.

[Visual Basic]
Overridable Public Sub Close()
[C#]
public virtual void Close();

See Also

Stream Class | Kixforms Namespace


Stream.Flush Method

Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

[Visual Basic]
Overridable Public Sub Flush()
[C#]
public virtual void Flush();

See Also

Stream Class | Kixforms Namespace


Stream.ReadByte Method

Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.

[Visual Basic]
Overridable Public Function ReadByte() As Integer
[C#]
public virtual int ReadByte();

Return Value

The byte cast to an Integer, or -1 if the end of the stream has been reached.

Remarks

Use the CanRead property to determine whether the current instance supports reading.

See Also

Stream Class | Kixforms Namespace


Stream.Seek Method

Sets the position within the current stream.

[Visual Basic]
Overridable Public Function Seek( _
ByVal offset As Integer, _
ByVal origin As SeekOrigin _
) As Integer
[C#]
public virtual int Seek(
int offset,
SeekOrigin origin
);

Parameters

offset
A byte offset relative to origin. If offset is negative, the new position will precede the position specified by origin by the number of bytes specified by offset. If offset is zero, the new position will be the position specified by origin. If offset is positive, the new position will follow the position specified by origin by the number of bytes specified by offset.
origin
A value of type SeekOrigin indicating the reference point used to obtain the new position.

See Also

Stream Class | Kixforms Namespace


Stream.SetLength Method

Sets the length of the current stream.

[Visual Basic]
Overridable Public Sub SetLength( _
ByVal value As Integer _
)
[C#]
public virtual void SetLength(
int value
);

Parameters

value
The desired length of the current stream in bytes.

See Also

Stream Class | Kixforms Namespace


Stream.Write Method

Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

[Visual Basic]
Overridable Public Sub Write( _
ByVal buffer As Object(), _
ByVal offset As Integer, _
ByVal count As Integer _
)
[C#]
public virtual void Write(
object[] buffer,
int offset,
int count
);

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
The number of bytes to be written to the current stream.

See Also

Stream Class | Kixforms Namespace


Stream.WriteByte Method

Writes a byte to the current position in the stream and advances the position within the stream by one byte.

[Visual Basic]
Overridable Public Sub WriteByte( _
ByVal value As Byte _
)
[C#]
public virtual void WriteByte(
byte value
);

See Also

Stream Class | Kixforms Namespace


StreamReader Class

Implements a TextReader that reads characters from a byte stream in a particular encoding.

For a list of all members of this type, see StreamReader Members.

System.Object
Kixforms.StreamReader

[Visual Basic]
Public Class StreamReader
[C#]
public class StreamReader

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

StreamReader Members | Kixforms Namespace


StreamReader Members

StreamReader overview

Public Instance Constructors

StreamReader Constructor Creates a new instance of the StreamReader class.

Public Instance Methods

Close | Closes the StreamReader and releases any system resources associated with the reader.
Peek | Returns the next available character but does not consume it.
ReadLine | Reads a line of characters from the current stream and returns the data as a string. Returns a null reference if the end of the input stream is reached.
ReadToEnd | Reads the stream from the current position to the end of the stream.

See Also

StreamReader Class | Kixforms Namespace


StreamReader Constructor

Creates a new instance of the StreamReader class.

[Visual Basic]
Overloads Public Sub New( _
ByVal path As String _
)
[C#]
public StreamReader(
string path
);

See Also

StreamReader Class | Kixforms Namespace


StreamReader Methods

The methods of the StreamReader class are listed below. For a complete list of StreamReader class members, see the StreamReader Members topic.

Public Instance Methods

Close | Closes the StreamReader and releases any system resources associated with the reader.
Peek | Returns the next available character but does not consume it.
ReadLine | Reads a line of characters from the current stream and returns the data as a string. Returns a null reference if the end of the input stream is reached.
ReadToEnd | Reads the stream from the current position to the end of the stream.

See Also

StreamReader Class | Kixforms Namespace


StreamReader.Close Method

Closes the StreamReader and releases any system resources associated with the reader.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

StreamReader Class | Kixforms Namespace


StreamReader.Peek Method

Returns the next available character but does not consume it.

[Visual Basic]
Public Function Peek() As Integer
[C#]
public int Peek();

See Also

StreamReader Class | Kixforms Namespace


StreamReader.ReadLine Method

Reads a line of characters from the current stream and returns the data as a string. Returns a null reference if the end of the input stream is reached.

[Visual Basic]
Public Function ReadLine() As String
[C#]
public string ReadLine();

See Also

StreamReader Class | Kixforms Namespace


StreamReader.ReadToEnd Method

Reads the stream from the current position to the end of the stream.

[Visual Basic]
Public Function ReadToEnd() As String
[C#]
public string ReadToEnd();

See Also

StreamReader Class | Kixforms Namespace


StreamWriter Class

Implements a TextWriter for writing characters to a stream in a particular encoding.

For a list of all members of this type, see StreamWriter Members.

System.Object
Kixforms.StreamWriter

[Visual Basic]
Public Class StreamWriter
[C#]
public class StreamWriter

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

StreamWriter Members | Kixforms Namespace


StreamWriter Members

StreamWriter overview

Public Instance Constructors

StreamWriter Constructor Initializes a new instance of the StreamWriter class.

Public Instance Methods

Close | Closes the current StreamWriter and the underlying stream.
Write | Writes to the stream.

See Also

StreamWriter Class | Kixforms Namespace


StreamWriter Constructor

Initializes a new instance of the StreamWriter class.

[Visual Basic]
Public Sub New( _
Optional ByVal path As String = "Nothing" _
)
[C#]
public StreamWriter(
string path
);

See Also

StreamWriter Class | Kixforms Namespace


StreamWriter Methods

The methods of the StreamWriter class are listed below. For a complete list of StreamWriter class members, see the StreamWriter Members topic.

Public Instance Methods

Close | Closes the current StreamWriter and the underlying stream.
Write | Writes to the stream.

See Also

StreamWriter Class | Kixforms Namespace


StreamWriter.Close Method

Closes the current StreamWriter and the underlying stream.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

See Also

StreamWriter Class | Kixforms Namespace


StreamWriter.Write Method

Writes to the stream.

[Visual Basic]
Public Sub Write( _
ByVal obj As Object _
)
[C#]
public void Write(
object obj
);

See Also

StreamWriter Class | Kixforms Namespace


System Class

Represents the entire system namespace. The System object contains fields, properties and methods that return top-level objects, such as Forms, Files, Processes, Enumerations and so on.

For a list of all members of this type, see System Members.

System.Object
Kixforms.System

[Visual Basic]
Public Class System
[C#]
public class System

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

System Members | Kixforms Namespace


System Members

System overview

Public Instance Constructors

System Constructor Initializes a new instance of the System Class.

Public Instance Fields

AnchorStyles_Bottom
AnchorStyles_Left
AnchorStyles_None
AnchorStyles_Right
AnchorStyles_Top
Appearance_Button
Appearance_Normal
BorderStyle_Fixed3D
BorderStyle_FixedSingle
BorderStyle_None
CharacterCasing_Lower
CharacterCasing_Normal
CharacterCasing_Upper
CheckState_Checked
CheckState_Indeterminate
CheckState_Unchecked
ColorDepth_Depth16Bit
ColorDepth_Depth24Bit
ColorDepth_Depth32Bit
ColorDepth_Depth4Bit
ColorDepth_Depth8Bit
ColumnHeaderStyle_Clickable
ColumnHeaderStyle_Nonclickable
ColumnHeaderStyle_None
ComboBoxStyle_DropDown
ComboBoxStyle_DropDownList
ComboBoxStyle_Simple
ContentAlignment_BottomCenter
ContentAlignment_BottomLeft
ContentAlignment_BottomRight
ContentAlignment_MiddleCenter
ContentAlignment_MiddleLeft
ContentAlignment_MiddleRight
ContentAlignment_TopCenter
ContentAlignment_TopLeft
ContentAlignment_TopRight
DialogResult_Abort
DialogResult_Cancel
DialogResult_Ignore
DialogResult_No
DialogResult_None
DialogResult_OK
DialogResult_Retry
DialogResult_Yes
DockStyle_Bottom
DockStyle_Fill
DockStyle_Left
DockStyle_None
DockStyle_Right
DockStyle_Top
FileAccess_Read
FileAccess_ReadWrite
FileAccess_Write
FileMode_Append
FileMode_Create
FileMode_CreateNew
FileMode_Open
FileMode_OpenOrCreate
FileMode_Truncate
FileShare_None
FileShare_Read
FileShare_ReadWrite
FileShare_Write
FlatStyle_Flat
FlatStyle_Popup
FlatStyle_Standard
FlatStyle_System
FontStyle_Bold
FontStyle_Italic
FontStyle_Regular
FontStyle_Strikeout
FontStyle_Underline
FormBorderStyle_Fixed3D
FormBorderStyle_FixedDialog
FormBorderStyle_FixedSingle
FormBorderStyle_FixedToolWindow
FormBorderStyle_None
FormBorderStyle_Sizable
FormBorderStyle_SizableToolWindow
FormStartPosition_CenterParent
FormStartPosition_CenterScreen
FormStartPosition_Manual
FormStartPosition_WindowsDefaultBounds
FormStartPosition_WindowsDefaultLocation
FormWindowState_Maximized
FormWindowState_Minimized
FormWindowState_Normal
HatchStyle_BackwardDiagonal
HatchStyle_Cross
HatchStyle_DarkDownwardDiagonal
HatchStyle_DarkHorizontal
HatchStyle_DarkUpwardDiagonal
HatchStyle_DarkVertical
HatchStyle_DashedDownwardDiagonal
HatchStyle_DashedHorizontal
HatchStyle_DashedUpwardDiagonal
HatchStyle_DashedVertical
HatchStyle_DiagonalBrick
HatchStyle_DiagonalCross
HatchStyle_Divot
HatchStyle_DottedDiamond
HatchStyle_DottedGrid
HatchStyle_ForwardDiagonal
HatchStyle_Horizontal
HatchStyle_HorizontalBrick
HatchStyle_LargeCheckerBoard
HatchStyle_LargeConfetti
HatchStyle_LargeGrid
HatchStyle_LightDownwardDiagonal
HatchStyle_LightHorizontal
HatchStyle_LightUpwardDiagonal
HatchStyle_LightVertical
HatchStyle_Max
HatchStyle_Min
HatchStyle_NarrowHorizontal
HatchStyle_NarrowVertical
HatchStyle_OutlinedDiamond
HatchStyle_Percent05
HatchStyle_Percent10
HatchStyle_Percent20
HatchStyle_Percent25
HatchStyle_Percent30
HatchStyle_Percent40
HatchStyle_Percent50
HatchStyle_Percent60
HatchStyle_Percent70
HatchStyle_Percent75
HatchStyle_Percent80
HatchStyle_Percent90
HatchStyle_Plaid
HatchStyle_Shingle
HatchStyle_SmallCheckerBoard
HatchStyle_SmallConfetti
HatchStyle_SmallGrid
HatchStyle_SolidDiamond
HatchStyle_Sphere
HatchStyle_Trellis
HatchStyle_Vertical
HatchStyle_Wave
HatchStyle_Weave
HatchStyle_WideDownwardDiagonal
HatchStyle_WideUpwardDiagonal
HatchStyle_ZigZag
HorizontalAlignment_Center
HorizontalAlignment_Left
HorizontalAlignment_Right
ItemActivation_OneClick
ItemActivation_Standard
ItemActivation_TwoClick
Keys_A
Keys_Add
Keys_Alt
Keys_Apps
Keys_Attn
Keys_B
Keys_Back
Keys_BrowserBack
Keys_BrowserFavorites
Keys_BrowserForward
Keys_BrowserHome
Keys_BrowserRefresh
Keys_BrowserSearch
Keys_BrowserStop
Keys_C
Keys_Cancel
Keys_Capital
Keys_CapsLock
Keys_Clear
Keys_Control
Keys_ControlKey
Keys_Crsel
Keys_D
Keys_D0
Keys_D1
Keys_D2
Keys_D3
Keys_D4
Keys_D5
Keys_D6
Keys_D7
Keys_D8
Keys_D9
Keys_Decimal
Keys_Delete
Keys_Divide
Keys_Down
Keys_E
Keys_End
Keys_Enter
Keys_EraseEof
Keys_Escape
Keys_Execute
Keys_Exsel
Keys_F
Keys_F1
Keys_F10
Keys_F11
Keys_F12
Keys_F13
Keys_F14
Keys_F15
Keys_F16
Keys_F17
Keys_F18
Keys_F19
Keys_F2
Keys_F20
Keys_F21
Keys_F22
Keys_F23
Keys_F24
Keys_F3
Keys_F4
Keys_F5
Keys_F6
Keys_F7
Keys_F8
Keys_F9
Keys_FinalMode
Keys_G
Keys_H
Keys_HanguelMode
Keys_HangulMode
Keys_HanjaMode
Keys_Help
Keys_Home
Keys_I
Keys_IMEAceept
Keys_IMEConvert
Keys_IMEModeChange
Keys_IMENonconvert
Keys_Insert
Keys_J
Keys_JunjaMode
Keys_K
Keys_KanaMode
Keys_KanjiMode
Keys_KeyCode
Keys_L
Keys_LaunchApplication1
Keys_LaunchApplication2
Keys_LaunchMail
Keys_LButton
Keys_LControlKey
Keys_Left
Keys_LineFeed
Keys_LMenu
Keys_LShiftKey
Keys_LWin
Keys_M
Keys_MButton
Keys_MediaNextTrack
Keys_MediaPlayPause
Keys_MediaPreviousTrack
Keys_MediaStop
Keys_Menu
Keys_Modifiers
Keys_Multiply
Keys_N
Keys_Next
Keys_NoName
Keys_None
Keys_NumLock
Keys_NumPad0
Keys_NumPad1
Keys_NumPad2
Keys_NumPad3
Keys_NumPad4
Keys_NumPad5
Keys_NumPad6
Keys_NumPad7
Keys_NumPad8
Keys_NumPad9
Keys_O
Keys_Oem8
Keys_OemBackslash
Keys_OemClear
Keys_OemCloseBrackets
Keys_Oemcomma
Keys_OemMinus
Keys_OemOpenBrackets
Keys_OemPeriod
Keys_OemPipe
Keys_Oemplus
Keys_OemQuestion
Keys_OemQuotes
Keys_OemSemicolon
Keys_Oemtilde
Keys_P
Keys_Pa1
Keys_PageDown
Keys_PageUp
Keys_Pause
Keys_Play
Keys_Print
Keys_PrintScreen
Keys_Prior
Keys_ProcessKey
Keys_Q
Keys_R
Keys_RButton
Keys_RControlKey
Keys_Return
Keys_Right
Keys_RMenu
Keys_RShiftKey
Keys_RWin
Keys_S
Keys_Scroll
Keys_Select
Keys_SelectMedia
Keys_Separator
Keys_Shift
Keys_ShiftKey
Keys_Snapshot
Keys_Space
Keys_Subtract
Keys_T
Keys_Tab
Keys_U
Keys_Up
Keys_V
Keys_VolumeDown
Keys_VolumeMute
Keys_VolumeUp
Keys_W
Keys_X
Keys_XButton1
Keys_XButton2
Keys_Y
Keys_Z
Keys_Zoom
ListViewAlignment_Default
ListViewAlignment_Left
ListViewAlignment_SnapToGrid
ListViewAlignment_Top
MdiLayout_ArrangeIcons
MdiLayout_Cascade
MdiLayout_TileHorizontal
MdiLayout_TileVertical
MenuMerge_Add
MenuMerge_MergeItems
MenuMerge_Remove
MenuMerge_Replace
MessageBoxButtons_Add
MessageBoxButtons_OK
MessageBoxButtons_OKCancel
MessageBoxButtons_RetryCancel
MessageBoxButtons_YesNo
MessageBoxButtons_YesNoCancel
MessageBoxIcon_Asterisk
MessageBoxIcon_Error
MessageBoxIcon_Exclamation
MessageBoxIcon_Hand
MessageBoxIcon_Information
MessageBoxIcon_None
MessageBoxIcon_Question
MessageBoxIcon_Stop
MessageBoxIcon_Warning
MouseButtons_Left
MouseButtons_Middle
MouseButtons_Right
PictureBoxSizeMode_AutoSize
PictureBoxSizeMode_CenterImage
PictureBoxSizeMode_Normal
PictureBoxSizeMode_StretchImage
ProcessWindowStyle_Hidden
ProcessWindowStyle_Maximized
ProcessWindowStyle_Minimized
ProcessWindowStyle_Normal
PropertySort_Alphabetical
PropertySort_Categorized
PropertySort_CategorizedAlphabetical
PropertySort_NoSort
RichTextBoxFinds_MatchCase
RichTextBoxFinds_NoHighlight
RichTextBoxFinds_None
RichTextBoxFinds_Reverse
RichTextBoxFinds_WholeWord
RichTextBoxStreamType_PlainText
RichTextBoxStreamType_RichNoOleObjs
RichTextBoxStreamType_RichText
RichTextBoxStreamType_TextTextOleObjs
RichTextBoxStreamType_UnicodePlainText
ScrollBars_Both
ScrollBars_Horizontal
ScrollBars_None
ScrollBars_Vertical
SeekOrigin_Begin
SeekOrigin_Current
SeekOrigin_End
SelectionMode_MultiExtended
SelectionMode_MultiSimple
SelectionMode_None
SelectionMode_One
Shortcut_Alt0
Shortcut_Alt1
Shortcut_Alt2
Shortcut_Alt3
Shortcut_Alt4
Shortcut_Alt5
Shortcut_Alt6
Shortcut_Alt7
Shortcut_Alt8
Shortcut_Alt9
Shortcut_AltBksp
Shortcut_AltF1
Shortcut_AltF10
Shortcut_AltF11
Shortcut_AltF12
Shortcut_AltF2
Shortcut_AltF3
Shortcut_AltF4
Shortcut_AltF5
Shortcut_AltF6
Shortcut_AltF7
Shortcut_AltF8
Shortcut_AltF9
Shortcut_Ctrl0
Shortcut_Ctrl1
Shortcut_Ctrl2
Shortcut_Ctrl3
Shortcut_Ctrl4
Shortcut_Ctrl5
Shortcut_Ctrl6
Shortcut_Ctrl7
Shortcut_Ctrl8
Shortcut_Ctrl9
Shortcut_CtrlA
Shortcut_CtrlB
Shortcut_CtrlC
Shortcut_CtrlD
Shortcut_CtrlDel
Shortcut_CtrlE
Shortcut_CtrlF
Shortcut_CtrlF1
Shortcut_CtrlF10
Shortcut_CtrlF11
Shortcut_CtrlF12
Shortcut_CtrlF2
Shortcut_CtrlF3
Shortcut_CtrlF4
Shortcut_CtrlF5
Shortcut_CtrlF6
Shortcut_CtrlF7
Shortcut_CtrlF8
Shortcut_CtrlF9
Shortcut_CtrlG
Shortcut_CtrlH
Shortcut_CtrlI
Shortcut_CtrlIns
Shortcut_CtrlJ
Shortcut_CtrlK
Shortcut_CtrlL
Shortcut_CtrlM
Shortcut_CtrlN
Shortcut_CtrlO
Shortcut_CtrlP
Shortcut_CtrlQ
Shortcut_CtrlR
Shortcut_CtrlS
Shortcut_CtrlShift0
Shortcut_CtrlShift1
Shortcut_CtrlShift2
Shortcut_CtrlShift3
Shortcut_CtrlShift4
Shortcut_CtrlShift5
Shortcut_CtrlShift6
Shortcut_CtrlShift7
Shortcut_CtrlShift8
Shortcut_CtrlShift9
Shortcut_CtrlShiftA
Shortcut_CtrlShiftB
Shortcut_CtrlShiftC
Shortcut_CtrlShiftD
Shortcut_CtrlShiftE
Shortcut_CtrlShiftF
Shortcut_CtrlShiftF1
Shortcut_CtrlShiftF10
Shortcut_CtrlShiftF11
Shortcut_CtrlShiftF12
Shortcut_CtrlShiftF2
Shortcut_CtrlShiftF3
Shortcut_CtrlShiftF4
Shortcut_CtrlShiftF5
Shortcut_CtrlShiftF6
Shortcut_CtrlShiftF7
Shortcut_CtrlShiftF8
Shortcut_CtrlShiftF9
Shortcut_CtrlShiftG
Shortcut_CtrlShiftH
Shortcut_CtrlShiftI
Shortcut_CtrlShiftJ
Shortcut_CtrlShiftK
Shortcut_CtrlShiftL
Shortcut_CtrlShiftM
Shortcut_CtrlShiftN
Shortcut_CtrlShiftO
Shortcut_CtrlShiftP
Shortcut_CtrlShiftQ
Shortcut_CtrlShiftR
Shortcut_CtrlShiftS
Shortcut_CtrlShiftT
Shortcut_CtrlShiftU
Shortcut_CtrlShiftV
Shortcut_CtrlShiftW
Shortcut_CtrlShiftX
Shortcut_CtrlShiftY
Shortcut_CtrlShiftZ
Shortcut_CtrlT
Shortcut_CtrlU
Shortcut_CtrlV
Shortcut_CtrlW
Shortcut_CtrlX
Shortcut_CtrlY
Shortcut_CtrlZ
Shortcut_Del
Shortcut_F1
Shortcut_F10
Shortcut_F11
Shortcut_F12
Shortcut_F2
Shortcut_F3
Shortcut_F4
Shortcut_F5
Shortcut_F6
Shortcut_F7
Shortcut_F8
Shortcut_F9
Shortcut_Ins
Shortcut_None
Shortcut_ShiftDel
Shortcut_ShiftF1
Shortcut_ShiftF10
Shortcut_ShiftF11
Shortcut_ShiftF12
Shortcut_ShiftF2
Shortcut_ShiftF3
Shortcut_ShiftF4
Shortcut_ShiftF5
Shortcut_ShiftF6
Shortcut_ShiftF7
Shortcut_ShiftF8
Shortcut_ShiftF9
Shortcut_ShiftIns
SortOrder_Ascending
SortOrder_Descending
SortOrder_None
SpecialFolder_ApplicationData
SpecialFolder_CommonApplicationData
SpecialFolder_CommonProgramFiles
SpecialFolder_Cookies
SpecialFolder_Desktop
SpecialFolder_DesktopDirectory
SpecialFolder_Favorites
SpecialFolder_History
SpecialFolder_InternetCache
SpecialFolder_LocalApplicationData
SpecialFolder_MyComputer
SpecialFolder_MyMusic
SpecialFolder_MyPictures
SpecialFolder_Personal
SpecialFolder_ProgramFiles
SpecialFolder_Programs
SpecialFolder_Recent
SpecialFolder_SendTo
SpecialFolder_StartMenu
SpecialFolder_Startup
SpecialFolder_System
SpecialFolder_Templates
StatusBarPanelAutoSize_Contents
StatusBarPanelAutoSize_None
StatusBarPanelAutoSize_Spring
StatusBarPanelBorderStyle_None
StatusBarPanelBorderStyle_Raised
StatusBarPanelBorderStyle_Sunken
TabAlignment_Bottom
TabAlignment_Left
TabAlignment_Right
TabAlignment_Top
TabAppearance_Buttons
TabAppearance_FlatButtons
TabAppearance_Normal
TabSizeMode_FillToRight
TabSizeMode_Fixed
TabSizeMode_Normal
ToolBarAppearance_Flat
ToolBarAppearance_Normal
ToolBarButtonStyle_DropDownButton
ToolBarButtonStyle_PushButton
ToolBarButtonStyle_Separator
ToolBarButtonStyle_ToggleButton
ToolBarTextAlign_Right
ToolBarTextAlign_Underneath
TreeViewAction_ByKeyboard
TreeViewAction_ByMouse
TreeViewAction_Collapse
TreeViewAction_Expand
TreeViewAction_Unknown
View_Details
View_LargeIcon
View_List
View_SmallIcon
XmlReadMode_Auto
XmlReadMode_DiffGram
XmlReadMode_Fragment
XmlReadMode_IgnoreSchema
XmlReadMode_InferSchema
XmlReadMode_ReadSchema
XmlWriteMode_DiffGram
XmlWriteMode_IgnoreSchema
XmlWriteMode_WriteSchema

Public Instance Properties

Build |
EventArgs | Gets the event arguments that are associated with the action that raised the last event.
ProductName |
ProductVersion |
Sender | The source (object) of the last event.

Public Instance Methods

Application | Initializes a new instance of the Application class.
ArrayList | Creates a new instance of the ArrayList class.
Bitmap | Initializes a new instance of the Bitmap class.
Button | Initializes a new instance of the Button class.
CheckBox | Initializes a new instance of the CheckBox class.
Collection | Initializes a new instance of the Collection class.
Color | Initializes a new instance of the Color class.
ColumnHeader | Initializes a new instance of the ColumnHeader class.
ComboBox | Initializes a new instance of the ComboBox class.
ContextMenu | Initializes a new instance of the ContextMenu class.
Cursor | Initializes a new instance of the Cursor class.
Cursors | Initializes a new instance of the Cursors class.
DataColumn | Initializes a new instance of the DataColumn class.
DataGrid | Initializes a new instance of the DataGrid class.
DataGridCell | Initializes a new instance of the DataGridCell class.
DataGridTableStyle | Initializes a new instance of the DataGridTableStyle class.
DataSet | Initializes a new instance of the DataSet class.
DataTable | Initializes a new instance of the DataTable class.
DataView | Initializes a new instance of the DataView class.
DictionaryEntry | Initializes a new instance of the DictionaryEntry class.
Dns | Provides simple domain name resolution functionality.
DoEvents | Returns the next event in the event queue.
Encoding | Initializes a new instance of the Encoding class.
Environment | Initializes a new instance of the Environment class.
File | Initializes a new instance of the File class.
FileStream | Initializes a new instance of the FileStream class.
FolderBrowserDialog | Initializes a new instance of the FolderBrowserDialog class.
Font | Initializes a new instance of the EventArgs class.
FontDialog | Initializes a new instance of the FontDialog class.
Form | Initializes a new instance of the Form class.
Graphics | Initializes a new instance of the Graphics class.
GroupBox | Initializes a new instance of the GroupBox class.
HatchBrush | Initializes a new instance of the HatchBrush class.
Icon | Initializes a new instance of the Icon class.
Image | Initializes a new instance of the Image class.
ImageFormat | Initializes a new instance of the ImageFormat class.
ImageList | Initializes a new instance of the ImageList class.
InputBox | Initializes a new instance of the InputBox class.
IPAddress | Initializes a new instance of the IPAddress.
IPHostEntry | Provides a container class for Internet host address information.
Label |
LinearGradientBrush |
ListBox | Initializes a new instance of the ListBox class.
ListItem | Initializes a new instance of the ListItem class.
ListView | Initializes a new instance of the ListView class.
ListViewItem | Initializes a new instance of the ListViewItem class.
ListViewSubItem | Initializes a new instance of the ListViweSubItem class.
MainMenu | Initializes a new instance of the MainMenu class.
Math | Initializes a new instance of the Math class.
MemoryStream | Initializes a new instance of the MemoryStream class.
MenuItem | Initializes a new instance of the MenuItem class.
MessageBox | Initializes a new instance of the MessageBox class.
Nothing | Initializes a new instance of the Nothing class.
NotifyIcon | Initializes a new instance of the NotifyIcon class.
NumericUpDown | Initializes a new instance of the NumericUpDown class.
OpenFileDialog | Initializes a new instance of the OpenFileDialog class.
Panel | Initializes a new instance of the Panel class.
Pen | Initializes a new instance of the Pen class.
PictureBox | Initializes a new instance of the PictureBox class.
Point | Initializes a new instance of the Point class.
PrintDialog | Initializes a new instance of the PrintDialog class.
Process | Initializes a new instance of the Process class.
ProcessStartInfo | Initializes a new instance of the ProcessStartInfo class.
ProgressBar | Initializes a new instance of the ProgressBar class.
PropertyGrid | Initializes a new instance of the PropertyGrid class.
RadioButton | Initializes a new instance of the RadioButton class.
Rectangle | Initializes a new instance of the Rectangle class.
RichTextBox | Initializes a new instance of the RichTextBox class.
SaveFileDialog | Initializes a new instance of the SaveFileDialog class.
Screen | Initializes a new instance of the Screen class.
Size | Initializes a new instance of the Size class.
SolidBrush | Initializes a new instance of the SolidBrush class.
SortedList | Initializes a new instance of the SortedList class.
Sound | Initializes a new instance of the Sound class.
Splitter | Initializes a new instance of the Splitter class.
StatusBar | Initializes a new instance of the StatusBar class.
StatusBarPanel |
StreamReader |
StreamWriter |
TabControl |
TabPage |
TCPClient | Provides client connections for TCP network services.
TCPListener | Listens for connections from TCP network clients.
TextBox |
TextureBrush | Initializes a new instance of the SolidBrush class.
Timer |
ToolBar |
ToolBarButton |
ToolTip | Initializes a new instance of the ToolTip class.
TreeNode | Initializes a new instance of the TreeNode class.
TreeView | Initializes a new instance of the TreeView class.
Type |
UserControl | Experimental. Initializes a new instance of the UserControl class.
VScrollBar | Initializes a new instance of the VScrollBar class.

See Also

System Class | Kixforms Namespace


System Constructor

Initializes a new instance of the System Class.

[Visual Basic]
Public Sub New()
[C#]
public System();

See Also

System Class | Kixforms Namespace


System Fields

The fields of the System class are listed below. For a complete list of System class members, see the System Members topic.

Public Instance Fields

AnchorStyles_Bottom
AnchorStyles_Left
AnchorStyles_None
AnchorStyles_Right
AnchorStyles_Top
Appearance_Button
Appearance_Normal
BorderStyle_Fixed3D
BorderStyle_FixedSingle
BorderStyle_None
CharacterCasing_Lower
CharacterCasing_Normal
CharacterCasing_Upper
CheckState_Checked
CheckState_Indeterminate
CheckState_Unchecked
ColorDepth_Depth16Bit
ColorDepth_Depth24Bit
ColorDepth_Depth32Bit
ColorDepth_Depth4Bit
ColorDepth_Depth8Bit
ColumnHeaderStyle_Clickable
ColumnHeaderStyle_Nonclickable
ColumnHeaderStyle_None
ComboBoxStyle_DropDown
ComboBoxStyle_DropDownList
ComboBoxStyle_Simple
ContentAlignment_BottomCenter
ContentAlignment_BottomLeft
ContentAlignment_BottomRight
ContentAlignment_MiddleCenter
ContentAlignment_MiddleLeft
ContentAlignment_MiddleRight
ContentAlignment_TopCenter
ContentAlignment_TopLeft
ContentAlignment_TopRight
DialogResult_Abort
DialogResult_Cancel
DialogResult_Ignore
DialogResult_No
DialogResult_None
DialogResult_OK
DialogResult_Retry
DialogResult_Yes
DockStyle_Bottom
DockStyle_Fill
DockStyle_Left
DockStyle_None
DockStyle_Right
DockStyle_Top
FileAccess_Read
FileAccess_ReadWrite
FileAccess_Write
FileMode_Append
FileMode_Create
FileMode_CreateNew
FileMode_Open
FileMode_OpenOrCreate
FileMode_Truncate
FileShare_None
FileShare_Read
FileShare_ReadWrite
FileShare_Write
FlatStyle_Flat
FlatStyle_Popup
FlatStyle_Standard
FlatStyle_System
FontStyle_Bold
FontStyle_Italic
FontStyle_Regular
FontStyle_Strikeout
FontStyle_Underline
FormBorderStyle_Fixed3D
FormBorderStyle_FixedDialog
FormBorderStyle_FixedSingle
FormBorderStyle_FixedToolWindow
FormBorderStyle_None
FormBorderStyle_Sizable
FormBorderStyle_SizableToolWindow
FormStartPosition_CenterParent
FormStartPosition_CenterScreen
FormStartPosition_Manual
FormStartPosition_WindowsDefaultBounds
FormStartPosition_WindowsDefaultLocation
FormWindowState_Maximized
FormWindowState_Minimized
FormWindowState_Normal
HatchStyle_BackwardDiagonal
HatchStyle_Cross
HatchStyle_DarkDownwardDiagonal
HatchStyle_DarkHorizontal
HatchStyle_DarkUpwardDiagonal
HatchStyle_DarkVertical
HatchStyle_DashedDownwardDiagonal
HatchStyle_DashedHorizontal
HatchStyle_DashedUpwardDiagonal
HatchStyle_DashedVertical
HatchStyle_DiagonalBrick
HatchStyle_DiagonalCross
HatchStyle_Divot
HatchStyle_DottedDiamond
HatchStyle_DottedGrid
HatchStyle_ForwardDiagonal
HatchStyle_Horizontal
HatchStyle_HorizontalBrick
HatchStyle_LargeCheckerBoard
HatchStyle_LargeConfetti
HatchStyle_LargeGrid
HatchStyle_LightDownwardDiagonal
HatchStyle_LightHorizontal
HatchStyle_LightUpwardDiagonal
HatchStyle_LightVertical
HatchStyle_Max
HatchStyle_Min
HatchStyle_NarrowHorizontal
HatchStyle_NarrowVertical
HatchStyle_OutlinedDiamond
HatchStyle_Percent05
HatchStyle_Percent10
HatchStyle_Percent20
HatchStyle_Percent25
HatchStyle_Percent30
HatchStyle_Percent40
HatchStyle_Percent50
HatchStyle_Percent60
HatchStyle_Percent70
HatchStyle_Percent75
HatchStyle_Percent80
HatchStyle_Percent90
HatchStyle_Plaid
HatchStyle_Shingle
HatchStyle_SmallCheckerBoard
HatchStyle_SmallConfetti
HatchStyle_SmallGrid
HatchStyle_SolidDiamond
HatchStyle_Sphere
HatchStyle_Trellis
HatchStyle_Vertical
HatchStyle_Wave
HatchStyle_Weave
HatchStyle_WideDownwardDiagonal
HatchStyle_WideUpwardDiagonal
HatchStyle_ZigZag
HorizontalAlignment_Center
HorizontalAlignment_Left
HorizontalAlignment_Right
ItemActivation_OneClick
ItemActivation_Standard
ItemActivation_TwoClick
Keys_A
Keys_Add
Keys_Alt
Keys_Apps
Keys_Attn
Keys_B
Keys_Back
Keys_BrowserBack
Keys_BrowserFavorites
Keys_BrowserForward
Keys_BrowserHome
Keys_BrowserRefresh
Keys_BrowserSearch
Keys_BrowserStop
Keys_C
Keys_Cancel
Keys_Capital
Keys_CapsLock
Keys_Clear
Keys_Control
Keys_ControlKey
Keys_Crsel
Keys_D
Keys_D0
Keys_D1
Keys_D2
Keys_D3
Keys_D4
Keys_D5
Keys_D6
Keys_D7
Keys_D8
Keys_D9
Keys_Decimal
Keys_Delete
Keys_Divide
Keys_Down
Keys_E
Keys_End
Keys_Enter
Keys_EraseEof
Keys_Escape
Keys_Execute
Keys_Exsel
Keys_F
Keys_F1
Keys_F10
Keys_F11
Keys_F12
Keys_F13
Keys_F14
Keys_F15
Keys_F16
Keys_F17
Keys_F18
Keys_F19
Keys_F2
Keys_F20
Keys_F21
Keys_F22
Keys_F23
Keys_F24
Keys_F3
Keys_F4
Keys_F5
Keys_F6
Keys_F7
Keys_F8
Keys_F9
Keys_FinalMode
Keys_G
Keys_H
Keys_HanguelMode
Keys_HangulMode
Keys_HanjaMode
Keys_Help
Keys_Home
Keys_I
Keys_IMEAceept
Keys_IMEConvert
Keys_IMEModeChange
Keys_IMENonconvert
Keys_Insert
Keys_J
Keys_JunjaMode
Keys_K
Keys_KanaMode
Keys_KanjiMode
Keys_KeyCode
Keys_L
Keys_LaunchApplication1
Keys_LaunchApplication2
Keys_LaunchMail
Keys_LButton
Keys_LControlKey
Keys_Left
Keys_LineFeed
Keys_LMenu
Keys_LShiftKey
Keys_LWin
Keys_M
Keys_MButton
Keys_MediaNextTrack
Keys_MediaPlayPause
Keys_MediaPreviousTrack
Keys_MediaStop
Keys_Menu
Keys_Modifiers
Keys_Multiply
Keys_N
Keys_Next
Keys_NoName
Keys_None
Keys_NumLock
Keys_NumPad0
Keys_NumPad1
Keys_NumPad2
Keys_NumPad3
Keys_NumPad4
Keys_NumPad5
Keys_NumPad6
Keys_NumPad7
Keys_NumPad8
Keys_NumPad9
Keys_O
Keys_Oem8
Keys_OemBackslash
Keys_OemClear
Keys_OemCloseBrackets
Keys_Oemcomma
Keys_OemMinus
Keys_OemOpenBrackets
Keys_OemPeriod
Keys_OemPipe
Keys_Oemplus
Keys_OemQuestion
Keys_OemQuotes
Keys_OemSemicolon
Keys_Oemtilde
Keys_P
Keys_Pa1
Keys_PageDown
Keys_PageUp
Keys_Pause
Keys_Play
Keys_Print
Keys_PrintScreen
Keys_Prior
Keys_ProcessKey
Keys_Q
Keys_R
Keys_RButton
Keys_RControlKey
Keys_Return
Keys_Right
Keys_RMenu
Keys_RShiftKey
Keys_RWin
Keys_S
Keys_Scroll
Keys_Select
Keys_SelectMedia
Keys_Separator
Keys_Shift
Keys_ShiftKey
Keys_Snapshot
Keys_Space
Keys_Subtract
Keys_T
Keys_Tab
Keys_U
Keys_Up
Keys_V
Keys_VolumeDown
Keys_VolumeMute
Keys_VolumeUp
Keys_W
Keys_X
Keys_XButton1
Keys_XButton2
Keys_Y
Keys_Z
Keys_Zoom
ListViewAlignment_Default
ListViewAlignment_Left
ListViewAlignment_SnapToGrid
ListViewAlignment_Top
MdiLayout_ArrangeIcons
MdiLayout_Cascade
MdiLayout_TileHorizontal
MdiLayout_TileVertical
MenuMerge_Add
MenuMerge_MergeItems
MenuMerge_Remove
MenuMerge_Replace
MessageBoxButtons_Add
MessageBoxButtons_OK
MessageBoxButtons_OKCancel
MessageBoxButtons_RetryCancel
MessageBoxButtons_YesNo
MessageBoxButtons_YesNoCancel
MessageBoxIcon_Asterisk
MessageBoxIcon_Error
MessageBoxIcon_Exclamation
MessageBoxIcon_Hand
MessageBoxIcon_Information
MessageBoxIcon_None
MessageBoxIcon_Question
MessageBoxIcon_Stop
MessageBoxIcon_Warning
MouseButtons_Left
MouseButtons_Middle
MouseButtons_Right
PictureBoxSizeMode_AutoSize
PictureBoxSizeMode_CenterImage
PictureBoxSizeMode_Normal
PictureBoxSizeMode_StretchImage
ProcessWindowStyle_Hidden
ProcessWindowStyle_Maximized
ProcessWindowStyle_Minimized
ProcessWindowStyle_Normal
PropertySort_Alphabetical
PropertySort_Categorized
PropertySort_CategorizedAlphabetical
PropertySort_NoSort
RichTextBoxFinds_MatchCase
RichTextBoxFinds_NoHighlight
RichTextBoxFinds_None
RichTextBoxFinds_Reverse
RichTextBoxFinds_WholeWord
RichTextBoxStreamType_PlainText
RichTextBoxStreamType_RichNoOleObjs
RichTextBoxStreamType_RichText
RichTextBoxStreamType_TextTextOleObjs
RichTextBoxStreamType_UnicodePlainText
ScrollBars_Both
ScrollBars_Horizontal
ScrollBars_None
ScrollBars_Vertical
SeekOrigin_Begin
SeekOrigin_Current
SeekOrigin_End
SelectionMode_MultiExtended
SelectionMode_MultiSimple
SelectionMode_None
SelectionMode_One
Shortcut_Alt0
Shortcut_Alt1
Shortcut_Alt2
Shortcut_Alt3
Shortcut_Alt4
Shortcut_Alt5
Shortcut_Alt6
Shortcut_Alt7
Shortcut_Alt8
Shortcut_Alt9
Shortcut_AltBksp
Shortcut_AltF1
Shortcut_AltF10
Shortcut_AltF11
Shortcut_AltF12
Shortcut_AltF2
Shortcut_AltF3
Shortcut_AltF4
Shortcut_AltF5
Shortcut_AltF6
Shortcut_AltF7
Shortcut_AltF8
Shortcut_AltF9
Shortcut_Ctrl0
Shortcut_Ctrl1
Shortcut_Ctrl2
Shortcut_Ctrl3
Shortcut_Ctrl4
Shortcut_Ctrl5
Shortcut_Ctrl6
Shortcut_Ctrl7
Shortcut_Ctrl8
Shortcut_Ctrl9
Shortcut_CtrlA
Shortcut_CtrlB
Shortcut_CtrlC
Shortcut_CtrlD
Shortcut_CtrlDel
Shortcut_CtrlE
Shortcut_CtrlF
Shortcut_CtrlF1
Shortcut_CtrlF10
Shortcut_CtrlF11
Shortcut_CtrlF12
Shortcut_CtrlF2
Shortcut_CtrlF3
Shortcut_CtrlF4
Shortcut_CtrlF5
Shortcut_CtrlF6
Shortcut_CtrlF7
Shortcut_CtrlF8
Shortcut_CtrlF9
Shortcut_CtrlG
Shortcut_CtrlH
Shortcut_CtrlI
Shortcut_CtrlIns
Shortcut_CtrlJ
Shortcut_CtrlK
Shortcut_CtrlL
Shortcut_CtrlM
Shortcut_CtrlN
Shortcut_CtrlO
Shortcut_CtrlP
Shortcut_CtrlQ
Shortcut_CtrlR
Shortcut_CtrlS
Shortcut_CtrlShift0
Shortcut_CtrlShift1
Shortcut_CtrlShift2
Shortcut_CtrlShift3
Shortcut_CtrlShift4
Shortcut_CtrlShift5
Shortcut_CtrlShift6
Shortcut_CtrlShift7
Shortcut_CtrlShift8
Shortcut_CtrlShift9
Shortcut_CtrlShiftA
Shortcut_CtrlShiftB
Shortcut_CtrlShiftC
Shortcut_CtrlShiftD
Shortcut_CtrlShiftE
Shortcut_CtrlShiftF
Shortcut_CtrlShiftF1
Shortcut_CtrlShiftF10
Shortcut_CtrlShiftF11
Shortcut_CtrlShiftF12
Shortcut_CtrlShiftF2
Shortcut_CtrlShiftF3
Shortcut_CtrlShiftF4
Shortcut_CtrlShiftF5
Shortcut_CtrlShiftF6
Shortcut_CtrlShiftF7
Shortcut_CtrlShiftF8
Shortcut_CtrlShiftF9
Shortcut_CtrlShiftG
Shortcut_CtrlShiftH
Shortcut_CtrlShiftI
Shortcut_CtrlShiftJ
Shortcut_CtrlShiftK
Shortcut_CtrlShiftL
Shortcut_CtrlShiftM
Shortcut_CtrlShiftN
Shortcut_CtrlShiftO
Shortcut_CtrlShiftP
Shortcut_CtrlShiftQ
Shortcut_CtrlShiftR
Shortcut_CtrlShiftS
Shortcut_CtrlShiftT
Shortcut_CtrlShiftU
Shortcut_CtrlShiftV
Shortcut_CtrlShiftW
Shortcut_CtrlShiftX
Shortcut_CtrlShiftY
Shortcut_CtrlShiftZ
Shortcut_CtrlT
Shortcut_CtrlU
Shortcut_CtrlV
Shortcut_CtrlW
Shortcut_CtrlX
Shortcut_CtrlY
Shortcut_CtrlZ
Shortcut_Del
Shortcut_F1
Shortcut_F10
Shortcut_F11
Shortcut_F12
Shortcut_F2
Shortcut_F3
Shortcut_F4
Shortcut_F5
Shortcut_F6
Shortcut_F7
Shortcut_F8
Shortcut_F9
Shortcut_Ins
Shortcut_None
Shortcut_ShiftDel
Shortcut_ShiftF1
Shortcut_ShiftF10
Shortcut_ShiftF11
Shortcut_ShiftF12
Shortcut_ShiftF2
Shortcut_ShiftF3
Shortcut_ShiftF4
Shortcut_ShiftF5
Shortcut_ShiftF6
Shortcut_ShiftF7
Shortcut_ShiftF8
Shortcut_ShiftF9
Shortcut_ShiftIns
SortOrder_Ascending
SortOrder_Descending
SortOrder_None
SpecialFolder_ApplicationData
SpecialFolder_CommonApplicationData
SpecialFolder_CommonProgramFiles
SpecialFolder_Cookies
SpecialFolder_Desktop
SpecialFolder_DesktopDirectory
SpecialFolder_Favorites
SpecialFolder_History
SpecialFolder_InternetCache
SpecialFolder_LocalApplicationData
SpecialFolder_MyComputer
SpecialFolder_MyMusic
SpecialFolder_MyPictures
SpecialFolder_Personal
SpecialFolder_ProgramFiles
SpecialFolder_Programs
SpecialFolder_Recent
SpecialFolder_SendTo
SpecialFolder_StartMenu
SpecialFolder_Startup
SpecialFolder_System
SpecialFolder_Templates
StatusBarPanelAutoSize_Contents
StatusBarPanelAutoSize_None
StatusBarPanelAutoSize_Spring
StatusBarPanelBorderStyle_None
StatusBarPanelBorderStyle_Raised
StatusBarPanelBorderStyle_Sunken
TabAlignment_Bottom
TabAlignment_Left
TabAlignment_Right
TabAlignment_Top
TabAppearance_Buttons
TabAppearance_FlatButtons
TabAppearance_Normal
TabSizeMode_FillToRight
TabSizeMode_Fixed
TabSizeMode_Normal
ToolBarAppearance_Flat
ToolBarAppearance_Normal
ToolBarButtonStyle_DropDownButton
ToolBarButtonStyle_PushButton
ToolBarButtonStyle_Separator
ToolBarButtonStyle_ToggleButton
ToolBarTextAlign_Right
ToolBarTextAlign_Underneath
TreeViewAction_ByKeyboard
TreeViewAction_ByMouse
TreeViewAction_Collapse
TreeViewAction_Expand
TreeViewAction_Unknown
View_Details
View_LargeIcon
View_List
View_SmallIcon
XmlReadMode_Auto
XmlReadMode_DiffGram
XmlReadMode_Fragment
XmlReadMode_IgnoreSchema
XmlReadMode_InferSchema
XmlReadMode_ReadSchema
XmlWriteMode_DiffGram
XmlWriteMode_IgnoreSchema
XmlWriteMode_WriteSchema

See Also

System Class | Kixforms Namespace


System.AnchorStyles_Bottom Field

[Visual Basic]
Public AnchorStyles_Bottom As AnchorStyles
[C#]
public AnchorStyles AnchorStyles_Bottom;

See Also

System Class | Kixforms Namespace


System.AnchorStyles_Left Field

[Visual Basic]
Public AnchorStyles_Left As AnchorStyles
[C#]
public AnchorStyles AnchorStyles_Left;

See Also

System Class | Kixforms Namespace


System.AnchorStyles_None Field

[Visual Basic]
Public AnchorStyles_None As AnchorStyles
[C#]
public AnchorStyles AnchorStyles_None;

See Also

System Class | Kixforms Namespace


System.AnchorStyles_Right Field

[Visual Basic]
Public AnchorStyles_Right As AnchorStyles
[C#]
public AnchorStyles AnchorStyles_Right;

See Also

System Class | Kixforms Namespace


System.AnchorStyles_Top Field

[Visual Basic]
Public AnchorStyles_Top As AnchorStyles
[C#]
public AnchorStyles AnchorStyles_Top;

See Also

System Class | Kixforms Namespace


System.Appearance_Button Field

[Visual Basic]
Public Appearance_Button As Appearance
[C#]
public Appearance Appearance_Button;

See Also

System Class | Kixforms Namespace


System.Appearance_Normal Field

[Visual Basic]
Public Appearance_Normal As Appearance
[C#]
public Appearance Appearance_Normal;

See Also

System Class | Kixforms Namespace


System.BorderStyle_Fixed3D Field

[Visual Basic]
Public BorderStyle_Fixed3D As BorderStyle
[C#]
public BorderStyle BorderStyle_Fixed3D;

See Also

System Class | Kixforms Namespace


System.BorderStyle_FixedSingle Field

[Visual Basic]
Public BorderStyle_FixedSingle As BorderStyle
[C#]
public BorderStyle BorderStyle_FixedSingle;

See Also

System Class | Kixforms Namespace


System.BorderStyle_None Field

[Visual Basic]
Public BorderStyle_None As BorderStyle
[C#]
public BorderStyle BorderStyle_None;

See Also

System Class | Kixforms Namespace


System.CharacterCasing_Lower Field

[Visual Basic]
Public CharacterCasing_Lower As CharacterCasing
[C#]
public CharacterCasing CharacterCasing_Lower;

See Also

System Class | Kixforms Namespace


System.CharacterCasing_Normal Field

[Visual Basic]
Public CharacterCasing_Normal As CharacterCasing
[C#]
public CharacterCasing CharacterCasing_Normal;

See Also

System Class | Kixforms Namespace


System.CharacterCasing_Upper Field

[Visual Basic]
Public CharacterCasing_Upper As CharacterCasing
[C#]
public CharacterCasing CharacterCasing_Upper;

See Also

System Class | Kixforms Namespace


System.CheckState_Checked Field

[Visual Basic]
Public CheckState_Checked As CheckState
[C#]
public CheckState CheckState_Checked;

See Also

System Class | Kixforms Namespace


System.CheckState_Indeterminate Field

[Visual Basic]
Public CheckState_Indeterminate As CheckState
[C#]
public CheckState CheckState_Indeterminate;

See Also

System Class | Kixforms Namespace


System.CheckState_Unchecked Field

[Visual Basic]
Public CheckState_Unchecked As CheckState
[C#]
public CheckState CheckState_Unchecked;

See Also

System Class | Kixforms Namespace


System.ColorDepth_Depth16Bit Field

[Visual Basic]
Public ColorDepth_Depth16Bit As ColorDepth
[C#]
public ColorDepth ColorDepth_Depth16Bit;

See Also

System Class | Kixforms Namespace


System.ColorDepth_Depth24Bit Field

[Visual Basic]
Public ColorDepth_Depth24Bit As ColorDepth
[C#]
public ColorDepth ColorDepth_Depth24Bit;

See Also

System Class | Kixforms Namespace


System.ColorDepth_Depth32Bit Field

[Visual Basic]
Public ColorDepth_Depth32Bit As ColorDepth
[C#]
public ColorDepth ColorDepth_Depth32Bit;

See Also

System Class | Kixforms Namespace


System.ColorDepth_Depth4Bit Field

[Visual Basic]
Public ColorDepth_Depth4Bit As ColorDepth
[C#]
public ColorDepth ColorDepth_Depth4Bit;

See Also

System Class | Kixforms Namespace


System.ColorDepth_Depth8Bit Field

[Visual Basic]
Public ColorDepth_Depth8Bit As ColorDepth
[C#]
public ColorDepth ColorDepth_Depth8Bit;

See Also

System Class | Kixforms Namespace


System.ColumnHeaderStyle_Clickable Field

[Visual Basic]
Public ColumnHeaderStyle_Clickable As ColumnHeaderStyle
[C#]
public ColumnHeaderStyle ColumnHeaderStyle_Clickable;

See Also

System Class | Kixforms Namespace


System.ColumnHeaderStyle_Nonclickable Field

[Visual Basic]
Public ColumnHeaderStyle_Nonclickable As ColumnHeaderStyle
[C#]
public ColumnHeaderStyle ColumnHeaderStyle_Nonclickable;

See Also

System Class | Kixforms Namespace


System.ColumnHeaderStyle_None Field

[Visual Basic]
Public ColumnHeaderStyle_None As ColumnHeaderStyle
[C#]
public ColumnHeaderStyle ColumnHeaderStyle_None;

See Also

System Class | Kixforms Namespace


System.ComboBoxStyle_DropDown Field

[Visual Basic]
Public ComboBoxStyle_DropDown As ComboBoxStyle
[C#]
public ComboBoxStyle ComboBoxStyle_DropDown;

See Also

System Class | Kixforms Namespace


System.ComboBoxStyle_DropDownList Field

[Visual Basic]
Public ComboBoxStyle_DropDownList As ComboBoxStyle
[C#]
public ComboBoxStyle ComboBoxStyle_DropDownList;

See Also

System Class | Kixforms Namespace


System.ComboBoxStyle_Simple Field

[Visual Basic]
Public ComboBoxStyle_Simple As ComboBoxStyle
[C#]
public ComboBoxStyle ComboBoxStyle_Simple;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_BottomCenter Field

[Visual Basic]
Public ContentAlignment_BottomCenter As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_BottomCenter;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_BottomLeft Field

[Visual Basic]
Public ContentAlignment_BottomLeft As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_BottomLeft;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_BottomRight Field

[Visual Basic]
Public ContentAlignment_BottomRight As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_BottomRight;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_MiddleCenter Field

[Visual Basic]
Public ContentAlignment_MiddleCenter As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_MiddleCenter;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_MiddleLeft Field

[Visual Basic]
Public ContentAlignment_MiddleLeft As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_MiddleLeft;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_MiddleRight Field

[Visual Basic]
Public ContentAlignment_MiddleRight As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_MiddleRight;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_TopCenter Field

[Visual Basic]
Public ContentAlignment_TopCenter As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_TopCenter;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_TopLeft Field

[Visual Basic]
Public ContentAlignment_TopLeft As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_TopLeft;

See Also

System Class | Kixforms Namespace


System.ContentAlignment_TopRight Field

[Visual Basic]
Public ContentAlignment_TopRight As ContentAlignment
[C#]
public ContentAlignment ContentAlignment_TopRight;

See Also

System Class | Kixforms Namespace


System.DialogResult_Abort Field

[Visual Basic]
Public DialogResult_Abort As DialogResult
[C#]
public DialogResult DialogResult_Abort;

See Also

System Class | Kixforms Namespace


System.DialogResult_Cancel Field

[Visual Basic]
Public DialogResult_Cancel As DialogResult
[C#]
public DialogResult DialogResult_Cancel;

See Also

System Class | Kixforms Namespace


System.DialogResult_Ignore Field

[Visual Basic]
Public DialogResult_Ignore As DialogResult
[C#]
public DialogResult DialogResult_Ignore;

See Also

System Class | Kixforms Namespace


System.DialogResult_No Field

[Visual Basic]
Public DialogResult_No As DialogResult
[C#]
public DialogResult DialogResult_No;

See Also

System Class | Kixforms Namespace


System.DialogResult_None Field

[Visual Basic]
Public DialogResult_None As DialogResult
[C#]
public DialogResult DialogResult_None;

See Also

System Class | Kixforms Namespace


System.DialogResult_OK Field

[Visual Basic]
Public DialogResult_OK As DialogResult
[C#]
public DialogResult DialogResult_OK;

See Also

System Class | Kixforms Namespace


System.DialogResult_Retry Field

[Visual Basic]
Public DialogResult_Retry As DialogResult
[C#]
public DialogResult DialogResult_Retry;

See Also

System Class | Kixforms Namespace


System.DialogResult_Yes Field

[Visual Basic]
Public DialogResult_Yes As DialogResult
[C#]
public DialogResult DialogResult_Yes;

See Also

System Class | Kixforms Namespace


System.DockStyle_Bottom Field

[Visual Basic]
Public DockStyle_Bottom As DockStyle
[C#]
public DockStyle DockStyle_Bottom;

See Also

System Class | Kixforms Namespace


System.DockStyle_Fill Field

[Visual Basic]
Public DockStyle_Fill As DockStyle
[C#]
public DockStyle DockStyle_Fill;

See Also

System Class | Kixforms Namespace


System.DockStyle_Left Field

[Visual Basic]
Public DockStyle_Left As DockStyle
[C#]
public DockStyle DockStyle_Left;

See Also

System Class | Kixforms Namespace


System.DockStyle_None Field

[Visual Basic]
Public DockStyle_None As DockStyle
[C#]
public DockStyle DockStyle_None;

See Also

System Class | Kixforms Namespace


System.DockStyle_Right Field

[Visual Basic]
Public DockStyle_Right As DockStyle
[C#]
public DockStyle DockStyle_Right;

See Also

System Class | Kixforms Namespace


System.DockStyle_Top Field

[Visual Basic]
Public DockStyle_Top As DockStyle
[C#]
public DockStyle DockStyle_Top;

See Also

System Class | Kixforms Namespace


System.FileAccess_Read Field

[Visual Basic]
Public FileAccess_Read As FileAccess
[C#]
public FileAccess FileAccess_Read;

See Also

System Class | Kixforms Namespace


System.FileAccess_ReadWrite Field

[Visual Basic]
Public FileAccess_ReadWrite As FileAccess
[C#]
public FileAccess FileAccess_ReadWrite;

See Also

System Class | Kixforms Namespace


System.FileAccess_Write Field

[Visual Basic]
Public FileAccess_Write As FileAccess
[C#]
public FileAccess FileAccess_Write;

See Also

System Class | Kixforms Namespace


System.FileMode_Append Field

[Visual Basic]
Public FileMode_Append As FileMode
[C#]
public FileMode FileMode_Append;

See Also

System Class | Kixforms Namespace


System.FileMode_Create Field

[Visual Basic]
Public FileMode_Create As FileMode
[C#]
public FileMode FileMode_Create;

See Also

System Class | Kixforms Namespace


System.FileMode_CreateNew Field

[Visual Basic]
Public FileMode_CreateNew As FileMode
[C#]
public FileMode FileMode_CreateNew;

See Also

System Class | Kixforms Namespace


System.FileMode_Open Field

[Visual Basic]
Public FileMode_Open As FileMode
[C#]
public FileMode FileMode_Open;

See Also

System Class | Kixforms Namespace


System.FileMode_OpenOrCreate Field

[Visual Basic]
Public FileMode_OpenOrCreate As FileMode
[C#]
public FileMode FileMode_OpenOrCreate;

See Also

System Class | Kixforms Namespace


System.FileMode_Truncate Field

[Visual Basic]
Public FileMode_Truncate As FileMode
[C#]
public FileMode FileMode_Truncate;

See Also

System Class | Kixforms Namespace


System.FileShare_None Field

[Visual Basic]
Public FileShare_None As FileShare
[C#]
public FileShare FileShare_None;

See Also

System Class | Kixforms Namespace


System.FileShare_Read Field

[Visual Basic]
Public FileShare_Read As FileShare
[C#]
public FileShare FileShare_Read;

See Also

System Class | Kixforms Namespace


System.FileShare_ReadWrite Field

[Visual Basic]
Public FileShare_ReadWrite As FileShare
[C#]
public FileShare FileShare_ReadWrite;

See Also

System Class | Kixforms Namespace


System.FileShare_Write Field

[Visual Basic]
Public FileShare_Write As FileShare
[C#]
public FileShare FileShare_Write;

See Also

System Class | Kixforms Namespace


System.FlatStyle_Flat Field

[Visual Basic]
Public FlatStyle_Flat As FlatStyle
[C#]
public FlatStyle FlatStyle_Flat;

See Also

System Class | Kixforms Namespace


System.FlatStyle_Popup Field

[Visual Basic]
Public FlatStyle_Popup As FlatStyle
[C#]
public FlatStyle FlatStyle_Popup;

See Also

System Class | Kixforms Namespace


System.FlatStyle_Standard Field

[Visual Basic]
Public FlatStyle_Standard As FlatStyle
[C#]
public FlatStyle FlatStyle_Standard;

See Also

System Class | Kixforms Namespace


System.FlatStyle_System Field

[Visual Basic]
Public FlatStyle_System As FlatStyle
[C#]
public FlatStyle FlatStyle_System;

See Also

System Class | Kixforms Namespace


System.FontStyle_Bold Field

[Visual Basic]
Public FontStyle_Bold As FontStyle
[C#]
public FontStyle FontStyle_Bold;

See Also

System Class | Kixforms Namespace


System.FontStyle_Italic Field

[Visual Basic]
Public FontStyle_Italic As FontStyle
[C#]
public FontStyle FontStyle_Italic;

See Also

System Class | Kixforms Namespace


System.FontStyle_Regular Field

[Visual Basic]
Public FontStyle_Regular As FontStyle
[C#]
public FontStyle FontStyle_Regular;

See Also

System Class | Kixforms Namespace


System.FontStyle_Strikeout Field

[Visual Basic]
Public FontStyle_Strikeout As FontStyle
[C#]
public FontStyle FontStyle_Strikeout;

See Also

System Class | Kixforms Namespace


System.FontStyle_Underline Field

[Visual Basic]
Public FontStyle_Underline As FontStyle
[C#]
public FontStyle FontStyle_Underline;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_Fixed3D Field

[Visual Basic]
Public FormBorderStyle_Fixed3D As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_Fixed3D;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_FixedDialog Field

[Visual Basic]
Public FormBorderStyle_FixedDialog As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_FixedDialog;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_FixedSingle Field

[Visual Basic]
Public FormBorderStyle_FixedSingle As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_FixedSingle;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_FixedToolWindow Field

[Visual Basic]
Public FormBorderStyle_FixedToolWindow As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_FixedToolWindow;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_None Field

[Visual Basic]
Public FormBorderStyle_None As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_None;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_Sizable Field

[Visual Basic]
Public FormBorderStyle_Sizable As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_Sizable;

See Also

System Class | Kixforms Namespace


System.FormBorderStyle_SizableToolWindow Field

[Visual Basic]
Public FormBorderStyle_SizableToolWindow As FormBorderStyle
[C#]
public FormBorderStyle FormBorderStyle_SizableToolWindow;

See Also

System Class | Kixforms Namespace


System.FormStartPosition_CenterParent Field

[Visual Basic]
Public FormStartPosition_CenterParent As FormStartPosition
[C#]
public FormStartPosition FormStartPosition_CenterParent;

See Also

System Class | Kixforms Namespace


System.FormStartPosition_CenterScreen Field

[Visual Basic]
Public FormStartPosition_CenterScreen As FormStartPosition
[C#]
public FormStartPosition FormStartPosition_CenterScreen;

See Also

System Class | Kixforms Namespace


System.FormStartPosition_Manual Field

[Visual Basic]
Public FormStartPosition_Manual As FormStartPosition
[C#]
public FormStartPosition FormStartPosition_Manual;

See Also

System Class | Kixforms Namespace


System.FormStartPosition_WindowsDefaultBounds Field

[Visual Basic]
Public FormStartPosition_WindowsDefaultBounds As FormStartPosition
[C#]
public FormStartPosition FormStartPosition_WindowsDefaultBounds;

See Also

System Class | Kixforms Namespace


System.FormStartPosition_WindowsDefaultLocation Field

[Visual Basic]
Public FormStartPosition_WindowsDefaultLocation As FormStartPosition
[C#]
public FormStartPosition FormStartPosition_WindowsDefaultLocation;

See Also

System Class | Kixforms Namespace


System.FormWindowState_Maximized Field

[Visual Basic]
Public FormWindowState_Maximized As FormWindowState
[C#]
public FormWindowState FormWindowState_Maximized;

See Also

System Class | Kixforms Namespace


System.FormWindowState_Minimized Field

[Visual Basic]
Public FormWindowState_Minimized As FormWindowState
[C#]
public FormWindowState FormWindowState_Minimized;

See Also

System Class | Kixforms Namespace


System.FormWindowState_Normal Field

[Visual Basic]
Public FormWindowState_Normal As FormWindowState
[C#]
public FormWindowState FormWindowState_Normal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_BackwardDiagonal Field

[Visual Basic]
Public HatchStyle_BackwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_BackwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Cross Field

[Visual Basic]
Public HatchStyle_Cross As HatchStyle
[C#]
public HatchStyle HatchStyle_Cross;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DarkDownwardDiagonal Field

[Visual Basic]
Public HatchStyle_DarkDownwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_DarkDownwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DarkHorizontal Field

[Visual Basic]
Public HatchStyle_DarkHorizontal As HatchStyle
[C#]
public HatchStyle HatchStyle_DarkHorizontal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DarkUpwardDiagonal Field

[Visual Basic]
Public HatchStyle_DarkUpwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_DarkUpwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DarkVertical Field

[Visual Basic]
Public HatchStyle_DarkVertical As HatchStyle
[C#]
public HatchStyle HatchStyle_DarkVertical;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DashedDownwardDiagonal Field

[Visual Basic]
Public HatchStyle_DashedDownwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_DashedDownwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DashedHorizontal Field

[Visual Basic]
Public HatchStyle_DashedHorizontal As HatchStyle
[C#]
public HatchStyle HatchStyle_DashedHorizontal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DashedUpwardDiagonal Field

[Visual Basic]
Public HatchStyle_DashedUpwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_DashedUpwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DashedVertical Field

[Visual Basic]
Public HatchStyle_DashedVertical As HatchStyle
[C#]
public HatchStyle HatchStyle_DashedVertical;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DiagonalBrick Field

[Visual Basic]
Public HatchStyle_DiagonalBrick As HatchStyle
[C#]
public HatchStyle HatchStyle_DiagonalBrick;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DiagonalCross Field

[Visual Basic]
Public HatchStyle_DiagonalCross As HatchStyle
[C#]
public HatchStyle HatchStyle_DiagonalCross;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Divot Field

[Visual Basic]
Public HatchStyle_Divot As HatchStyle
[C#]
public HatchStyle HatchStyle_Divot;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DottedDiamond Field

[Visual Basic]
Public HatchStyle_DottedDiamond As HatchStyle
[C#]
public HatchStyle HatchStyle_DottedDiamond;

See Also

System Class | Kixforms Namespace


System.HatchStyle_DottedGrid Field

[Visual Basic]
Public HatchStyle_DottedGrid As HatchStyle
[C#]
public HatchStyle HatchStyle_DottedGrid;

See Also

System Class | Kixforms Namespace


System.HatchStyle_ForwardDiagonal Field

[Visual Basic]
Public HatchStyle_ForwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_ForwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Horizontal Field

[Visual Basic]
Public HatchStyle_Horizontal As HatchStyle
[C#]
public HatchStyle HatchStyle_Horizontal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_HorizontalBrick Field

[Visual Basic]
Public HatchStyle_HorizontalBrick As HatchStyle
[C#]
public HatchStyle HatchStyle_HorizontalBrick;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LargeCheckerBoard Field

[Visual Basic]
Public HatchStyle_LargeCheckerBoard As HatchStyle
[C#]
public HatchStyle HatchStyle_LargeCheckerBoard;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LargeConfetti Field

[Visual Basic]
Public HatchStyle_LargeConfetti As HatchStyle
[C#]
public HatchStyle HatchStyle_LargeConfetti;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LargeGrid Field

[Visual Basic]
Public HatchStyle_LargeGrid As HatchStyle
[C#]
public HatchStyle HatchStyle_LargeGrid;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LightDownwardDiagonal Field

[Visual Basic]
Public HatchStyle_LightDownwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_LightDownwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LightHorizontal Field

[Visual Basic]
Public HatchStyle_LightHorizontal As HatchStyle
[C#]
public HatchStyle HatchStyle_LightHorizontal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LightUpwardDiagonal Field

[Visual Basic]
Public HatchStyle_LightUpwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_LightUpwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_LightVertical Field

[Visual Basic]
Public HatchStyle_LightVertical As HatchStyle
[C#]
public HatchStyle HatchStyle_LightVertical;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Max Field

[Visual Basic]
Public HatchStyle_Max As HatchStyle
[C#]
public HatchStyle HatchStyle_Max;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Min Field

[Visual Basic]
Public HatchStyle_Min As HatchStyle
[C#]
public HatchStyle HatchStyle_Min;

See Also

System Class | Kixforms Namespace


System.HatchStyle_NarrowHorizontal Field

[Visual Basic]
Public HatchStyle_NarrowHorizontal As HatchStyle
[C#]
public HatchStyle HatchStyle_NarrowHorizontal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_NarrowVertical Field

[Visual Basic]
Public HatchStyle_NarrowVertical As HatchStyle
[C#]
public HatchStyle HatchStyle_NarrowVertical;

See Also

System Class | Kixforms Namespace


System.HatchStyle_OutlinedDiamond Field

[Visual Basic]
Public HatchStyle_OutlinedDiamond As HatchStyle
[C#]
public HatchStyle HatchStyle_OutlinedDiamond;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent05 Field

[Visual Basic]
Public HatchStyle_Percent05 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent05;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent10 Field

[Visual Basic]
Public HatchStyle_Percent10 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent10;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent20 Field

[Visual Basic]
Public HatchStyle_Percent20 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent20;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent25 Field

[Visual Basic]
Public HatchStyle_Percent25 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent25;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent30 Field

[Visual Basic]
Public HatchStyle_Percent30 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent30;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent40 Field

[Visual Basic]
Public HatchStyle_Percent40 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent40;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent50 Field

[Visual Basic]
Public HatchStyle_Percent50 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent50;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent60 Field

[Visual Basic]
Public HatchStyle_Percent60 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent60;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent70 Field

[Visual Basic]
Public HatchStyle_Percent70 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent70;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent75 Field

[Visual Basic]
Public HatchStyle_Percent75 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent75;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent80 Field

[Visual Basic]
Public HatchStyle_Percent80 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent80;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Percent90 Field

[Visual Basic]
Public HatchStyle_Percent90 As HatchStyle
[C#]
public HatchStyle HatchStyle_Percent90;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Plaid Field

[Visual Basic]
Public HatchStyle_Plaid As HatchStyle
[C#]
public HatchStyle HatchStyle_Plaid;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Shingle Field

[Visual Basic]
Public HatchStyle_Shingle As HatchStyle
[C#]
public HatchStyle HatchStyle_Shingle;

See Also

System Class | Kixforms Namespace


System.HatchStyle_SmallCheckerBoard Field

[Visual Basic]
Public HatchStyle_SmallCheckerBoard As HatchStyle
[C#]
public HatchStyle HatchStyle_SmallCheckerBoard;

See Also

System Class | Kixforms Namespace


System.HatchStyle_SmallConfetti Field

[Visual Basic]
Public HatchStyle_SmallConfetti As HatchStyle
[C#]
public HatchStyle HatchStyle_SmallConfetti;

See Also

System Class | Kixforms Namespace


System.HatchStyle_SmallGrid Field

[Visual Basic]
Public HatchStyle_SmallGrid As HatchStyle
[C#]
public HatchStyle HatchStyle_SmallGrid;

See Also

System Class | Kixforms Namespace


System.HatchStyle_SolidDiamond Field

[Visual Basic]
Public HatchStyle_SolidDiamond As HatchStyle
[C#]
public HatchStyle HatchStyle_SolidDiamond;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Sphere Field

[Visual Basic]
Public HatchStyle_Sphere As HatchStyle
[C#]
public HatchStyle HatchStyle_Sphere;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Trellis Field

[Visual Basic]
Public HatchStyle_Trellis As HatchStyle
[C#]
public HatchStyle HatchStyle_Trellis;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Vertical Field

[Visual Basic]
Public HatchStyle_Vertical As HatchStyle
[C#]
public HatchStyle HatchStyle_Vertical;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Wave Field

[Visual Basic]
Public HatchStyle_Wave As HatchStyle
[C#]
public HatchStyle HatchStyle_Wave;

See Also

System Class | Kixforms Namespace


System.HatchStyle_Weave Field

[Visual Basic]
Public HatchStyle_Weave As HatchStyle
[C#]
public HatchStyle HatchStyle_Weave;

See Also

System Class | Kixforms Namespace


System.HatchStyle_WideDownwardDiagonal Field

[Visual Basic]
Public HatchStyle_WideDownwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_WideDownwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_WideUpwardDiagonal Field

[Visual Basic]
Public HatchStyle_WideUpwardDiagonal As HatchStyle
[C#]
public HatchStyle HatchStyle_WideUpwardDiagonal;

See Also

System Class | Kixforms Namespace


System.HatchStyle_ZigZag Field

[Visual Basic]
Public HatchStyle_ZigZag As HatchStyle
[C#]
public HatchStyle HatchStyle_ZigZag;

See Also

System Class | Kixforms Namespace


System.HorizontalAlignment_Center Field

[Visual Basic]
Public HorizontalAlignment_Center As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment_Center;

See Also

System Class | Kixforms Namespace


System.HorizontalAlignment_Left Field

[Visual Basic]
Public HorizontalAlignment_Left As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment_Left;

See Also

System Class | Kixforms Namespace


System.HorizontalAlignment_Right Field

[Visual Basic]
Public HorizontalAlignment_Right As HorizontalAlignment
[C#]
public HorizontalAlignment HorizontalAlignment_Right;

See Also

System Class | Kixforms Namespace


System.ItemActivation_OneClick Field

[Visual Basic]
Public ItemActivation_OneClick As ItemActivation
[C#]
public ItemActivation ItemActivation_OneClick;

See Also

System Class | Kixforms Namespace


System.ItemActivation_Standard Field

[Visual Basic]
Public ItemActivation_Standard As ItemActivation
[C#]
public ItemActivation ItemActivation_Standard;

See Also

System Class | Kixforms Namespace


System.ItemActivation_TwoClick Field

[Visual Basic]
Public ItemActivation_TwoClick As ItemActivation
[C#]
public ItemActivation ItemActivation_TwoClick;

See Also

System Class | Kixforms Namespace


System.Keys_A Field

[Visual Basic]
Public Keys_A As Keys
[C#]
public Keys Keys_A;

See Also

System Class | Kixforms Namespace


System.Keys_Add Field

[Visual Basic]
Public Keys_Add As Keys
[C#]
public Keys Keys_Add;

See Also

System Class | Kixforms Namespace


System.Keys_Alt Field

[Visual Basic]
Public Keys_Alt As Keys
[C#]
public Keys Keys_Alt;

See Also

System Class | Kixforms Namespace


System.Keys_Apps Field

[Visual Basic]
Public Keys_Apps As Keys
[C#]
public Keys Keys_Apps;

See Also

System Class | Kixforms Namespace


System.Keys_Attn Field

[Visual Basic]
Public Keys_Attn As Keys
[C#]
public Keys Keys_Attn;

See Also

System Class | Kixforms Namespace


System.Keys_B Field

[Visual Basic]
Public Keys_B As Keys
[C#]
public Keys Keys_B;

See Also

System Class | Kixforms Namespace


System.Keys_Back Field

[Visual Basic]
Public Keys_Back As Keys
[C#]
public Keys Keys_Back;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserBack Field

[Visual Basic]
Public Keys_BrowserBack As Keys
[C#]
public Keys Keys_BrowserBack;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserFavorites Field

[Visual Basic]
Public Keys_BrowserFavorites As Keys
[C#]
public Keys Keys_BrowserFavorites;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserForward Field

[Visual Basic]
Public Keys_BrowserForward As Keys
[C#]
public Keys Keys_BrowserForward;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserHome Field

[Visual Basic]
Public Keys_BrowserHome As Keys
[C#]
public Keys Keys_BrowserHome;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserRefresh Field

[Visual Basic]
Public Keys_BrowserRefresh As Keys
[C#]
public Keys Keys_BrowserRefresh;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserSearch Field

[Visual Basic]
Public Keys_BrowserSearch As Keys
[C#]
public Keys Keys_BrowserSearch;

See Also

System Class | Kixforms Namespace


System.Keys_BrowserStop Field

[Visual Basic]
Public Keys_BrowserStop As Keys
[C#]
public Keys Keys_BrowserStop;

See Also

System Class | Kixforms Namespace


System.Keys_C Field

[Visual Basic]
Public Keys_C As Keys
[C#]
public Keys Keys_C;

See Also

System Class | Kixforms Namespace


System.Keys_Cancel Field

[Visual Basic]
Public Keys_Cancel As Keys
[C#]
public Keys Keys_Cancel;

See Also

System Class | Kixforms Namespace


System.Keys_Capital Field

[Visual Basic]
Public Keys_Capital As Keys
[C#]
public Keys Keys_Capital;

See Also

System Class | Kixforms Namespace


System.Keys_CapsLock Field

[Visual Basic]
Public Keys_CapsLock As Keys
[C#]
public Keys Keys_CapsLock;

See Also

System Class | Kixforms Namespace


System.Keys_Clear Field

[Visual Basic]
Public Keys_Clear As Keys
[C#]
public Keys Keys_Clear;

See Also

System Class | Kixforms Namespace


System.Keys_Control Field

[Visual Basic]
Public Keys_Control As Keys
[C#]
public Keys Keys_Control;

See Also

System Class | Kixforms Namespace


System.Keys_ControlKey Field

[Visual Basic]
Public Keys_ControlKey As Keys
[C#]
public Keys Keys_ControlKey;

See Also

System Class | Kixforms Namespace


System.Keys_Crsel Field

[Visual Basic]
Public Keys_Crsel As Keys
[C#]
public Keys Keys_Crsel;

See Also

System Class | Kixforms Namespace


System.Keys_D Field

[Visual Basic]
Public Keys_D As Keys
[C#]
public Keys Keys_D;

See Also

System Class | Kixforms Namespace


System.Keys_D0 Field

[Visual Basic]
Public Keys_D0 As Keys
[C#]
public Keys Keys_D0;

See Also

System Class | Kixforms Namespace


System.Keys_D1 Field

[Visual Basic]
Public Keys_D1 As Keys
[C#]
public Keys Keys_D1;

See Also

System Class | Kixforms Namespace


System.Keys_D2 Field

[Visual Basic]
Public Keys_D2 As Keys
[C#]
public Keys Keys_D2;

See Also

System Class | Kixforms Namespace


System.Keys_D3 Field

[Visual Basic]
Public Keys_D3 As Keys
[C#]
public Keys Keys_D3;

See Also

System Class | Kixforms Namespace


System.Keys_D4 Field

[Visual Basic]
Public Keys_D4 As Keys
[C#]
public Keys Keys_D4;

See Also

System Class | Kixforms Namespace


System.Keys_D5 Field

[Visual Basic]
Public Keys_D5 As Keys
[C#]
public Keys Keys_D5;

See Also

System Class | Kixforms Namespace


System.Keys_D6 Field

[Visual Basic]
Public Keys_D6 As Keys
[C#]
public Keys Keys_D6;

See Also

System Class | Kixforms Namespace


System.Keys_D7 Field

[Visual Basic]
Public Keys_D7 As Keys
[C#]
public Keys Keys_D7;

See Also

System Class | Kixforms Namespace


System.Keys_D8 Field

[Visual Basic]
Public Keys_D8 As Keys
[C#]
public Keys Keys_D8;

See Also

System Class | Kixforms Namespace


System.Keys_D9 Field

[Visual Basic]
Public Keys_D9 As Keys
[C#]
public Keys Keys_D9;

See Also

System Class | Kixforms Namespace


System.Keys_Decimal Field

[Visual Basic]
Public Keys_Decimal As Keys
[C#]
public Keys Keys_Decimal;

See Also

System Class | Kixforms Namespace


System.Keys_Delete Field

[Visual Basic]
Public Keys_Delete As Keys
[C#]
public Keys Keys_Delete;

See Also

System Class | Kixforms Namespace


System.Keys_Divide Field

[Visual Basic]
Public Keys_Divide As Keys
[C#]
public Keys Keys_Divide;

See Also

System Class | Kixforms Namespace


System.Keys_Down Field

[Visual Basic]
Public Keys_Down As Keys
[C#]
public Keys Keys_Down;

See Also

System Class | Kixforms Namespace


System.Keys_E Field

[Visual Basic]
Public Keys_E As Keys
[C#]
public Keys Keys_E;

See Also

System Class | Kixforms Namespace


System.Keys_End Field

[Visual Basic]
Public Keys_End As Keys
[C#]
public Keys Keys_End;

See Also

System Class | Kixforms Namespace


System.Keys_Enter Field

[Visual Basic]
Public Keys_Enter As Keys
[C#]
public Keys Keys_Enter;

See Also

System Class | Kixforms Namespace


System.Keys_EraseEof Field

[Visual Basic]
Public Keys_EraseEof As Keys
[C#]
public Keys Keys_EraseEof;

See Also

System Class | Kixforms Namespace


System.Keys_Escape Field

[Visual Basic]
Public Keys_Escape As Keys
[C#]
public Keys Keys_Escape;

See Also

System Class | Kixforms Namespace


System.Keys_Execute Field

[Visual Basic]
Public Keys_Execute As Keys
[C#]
public Keys Keys_Execute;

See Also

System Class | Kixforms Namespace


System.Keys_Exsel Field

[Visual Basic]
Public Keys_Exsel As Keys
[C#]
public Keys Keys_Exsel;

See Also

System Class | Kixforms Namespace


System.Keys_F Field

[Visual Basic]
Public Keys_F As Keys
[C#]
public Keys Keys_F;

See Also

System Class | Kixforms Namespace


System.Keys_F1 Field

[Visual Basic]
Public Keys_F1 As Keys
[C#]
public Keys Keys_F1;

See Also

System Class | Kixforms Namespace


System.Keys_F10 Field

[Visual Basic]
Public Keys_F10 As Keys
[C#]
public Keys Keys_F10;

See Also

System Class | Kixforms Namespace


System.Keys_F11 Field

[Visual Basic]
Public Keys_F11 As Keys
[C#]
public Keys Keys_F11;

See Also

System Class | Kixforms Namespace


System.Keys_F12 Field

[Visual Basic]
Public Keys_F12 As Keys
[C#]
public Keys Keys_F12;

See Also

System Class | Kixforms Namespace


System.Keys_F13 Field

[Visual Basic]
Public Keys_F13 As Keys
[C#]
public Keys Keys_F13;

See Also

System Class | Kixforms Namespace


System.Keys_F14 Field

[Visual Basic]
Public Keys_F14 As Keys
[C#]
public Keys Keys_F14;

See Also

System Class | Kixforms Namespace


System.Keys_F15 Field

[Visual Basic]
Public Keys_F15 As Keys
[C#]
public Keys Keys_F15;

See Also

System Class | Kixforms Namespace


System.Keys_F16 Field

[Visual Basic]
Public Keys_F16 As Keys
[C#]
public Keys Keys_F16;

See Also

System Class | Kixforms Namespace


System.Keys_F17 Field

[Visual Basic]
Public Keys_F17 As Keys
[C#]
public Keys Keys_F17;

See Also

System Class | Kixforms Namespace


System.Keys_F18 Field

[Visual Basic]
Public Keys_F18 As Keys
[C#]
public Keys Keys_F18;

See Also

System Class | Kixforms Namespace


System.Keys_F19 Field

[Visual Basic]
Public Keys_F19 As Keys
[C#]
public Keys Keys_F19;

See Also

System Class | Kixforms Namespace


System.Keys_F2 Field

[Visual Basic]
Public Keys_F2 As Keys
[C#]
public Keys Keys_F2;

See Also

System Class | Kixforms Namespace


System.Keys_F20 Field

[Visual Basic]
Public Keys_F20 As Keys
[C#]
public Keys Keys_F20;

See Also

System Class | Kixforms Namespace


System.Keys_F21 Field

[Visual Basic]
Public Keys_F21 As Keys
[C#]
public Keys Keys_F21;

See Also

System Class | Kixforms Namespace


System.Keys_F22 Field

[Visual Basic]
Public Keys_F22 As Keys
[C#]
public Keys Keys_F22;

See Also

System Class | Kixforms Namespace


System.Keys_F23 Field

[Visual Basic]
Public Keys_F23 As Keys
[C#]
public Keys Keys_F23;

See Also

System Class | Kixforms Namespace


System.Keys_F24 Field

[Visual Basic]
Public Keys_F24 As Keys
[C#]
public Keys Keys_F24;

See Also

System Class | Kixforms Namespace


System.Keys_F3 Field

[Visual Basic]
Public Keys_F3 As Keys
[C#]
public Keys Keys_F3;

See Also

System Class | Kixforms Namespace


System.Keys_F4 Field

[Visual Basic]
Public Keys_F4 As Keys
[C#]
public Keys Keys_F4;

See Also

System Class | Kixforms Namespace


System.Keys_F5 Field

[Visual Basic]
Public Keys_F5 As Keys
[C#]
public Keys Keys_F5;

See Also

System Class | Kixforms Namespace


System.Keys_F6 Field

[Visual Basic]
Public Keys_F6 As Keys
[C#]
public Keys Keys_F6;

See Also

System Class | Kixforms Namespace


System.Keys_F7 Field

[Visual Basic]
Public Keys_F7 As Keys
[C#]
public Keys Keys_F7;

See Also

System Class | Kixforms Namespace


System.Keys_F8 Field

[Visual Basic]
Public Keys_F8 As Keys
[C#]
public Keys Keys_F8;

See Also

System Class | Kixforms Namespace


System.Keys_F9 Field

[Visual Basic]
Public Keys_F9 As Keys
[C#]
public Keys Keys_F9;

See Also

System Class | Kixforms Namespace


System.Keys_FinalMode Field

[Visual Basic]
Public Keys_FinalMode As Keys
[C#]
public Keys Keys_FinalMode;

See Also

System Class | Kixforms Namespace


System.Keys_G Field

[Visual Basic]
Public Keys_G As Keys
[C#]
public Keys Keys_G;

See Also

System Class | Kixforms Namespace


System.Keys_H Field

[Visual Basic]
Public Keys_H As Keys
[C#]
public Keys Keys_H;

See Also

System Class | Kixforms Namespace


System.Keys_HanguelMode Field

[Visual Basic]
Public Keys_HanguelMode As Keys
[C#]
public Keys Keys_HanguelMode;

See Also

System Class | Kixforms Namespace


System.Keys_HangulMode Field

[Visual Basic]
Public Keys_HangulMode As Keys
[C#]
public Keys Keys_HangulMode;

See Also

System Class | Kixforms Namespace


System.Keys_HanjaMode Field

[Visual Basic]
Public Keys_HanjaMode As Keys
[C#]
public Keys Keys_HanjaMode;

See Also

System Class | Kixforms Namespace


System.Keys_Help Field

[Visual Basic]
Public Keys_Help As Keys
[C#]
public Keys Keys_Help;

See Also

System Class | Kixforms Namespace


System.Keys_Home Field

[Visual Basic]
Public Keys_Home As Keys
[C#]
public Keys Keys_Home;

See Also

System Class | Kixforms Namespace


System.Keys_I Field

[Visual Basic]
Public Keys_I As Keys
[C#]
public Keys Keys_I;

See Also

System Class | Kixforms Namespace


System.Keys_IMEAceept Field

[Visual Basic]
Public Keys_IMEAceept As Keys
[C#]
public Keys Keys_IMEAceept;

See Also

System Class | Kixforms Namespace


System.Keys_IMEConvert Field

[Visual Basic]
Public Keys_IMEConvert As Keys
[C#]
public Keys Keys_IMEConvert;

See Also

System Class | Kixforms Namespace


System.Keys_IMEModeChange Field

[Visual Basic]
Public Keys_IMEModeChange As Keys
[C#]
public Keys Keys_IMEModeChange;

See Also

System Class | Kixforms Namespace


System.Keys_IMENonconvert Field

[Visual Basic]
Public Keys_IMENonconvert As Keys
[C#]
public Keys Keys_IMENonconvert;

See Also

System Class | Kixforms Namespace


System.Keys_Insert Field

[Visual Basic]
Public Keys_Insert As Keys
[C#]
public Keys Keys_Insert;

See Also

System Class | Kixforms Namespace


System.Keys_J Field

[Visual Basic]
Public Keys_J As Keys
[C#]
public Keys Keys_J;

See Also

System Class | Kixforms Namespace


System.Keys_JunjaMode Field

[Visual Basic]
Public Keys_JunjaMode As Keys
[C#]
public Keys Keys_JunjaMode;

See Also

System Class | Kixforms Namespace


System.Keys_K Field

[Visual Basic]
Public Keys_K As Keys
[C#]
public Keys Keys_K;

See Also

System Class | Kixforms Namespace


System.Keys_KanaMode Field

[Visual Basic]
Public Keys_KanaMode As Keys
[C#]
public Keys Keys_KanaMode;

See Also

System Class | Kixforms Namespace


System.Keys_KanjiMode Field

[Visual Basic]
Public Keys_KanjiMode As Keys
[C#]
public Keys Keys_KanjiMode;

See Also

System Class | Kixforms Namespace


System.Keys_KeyCode Field

[Visual Basic]
Public Keys_KeyCode As Keys
[C#]
public Keys Keys_KeyCode;

See Also

System Class | Kixforms Namespace


System.Keys_L Field

[Visual Basic]
Public Keys_L As Keys
[C#]
public Keys Keys_L;

See Also

System Class | Kixforms Namespace


System.Keys_LaunchApplication1 Field

[Visual Basic]
Public Keys_LaunchApplication1 As Keys
[C#]
public Keys Keys_LaunchApplication1;

See Also

System Class | Kixforms Namespace


System.Keys_LaunchApplication2 Field

[Visual Basic]
Public Keys_LaunchApplication2 As Keys
[C#]
public Keys Keys_LaunchApplication2;

See Also

System Class | Kixforms Namespace


System.Keys_LaunchMail Field

[Visual Basic]
Public Keys_LaunchMail As Keys
[C#]
public Keys Keys_LaunchMail;

See Also

System Class | Kixforms Namespace


System.Keys_LButton Field

[Visual Basic]
Public Keys_LButton As Keys
[C#]
public Keys Keys_LButton;

See Also

System Class | Kixforms Namespace


System.Keys_LControlKey Field

[Visual Basic]
Public Keys_LControlKey As Keys
[C#]
public Keys Keys_LControlKey;

See Also

System Class | Kixforms Namespace


System.Keys_Left Field

[Visual Basic]
Public Keys_Left As Keys
[C#]
public Keys Keys_Left;

See Also

System Class | Kixforms Namespace


System.Keys_LineFeed Field

[Visual Basic]
Public Keys_LineFeed As Keys
[C#]
public Keys Keys_LineFeed;

See Also

System Class | Kixforms Namespace


System.Keys_LMenu Field

[Visual Basic]
Public Keys_LMenu As Keys
[C#]
public Keys Keys_LMenu;

See Also

System Class | Kixforms Namespace


System.Keys_LShiftKey Field

[Visual Basic]
Public Keys_LShiftKey As Keys
[C#]
public Keys Keys_LShiftKey;

See Also

System Class | Kixforms Namespace


System.Keys_LWin Field

[Visual Basic]
Public Keys_LWin As Keys
[C#]
public Keys Keys_LWin;

See Also

System Class | Kixforms Namespace


System.Keys_M Field

[Visual Basic]
Public Keys_M As Keys
[C#]
public Keys Keys_M;

See Also

System Class | Kixforms Namespace


System.Keys_MButton Field

[Visual Basic]
Public Keys_MButton As Keys
[C#]
public Keys Keys_MButton;

See Also

System Class | Kixforms Namespace


System.Keys_MediaNextTrack Field

[Visual Basic]
Public Keys_MediaNextTrack As Keys
[C#]
public Keys Keys_MediaNextTrack;

See Also

System Class | Kixforms Namespace


System.Keys_MediaPlayPause Field

[Visual Basic]
Public Keys_MediaPlayPause As Keys
[C#]
public Keys Keys_MediaPlayPause;

See Also

System Class | Kixforms Namespace


System.Keys_MediaPreviousTrack Field

[Visual Basic]
Public Keys_MediaPreviousTrack As Keys
[C#]
public Keys Keys_MediaPreviousTrack;

See Also

System Class | Kixforms Namespace


System.Keys_MediaStop Field

[Visual Basic]
Public Keys_MediaStop As Keys
[C#]
public Keys Keys_MediaStop;

See Also

System Class | Kixforms Namespace


System.Keys_Menu Field

[Visual Basic]
Public Keys_Menu As Keys
[C#]
public Keys Keys_Menu;

See Also

System Class | Kixforms Namespace


System.Keys_Modifiers Field

[Visual Basic]
Public Keys_Modifiers As Keys
[C#]
public Keys Keys_Modifiers;

See Also

System Class | Kixforms Namespace


System.Keys_Multiply Field

[Visual Basic]
Public Keys_Multiply As Keys
[C#]
public Keys Keys_Multiply;

See Also

System Class | Kixforms Namespace


System.Keys_N Field

[Visual Basic]
Public Keys_N As Keys
[C#]
public Keys Keys_N;

See Also

System Class | Kixforms Namespace


System.Keys_Next Field

[Visual Basic]
Public Keys_Next As Keys
[C#]
public Keys Keys_Next;

See Also

System Class | Kixforms Namespace


System.Keys_NoName Field

[Visual Basic]
Public Keys_NoName As Keys
[C#]
public Keys Keys_NoName;

See Also

System Class | Kixforms Namespace


System.Keys_None Field

[Visual Basic]
Public Keys_None As Keys
[C#]
public Keys Keys_None;

See Also

System Class | Kixforms Namespace


System.Keys_NumLock Field

[Visual Basic]
Public Keys_NumLock As Keys
[C#]
public Keys Keys_NumLock;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad0 Field

[Visual Basic]
Public Keys_NumPad0 As Keys
[C#]
public Keys Keys_NumPad0;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad1 Field

[Visual Basic]
Public Keys_NumPad1 As Keys
[C#]
public Keys Keys_NumPad1;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad2 Field

[Visual Basic]
Public Keys_NumPad2 As Keys
[C#]
public Keys Keys_NumPad2;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad3 Field

[Visual Basic]
Public Keys_NumPad3 As Keys
[C#]
public Keys Keys_NumPad3;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad4 Field

[Visual Basic]
Public Keys_NumPad4 As Keys
[C#]
public Keys Keys_NumPad4;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad5 Field

[Visual Basic]
Public Keys_NumPad5 As Keys
[C#]
public Keys Keys_NumPad5;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad6 Field

[Visual Basic]
Public Keys_NumPad6 As Keys
[C#]
public Keys Keys_NumPad6;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad7 Field

[Visual Basic]
Public Keys_NumPad7 As Keys
[C#]
public Keys Keys_NumPad7;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad8 Field

[Visual Basic]
Public Keys_NumPad8 As Keys
[C#]
public Keys Keys_NumPad8;

See Also

System Class | Kixforms Namespace


System.Keys_NumPad9 Field

[Visual Basic]
Public Keys_NumPad9 As Keys
[C#]
public Keys Keys_NumPad9;

See Also

System Class | Kixforms Namespace


System.Keys_O Field

[Visual Basic]
Public Keys_O As Keys
[C#]
public Keys Keys_O;

See Also

System Class | Kixforms Namespace


System.Keys_Oem8 Field

[Visual Basic]
Public Keys_Oem8 As Keys
[C#]
public Keys Keys_Oem8;

See Also

System Class | Kixforms Namespace


System.Keys_OemBackslash Field

[Visual Basic]
Public Keys_OemBackslash As Keys
[C#]
public Keys Keys_OemBackslash;

See Also

System Class | Kixforms Namespace


System.Keys_OemClear Field

[Visual Basic]
Public Keys_OemClear As Keys
[C#]
public Keys Keys_OemClear;

See Also

System Class | Kixforms Namespace


System.Keys_OemCloseBrackets Field

[Visual Basic]
Public Keys_OemCloseBrackets As Keys
[C#]
public Keys Keys_OemCloseBrackets;

See Also

System Class | Kixforms Namespace


System.Keys_Oemcomma Field

[Visual Basic]
Public Keys_Oemcomma As Keys
[C#]
public Keys Keys_Oemcomma;

See Also

System Class | Kixforms Namespace


System.Keys_OemMinus Field

[Visual Basic]
Public Keys_OemMinus As Keys
[C#]
public Keys Keys_OemMinus;

See Also

System Class | Kixforms Namespace


System.Keys_OemOpenBrackets Field

[Visual Basic]
Public Keys_OemOpenBrackets As Keys
[C#]
public Keys Keys_OemOpenBrackets;

See Also

System Class | Kixforms Namespace


System.Keys_OemPeriod Field

[Visual Basic]
Public Keys_OemPeriod As Keys
[C#]
public Keys Keys_OemPeriod;

See Also

System Class | Kixforms Namespace


System.Keys_OemPipe Field

[Visual Basic]
Public Keys_OemPipe As Keys
[C#]
public Keys Keys_OemPipe;

See Also

System Class | Kixforms Namespace


System.Keys_Oemplus Field

[Visual Basic]
Public Keys_Oemplus As Keys
[C#]
public Keys Keys_Oemplus;

See Also

System Class | Kixforms Namespace


System.Keys_OemQuestion Field

[Visual Basic]
Public Keys_OemQuestion As Keys
[C#]
public Keys Keys_OemQuestion;

See Also

System Class | Kixforms Namespace


System.Keys_OemQuotes Field

[Visual Basic]
Public Keys_OemQuotes As Keys
[C#]
public Keys Keys_OemQuotes;

See Also

System Class | Kixforms Namespace


System.Keys_OemSemicolon Field

[Visual Basic]
Public Keys_OemSemicolon As Keys
[C#]
public Keys Keys_OemSemicolon;

See Also

System Class | Kixforms Namespace


System.Keys_Oemtilde Field

[Visual Basic]
Public Keys_Oemtilde As Keys
[C#]
public Keys Keys_Oemtilde;

See Also

System Class | Kixforms Namespace


System.Keys_P Field

[Visual Basic]
Public Keys_P As Keys
[C#]
public Keys Keys_P;

See Also

System Class | Kixforms Namespace


System.Keys_Pa1 Field

[Visual Basic]
Public Keys_Pa1 As Keys
[C#]
public Keys Keys_Pa1;

See Also

System Class | Kixforms Namespace


System.Keys_PageDown Field

[Visual Basic]
Public Keys_PageDown As Keys
[C#]
public Keys Keys_PageDown;

See Also

System Class | Kixforms Namespace


System.Keys_PageUp Field

[Visual Basic]
Public Keys_PageUp As Keys
[C#]
public Keys Keys_PageUp;

See Also

System Class | Kixforms Namespace


System.Keys_Pause Field

[Visual Basic]
Public Keys_Pause As Keys
[C#]
public Keys Keys_Pause;

See Also

System Class | Kixforms Namespace


System.Keys_Play Field

[Visual Basic]
Public Keys_Play As Keys
[C#]
public Keys Keys_Play;

See Also

System Class | Kixforms Namespace


System.Keys_Print Field

[Visual Basic]
Public Keys_Print As Keys
[C#]
public Keys Keys_Print;

See Also

System Class | Kixforms Namespace


System.Keys_PrintScreen Field

[Visual Basic]
Public Keys_PrintScreen As Keys
[C#]
public Keys Keys_PrintScreen;

See Also

System Class | Kixforms Namespace


System.Keys_Prior Field

[Visual Basic]
Public Keys_Prior As Keys
[C#]
public Keys Keys_Prior;

See Also

System Class | Kixforms Namespace


System.Keys_ProcessKey Field

[Visual Basic]
Public Keys_ProcessKey As Keys
[C#]
public Keys Keys_ProcessKey;

See Also

System Class | Kixforms Namespace


System.Keys_Q Field

[Visual Basic]
Public Keys_Q As Keys
[C#]
public Keys Keys_Q;

See Also

System Class | Kixforms Namespace


System.Keys_R Field

[Visual Basic]
Public Keys_R As Keys
[C#]
public Keys Keys_R;

See Also

System Class | Kixforms Namespace


System.Keys_RButton Field

[Visual Basic]
Public Keys_RButton As Keys
[C#]
public Keys Keys_RButton;

See Also

System Class | Kixforms Namespace


System.Keys_RControlKey Field

[Visual Basic]
Public Keys_RControlKey As Keys
[C#]
public Keys Keys_RControlKey;

See Also

System Class | Kixforms Namespace


System.Keys_Return Field

[Visual Basic]
Public Keys_Return As Keys
[C#]
public Keys Keys_Return;

See Also

System Class | Kixforms Namespace


System.Keys_Right Field

[Visual Basic]
Public Keys_Right As Keys
[C#]
public Keys Keys_Right;

See Also

System Class | Kixforms Namespace


System.Keys_RMenu Field

[Visual Basic]
Public Keys_RMenu As Keys
[C#]
public Keys Keys_RMenu;

See Also

System Class | Kixforms Namespace


System.Keys_RShiftKey Field

[Visual Basic]
Public Keys_RShiftKey As Keys
[C#]
public Keys Keys_RShiftKey;

See Also

System Class | Kixforms Namespace


System.Keys_RWin Field

[Visual Basic]
Public Keys_RWin As Keys
[C#]
public Keys Keys_RWin;

See Also

System Class | Kixforms Namespace


System.Keys_S Field

[Visual Basic]
Public Keys_S As Keys
[C#]
public Keys Keys_S;

See Also

System Class | Kixforms Namespace


System.Keys_Scroll Field

[Visual Basic]
Public Keys_Scroll As Keys
[C#]
public Keys Keys_Scroll;

See Also

System Class | Kixforms Namespace


System.Keys_Select Field

[Visual Basic]
Public Keys_Select As Keys
[C#]
public Keys Keys_Select;

See Also

System Class | Kixforms Namespace


System.Keys_SelectMedia Field

[Visual Basic]
Public Keys_SelectMedia As Keys
[C#]
public Keys Keys_SelectMedia;

See Also

System Class | Kixforms Namespace


System.Keys_Separator Field

[Visual Basic]
Public Keys_Separator As Keys
[C#]
public Keys Keys_Separator;

See Also

System Class | Kixforms Namespace


System.Keys_Shift Field

[Visual Basic]
Public Keys_Shift As Keys
[C#]
public Keys Keys_Shift;

See Also

System Class | Kixforms Namespace


System.Keys_ShiftKey Field

[Visual Basic]
Public Keys_ShiftKey As Keys
[C#]
public Keys Keys_ShiftKey;

See Also

System Class | Kixforms Namespace


System.Keys_Snapshot Field

[Visual Basic]
Public Keys_Snapshot As Keys
[C#]
public Keys Keys_Snapshot;

See Also

System Class | Kixforms Namespace


System.Keys_Space Field

[Visual Basic]
Public Keys_Space As Keys
[C#]
public Keys Keys_Space;

See Also

System Class | Kixforms Namespace


System.Keys_Subtract Field

[Visual Basic]
Public Keys_Subtract As Keys
[C#]
public Keys Keys_Subtract;

See Also

System Class | Kixforms Namespace


System.Keys_T Field

[Visual Basic]
Public Keys_T As Keys
[C#]
public Keys Keys_T;

See Also

System Class | Kixforms Namespace


System.Keys_Tab Field

[Visual Basic]
Public Keys_Tab As Keys
[C#]
public Keys Keys_Tab;

See Also

System Class | Kixforms Namespace


System.Keys_U Field

[Visual Basic]
Public Keys_U As Keys
[C#]
public Keys Keys_U;

See Also

System Class | Kixforms Namespace


System.Keys_Up Field

[Visual Basic]
Public Keys_Up As Keys
[C#]
public Keys Keys_Up;

See Also

System Class | Kixforms Namespace


System.Keys_V Field

[Visual Basic]
Public Keys_V As Keys
[C#]
public Keys Keys_V;

See Also

System Class | Kixforms Namespace


System.Keys_VolumeDown Field

[Visual Basic]
Public Keys_VolumeDown As Keys
[C#]
public Keys Keys_VolumeDown;

See Also

System Class | Kixforms Namespace


System.Keys_VolumeMute Field

[Visual Basic]
Public Keys_VolumeMute As Keys
[C#]
public Keys Keys_VolumeMute;

See Also

System Class | Kixforms Namespace


System.Keys_VolumeUp Field

[Visual Basic]
Public Keys_VolumeUp As Keys
[C#]
public Keys Keys_VolumeUp;

See Also

System Class | Kixforms Namespace


System.Keys_W Field

[Visual Basic]
Public Keys_W As Keys
[C#]
public Keys Keys_W;

See Also

System Class | Kixforms Namespace


System.Keys_X Field

[Visual Basic]
Public Keys_X As Keys
[C#]
public Keys Keys_X;

See Also

System Class | Kixforms Namespace


System.Keys_XButton1 Field

[Visual Basic]
Public Keys_XButton1 As Keys
[C#]
public Keys Keys_XButton1;

See Also

System Class | Kixforms Namespace


System.Keys_XButton2 Field

[Visual Basic]
Public Keys_XButton2 As Keys
[C#]
public Keys Keys_XButton2;

See Also

System Class | Kixforms Namespace


System.Keys_Y Field

[Visual Basic]
Public Keys_Y As Keys
[C#]
public Keys Keys_Y;

See Also

System Class | Kixforms Namespace


System.Keys_Z Field

[Visual Basic]
Public Keys_Z As Keys
[C#]
public Keys Keys_Z;

See Also

System Class | Kixforms Namespace


System.Keys_Zoom Field

[Visual Basic]
Public Keys_Zoom As Keys
[C#]
public Keys Keys_Zoom;

See Also

System Class | Kixforms Namespace


System.ListViewAlignment_Default Field

[Visual Basic]
Public ListViewAlignment_Default As ListViewAlignment
[C#]
public ListViewAlignment ListViewAlignment_Default;

See Also

System Class | Kixforms Namespace


System.ListViewAlignment_Left Field

[Visual Basic]
Public ListViewAlignment_Left As ListViewAlignment
[C#]
public ListViewAlignment ListViewAlignment_Left;

See Also

System Class | Kixforms Namespace


System.ListViewAlignment_SnapToGrid Field

[Visual Basic]
Public ListViewAlignment_SnapToGrid As ListViewAlignment
[C#]
public ListViewAlignment ListViewAlignment_SnapToGrid;

See Also

System Class | Kixforms Namespace


System.ListViewAlignment_Top Field

[Visual Basic]
Public ListViewAlignment_Top As ListViewAlignment
[C#]
public ListViewAlignment ListViewAlignment_Top;

See Also

System Class | Kixforms Namespace


System.MdiLayout_ArrangeIcons Field

[Visual Basic]
Public MdiLayout_ArrangeIcons As MdiLayout
[C#]
public MdiLayout MdiLayout_ArrangeIcons;

See Also

System Class | Kixforms Namespace


System.MdiLayout_Cascade Field

[Visual Basic]
Public MdiLayout_Cascade As MdiLayout
[C#]
public MdiLayout MdiLayout_Cascade;

See Also

System Class | Kixforms Namespace


System.MdiLayout_TileHorizontal Field

[Visual Basic]
Public MdiLayout_TileHorizontal As MdiLayout
[C#]
public MdiLayout MdiLayout_TileHorizontal;

See Also

System Class | Kixforms Namespace


System.MdiLayout_TileVertical Field

[Visual Basic]
Public MdiLayout_TileVertical As MdiLayout
[C#]
public MdiLayout MdiLayout_TileVertical;

See Also

System Class | Kixforms Namespace


System.MenuMerge_Add Field

[Visual Basic]
Public MenuMerge_Add As MenuMerge
[C#]
public MenuMerge MenuMerge_Add;

See Also

System Class | Kixforms Namespace


System.MenuMerge_MergeItems Field

[Visual Basic]
Public MenuMerge_MergeItems As MenuMerge
[C#]
public MenuMerge MenuMerge_MergeItems;

See Also

System Class | Kixforms Namespace


System.MenuMerge_Remove Field

[Visual Basic]
Public MenuMerge_Remove As MenuMerge
[C#]
public MenuMerge MenuMerge_Remove;

See Also

System Class | Kixforms Namespace


System.MenuMerge_Replace Field

[Visual Basic]
Public MenuMerge_Replace As MenuMerge
[C#]
public MenuMerge MenuMerge_Replace;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_Add Field

[Visual Basic]
Public MessageBoxButtons_Add As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_Add;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_OK Field

[Visual Basic]
Public MessageBoxButtons_OK As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_OK;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_OKCancel Field

[Visual Basic]
Public MessageBoxButtons_OKCancel As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_OKCancel;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_RetryCancel Field

[Visual Basic]
Public MessageBoxButtons_RetryCancel As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_RetryCancel;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_YesNo Field

[Visual Basic]
Public MessageBoxButtons_YesNo As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_YesNo;

See Also

System Class | Kixforms Namespace


System.MessageBoxButtons_YesNoCancel Field

[Visual Basic]
Public MessageBoxButtons_YesNoCancel As MessageBoxButtons
[C#]
public MessageBoxButtons MessageBoxButtons_YesNoCancel;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Asterisk Field

[Visual Basic]
Public MessageBoxIcon_Asterisk As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Asterisk;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Error Field

[Visual Basic]
Public MessageBoxIcon_Error As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Error;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Exclamation Field

[Visual Basic]
Public MessageBoxIcon_Exclamation As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Exclamation;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Hand Field

[Visual Basic]
Public MessageBoxIcon_Hand As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Hand;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Information Field

[Visual Basic]
Public MessageBoxIcon_Information As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Information;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_None Field

[Visual Basic]
Public MessageBoxIcon_None As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_None;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Question Field

[Visual Basic]
Public MessageBoxIcon_Question As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Question;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Stop Field

[Visual Basic]
Public MessageBoxIcon_Stop As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Stop;

See Also

System Class | Kixforms Namespace


System.MessageBoxIcon_Warning Field

[Visual Basic]
Public MessageBoxIcon_Warning As MessageBoxIcon
[C#]
public MessageBoxIcon MessageBoxIcon_Warning;

See Also

System Class | Kixforms Namespace


System.MouseButtons_Left Field

[Visual Basic]
Public MouseButtons_Left As MouseButtons
[C#]
public MouseButtons MouseButtons_Left;

See Also

System Class | Kixforms Namespace


System.MouseButtons_Middle Field

[Visual Basic]
Public MouseButtons_Middle As MouseButtons
[C#]
public MouseButtons MouseButtons_Middle;

See Also

System Class | Kixforms Namespace


System.MouseButtons_Right Field

[Visual Basic]
Public MouseButtons_Right As MouseButtons
[C#]
public MouseButtons MouseButtons_Right;

See Also

System Class | Kixforms Namespace


System.PictureBoxSizeMode_AutoSize Field

[Visual Basic]
Public PictureBoxSizeMode_AutoSize As PictureBoxSizeMode
[C#]
public PictureBoxSizeMode PictureBoxSizeMode_AutoSize;

See Also

System Class | Kixforms Namespace


System.PictureBoxSizeMode_CenterImage Field

[Visual Basic]
Public PictureBoxSizeMode_CenterImage As PictureBoxSizeMode
[C#]
public PictureBoxSizeMode PictureBoxSizeMode_CenterImage;

See Also

System Class | Kixforms Namespace


System.PictureBoxSizeMode_Normal Field

[Visual Basic]
Public PictureBoxSizeMode_Normal As PictureBoxSizeMode
[C#]
public PictureBoxSizeMode PictureBoxSizeMode_Normal;

See Also

System Class | Kixforms Namespace


System.PictureBoxSizeMode_StretchImage Field

[Visual Basic]
Public PictureBoxSizeMode_StretchImage As PictureBoxSizeMode
[C#]
public PictureBoxSizeMode PictureBoxSizeMode_StretchImage;

See Also

System Class | Kixforms Namespace


System.ProcessWindowStyle_Hidden Field

[Visual Basic]
Public ProcessWindowStyle_Hidden As ProcessWindowStyle
[C#]
public ProcessWindowStyle ProcessWindowStyle_Hidden;

See Also

System Class | Kixforms Namespace


System.ProcessWindowStyle_Maximized Field

[Visual Basic]
Public ProcessWindowStyle_Maximized As ProcessWindowStyle
[C#]
public ProcessWindowStyle ProcessWindowStyle_Maximized;

See Also

System Class | Kixforms Namespace


System.ProcessWindowStyle_Minimized Field

[Visual Basic]
Public ProcessWindowStyle_Minimized As ProcessWindowStyle
[C#]
public ProcessWindowStyle ProcessWindowStyle_Minimized;

See Also

System Class | Kixforms Namespace


System.ProcessWindowStyle_Normal Field

[Visual Basic]
Public ProcessWindowStyle_Normal As ProcessWindowStyle
[C#]
public ProcessWindowStyle ProcessWindowStyle_Normal;

See Also

System Class | Kixforms Namespace


System.PropertySort_Alphabetical Field

[Visual Basic]
Public PropertySort_Alphabetical As PropertySort
[C#]
public PropertySort PropertySort_Alphabetical;

See Also

System Class | Kixforms Namespace


System.PropertySort_Categorized Field

[Visual Basic]
Public PropertySort_Categorized As PropertySort
[C#]
public PropertySort PropertySort_Categorized;

See Also

System Class | Kixforms Namespace


System.PropertySort_CategorizedAlphabetical Field

[Visual Basic]
Public PropertySort_CategorizedAlphabetical As PropertySort
[C#]
public PropertySort PropertySort_CategorizedAlphabetical;

See Also

System Class | Kixforms Namespace


System.PropertySort_NoSort Field

[Visual Basic]
Public PropertySort_NoSort As PropertySort
[C#]
public PropertySort PropertySort_NoSort;

See Also

System Class | Kixforms Namespace


System.RichTextBoxFinds_MatchCase Field

[Visual Basic]
Public RichTextBoxFinds_MatchCase As RichTextBoxFinds
[C#]
public RichTextBoxFinds RichTextBoxFinds_MatchCase;

See Also

System Class | Kixforms Namespace


System.RichTextBoxFinds_NoHighlight Field

[Visual Basic]
Public RichTextBoxFinds_NoHighlight As RichTextBoxFinds
[C#]
public RichTextBoxFinds RichTextBoxFinds_NoHighlight;

See Also

System Class | Kixforms Namespace


System.RichTextBoxFinds_None Field

[Visual Basic]
Public RichTextBoxFinds_None As RichTextBoxFinds
[C#]
public RichTextBoxFinds RichTextBoxFinds_None;

See Also

System Class | Kixforms Namespace


System.RichTextBoxFinds_Reverse Field

[Visual Basic]
Public RichTextBoxFinds_Reverse As RichTextBoxFinds
[C#]
public RichTextBoxFinds RichTextBoxFinds_Reverse;

See Also

System Class | Kixforms Namespace


System.RichTextBoxFinds_WholeWord Field

[Visual Basic]
Public RichTextBoxFinds_WholeWord As RichTextBoxFinds
[C#]
public RichTextBoxFinds RichTextBoxFinds_WholeWord;

See Also

System Class | Kixforms Namespace


System.RichTextBoxStreamType_PlainText Field

[Visual Basic]
Public RichTextBoxStreamType_PlainText As RichTextBoxStreamType
[C#]
public RichTextBoxStreamType RichTextBoxStreamType_PlainText;

See Also

System Class | Kixforms Namespace


System.RichTextBoxStreamType_RichNoOleObjs Field

[Visual Basic]
Public RichTextBoxStreamType_RichNoOleObjs As RichTextBoxStreamType
[C#]
public RichTextBoxStreamType RichTextBoxStreamType_RichNoOleObjs;

See Also

System Class | Kixforms Namespace


System.RichTextBoxStreamType_RichText Field

[Visual Basic]
Public RichTextBoxStreamType_RichText As RichTextBoxStreamType
[C#]
public RichTextBoxStreamType RichTextBoxStreamType_RichText;

See Also

System Class | Kixforms Namespace


System.RichTextBoxStreamType_TextTextOleObjs Field

[Visual Basic]
Public RichTextBoxStreamType_TextTextOleObjs As RichTextBoxStreamType
[C#]
public RichTextBoxStreamType RichTextBoxStreamType_TextTextOleObjs;

See Also

System Class | Kixforms Namespace


System.RichTextBoxStreamType_UnicodePlainText Field

[Visual Basic]
Public RichTextBoxStreamType_UnicodePlainText As RichTextBoxStreamType
[C#]
public RichTextBoxStreamType RichTextBoxStreamType_UnicodePlainText;

See Also

System Class | Kixforms Namespace


System.ScrollBars_Both Field

[Visual Basic]
Public ScrollBars_Both As ScrollBars
[C#]
public ScrollBars ScrollBars_Both;

See Also

System Class | Kixforms Namespace


System.ScrollBars_Horizontal Field

[Visual Basic]
Public ScrollBars_Horizontal As ScrollBars
[C#]
public ScrollBars ScrollBars_Horizontal;

See Also

System Class | Kixforms Namespace


System.ScrollBars_None Field

[Visual Basic]
Public ScrollBars_None As ScrollBars
[C#]
public ScrollBars ScrollBars_None;

See Also

System Class | Kixforms Namespace


System.ScrollBars_Vertical Field

[Visual Basic]
Public ScrollBars_Vertical As ScrollBars
[C#]
public ScrollBars ScrollBars_Vertical;

See Also

System Class | Kixforms Namespace


System.SeekOrigin_Begin Field

[Visual Basic]
Public SeekOrigin_Begin As SeekOrigin
[C#]
public SeekOrigin SeekOrigin_Begin;

See Also

System Class | Kixforms Namespace


System.SeekOrigin_Current Field

[Visual Basic]
Public SeekOrigin_Current As SeekOrigin
[C#]
public SeekOrigin SeekOrigin_Current;

See Also

System Class | Kixforms Namespace


System.SeekOrigin_End Field

[Visual Basic]
Public SeekOrigin_End As SeekOrigin
[C#]
public SeekOrigin SeekOrigin_End;

See Also

System Class | Kixforms Namespace


System.SelectionMode_MultiExtended Field

[Visual Basic]
Public SelectionMode_MultiExtended As SelectionMode
[C#]
public SelectionMode SelectionMode_MultiExtended;

See Also

System Class | Kixforms Namespace


System.SelectionMode_MultiSimple Field

[Visual Basic]
Public SelectionMode_MultiSimple As SelectionMode
[C#]
public SelectionMode SelectionMode_MultiSimple;

See Also

System Class | Kixforms Namespace


System.SelectionMode_None Field

[Visual Basic]
Public SelectionMode_None As SelectionMode
[C#]
public SelectionMode SelectionMode_None;

See Also

System Class | Kixforms Namespace


System.SelectionMode_One Field

[Visual Basic]
Public SelectionMode_One As SelectionMode
[C#]
public SelectionMode SelectionMode_One;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt0 Field

[Visual Basic]
Public Shortcut_Alt0 As Shortcut
[C#]
public Shortcut Shortcut_Alt0;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt1 Field

[Visual Basic]
Public Shortcut_Alt1 As Shortcut
[C#]
public Shortcut Shortcut_Alt1;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt2 Field

[Visual Basic]
Public Shortcut_Alt2 As Shortcut
[C#]
public Shortcut Shortcut_Alt2;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt3 Field

[Visual Basic]
Public Shortcut_Alt3 As Shortcut
[C#]
public Shortcut Shortcut_Alt3;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt4 Field

[Visual Basic]
Public Shortcut_Alt4 As Shortcut
[C#]
public Shortcut Shortcut_Alt4;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt5 Field

[Visual Basic]
Public Shortcut_Alt5 As Shortcut
[C#]
public Shortcut Shortcut_Alt5;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt6 Field

[Visual Basic]
Public Shortcut_Alt6 As Shortcut
[C#]
public Shortcut Shortcut_Alt6;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt7 Field

[Visual Basic]
Public Shortcut_Alt7 As Shortcut
[C#]
public Shortcut Shortcut_Alt7;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt8 Field

[Visual Basic]
Public Shortcut_Alt8 As Shortcut
[C#]
public Shortcut Shortcut_Alt8;

See Also

System Class | Kixforms Namespace


System.Shortcut_Alt9 Field

[Visual Basic]
Public Shortcut_Alt9 As Shortcut
[C#]
public Shortcut Shortcut_Alt9;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltBksp Field

[Visual Basic]
Public Shortcut_AltBksp As Shortcut
[C#]
public Shortcut Shortcut_AltBksp;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF1 Field

[Visual Basic]
Public Shortcut_AltF1 As Shortcut
[C#]
public Shortcut Shortcut_AltF1;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF10 Field

[Visual Basic]
Public Shortcut_AltF10 As Shortcut
[C#]
public Shortcut Shortcut_AltF10;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF11 Field

[Visual Basic]
Public Shortcut_AltF11 As Shortcut
[C#]
public Shortcut Shortcut_AltF11;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF12 Field

[Visual Basic]
Public Shortcut_AltF12 As Shortcut
[C#]
public Shortcut Shortcut_AltF12;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF2 Field

[Visual Basic]
Public Shortcut_AltF2 As Shortcut
[C#]
public Shortcut Shortcut_AltF2;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF3 Field

[Visual Basic]
Public Shortcut_AltF3 As Shortcut
[C#]
public Shortcut Shortcut_AltF3;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF4 Field

[Visual Basic]
Public Shortcut_AltF4 As Shortcut
[C#]
public Shortcut Shortcut_AltF4;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF5 Field

[Visual Basic]
Public Shortcut_AltF5 As Shortcut
[C#]
public Shortcut Shortcut_AltF5;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF6 Field

[Visual Basic]
Public Shortcut_AltF6 As Shortcut
[C#]
public Shortcut Shortcut_AltF6;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF7 Field

[Visual Basic]
Public Shortcut_AltF7 As Shortcut
[C#]
public Shortcut Shortcut_AltF7;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF8 Field

[Visual Basic]
Public Shortcut_AltF8 As Shortcut
[C#]
public Shortcut Shortcut_AltF8;

See Also

System Class | Kixforms Namespace


System.Shortcut_AltF9 Field

[Visual Basic]
Public Shortcut_AltF9 As Shortcut
[C#]
public Shortcut Shortcut_AltF9;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl0 Field

[Visual Basic]
Public Shortcut_Ctrl0 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl0;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl1 Field

[Visual Basic]
Public Shortcut_Ctrl1 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl1;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl2 Field

[Visual Basic]
Public Shortcut_Ctrl2 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl2;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl3 Field

[Visual Basic]
Public Shortcut_Ctrl3 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl3;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl4 Field

[Visual Basic]
Public Shortcut_Ctrl4 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl4;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl5 Field

[Visual Basic]
Public Shortcut_Ctrl5 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl5;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl6 Field

[Visual Basic]
Public Shortcut_Ctrl6 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl6;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl7 Field

[Visual Basic]
Public Shortcut_Ctrl7 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl7;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl8 Field

[Visual Basic]
Public Shortcut_Ctrl8 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl8;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ctrl9 Field

[Visual Basic]
Public Shortcut_Ctrl9 As Shortcut
[C#]
public Shortcut Shortcut_Ctrl9;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlA Field

[Visual Basic]
Public Shortcut_CtrlA As Shortcut
[C#]
public Shortcut Shortcut_CtrlA;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlB Field

[Visual Basic]
Public Shortcut_CtrlB As Shortcut
[C#]
public Shortcut Shortcut_CtrlB;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlC Field

[Visual Basic]
Public Shortcut_CtrlC As Shortcut
[C#]
public Shortcut Shortcut_CtrlC;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlD Field

[Visual Basic]
Public Shortcut_CtrlD As Shortcut
[C#]
public Shortcut Shortcut_CtrlD;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlDel Field

[Visual Basic]
Public Shortcut_CtrlDel As Shortcut
[C#]
public Shortcut Shortcut_CtrlDel;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlE Field

[Visual Basic]
Public Shortcut_CtrlE As Shortcut
[C#]
public Shortcut Shortcut_CtrlE;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF Field

[Visual Basic]
Public Shortcut_CtrlF As Shortcut
[C#]
public Shortcut Shortcut_CtrlF;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF1 Field

[Visual Basic]
Public Shortcut_CtrlF1 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF1;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF10 Field

[Visual Basic]
Public Shortcut_CtrlF10 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF10;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF11 Field

[Visual Basic]
Public Shortcut_CtrlF11 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF11;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF12 Field

[Visual Basic]
Public Shortcut_CtrlF12 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF12;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF2 Field

[Visual Basic]
Public Shortcut_CtrlF2 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF2;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF3 Field

[Visual Basic]
Public Shortcut_CtrlF3 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF3;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF4 Field

[Visual Basic]
Public Shortcut_CtrlF4 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF4;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF5 Field

[Visual Basic]
Public Shortcut_CtrlF5 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF5;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF6 Field

[Visual Basic]
Public Shortcut_CtrlF6 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF6;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF7 Field

[Visual Basic]
Public Shortcut_CtrlF7 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF7;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF8 Field

[Visual Basic]
Public Shortcut_CtrlF8 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF8;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlF9 Field

[Visual Basic]
Public Shortcut_CtrlF9 As Shortcut
[C#]
public Shortcut Shortcut_CtrlF9;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlG Field

[Visual Basic]
Public Shortcut_CtrlG As Shortcut
[C#]
public Shortcut Shortcut_CtrlG;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlH Field

[Visual Basic]
Public Shortcut_CtrlH As Shortcut
[C#]
public Shortcut Shortcut_CtrlH;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlI Field

[Visual Basic]
Public Shortcut_CtrlI As Shortcut
[C#]
public Shortcut Shortcut_CtrlI;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlIns Field

[Visual Basic]
Public Shortcut_CtrlIns As Shortcut
[C#]
public Shortcut Shortcut_CtrlIns;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlJ Field

[Visual Basic]
Public Shortcut_CtrlJ As Shortcut
[C#]
public Shortcut Shortcut_CtrlJ;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlK Field

[Visual Basic]
Public Shortcut_CtrlK As Shortcut
[C#]
public Shortcut Shortcut_CtrlK;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlL Field

[Visual Basic]
Public Shortcut_CtrlL As Shortcut
[C#]
public Shortcut Shortcut_CtrlL;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlM Field

[Visual Basic]
Public Shortcut_CtrlM As Shortcut
[C#]
public Shortcut Shortcut_CtrlM;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlN Field

[Visual Basic]
Public Shortcut_CtrlN As Shortcut
[C#]
public Shortcut Shortcut_CtrlN;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlO Field

[Visual Basic]
Public Shortcut_CtrlO As Shortcut
[C#]
public Shortcut Shortcut_CtrlO;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlP Field

[Visual Basic]
Public Shortcut_CtrlP As Shortcut
[C#]
public Shortcut Shortcut_CtrlP;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlQ Field

[Visual Basic]
Public Shortcut_CtrlQ As Shortcut
[C#]
public Shortcut Shortcut_CtrlQ;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlR Field

[Visual Basic]
Public Shortcut_CtrlR As Shortcut
[C#]
public Shortcut Shortcut_CtrlR;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlS Field

[Visual Basic]
Public Shortcut_CtrlS As Shortcut
[C#]
public Shortcut Shortcut_CtrlS;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift0 Field

[Visual Basic]
Public Shortcut_CtrlShift0 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift0;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift1 Field

[Visual Basic]
Public Shortcut_CtrlShift1 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift1;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift2 Field

[Visual Basic]
Public Shortcut_CtrlShift2 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift2;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift3 Field

[Visual Basic]
Public Shortcut_CtrlShift3 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift3;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift4 Field

[Visual Basic]
Public Shortcut_CtrlShift4 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift4;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift5 Field

[Visual Basic]
Public Shortcut_CtrlShift5 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift5;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift6 Field

[Visual Basic]
Public Shortcut_CtrlShift6 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift6;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift7 Field

[Visual Basic]
Public Shortcut_CtrlShift7 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift7;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift8 Field

[Visual Basic]
Public Shortcut_CtrlShift8 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift8;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShift9 Field

[Visual Basic]
Public Shortcut_CtrlShift9 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShift9;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftA Field

[Visual Basic]
Public Shortcut_CtrlShiftA As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftA;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftB Field

[Visual Basic]
Public Shortcut_CtrlShiftB As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftB;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftC Field

[Visual Basic]
Public Shortcut_CtrlShiftC As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftC;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftD Field

[Visual Basic]
Public Shortcut_CtrlShiftD As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftD;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftE Field

[Visual Basic]
Public Shortcut_CtrlShiftE As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftE;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF Field

[Visual Basic]
Public Shortcut_CtrlShiftF As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF1 Field

[Visual Basic]
Public Shortcut_CtrlShiftF1 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF1;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF10 Field

[Visual Basic]
Public Shortcut_CtrlShiftF10 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF10;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF11 Field

[Visual Basic]
Public Shortcut_CtrlShiftF11 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF11;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF12 Field

[Visual Basic]
Public Shortcut_CtrlShiftF12 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF12;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF2 Field

[Visual Basic]
Public Shortcut_CtrlShiftF2 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF2;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF3 Field

[Visual Basic]
Public Shortcut_CtrlShiftF3 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF3;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF4 Field

[Visual Basic]
Public Shortcut_CtrlShiftF4 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF4;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF5 Field

[Visual Basic]
Public Shortcut_CtrlShiftF5 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF5;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF6 Field

[Visual Basic]
Public Shortcut_CtrlShiftF6 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF6;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF7 Field

[Visual Basic]
Public Shortcut_CtrlShiftF7 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF7;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF8 Field

[Visual Basic]
Public Shortcut_CtrlShiftF8 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF8;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftF9 Field

[Visual Basic]
Public Shortcut_CtrlShiftF9 As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftF9;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftG Field

[Visual Basic]
Public Shortcut_CtrlShiftG As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftG;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftH Field

[Visual Basic]
Public Shortcut_CtrlShiftH As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftH;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftI Field

[Visual Basic]
Public Shortcut_CtrlShiftI As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftI;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftJ Field

[Visual Basic]
Public Shortcut_CtrlShiftJ As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftJ;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftK Field

[Visual Basic]
Public Shortcut_CtrlShiftK As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftK;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftL Field

[Visual Basic]
Public Shortcut_CtrlShiftL As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftL;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftM Field

[Visual Basic]
Public Shortcut_CtrlShiftM As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftM;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftN Field

[Visual Basic]
Public Shortcut_CtrlShiftN As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftN;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftO Field

[Visual Basic]
Public Shortcut_CtrlShiftO As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftO;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftP Field

[Visual Basic]
Public Shortcut_CtrlShiftP As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftP;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftQ Field

[Visual Basic]
Public Shortcut_CtrlShiftQ As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftQ;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftR Field

[Visual Basic]
Public Shortcut_CtrlShiftR As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftR;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftS Field

[Visual Basic]
Public Shortcut_CtrlShiftS As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftS;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftT Field

[Visual Basic]
Public Shortcut_CtrlShiftT As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftT;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftU Field

[Visual Basic]
Public Shortcut_CtrlShiftU As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftU;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftV Field

[Visual Basic]
Public Shortcut_CtrlShiftV As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftV;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftW Field

[Visual Basic]
Public Shortcut_CtrlShiftW As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftW;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftX Field

[Visual Basic]
Public Shortcut_CtrlShiftX As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftX;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftY Field

[Visual Basic]
Public Shortcut_CtrlShiftY As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftY;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlShiftZ Field

[Visual Basic]
Public Shortcut_CtrlShiftZ As Shortcut
[C#]
public Shortcut Shortcut_CtrlShiftZ;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlT Field

[Visual Basic]
Public Shortcut_CtrlT As Shortcut
[C#]
public Shortcut Shortcut_CtrlT;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlU Field

[Visual Basic]
Public Shortcut_CtrlU As Shortcut
[C#]
public Shortcut Shortcut_CtrlU;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlV Field

[Visual Basic]
Public Shortcut_CtrlV As Shortcut
[C#]
public Shortcut Shortcut_CtrlV;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlW Field

[Visual Basic]
Public Shortcut_CtrlW As Shortcut
[C#]
public Shortcut Shortcut_CtrlW;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlX Field

[Visual Basic]
Public Shortcut_CtrlX As Shortcut
[C#]
public Shortcut Shortcut_CtrlX;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlY Field

[Visual Basic]
Public Shortcut_CtrlY As Shortcut
[C#]
public Shortcut Shortcut_CtrlY;

See Also

System Class | Kixforms Namespace


System.Shortcut_CtrlZ Field

[Visual Basic]
Public Shortcut_CtrlZ As Shortcut
[C#]
public Shortcut Shortcut_CtrlZ;

See Also

System Class | Kixforms Namespace


System.Shortcut_Del Field

[Visual Basic]
Public Shortcut_Del As Shortcut
[C#]
public Shortcut Shortcut_Del;

See Also

System Class | Kixforms Namespace


System.Shortcut_F1 Field

[Visual Basic]
Public Shortcut_F1 As Shortcut
[C#]
public Shortcut Shortcut_F1;

See Also

System Class | Kixforms Namespace


System.Shortcut_F10 Field

[Visual Basic]
Public Shortcut_F10 As Shortcut
[C#]
public Shortcut Shortcut_F10;

See Also

System Class | Kixforms Namespace


System.Shortcut_F11 Field

[Visual Basic]
Public Shortcut_F11 As Shortcut
[C#]
public Shortcut Shortcut_F11;

See Also

System Class | Kixforms Namespace


System.Shortcut_F12 Field

[Visual Basic]
Public Shortcut_F12 As Shortcut
[C#]
public Shortcut Shortcut_F12;

See Also

System Class | Kixforms Namespace


System.Shortcut_F2 Field

[Visual Basic]
Public Shortcut_F2 As Shortcut
[C#]
public Shortcut Shortcut_F2;

See Also

System Class | Kixforms Namespace


System.Shortcut_F3 Field

[Visual Basic]
Public Shortcut_F3 As Shortcut
[C#]
public Shortcut Shortcut_F3;

See Also

System Class | Kixforms Namespace


System.Shortcut_F4 Field

[Visual Basic]
Public Shortcut_F4 As Shortcut
[C#]
public Shortcut Shortcut_F4;

See Also

System Class | Kixforms Namespace


System.Shortcut_F5 Field

[Visual Basic]
Public Shortcut_F5 As Shortcut
[C#]
public Shortcut Shortcut_F5;

See Also

System Class | Kixforms Namespace


System.Shortcut_F6 Field

[Visual Basic]
Public Shortcut_F6 As Shortcut
[C#]
public Shortcut Shortcut_F6;

See Also

System Class | Kixforms Namespace


System.Shortcut_F7 Field

[Visual Basic]
Public Shortcut_F7 As Shortcut
[C#]
public Shortcut Shortcut_F7;

See Also

System Class | Kixforms Namespace


System.Shortcut_F8 Field

[Visual Basic]
Public Shortcut_F8 As Shortcut
[C#]
public Shortcut Shortcut_F8;

See Also

System Class | Kixforms Namespace


System.Shortcut_F9 Field

[Visual Basic]
Public Shortcut_F9 As Shortcut
[C#]
public Shortcut Shortcut_F9;

See Also

System Class | Kixforms Namespace


System.Shortcut_Ins Field

[Visual Basic]
Public Shortcut_Ins As Shortcut
[C#]
public Shortcut Shortcut_Ins;

See Also

System Class | Kixforms Namespace


System.Shortcut_None Field

[Visual Basic]
Public Shortcut_None As Shortcut
[C#]
public Shortcut Shortcut_None;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftDel Field

[Visual Basic]
Public Shortcut_ShiftDel As Shortcut
[C#]
public Shortcut Shortcut_ShiftDel;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF1 Field

[Visual Basic]
Public Shortcut_ShiftF1 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF1;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF10 Field

[Visual Basic]
Public Shortcut_ShiftF10 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF10;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF11 Field

[Visual Basic]
Public Shortcut_ShiftF11 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF11;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF12 Field

[Visual Basic]
Public Shortcut_ShiftF12 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF12;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF2 Field

[Visual Basic]
Public Shortcut_ShiftF2 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF2;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF3 Field

[Visual Basic]
Public Shortcut_ShiftF3 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF3;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF4 Field

[Visual Basic]
Public Shortcut_ShiftF4 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF4;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF5 Field

[Visual Basic]
Public Shortcut_ShiftF5 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF5;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF6 Field

[Visual Basic]
Public Shortcut_ShiftF6 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF6;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF7 Field

[Visual Basic]
Public Shortcut_ShiftF7 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF7;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF8 Field

[Visual Basic]
Public Shortcut_ShiftF8 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF8;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftF9 Field

[Visual Basic]
Public Shortcut_ShiftF9 As Shortcut
[C#]
public Shortcut Shortcut_ShiftF9;

See Also

System Class | Kixforms Namespace


System.Shortcut_ShiftIns Field

[Visual Basic]
Public Shortcut_ShiftIns As Shortcut
[C#]
public Shortcut Shortcut_ShiftIns;

See Also

System Class | Kixforms Namespace


System.SortOrder_Ascending Field

[Visual Basic]
Public SortOrder_Ascending As SortOrder
[C#]
public SortOrder SortOrder_Ascending;

See Also

System Class | Kixforms Namespace


System.SortOrder_Descending Field

[Visual Basic]
Public SortOrder_Descending As SortOrder
[C#]
public SortOrder SortOrder_Descending;

See Also

System Class | Kixforms Namespace


System.SortOrder_None Field

[Visual Basic]
Public SortOrder_None As SortOrder
[C#]
public SortOrder SortOrder_None;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_ApplicationData Field

[Visual Basic]
Public SpecialFolder_ApplicationData As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_ApplicationData;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_CommonApplicationData Field

[Visual Basic]
Public SpecialFolder_CommonApplicationData As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_CommonApplicationData;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_CommonProgramFiles Field

[Visual Basic]
Public SpecialFolder_CommonProgramFiles As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_CommonProgramFiles;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Cookies Field

[Visual Basic]
Public SpecialFolder_Cookies As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Cookies;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Desktop Field

[Visual Basic]
Public SpecialFolder_Desktop As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Desktop;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_DesktopDirectory Field

[Visual Basic]
Public SpecialFolder_DesktopDirectory As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_DesktopDirectory;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Favorites Field

[Visual Basic]
Public SpecialFolder_Favorites As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Favorites;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_History Field

[Visual Basic]
Public SpecialFolder_History As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_History;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_InternetCache Field

[Visual Basic]
Public SpecialFolder_InternetCache As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_InternetCache;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_LocalApplicationData Field

[Visual Basic]
Public SpecialFolder_LocalApplicationData As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_LocalApplicationData;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_MyComputer Field

[Visual Basic]
Public SpecialFolder_MyComputer As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_MyComputer;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_MyMusic Field

[Visual Basic]
Public SpecialFolder_MyMusic As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_MyMusic;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_MyPictures Field

[Visual Basic]
Public SpecialFolder_MyPictures As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_MyPictures;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Personal Field

[Visual Basic]
Public SpecialFolder_Personal As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Personal;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_ProgramFiles Field

[Visual Basic]
Public SpecialFolder_ProgramFiles As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_ProgramFiles;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Programs Field

[Visual Basic]
Public SpecialFolder_Programs As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Programs;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Recent Field

[Visual Basic]
Public SpecialFolder_Recent As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Recent;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_SendTo Field

[Visual Basic]
Public SpecialFolder_SendTo As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_SendTo;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_StartMenu Field

[Visual Basic]
Public SpecialFolder_StartMenu As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_StartMenu;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Startup Field

[Visual Basic]
Public SpecialFolder_Startup As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Startup;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_System Field

[Visual Basic]
Public SpecialFolder_System As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_System;

See Also

System Class | Kixforms Namespace


System.SpecialFolder_Templates Field

[Visual Basic]
Public SpecialFolder_Templates As SpecialFolder
[C#]
public SpecialFolder SpecialFolder_Templates;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelAutoSize_Contents Field

[Visual Basic]
Public StatusBarPanelAutoSize_Contents As StatusBarPanelAutoSize
[C#]
public StatusBarPanelAutoSize StatusBarPanelAutoSize_Contents;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelAutoSize_None Field

[Visual Basic]
Public StatusBarPanelAutoSize_None As StatusBarPanelAutoSize
[C#]
public StatusBarPanelAutoSize StatusBarPanelAutoSize_None;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelAutoSize_Spring Field

[Visual Basic]
Public StatusBarPanelAutoSize_Spring As StatusBarPanelAutoSize
[C#]
public StatusBarPanelAutoSize StatusBarPanelAutoSize_Spring;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelBorderStyle_None Field

[Visual Basic]
Public StatusBarPanelBorderStyle_None As StatusBarPanelBorderStyle
[C#]
public StatusBarPanelBorderStyle StatusBarPanelBorderStyle_None;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelBorderStyle_Raised Field

[Visual Basic]
Public StatusBarPanelBorderStyle_Raised As StatusBarPanelBorderStyle
[C#]
public StatusBarPanelBorderStyle StatusBarPanelBorderStyle_Raised;

See Also

System Class | Kixforms Namespace


System.StatusBarPanelBorderStyle_Sunken Field

[Visual Basic]
Public StatusBarPanelBorderStyle_Sunken As StatusBarPanelBorderStyle
[C#]
public StatusBarPanelBorderStyle StatusBarPanelBorderStyle_Sunken;

See Also

System Class | Kixforms Namespace


System.TabAlignment_Bottom Field

[Visual Basic]
Public TabAlignment_Bottom As TabAlignment
[C#]
public TabAlignment TabAlignment_Bottom;

See Also

System Class | Kixforms Namespace


System.TabAlignment_Left Field

[Visual Basic]
Public TabAlignment_Left As TabAlignment
[C#]
public TabAlignment TabAlignment_Left;

See Also

System Class | Kixforms Namespace


System.TabAlignment_Right Field

[Visual Basic]
Public TabAlignment_Right As TabAlignment
[C#]
public TabAlignment TabAlignment_Right;

See Also

System Class | Kixforms Namespace


System.TabAlignment_Top Field

[Visual Basic]
Public TabAlignment_Top As TabAlignment
[C#]
public TabAlignment TabAlignment_Top;

See Also

System Class | Kixforms Namespace


System.TabAppearance_Buttons Field

[Visual Basic]
Public TabAppearance_Buttons As TabAppearance
[C#]
public TabAppearance TabAppearance_Buttons;

See Also

System Class | Kixforms Namespace


System.TabAppearance_FlatButtons Field

[Visual Basic]
Public TabAppearance_FlatButtons As TabAppearance
[C#]
public TabAppearance TabAppearance_FlatButtons;

See Also

System Class | Kixforms Namespace


System.TabAppearance_Normal Field

[Visual Basic]
Public TabAppearance_Normal As TabAppearance
[C#]
public TabAppearance TabAppearance_Normal;

See Also

System Class | Kixforms Namespace


System.TabSizeMode_FillToRight Field

[Visual Basic]
Public TabSizeMode_FillToRight As TabSizeMode
[C#]
public TabSizeMode TabSizeMode_FillToRight;

See Also

System Class | Kixforms Namespace


System.TabSizeMode_Fixed Field

[Visual Basic]
Public TabSizeMode_Fixed As TabSizeMode
[C#]
public TabSizeMode TabSizeMode_Fixed;

See Also

System Class | Kixforms Namespace


System.TabSizeMode_Normal Field

[Visual Basic]
Public TabSizeMode_Normal As TabSizeMode
[C#]
public TabSizeMode TabSizeMode_Normal;

See Also

System Class | Kixforms Namespace


System.ToolBarAppearance_Flat Field

[Visual Basic]
Public ToolBarAppearance_Flat As ToolBarAppearance
[C#]
public ToolBarAppearance ToolBarAppearance_Flat;

See Also

System Class | Kixforms Namespace


System.ToolBarAppearance_Normal Field

[Visual Basic]
Public ToolBarAppearance_Normal As ToolBarAppearance
[C#]
public ToolBarAppearance ToolBarAppearance_Normal;

See Also

System Class | Kixforms Namespace


System.ToolBarButtonStyle_DropDownButton Field

[Visual Basic]
Public ToolBarButtonStyle_DropDownButton As ToolBarButtonStyle
[C#]
public ToolBarButtonStyle ToolBarButtonStyle_DropDownButton;

See Also

System Class | Kixforms Namespace


System.ToolBarButtonStyle_PushButton Field

[Visual Basic]
Public ToolBarButtonStyle_PushButton As ToolBarButtonStyle
[C#]
public ToolBarButtonStyle ToolBarButtonStyle_PushButton;

See Also

System Class | Kixforms Namespace


System.ToolBarButtonStyle_Separator Field

[Visual Basic]
Public ToolBarButtonStyle_Separator As ToolBarButtonStyle
[C#]
public ToolBarButtonStyle ToolBarButtonStyle_Separator;

See Also

System Class | Kixforms Namespace


System.ToolBarButtonStyle_ToggleButton Field

[Visual Basic]
Public ToolBarButtonStyle_ToggleButton As ToolBarButtonStyle
[C#]
public ToolBarButtonStyle ToolBarButtonStyle_ToggleButton;

See Also

System Class | Kixforms Namespace


System.ToolBarTextAlign_Right Field

[Visual Basic]
Public ToolBarTextAlign_Right As ToolBarTextAlign
[C#]
public ToolBarTextAlign ToolBarTextAlign_Right;

See Also

System Class | Kixforms Namespace


System.ToolBarTextAlign_Underneath Field

[Visual Basic]
Public ToolBarTextAlign_Underneath As ToolBarTextAlign
[C#]
public ToolBarTextAlign ToolBarTextAlign_Underneath;

See Also

System Class | Kixforms Namespace


System.TreeViewAction_ByKeyboard Field

[Visual Basic]
Public TreeViewAction_ByKeyboard As TreeViewAction
[C#]
public TreeViewAction TreeViewAction_ByKeyboard;

See Also

System Class | Kixforms Namespace


System.TreeViewAction_ByMouse Field

[Visual Basic]
Public TreeViewAction_ByMouse As TreeViewAction
[C#]
public TreeViewAction TreeViewAction_ByMouse;

See Also

System Class | Kixforms Namespace


System.TreeViewAction_Collapse Field

[Visual Basic]
Public TreeViewAction_Collapse As TreeViewAction
[C#]
public TreeViewAction TreeViewAction_Collapse;

See Also

System Class | Kixforms Namespace


System.TreeViewAction_Expand Field

[Visual Basic]
Public TreeViewAction_Expand As TreeViewAction
[C#]
public TreeViewAction TreeViewAction_Expand;

See Also

System Class | Kixforms Namespace


System.TreeViewAction_Unknown Field

[Visual Basic]
Public TreeViewAction_Unknown As TreeViewAction
[C#]
public TreeViewAction TreeViewAction_Unknown;

See Also

System Class | Kixforms Namespace


System.View_Details Field

[Visual Basic]
Public View_Details As View
[C#]
public View View_Details;

See Also

System Class | Kixforms Namespace


System.View_LargeIcon Field

[Visual Basic]
Public View_LargeIcon As View
[C#]
public View View_LargeIcon;

See Also

System Class | Kixforms Namespace


System.View_List Field

[Visual Basic]
Public View_List As View
[C#]
public View View_List;

See Also

System Class | Kixforms Namespace


System.View_SmallIcon Field

[Visual Basic]
Public View_SmallIcon As View
[C#]
public View View_SmallIcon;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_Auto Field

[Visual Basic]
Public XmlReadMode_Auto As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_Auto;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_DiffGram Field

[Visual Basic]
Public XmlReadMode_DiffGram As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_DiffGram;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_Fragment Field

[Visual Basic]
Public XmlReadMode_Fragment As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_Fragment;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_IgnoreSchema Field

[Visual Basic]
Public XmlReadMode_IgnoreSchema As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_IgnoreSchema;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_InferSchema Field

[Visual Basic]
Public XmlReadMode_InferSchema As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_InferSchema;

See Also

System Class | Kixforms Namespace


System.XmlReadMode_ReadSchema Field

[Visual Basic]
Public XmlReadMode_ReadSchema As XmlReadMode
[C#]
public XmlReadMode XmlReadMode_ReadSchema;

See Also

System Class | Kixforms Namespace


System.XmlWriteMode_DiffGram Field

[Visual Basic]
Public XmlWriteMode_DiffGram As XmlWriteMode
[C#]
public XmlWriteMode XmlWriteMode_DiffGram;

See Also

System Class | Kixforms Namespace


System.XmlWriteMode_IgnoreSchema Field

[Visual Basic]
Public XmlWriteMode_IgnoreSchema As XmlWriteMode
[C#]
public XmlWriteMode XmlWriteMode_IgnoreSchema;

See Also

System Class | Kixforms Namespace


System.XmlWriteMode_WriteSchema Field

[Visual Basic]
Public XmlWriteMode_WriteSchema As XmlWriteMode
[C#]
public XmlWriteMode XmlWriteMode_WriteSchema;

See Also

System Class | Kixforms Namespace


System Properties

The properties of the System class are listed below. For a complete list of System class members, see the System Members topic.

Public Instance Properties

Build |
EventArgs | Gets the event arguments that are associated with the action that raised the last event.
ProductName |
ProductVersion |
Sender | The source (object) of the last event.

See Also

System Class | Kixforms Namespace


Build Property

KiXforms.NET Class Library

System.Build Property

[Visual Basic]
Public ReadOnly Property Build As Integer
[C#]
public int Build {get;}

See Also

System Class | Kixforms Namespace


EventArgs Property

KiXforms.NET Class Library

System.EventArgs Property

Gets the event arguments that are associated with the action that raised the last event.

[Visual Basic]
Public ReadOnly Property EventArgs As EventArgs
[C#]
public EventArgs EventArgs {get;}

See Also

System Class | Kixforms Namespace


ProductName Property

KiXforms.NET Class Library

System.ProductName Property

[Visual Basic]
Public ReadOnly Property ProductName As String
[C#]
public string ProductName {get;}

See Also

System Class | Kixforms Namespace


ProductVersion Property

KiXforms.NET Class Library

System.ProductVersion Property

[Visual Basic]
Public ReadOnly Property ProductVersion As Version
[C#]
public Version ProductVersion {get;}

See Also

System Class | Kixforms Namespace


Sender Property

KiXforms.NET Class Library

System.Sender Property

The source (object) of the last event.

[Visual Basic]
Public ReadOnly Property Sender As Object
[C#]
public object Sender {get;}

See Also

System Class | Kixforms Namespace


System Methods

The methods of the System class are listed below. For a complete list of System class members, see the System Members topic.

Public Instance Methods

Application | Initializes a new instance of the Application class.
ArrayList | Creates a new instance of the ArrayList class.
Bitmap | Initializes a new instance of the Bitmap class.
Button | Initializes a new instance of the Button class.
CheckBox | Initializes a new instance of the CheckBox class.
Collection | Initializes a new instance of the Collection class.
Color | Initializes a new instance of the Color class.
ColumnHeader | Initializes a new instance of the ColumnHeader class.
ComboBox | Initializes a new instance of the ComboBox class.
ContextMenu | Initializes a new instance of the ContextMenu class.
Cursor | Initializes a new instance of the Cursor class.
Cursors | Initializes a new instance of the Cursors class.
DataColumn | Initializes a new instance of the DataColumn class.
DataGrid | Initializes a new instance of the DataGrid class.
DataGridCell | Initializes a new instance of the DataGridCell class.
DataGridTableStyle | Initializes a new instance of the DataGridTableStyle class.
DataSet | Initializes a new instance of the DataSet class.
DataTable | Initializes a new instance of the DataTable class.
DataView | Initializes a new instance of the DataView class.
DictionaryEntry | Initializes a new instance of the DictionaryEntry class.
Dns | Provides simple domain name resolution functionality.
DoEvents | Returns the next event in the event queue.
Encoding | Initializes a new instance of the Encoding class.
Environment | Initializes a new instance of the Environment class.
File | Initializes a new instance of the File class.
FileStream | Initializes a new instance of the FileStream class.
FolderBrowserDialog | Initializes a new instance of the FolderBrowserDialog class.
Font | Initializes a new instance of the EventArgs class.
FontDialog | Initializes a new instance of the FontDialog class.
Form | Initializes a new instance of the Form class.
Graphics | Initializes a new instance of the Graphics class.
GroupBox | Initializes a new instance of the GroupBox class.
HatchBrush | Initializes a new instance of the HatchBrush class.
Icon | Initializes a new instance of the Icon class.
Image | Initializes a new instance of the Image class.
ImageFormat | Initializes a new instance of the ImageFormat class.
ImageList | Initializes a new instance of the ImageList class.
InputBox | Initializes a new instance of the InputBox class.
IPAddress | Initializes a new instance of the IPAddress.
IPHostEntry | Provides a container class for Internet host address information.
Label |
LinearGradientBrush |
ListBox | Initializes a new instance of the ListBox class.
ListItem | Initializes a new instance of the ListItem class.
ListView | Initializes a new instance of the ListView class.
ListViewItem | Initializes a new instance of the ListViewItem class.
ListViewSubItem | Initializes a new instance of the ListViweSubItem class.
MainMenu | Initializes a new instance of the MainMenu class.
Math | Initializes a new instance of the Math class.
MemoryStream | Initializes a new instance of the MemoryStream class.
MenuItem | Initializes a new instance of the MenuItem class.
MessageBox | Initializes a new instance of the MessageBox class.
Nothing | Initializes a new instance of the Nothing class.
NotifyIcon | Initializes a new instance of the NotifyIcon class.
NumericUpDown | Initializes a new instance of the NumericUpDown class.
OpenFileDialog | Initializes a new instance of the OpenFileDialog class.
Panel | Initializes a new instance of the Panel class.
Pen | Initializes a new instance of the Pen class.
PictureBox | Initializes a new instance of the PictureBox class.
Point | Initializes a new instance of the Point class.
PrintDialog | Initializes a new instance of the PrintDialog class.
Process | Initializes a new instance of the Process class.
ProcessStartInfo | Initializes a new instance of the ProcessStartInfo class.
ProgressBar | Initializes a new instance of the ProgressBar class.
PropertyGrid | Initializes a new instance of the PropertyGrid class.
RadioButton | Initializes a new instance of the RadioButton class.
Rectangle | Initializes a new instance of the Rectangle class.
RichTextBox | Initializes a new instance of the RichTextBox class.
SaveFileDialog | Initializes a new instance of the SaveFileDialog class.
Screen | Initializes a new instance of the Screen class.
Size | Initializes a new instance of the Size class.
SolidBrush | Initializes a new instance of the SolidBrush class.
SortedList | Initializes a new instance of the SortedList class.
Sound | Initializes a new instance of the Sound class.
Splitter | Initializes a new instance of the Splitter class.
StatusBar | Initializes a new instance of the StatusBar class.
StatusBarPanel |
StreamReader |
StreamWriter |
TabControl |
TabPage |
TCPClient | Provides client connections for TCP network services.
TCPListener | Listens for connections from TCP network clients.
TextBox |
TextureBrush | Initializes a new instance of the SolidBrush class.
Timer |
ToolBar |
ToolBarButton |
ToolTip | Initializes a new instance of the ToolTip class.
TreeNode | Initializes a new instance of the TreeNode class.
TreeView | Initializes a new instance of the TreeView class.
Type |
UserControl | Experimental. Initializes a new instance of the UserControl class.
VScrollBar | Initializes a new instance of the VScrollBar class.

See Also

System Class | Kixforms Namespace


System.Application Method

Initializes a new instance of the Application class.

[Visual Basic]
Public Function Application() As Application
[C#]
public Application Application();

See Also

System Class | Kixforms Namespace


System.ArrayList Method

Creates a new instance of the ArrayList class.

[Visual Basic]
Public Function ArrayList() As ArrayList
[C#]
public ArrayList ArrayList();

See Also

System Class | Kixforms Namespace


System.Bitmap Method

Initializes a new instance of the Bitmap class.

[Visual Basic]
Public Function Bitmap( _
Optional ByVal FileName As String = "Nothing" _
) As Bitmap
[C#]
public Bitmap Bitmap(
string FileName
);

See Also

System Class | Kixforms Namespace


System.Button Method

Initializes a new instance of the Button class.

[Visual Basic]
Public Function Button() As Button
[C#]
public Button Button();

See Also

System Class | Kixforms Namespace


System.CheckBox Method

Initializes a new instance of the CheckBox class.

[Visual Basic]
Public Function CheckBox() As CheckBox
[C#]
public CheckBox CheckBox();

See Also

System Class | Kixforms Namespace


System.Collection Method

Initializes a new instance of the Collection class.

[Visual Basic]
Public Function Collection() As Collection
[C#]
public Collection Collection();

See Also

System Class | Kixforms Namespace


System.Color Method

Initializes a new instance of the Color class.

[Visual Basic]
Public Function Color() As Color
[C#]
public Color Color();

See Also

System Class | Kixforms Namespace


System.ColumnHeader Method

Initializes a new instance of the ColumnHeader class.

[Visual Basic]
Public Function ColumnHeader( _
Optional ByVal text As String = "", _
Optional ByVal width As Integer = 60, _
Optional ByVal textAlign As HorizontalAlignment = 0 _
) As ColumnHeader
[C#]
public ColumnHeader ColumnHeader(
string text,
int width,
HorizontalAlignment textAlign
);

See Also

System Class | Kixforms Namespace


System.ComboBox Method

Initializes a new instance of the ComboBox class.

[Visual Basic]
Public Function ComboBox() As ComboBox
[C#]
public ComboBox ComboBox();

See Also

System Class | Kixforms Namespace


System.ContextMenu Method

Initializes a new instance of the ContextMenu class.

[Visual Basic]
Public Function ContextMenu() As ContextMenu
[C#]
public ContextMenu ContextMenu();

See Also

System Class | Kixforms Namespace


System.Cursor Method

Initializes a new instance of the Cursor class.

[Visual Basic]
Public Function Cursor() As Cursor
[C#]
public Cursor Cursor();

See Also

System Class | Kixforms Namespace


System.Cursors Method

Initializes a new instance of the Cursors class.

[Visual Basic]
Public Function Cursors() As Cursors
[C#]
public Cursors Cursors();

See Also

System Class | Kixforms Namespace


System.DataColumn Method

Initializes a new instance of the DataColumn class.

[Visual Basic]
Public Function DataColumn( _
Optional ByVal name As String = "Nothing", _
Optional ByVal type As String = "Nothing" _
) As DataColumn
[C#]
public DataColumn DataColumn(
string name,
string type
);

See Also

System Class | Kixforms Namespace


System.DataGrid Method

Initializes a new instance of the DataGrid class.

[Visual Basic]
Public Function DataGrid() As DataGrid
[C#]
public DataGrid DataGrid();

See Also

System Class | Kixforms Namespace


System.DataGridCell Method

Initializes a new instance of the DataGridCell class.

[Visual Basic]
Public Function DataGridCell( _
Optional ByVal RowNumber As Integer = 0, _
Optional ByVal ColumnNumber As Integer = 0 _
) As DataGridCell
[C#]
public DataGridCell DataGridCell(
int RowNumber,
int ColumnNumber
);

See Also

System Class | Kixforms Namespace


System.DataGridTableStyle Method

Initializes a new instance of the DataGridTableStyle class.

[Visual Basic]
Public Function DataGridTableStyle() As DataGridTableStyle
[C#]
public DataGridTableStyle DataGridTableStyle();

See Also

System Class | Kixforms Namespace


System.DataSet Method

Initializes a new instance of the DataSet class.

[Visual Basic]
Public Function DataSet() As DataSet
[C#]
public DataSet DataSet();

See Also

System Class | Kixforms Namespace


System.DataTable Method

Initializes a new instance of the DataTable class.

[Visual Basic]
Public Function DataTable( _
Optional ByVal tableName As String = "Nothing" _
) As DataTable
[C#]
public DataTable DataTable(
string tableName
);

See Also

System Class | Kixforms Namespace


System.DataView Method

Initializes a new instance of the DataView class.

[Visual Basic]
Public Function DataView() As DataView
[C#]
public DataView DataView();

See Also

System Class | Kixforms Namespace


System.DictionaryEntry Method

Initializes a new instance of the DictionaryEntry class.

[Visual Basic]
Public Function DictionaryEntry( _
Optional ByVal key As Object = Nothing, _
Optional ByVal value As Object = Nothing _
) As DictionaryEntry
[C#]
public DictionaryEntry DictionaryEntry(
object key,
object value
);

See Also

System Class | Kixforms Namespace


System.Dns Method

Provides simple domain name resolution functionality.

[Visual Basic]
Public Function Dns() As Dns
[C#]
public Dns Dns();

See Also

System Class | Kixforms Namespace


System.DoEvents Method

Returns the next event in the event queue.

[Visual Basic]
Public Function DoEvents( _
Optional ByVal wait As Boolean = True _
) As String
[C#]
public string DoEvents(
bool wait
);

See Also

System Class | Kixforms Namespace


System.Encoding Method

Initializes a new instance of the Encoding class.

[Visual Basic]
Public Function Encoding() As Encoding
[C#]
public Encoding Encoding();

See Also

System Class | Kixforms Namespace


System.Environment Method

Initializes a new instance of the Environment class.

[Visual Basic]
Public Function Environment() As Environment
[C#]
public Environment Environment();

See Also

System Class | Kixforms Namespace


System.File Method

Initializes a new instance of the File class.

[Visual Basic]
Public Function File() As File
[C#]
public File File();

See Also

System Class | Kixforms Namespace


System.FileStream Method

Initializes a new instance of the FileStream class.

[Visual Basic]
Public Function FileStream( _
ByVal Path As String, _
ByVal FileOpenMode As FileMode, _
Optional ByVal FileAccessMode As FileAccess = 3, _
Optional ByVal FileShareMode As FileShare = 1 _
) As FileStream
[C#]
public FileStream FileStream(
string Path,
FileMode FileOpenMode,
FileAccess FileAccessMode,
FileShare FileShareMode
);

See Also

System Class | Kixforms Namespace


System.FolderBrowserDialog Method

Initializes a new instance of the FolderBrowserDialog class.

[Visual Basic]
Public Function FolderBrowserDialog() As FolderBrowserDialog
[C#]
public FolderBrowserDialog FolderBrowserDialog();

See Also

System Class | Kixforms Namespace


System.Font Method

Initializes a new instance of the EventArgs class.

[Visual Basic]
Public Function Font( _
ByVal family As String, _
Optional ByVal emSize As Single = -1, _
Optional ByVal style As FontStyle = 0 _
) As Font
[C#]
public Font Font(
string family,
float emSize,
FontStyle style
);

See Also

System Class | Kixforms Namespace


System.FontDialog Method

Initializes a new instance of the FontDialog class.

[Visual Basic]
Public Function FontDialog() As FontDialog
[C#]
public FontDialog FontDialog();

See Also

System Class | Kixforms Namespace


System.Form Method

Initializes a new instance of the Form class.

[Visual Basic]
Public Function Form() As Form
[C#]
public Form Form();

See Also

System Class | Kixforms Namespace


System.Graphics Method

Initializes a new instance of the Graphics class.

[Visual Basic]
Public Function Graphics() As Graphics
[C#]
public Graphics Graphics();

See Also

System Class | Kixforms Namespace


System.GroupBox Method

Initializes a new instance of the GroupBox class.

[Visual Basic]
Public Function GroupBox() As GroupBox
[C#]
public GroupBox GroupBox();

See Also

System Class | Kixforms Namespace


System.HatchBrush Method

Initializes a new instance of the HatchBrush class.

[Visual Basic]
Public Function HatchBrush( _
ByVal hatchStyle As HatchStyle, _
ByVal foreColor As Color, _
Optional ByVal backColor As Color = Nothing _
) As HatchBrush
[C#]
public HatchBrush HatchBrush(
HatchStyle hatchStyle,
Color foreColor,
Color backColor
);

See Also

System Class | Kixforms Namespace


System.Icon Method

Initializes a new instance of the Icon class.

[Visual Basic]
Public Function Icon( _
Optional ByVal p1 As String = "Nothing" _
) As Icon
[C#]
public Icon Icon(
string p1
);

See Also

System Class | Kixforms Namespace


System.Image Method

Initializes a new instance of the Image class.

[Visual Basic]
Public Function Image() As Image
[C#]
public Image Image();

See Also

System Class | Kixforms Namespace


System.ImageFormat Method

Initializes a new instance of the ImageFormat class.

[Visual Basic]
Public Function ImageFormat() As ImageFormat
[C#]
public ImageFormat ImageFormat();

See Also

System Class | Kixforms Namespace


System.ImageList Method

Initializes a new instance of the ImageList class.

[Visual Basic]
Public Function ImageList() As ImageList
[C#]
public ImageList ImageList();

See Also

System Class | Kixforms Namespace


System.InputBox Method

Initializes a new instance of the InputBox class.

[Visual Basic]
Public Function InputBox() As InputBox
[C#]
public InputBox InputBox();

See Also

System Class | Kixforms Namespace


System.IPAddress Method

Initializes a new instance of the IPAddress.

[Visual Basic]
Public Function IPAddress() As IpAddress
[C#]
public IpAddress IPAddress();

See Also

System Class | Kixforms Namespace


System.IPHostEntry Method

Provides a container class for Internet host address information.

[Visual Basic]
Public Function IPHostEntry() As IpHostEntry
[C#]
public IpHostEntry IPHostEntry();

See Also

System Class | Kixforms Namespace


System.Label Method

[Visual Basic]
Public Function Label() As Label
[C#]
public Label Label();

See Also

System Class | Kixforms Namespace


System.LinearGradientBrush Method

[Visual Basic]
Public Function LinearGradientBrush( _
ByVal Rectangle As Rectangle, _
ByVal Color1 As Color, _
ByVal Color2 As Color, _
ByVal Angle As Single _
) As LinearGradientBrush
[C#]
public LinearGradientBrush LinearGradientBrush(
Rectangle Rectangle,
Color Color1,
Color Color2,
float Angle
);

See Also

System Class | Kixforms Namespace


System.ListBox Method

Initializes a new instance of the ListBox class.

[Visual Basic]
Public Function ListBox() As ListBox
[C#]
public ListBox ListBox();

See Also

System Class | Kixforms Namespace


System.ListItem Method

Initializes a new instance of the ListItem class.

[Visual Basic]
Public Function ListItem( _
Optional ByVal text As Object = Nothing, _
Optional ByVal value As Object = Nothing _
) As ListItem
[C#]
public ListItem ListItem(
object text,
object value
);

See Also

System Class | Kixforms Namespace


System.ListView Method

Initializes a new instance of the ListView class.

[Visual Basic]
Public Function ListView() As ListView
[C#]
public ListView ListView();

See Also

System Class | Kixforms Namespace


System.ListViewItem Method

Initializes a new instance of the ListViewItem class.

[Visual Basic]
Public Function ListViewItem( _
Optional ByVal text As String = "Nothing", _
Optional ByVal imageIndex As Integer = 0 _
) As ListViewItem
[C#]
public ListViewItem ListViewItem(
string text,
int imageIndex
);

See Also

System Class | Kixforms Namespace


System.ListViewSubItem Method

Initializes a new instance of the ListViweSubItem class.

[Visual Basic]
Public Function ListViewSubItem( _
Optional ByVal text As String = "Nothing" _
) As ListViewSubItem
[C#]
public ListViewSubItem ListViewSubItem(
string text
);

See Also

System Class | Kixforms Namespace


System.MainMenu Method

Initializes a new instance of the MainMenu class.

[Visual Basic]
Public Function MainMenu() As MainMenu
[C#]
public MainMenu MainMenu();

See Also

System Class | Kixforms Namespace


System.Math Method

Initializes a new instance of the Math class.

[Visual Basic]
Public Function Math() As Math
[C#]
public Math Math();

See Also

System Class | Kixforms Namespace


System.MemoryStream Method

Initializes a new instance of the MemoryStream class.

[Visual Basic]
Public Function MemoryStream() As MemoryStream
[C#]
public MemoryStream MemoryStream();

See Also

System Class | Kixforms Namespace


System.MenuItem Method

Initializes a new instance of the MenuItem class.

[Visual Basic]
Public Function MenuItem( _
Optional ByVal Text As String = "", _
Optional ByVal OnClick As String = "", _
Optional ByVal ShortCut As Shortcut = 0 _
) As MenuItem
[C#]
public MenuItem MenuItem(
string Text,
string OnClick,
Shortcut ShortCut
);

See Also

System Class | Kixforms Namespace


System.MessageBox Method

Initializes a new instance of the MessageBox class.

[Visual Basic]
Public Function MessageBox() As MessageBox
[C#]
public MessageBox MessageBox();

See Also

System Class | Kixforms Namespace


System.Nothing Method

Initializes a new instance of the Nothing class.

[Visual Basic]
Public Function Nothing() As Object
[C#]
public object Nothing();

See Also

System Class | Kixforms Namespace


System.NotifyIcon Method

Initializes a new instance of the NotifyIcon class.

[Visual Basic]
Public Function NotifyIcon() As NotifyIcon
[C#]
public NotifyIcon NotifyIcon();

See Also

System Class | Kixforms Namespace


System.NumericUpDown Method

Initializes a new instance of the NumericUpDown class.

[Visual Basic]
Public Function NumericUpDown() As NumericUpDown
[C#]
public NumericUpDown NumericUpDown();

See Also

System Class | Kixforms Namespace


System.OpenFileDialog Method

Initializes a new instance of the OpenFileDialog class.

[Visual Basic]
Public Function OpenFileDialog() As OpenFileDialog
[C#]
public OpenFileDialog OpenFileDialog();

See Also

System Class | Kixforms Namespace


System.Panel Method

Initializes a new instance of the Panel class.

[Visual Basic]
Public Function Panel() As Panel
[C#]
public Panel Panel();

See Also

System Class | Kixforms Namespace


System.Pen Method

Initializes a new instance of the Pen class.

[Visual Basic]
Public Function Pen( _
Optional ByVal Color As Color = Nothing, _
Optional ByVal Width As Single = 0 _
) As Pen
[C#]
public Pen Pen(
Color Color,
float Width
);

See Also

System Class | Kixforms Namespace


System.PictureBox Method

Initializes a new instance of the PictureBox class.

[Visual Basic]
Public Function PictureBox() As PictureBox
[C#]
public PictureBox PictureBox();

See Also

System Class | Kixforms Namespace


System.Point Method

Initializes a new instance of the Point class.

[Visual Basic]
Public Function Point( _
Optional ByVal x As Integer = 0, _
Optional ByVal y As Integer = 0 _
) As Point
[C#]
public Point Point(
int x,
int y
);

See Also

System Class | Kixforms Namespace


System.PrintDialog Method

Initializes a new instance of the PrintDialog class.

[Visual Basic]
Public Function PrintDialog() As PrintDialog
[C#]
public PrintDialog PrintDialog();

See Also

System Class | Kixforms Namespace


System.Process Method

Initializes a new instance of the Process class.

[Visual Basic]
Public Function Process( _
Optional ByVal p1 As Object = Nothing, _
Optional ByVal p2 As Object = Nothing _
) As Process
[C#]
public Process Process(
object p1,
object p2
);

See Also

System Class | Kixforms Namespace


System.ProcessStartInfo Method

Initializes a new instance of the ProcessStartInfo class.

[Visual Basic]
Public Function ProcessStartInfo( _
Optional ByVal p1 As Object = Nothing, _
Optional ByVal p2 As Object = Nothing _
) As ProcessStartInfo
[C#]
public ProcessStartInfo ProcessStartInfo(
object p1,
object p2
);

See Also

System Class | Kixforms Namespace


System.ProgressBar Method

Initializes a new instance of the ProgressBar class.

[Visual Basic]
Public Function ProgressBar() As ProgressBar
[C#]
public ProgressBar ProgressBar();

See Also

System Class | Kixforms Namespace


System.PropertyGrid Method

Initializes a new instance of the PropertyGrid class.

[Visual Basic]
Public Function PropertyGrid() As PropertyGrid
[C#]
public PropertyGrid PropertyGrid();

See Also

System Class | Kixforms Namespace


System.RadioButton Method

Initializes a new instance of the RadioButton class.

[Visual Basic]
Public Function RadioButton() As RadioButton
[C#]
public RadioButton RadioButton();

See Also

System Class | Kixforms Namespace


System.Rectangle Method

Initializes a new instance of the Rectangle class.

[Visual Basic]
Public Function Rectangle( _
Optional ByVal x As Integer = 0, _
Optional ByVal y As Integer = 0, _
Optional ByVal width As Integer = 0, _
Optional ByVal height As Integer = 0 _
) As Rectangle
[C#]
public Rectangle Rectangle(
int x,
int y,
int width,
int height
);

See Also

System Class | Kixforms Namespace


System.RichTextBox Method

Initializes a new instance of the RichTextBox class.

[Visual Basic]
Public Function RichTextBox() As RichTextBox
[C#]
public RichTextBox RichTextBox();

See Also

System Class | Kixforms Namespace


System.SaveFileDialog Method

Initializes a new instance of the SaveFileDialog class.

[Visual Basic]
Public Function SaveFileDialog() As SaveFileDialog
[C#]
public SaveFileDialog SaveFileDialog();

See Also

System Class | Kixforms Namespace


System.Screen Method

Initializes a new instance of the Screen class.

[Visual Basic]
Public Function Screen() As Screen
[C#]
public Screen Screen();

See Also

System Class | Kixforms Namespace


System.Size Method

Initializes a new instance of the Size class.

[Visual Basic]
Public Function Size( _
ByVal width As Integer, _
ByVal height As Integer _
) As Size
[C#]
public Size Size(
int width,
int height
);

Parameters

width
The width component of the new Size.
height
The height component of the new Size.

See Also

System Class | Kixforms Namespace


System.SolidBrush Method

Initializes a new instance of the SolidBrush class.

[Visual Basic]
Public Function SolidBrush( _
Optional ByVal Color As Color = Nothing _
) As SolidBrush
[C#]
public SolidBrush SolidBrush(
Color Color
);

See Also

System Class | Kixforms Namespace


System.SortedList Method

Initializes a new instance of the SortedList class.

[Visual Basic]
Public Function SortedList() As SortedList
[C#]
public SortedList SortedList();

See Also

System Class | Kixforms Namespace


System.Sound Method

Initializes a new instance of the Sound class.

[Visual Basic]
Public Function Sound() As Sound
[C#]
public Sound Sound();

See Also

System Class | Kixforms Namespace


System.Splitter Method

Initializes a new instance of the Splitter class.

[Visual Basic]
Public Function Splitter() As Splitter
[C#]
public Splitter Splitter();

See Also

System Class | Kixforms Namespace


System.StatusBar Method

Initializes a new instance of the StatusBar class.

[Visual Basic]
Public Function StatusBar() As StatusBar
[C#]
public StatusBar StatusBar();

See Also

System Class | Kixforms Namespace


System.StatusBarPanel Method

[Visual Basic]
Public Function StatusBarPanel() As StatusBarPanel
[C#]
public StatusBarPanel StatusBarPanel();

See Also

System Class | Kixforms Namespace


System.StreamReader Method

[Visual Basic]
Public Function StreamReader( _
ByVal path As String _
) As StreamReader
[C#]
public StreamReader StreamReader(
string path
);

See Also

System Class | Kixforms Namespace


System.StreamWriter Method

[Visual Basic]
Public Function StreamWriter( _
Optional ByVal path As String = "Nothing" _
) As StreamWriter
[C#]
public StreamWriter StreamWriter(
string path
);

See Also

System Class | Kixforms Namespace


System.TabControl Method

[Visual Basic]
Public Function TabControl() As TabControl
[C#]
public TabControl TabControl();

See Also

System Class | Kixforms Namespace


System.TabPage Method

[Visual Basic]
Public Function TabPage( _
Optional ByVal text As String = "Nothing" _
) As TabPage
[C#]
public TabPage TabPage(
string text
);

See Also

System Class | Kixforms Namespace


System.TCPClient Method

Provides client connections for TCP network services.

[Visual Basic]
Public Function TCPClient( _
Optional ByVal HostName As String = "Nothing", _
Optional ByVal port As Integer = 0 _
) As Object
[C#]
public object TCPClient(
string HostName,
int port
);

See Also

System Class | Kixforms Namespace


System.TCPListener Method

Listens for connections from TCP network clients.

[Visual Basic]
Public Function TCPListener( _
ByVal pIpAddyObject As IpAddress, _
ByVal portNo As Integer _
) As Object
[C#]
public object TCPListener(
IpAddress pIpAddyObject,
int portNo
);

See Also

System Class | Kixforms Namespace


System.TextBox Method

[Visual Basic]
Public Function TextBox() As TextBox
[C#]
public TextBox TextBox();

See Also

System Class | Kixforms Namespace


System.TextureBrush Method

Initializes a new instance of the SolidBrush class.

[Visual Basic]
Public Function TextureBrush( _
ByVal bitmap As Image _
) As TextureBrush
[C#]
public TextureBrush TextureBrush(
Image bitmap
);

See Also

System Class | Kixforms Namespace


System.Timer Method

[Visual Basic]
Public Function Timer() As Timer
[C#]
public Timer Timer();

See Also

System Class | Kixforms Namespace


System.ToolBar Method

[Visual Basic]
Public Function ToolBar() As ToolBar
[C#]
public ToolBar ToolBar();

See Also

System Class | Kixforms Namespace


System.ToolBarButton Method

[Visual Basic]
Public Function ToolBarButton( _
Optional ByVal text As String = "Nothing" _
) As ToolBarButton
[C#]
public ToolBarButton ToolBarButton(
string text
);

See Also

System Class | Kixforms Namespace


System.ToolTip Method

Initializes a new instance of the ToolTip class.

[Visual Basic]
Public Function ToolTip() As ToolTip
[C#]
public ToolTip ToolTip();

See Also

System Class | Kixforms Namespace


System.TreeNode Method

Initializes a new instance of the TreeNode class.

[Visual Basic]
Public Function TreeNode( _
Optional ByVal Text As String = "Nothing" _
) As TreeNode
[C#]
public TreeNode TreeNode(
string Text
);

See Also

System Class | Kixforms Namespace


System.TreeView Method

Initializes a new instance of the TreeView class.

[Visual Basic]
Public Function TreeView() As TreeView
[C#]
public TreeView TreeView();

See Also

System Class | Kixforms Namespace


System.Type Method

[Visual Basic]
Public Function Type( _
ByVal name As String _
) As Type
[C#]
public Type Type(
string name
);

See Also

System Class | Kixforms Namespace


System.UserControl Method

Experimental. Initializes a new instance of the UserControl class.

[Visual Basic]
Public Function UserControl() As UserControl
[C#]
public UserControl UserControl();

See Also

System Class | Kixforms Namespace


System.VScrollBar Method

Initializes a new instance of the VScrollBar class.

[Visual Basic]
Public Function VScrollBar() As VScrollBar
[C#]
public VScrollBar VScrollBar();

See Also

System Class | Kixforms Namespace


TabAlignment Enumeration

[Visual Basic]
Public Enum TabAlignment
[C#]
public enum TabAlignment

Members

Member Name | Description
Bottom |
Left |
Right |
Top |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


TabAppearance Enumeration

[Visual Basic]
Public Enum TabAppearance
[C#]
public enum TabAppearance

Members

Member Name | Description
Buttons |
FlatButtons |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


TabControl Class

Manages a related set of tab pages.

For a list of all members of this type, see TabControl Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.TabControl

[Visual Basic]
Public Class TabControl
Inherits Control
[C#]
public class TabControl : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TabControl Members | Kixforms Namespace


TabControl Members

TabControl overview

Public Instance Constructors

TabControl Constructor Initializes a new instance of the TabControl class.

Public Instance Properties

Alignment | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageList | Gets or sets the images to display on the control's tabs.
ItemSize | Gets or sets the size of the control's tabs.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedIndex | Gets or sets the index of the currently-selected tab page.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property is changed.
SelectedTab | Gets or sets the currently-selected tab page.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizeMode | Gets or sets the way that the control's tabs are sized.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TabControl Class | Kixforms Namespace


TabControl Constructor

Initializes a new instance of the TabControl class.

[Visual Basic]
Public Sub New()
[C#]
public TabControl();

See Also

TabControl Class | Kixforms Namespace


TabControl Properties

The properties of the TabControl class are listed below. For a complete list of TabControl class members, see the TabControl Members topic.

Public Instance Properties

Alignment | Gets or sets the area of the control (for example, along the top) where the tabs are aligned.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or sets the visual appearance of the control's tabs.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageList | Gets or sets the images to display on the control's tabs.
ItemSize | Gets or sets the size of the control's tabs.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine | Gets or sets a value indicating whether more than one row of tabs can be displayed.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedIndex | Gets or sets the index of the currently-selected tab page.
SelectedIndexChanged | Gets or sets the code to execute when the SelectedIndex property is changed.
SelectedTab | Gets or sets the currently-selected tab page.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SizeMode | Gets or sets the way that the control's tabs are sized.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabPages | Gets the collection of tab pages in this tab control.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

TabControl Class | Kixforms Namespace


Alignment Property

KiXforms.NET Class Library

TabControl.Alignment Property

Gets or sets the area of the control (for example, along the top) where the tabs are aligned.

[Visual Basic]
Public Property Alignment As TabAlignment
[C#]
public TabAlignment Alignment {get; set;}

See Also

TabControl Class | Kixforms Namespace


Appearance Property

KiXforms.NET Class Library

TabControl.Appearance Property

Gets or sets the visual appearance of the control's tabs.

[Visual Basic]
Public Property Appearance As TabAppearance
[C#]
public TabAppearance Appearance {get; set;}

See Also

TabControl Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

TabControl.ImageList Property

Gets or sets the images to display on the control's tabs.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}

Property Value

An ImageList that specifies the images to display on the tabs.

See Also

TabControl Class | Kixforms Namespace


ItemSize Property

KiXforms.NET Class Library

TabControl.ItemSize Property

Gets or sets the size of the control's tabs.

[Visual Basic]
Public Property ItemSize As Size
[C#]
public Size ItemSize {get; set;}

Property Value

A Size object that represents the size of the tabs. The default automatically sizes the tabs to fit the icons and labels on the tabs.

See Also

TabControl Class | Kixforms Namespace


MultiLine Property

KiXforms.NET Class Library

TabControl.MultiLine Property

Gets or sets a value indicating whether more than one row of tabs can be displayed.

[Visual Basic]
Public Property MultiLine As Boolean
[C#]
public bool MultiLine {get; set;}

See Also

TabControl Class | Kixforms Namespace


SelectedIndex Property

KiXforms.NET Class Library

TabControl.SelectedIndex Property

Gets or sets the index of the currently-selected tab page.

[Visual Basic]
Public Property SelectedIndex As Integer
[C#]
public int SelectedIndex {get; set;}

See Also

TabControl Class | Kixforms Namespace


SelectedIndexChanged Property

KiXforms.NET Class Library

TabControl.SelectedIndexChanged Property

Gets or sets the code to execute when the SelectedIndex property is changed.

[Visual Basic]
Public Property SelectedIndexChanged As String
[C#]
public string SelectedIndexChanged {get; set;}

See Also

TabControl Class | Kixforms Namespace


SelectedTab Property

KiXforms.NET Class Library

TabControl.SelectedTab Property

Gets or sets the currently-selected tab page.

[Visual Basic]
Public Property SelectedTab As TabPage
[C#]
public TabPage SelectedTab {get; set;}

Property Value

A TabPage that represents the selected tab page. If no tab page is selected, the value is a null reference (Nothing in Visual Basic).

See Also

TabControl Class | Kixforms Namespace


SizeMode Property

KiXforms.NET Class Library

TabControl.SizeMode Property

Gets or sets the way that the control's tabs are sized.

[Visual Basic]
Public Property SizeMode As TabSizeMode
[C#]
public TabSizeMode SizeMode {get; set;}

See Also

TabControl Class | Kixforms Namespace


TabPages Property

KiXforms.NET Class Library

TabControl.TabPages Property

Gets the collection of tab pages in this tab control.

[Visual Basic]
Public ReadOnly Property TabPages As TabPageCollection
[C#]
public TabPageCollection TabPages {get;}

See Also

TabControl Class | Kixforms Namespace


TabPage Class

Represents a single tab page in a TabControl.

For a list of all members of this type, see TabPage Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.Panel
Kixforms.TabPage

[Visual Basic]
Public Class TabPage
Inherits Panel
[C#]
public class TabPage : Panel

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TabPage Members | Kixforms Namespace


TabPage Members

TabPage overview

Public Instance Constructors

TabPage Constructor Initializes a new instance of the TabPage class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageIndex | Gets or sets the index to the image displayed on this tab.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
ToolTipText | Gets or sets the ToolTip text for this tab.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TabPage Class | Kixforms Namespace


TabPage Constructor

Initializes a new instance of the TabPage class.

[Visual Basic]
Public Sub New( _
Optional ByVal text As String = "Nothing" _
)
[C#]
public TabPage(
string text
);

Parameters

text
The text for the tab.

See Also

TabPage Class | Kixforms Namespace


TabPage Properties

The properties of the TabPage class are listed below. For a complete list of TabPage class members, see the TabPage Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageIndex | Gets or sets the index to the image displayed on this tab.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
ToolTipText | Gets or sets the ToolTip text for this tab.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

TabPage Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

TabPage.ImageIndex Property

Gets or sets the index to the image displayed on this tab.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

Property Value

The zero-based index to the image in the TabControl.ImageList that appears on the tab. The default is -1, which signifies no image.

See Also

TabPage Class | Kixforms Namespace


ToolTipText Property

KiXforms.NET Class Library

TabPage.ToolTipText Property

Gets or sets the ToolTip text for this tab.

[Visual Basic]
Public Property ToolTipText As String
[C#]
public string ToolTipText {get; set;}

See Also

TabPage Class | Kixforms Namespace


TabPageCollection Class

Contains a collection of TabPage objects.

For a list of all members of this type, see TabPageCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.TabPageCollection

[Visual Basic]
Public Class TabPageCollection
Inherits CollectionBase
[C#]
public class TabPageCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TabPageCollection Members | Kixforms Namespace


TabPageCollection Members

TabPageCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Retrieves the TabPage at the specified indexed location in the collection.

Public Instance Methods

Add | Adds a tab page to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
IndexOf | Returns the index of the specified tab page in the collection.
Remove | Removes a tab page from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

TabPageCollection Class | Kixforms Namespace


TabPageCollection Properties

The properties of the TabPageCollection class are listed below. For a complete list of TabPageCollection class members, see the TabPageCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Retrieves the TabPage at the specified indexed location in the collection.

See Also

TabPageCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

TabPageCollection.Item Property

Retrieves the TabPage at the specified indexed location in the collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal index As Integer _
) As TabPage
[C#]
public TabPage this[
int index
] {get; set;}

Parameters

index
The zero-based index of the tab page to get or set.

See Also

TabPageCollection Class | Kixforms Namespace


TabPageCollection Methods

The methods of the TabPageCollection class are listed below. For a complete list of TabPageCollection class members, see the TabPageCollection Members topic.

Public Instance Methods

Add | Adds a tab page to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
IndexOf | Returns the index of the specified tab page in the collection.
Remove | Removes a tab page from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

TabPageCollection Class | Kixforms Namespace


TabPageCollection.Add Method

Adds a tab page to the collection.

[Visual Basic]
Public Function Add( _
ByVal page As TabPage _
) As TabPage
[C#]
public TabPage Add(
TabPage page
);

Parameters

page
The TabPage to add.

See Also

TabPageCollection Class | Kixforms Namespace


TabPageCollection.IndexOf Method

Returns the index of the specified tab page in the collection.

[Visual Basic]
Public Function IndexOf( _
ByVal TabPage As TabPage _
) As Object
[C#]
public object IndexOf(
TabPage TabPage
);

Parameters

TabPage
The TabPage to locate in the collection.

See Also

TabPageCollection Class | Kixforms Namespace


TabPageCollection.Remove Method

Removes a tab page from the collection.

[Visual Basic]
Public Function Remove( _
ByVal page As TabPage _
) As Object
[C#]
public object Remove(
TabPage page
);

Parameters

page
The TabPage to remove.

See Also

TabPageCollection Class | Kixforms Namespace


TabSizeMode Enumeration

[Visual Basic]
Public Enum TabSizeMode
[C#]
public enum TabSizeMode

Members

Member Name | Description
FillToRight |
Fixed |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


TCPClient Class

Provides the underlying stream of data for network access.

For a list of all members of this type, see TCPClient Members.

System.Object
Kixforms.TCPClient

[Visual Basic]
Public Class TCPClient
[C#]
public class TCPClient

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TCPClient Members | Kixforms Namespace


TCPClient Members

TCPClient overview

Public Instance Constructors

TCPClient Constructor Initializes a new instance of the TcpClient and if arguments given, connects to the specified port on the specified host.

Public Instance Methods

Close | Closes the TCP connection and releases all resources associated with the TcpClient.
Connect | Connects the client to the specified port on the specified remote TCP host using the specified IP address or HostName.
GetStream | Returns the NetworkStream used to send and receive data.

See Also

TCPClient Class | Kixforms Namespace


TCPClient Constructor

Initializes a new instance of the TcpClient and if arguments given, connects to the specified port on the specified host.

[Visual Basic]
Public Sub New( _
Optional ByVal HostName As String = "Nothing", _
Optional ByVal port As Integer = 0 _
)
[C#]
public TCPClient(
string HostName,
int port
);

Parameters

HostName
optional (if also portNo omitted). The name of the remote host to which you intend to connect.
port
optional (if also HostName omitted). The port number of the remote host to which you intend to connect.

Remarks

This constructor creates a new TcpClient and optionally makes a synchronous connection attempt to the provided host name and port number. The underlying service provider will assign the most appropriate local IP address and port number. if arguments given, TcpClient will block until it either connects or fails.

Example

gets new instance of TCPClient

$tcpClient = $System.TCPClient()
Connects directly to webservers port
$tcpClient = $System.TCPClient("www.kixforms.org",80)

See Also

TCPClient Class | Kixforms Namespace


TCPClient Methods

The methods of the TCPClient class are listed below. For a complete list of TCPClient class members, see the TCPClient Members topic.

Public Instance Methods

Close | Closes the TCP connection and releases all resources associated with the TcpClient.
Connect | Connects the client to the specified port on the specified remote TCP host using the specified IP address or HostName.
GetStream | Returns the NetworkStream used to send and receive data.

See Also

TCPClient Class | Kixforms Namespace


TCPClient.Close Method

Closes the TCP connection and releases all resources associated with the TcpClient.

[Visual Basic]
Public Sub Close()
[C#]
public void Close();

Remarks

The Close method closes the TCP connection. It calls the Dispose method passing a true value to release all managed and unmanaged resources associated with the TcpClient. These resources include the underlying Socket used for connecting with the remote host, and the NetworkStream used to send and receive data.

Example

$tcpClient = $System.TcpClient()
$tcpClient.Close()

See Also

TCPClient Class | Kixforms Namespace


TCPClient.Connect Method

Connects the client to the specified port on the specified remote TCP host using the specified IP address or HostName.

[Visual Basic]
Public Sub Connect( _
ByVal HostNameOrIpAddress As Object, _
ByVal portNo As Integer _
)
[C#]
public void Connect(
object HostNameOrIpAddress,
int portNo
);

Parameters

HostNameOrIpAddress
The DNS name or the IpAddress of the remote host to which you intend to connect.
portNo
The port number of the remote host to which you intend to connect.

Remarks

Call this method to establish a synchronous remote host connection to the specified host name or IpAddress and port number. The Connect method will block until it either connects or fails. After connecting with the remote host, use the GetStream method to obtain the underlying NetworkStream. Use this NetworkStream to send and receive data.

Example

$tcpClient = $System.TCPClient()
;connect to port 21 of www.kixforms.org
$tcpClient.Connect("www.KiXforms.org", 21)
; you can also use the ipAddress object to connect:
$tcpClient.close()
$ipAddy = $system.dns.resolve("www.kixforms.org").addresslist.item(0)
$tcpClient.Connect($ipAddy,21)

See Also

TCPClient Class | Kixforms Namespace


TCPClient.GetStream Method

Returns the NetworkStream used to send and receive data.

[Visual Basic]
Public Function GetStream() As Object
[C#]
public object GetStream();

Return Value

The underlying NetworkStream.

Remarks

CAUTION You must close the NetworkStream when you are through sending and receiving data. Closing TcpClient does not release the NetworkStream.

Example

$tcpClient = $System.TCPClient("www.kixforms.org",80)
$NetStream = $tcpClient.GetStream()

See Also

TCPClient Class | Kixforms Namespace


TCPListener Class

Listens for connections from TCP network clients.

For a list of all members of this type, see TCPListener Members.

System.Object
Kixforms.TCPListener

[Visual Basic]
Public Class TCPListener
[C#]
public class TCPListener

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TCPListener Members | Kixforms Namespace


TCPListener Members

TCPListener overview

Public Instance Constructors

TCPListener Constructor Listens for connections from TCP network clients.

Public Instance Methods

AcceptTCPclient | Accepts a pending connection request
Pending | Determines if there are pending connection requests.
Start | Starts listening for incoming connection requests.
Stop | Closes the listener.

See Also

TCPListener Class | Kixforms Namespace


TCPListener Constructor

Listens for connections from TCP network clients.

[Visual Basic]
Public Sub New( _
ByVal pIpAddyObject As IpAddress, _
ByVal portNo As Integer _
)
[C#]
public TCPListener(
IpAddress pIpAddyObject,
int portNo
);

Parameters

pIpAddyObject
IpAddress object of localhost
portNo
The port on which to listen for incoming connection attempts.

Remarks

The TcpListener class provides simple methods that listen for and accept incoming connection requests in blocking synchronous mode. You can use TcpClient to connect with a TcpListener. Create a TcpListener using a Local IP address and port number. Specify Any for the local IP address and 0 for the local port number if you want the underlying service provider to assign those values for you. If you choose to do this, you can use the LocalEndpoint to identify the assigned information.

Use the Start method to begin listening for incoming connection requests. Start will queue incoming connections until you either call the Stop method or it has queued MaxConnections. Use either AcceptSocket or AcceptTcpClient to pull a connection from the incoming connection request queue. These two methods will block. If you want to avoid blocking, you can use the Pending method first to determine if connection requests are available in the queue.

Call the Stop method to close the TcpListener.

Note The Stop method does not close any accepted connections. You are responsible for closing these separately.

Example

$TCPlistener = $System.TCPListener($System.IpAddress.LoopBack,77)

See Also

TCPListener Class | Kixforms Namespace


TCPListener Methods

The methods of the TCPListener class are listed below. For a complete list of TCPListener class members, see the TCPListener Members topic.

Public Instance Methods

AcceptTCPclient | Accepts a pending connection request
Pending | Determines if there are pending connection requests.
Start | Starts listening for incoming connection requests.
Stop | Closes the listener.

See Also

TCPListener Class | Kixforms Namespace


TCPListener.AcceptTCPclient Method

Accepts a pending connection request

[Visual Basic]
Public Function AcceptTCPclient() As TCPClient
[C#]
public TCPClient AcceptTCPclient();

Return Value

A TcpClient used to send and receive data.

Remarks

AcceptTcpClient is a blocking method that returns a TcpClient you can use to send and receive data. Use the Pending method to determine if connections requests are available in the incoming connection queue if you want to avoid blocking.

Use TcpClient.GetStream to obtain the underlying NetworkStream of the returned TcpClient. The NetworkStream will provide you with methods for sending and receiving with the remote host. When you are through with the TcpClient, be sure to call its Close method.

See Also

TCPListener Class | Kixforms Namespace


TCPListener.Pending Method

Determines if there are pending connection requests.

[Visual Basic]
Public Function Pending() As Boolean
[C#]
public bool Pending();

Return Value

true if connections are pending; otherwise, false.

See Also

TCPListener Class | Kixforms Namespace


TCPListener.Start Method

Starts listening for incoming connection requests.

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

Remarks

The Start method initializes the underlying Socket, binds it to a local endpoint, and listens for incoming connection attempts. If a connection request is received, Start will queue the request and continue listening for additional requests until you call the Stop method. If TcpListener receives a connection request after it has already queued the maximum number of connections it will throw a SocketException.

To remove a connection from the incoming connection queue, use either the AcceptTcpClient method. The AcceptTcpClient method will remove a connection from the queue and return a TcpClient that you can use to send and receive data. This method blocks execution until a connection request is available in the queue. Use the Pending method if you want to be sure a connection is available before attempting to accept.

Use the Stop method to close the TcpListener and stop listening. You are responsible for closing your accepted connections separately.

See Also

TCPListener Class | Kixforms Namespace


TCPListener.Stop Method

Closes the listener.

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

Remarks

Stop closes the listener. Any unaccepted connection requests in the queue will be lost. Remote hosts waiting for a connection to be accepted will throw a SocketException. You are responsible for closing your accepted connections separately.

See Also

TCPListener Class | Kixforms Namespace


TextBox Class

Represents a Windows text box control.

For a list of all members of this type, see TextBox Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.TextBoxBase
Kixforms.TextBox

[Visual Basic]
Public Class TextBox
Inherits TextBoxBase
[C#]
public class TextBox : TextBoxBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TextBox Members | Kixforms Namespace


TextBox Members

TextBox overview

Public Instance Constructors

TextBox Constructor Initializes a new instance of the TextBox class.

Public Instance Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBoxBase) | Gets or sets the number of characters selected in the text box.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Public Instance Methods

AppendText (inherited from TextBoxBase) | Appends text to the current text of text box.
BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
Copy (inherited from TextBoxBase) | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Cut (inherited from TextBoxBase) | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Paste (inherited from TextBoxBase) | Replaces the current selection in the text box with the contents of the Clipboard.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
ScrollToCaret (inherited from TextBoxBase) | Scrolls the contents of the control to the current caret position.
Select (inherited from Control) | Activates a control.
SelectAll (inherited from TextBoxBase) | Selects all text in the text box.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Undo (inherited from TextBoxBase) | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TextBox Class | Kixforms Namespace


TextBox Constructor

Initializes a new instance of the TextBox class.

[Visual Basic]
Public Sub New()
[C#]
public TextBox();

See Also

TextBox Class | Kixforms Namespace


TextBox Properties

The properties of the TextBox class are listed below. For a complete list of TextBox class members, see the TextBox Members topic.

Public Instance Properties

AcceptsReturn | Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.
AcceptsTab (inherited from TextBoxBase) | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize (inherited from TextBoxBase) | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle (inherited from TextBoxBase) | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanUndo (inherited from TextBoxBase) | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CharacterCasing | Gets or sets whether the TextBox control modifies the case of characters as they are typed.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection (inherited from TextBoxBase) | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength (inherited from TextBoxBase) | Gets or sets the maximum number of characters the user can type into the text box control.
Modified (inherited from TextBoxBase) | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine (inherited from TextBoxBase) | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PasswordChar | Gets or sets the character used to mask characters of a password in a single-line TextBox control.
PreferredHeight (inherited from TextBoxBase) | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly (inherited from TextBoxBase) | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ScrollBars | Gets or sets which scroll bars should appear in a multiline TextBox control.
SelectedText (inherited from TextBoxBase) | Gets or sets a value indicating the currently selected text in the control.
SelectionLength (inherited from TextBoxBase) | Gets or sets the number of characters selected in the text box.
SelectionStart (inherited from TextBoxBase) | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength (inherited from TextBoxBase) | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap (inherited from TextBoxBase) | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

See Also

TextBox Class | Kixforms Namespace


AcceptsReturn Property

KiXforms.NET Class Library

TextBox.AcceptsReturn Property

Gets or sets a value indicating whether pressing ENTER in a multiline TextBox control creates a new line of text in the control or activates the default button for the form.

[Visual Basic]
Public Property AcceptsReturn As Boolean
[C#]
public bool AcceptsReturn {get; set;}

Property Value

True if the ENTER key creates a new line of text in a multiline version of the control; false if the ENTER key activates the default button for the form. The default is true.

Remarks

If the value of this property is false, the user must press CTRL+ENTER to create a new line in a multiline TextBox control. If there is no default button for the form, then the ENTER key will always create a new line of text in the control, no matter what the value of this property.

See Also

TextBox Class | Kixforms Namespace


CharacterCasing Property

KiXforms.NET Class Library

TextBox.CharacterCasing Property

Gets or sets whether the TextBox control modifies the case of characters as they are typed.

[Visual Basic]
Public Property CharacterCasing As CharacterCasing
[C#]
public CharacterCasing CharacterCasing {get; set;}

See Also

TextBox Class | Kixforms Namespace


PasswordChar Property

KiXforms.NET Class Library

TextBox.PasswordChar Property

Gets or sets the character used to mask characters of a password in a single-line TextBox control.

[Visual Basic]
Public Property PasswordChar As String
[C#]
public string PasswordChar {get; set;}

See Also

TextBox Class | Kixforms Namespace


ScrollBars Property

KiXforms.NET Class Library

TextBox.ScrollBars Property

Gets or sets which scroll bars should appear in a multiline TextBox control.

[Visual Basic]
Public Property ScrollBars As ScrollBars
[C#]
public ScrollBars ScrollBars {get; set;}

See Also

TextBox Class | Kixforms Namespace


TextBoxBase Class

Implements the basic functionality required by text controls.

For a list of all members of this type, see TextBoxBase Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.TextBoxBase
Kixforms.RichTextBox
Kixforms.TextBox

[Visual Basic]
Public Class TextBoxBase
Inherits Control
[C#]
public class TextBoxBase : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TextBoxBase Members | Kixforms Namespace


TextBoxBase Members

TextBoxBase overview

Public Instance Properties

AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength | Gets or sets the maximum number of characters the user can type into the text box control.
Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedText | Gets or sets a value indicating the currently selected text in the control.
SelectionLength | Gets or sets the number of characters selected in the text box.
SelectionStart | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

Public Instance Methods

AppendText | Appends text to the current text of text box.
BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
Copy | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Cut | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Paste | Replaces the current selection in the text box with the contents of the Clipboard.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
ScrollToCaret | Scrolls the contents of the control to the current caret position.
Select (inherited from Control) | Activates a control.
SelectAll | Selects all text in the text box.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Undo | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase Properties

The properties of the TextBoxBase class are listed below. For a complete list of TextBoxBase class members, see the TextBoxBase Members topic.

Public Instance Properties

AcceptsTab | Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoSize | Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border type of the text box control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
CanUndo | Gets a value indicating whether the user can undo the previous operation in a text box control.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MaxLength | Gets or sets the maximum number of characters the user can type into the text box control.
Modified | Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
MultiLine | Gets or sets a value indicating whether this is a multiline text box control.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredHeight | Gets the preferred height for a single-line text box.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether text in the text box is read-only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
SelectedText | Gets or sets a value indicating the currently selected text in the control.
SelectionLength | Gets or sets the number of characters selected in the text box.
SelectionStart | Gets or sets the starting point of text selected in the text box.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
TextLength | Gets the length of text in the control.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WordWrap | Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

See Also

TextBoxBase Class | Kixforms Namespace


AcceptsTab Property

KiXforms.NET Class Library

TextBoxBase.AcceptsTab Property

Gets or sets a value indicating whether pressing the TAB key in a multiline text box control types a TAB character in the control instead of moving the focus to the next control in the tab order.

[Visual Basic]
Public Property AcceptsTab As Boolean
[C#]
public bool AcceptsTab {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


AutoSize Property

KiXforms.NET Class Library

TextBoxBase.AutoSize Property

Gets or sets a value indicating whether the height of the control automatically adjusts when the font assigned to the control is changed.

[Visual Basic]
Public Property AutoSize As Boolean
[C#]
public bool AutoSize {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

TextBoxBase.BorderStyle Property

Gets or sets the border type of the text box control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


CanUndo Property

KiXforms.NET Class Library

TextBoxBase.CanUndo Property

Gets a value indicating whether the user can undo the previous operation in a text box control.

[Visual Basic]
Public ReadOnly Property CanUndo As Boolean
[C#]
public bool CanUndo {get;}

Property Value

True if the user can undo the previous operation performed in a text box control; otherwise, false.

See Also

TextBoxBase Class | Kixforms Namespace


HideSelection Property

KiXforms.NET Class Library

TextBoxBase.HideSelection Property

Gets or sets a value indicating whether the selected text in the text box control remains highlighted when the control loses focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


MaxLength Property

KiXforms.NET Class Library

TextBoxBase.MaxLength Property

Gets or sets the maximum number of characters the user can type into the text box control.

[Visual Basic]
Public Property MaxLength As Integer
[C#]
public int MaxLength {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


Modified Property

KiXforms.NET Class Library

TextBoxBase.Modified Property

Gets or sets a value that indicates that the text box control has been modified by the user since the control was created or its contents were last set.

[Visual Basic]
Public Property Modified As Boolean
[C#]
public bool Modified {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


MultiLine Property

KiXforms.NET Class Library

TextBoxBase.MultiLine Property

Gets or sets a value indicating whether this is a multiline text box control.

[Visual Basic]
Public Property MultiLine As Boolean
[C#]
public bool MultiLine {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


PreferredHeight Property

KiXforms.NET Class Library

TextBoxBase.PreferredHeight Property

Gets the preferred height for a single-line text box.

[Visual Basic]
Overridable Public ReadOnly Property PreferredHeight As Integer
[C#]
public virtual int PreferredHeight {get;}

Property Value

The preferred height of a single-line text box.

Remarks

The size returned by this property is based on the font height and border style of the text box. You can use this property to determine the appropriate size of the text box to ensure that text is properly displayed in the control. The value returned by this property is in pixels.

See Also

TextBoxBase Class | Kixforms Namespace


ReadOnly Property

KiXforms.NET Class Library

TextBoxBase.ReadOnly Property

Gets or sets a value indicating whether text in the text box is read-only.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


SelectedText Property

KiXforms.NET Class Library

TextBoxBase.SelectedText Property

Gets or sets a value indicating the currently selected text in the control.

[Visual Basic]
Public Property SelectedText As String
[C#]
public string SelectedText {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


SelectionLength Property

KiXforms.NET Class Library

TextBoxBase.SelectionLength Property

Gets or sets the number of characters selected in the text box.

[Visual Basic]
Public Property SelectionLength As Integer
[C#]
public int SelectionLength {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


SelectionStart Property

KiXforms.NET Class Library

TextBoxBase.SelectionStart Property

Gets or sets the starting point of text selected in the text box.

[Visual Basic]
Public Property SelectionStart As Integer
[C#]
public int SelectionStart {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


TextLength Property

KiXforms.NET Class Library

TextBoxBase.TextLength Property

Gets the length of text in the control.

[Visual Basic]
Public ReadOnly Property TextLength As Integer
[C#]
public int TextLength {get;}

Property Value

The number of characters contained in the text of the control.

See Also

TextBoxBase Class | Kixforms Namespace


WordWrap Property

KiXforms.NET Class Library

TextBoxBase.WordWrap Property

Indicates whether a multiline text box control automatically wraps words to the beginning of the next line when necessary.

[Visual Basic]
Public Property WordWrap As Boolean
[C#]
public bool WordWrap {get; set;}

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase Methods

The methods of the TextBoxBase class are listed below. For a complete list of TextBoxBase class members, see the TextBoxBase Members topic.

Public Instance Methods

AppendText | Appends text to the current text of text box.
BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
Copy | Copies the current selection in the text box to the Clipboard.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Cut | Moves the current selection in the text box to the Clipboard.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
Paste | Replaces the current selection in the text box with the contents of the Clipboard.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
ScrollToCaret | Scrolls the contents of the control to the current caret position.
Select (inherited from Control) | Activates a control.
SelectAll | Selects all text in the text box.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Undo | Undoes the last edit operation in the text box.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.AppendText Method

Appends text to the current text of text box.

[Visual Basic]
Public Function AppendText( _
ByVal text As String _
) As Object
[C#]
public object AppendText(
string text
);

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.Copy Method

Copies the current selection in the text box to the Clipboard.

[Visual Basic]
Public Sub Copy()
[C#]
public void Copy();

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.Cut Method

Moves the current selection in the text box to the Clipboard.

[Visual Basic]
Public Sub Cut()
[C#]
public void Cut();

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.Paste Method

Replaces the current selection in the text box with the contents of the Clipboard.

[Visual Basic]
Public Sub Paste()
[C#]
public void Paste();

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.ScrollToCaret Method

Scrolls the contents of the control to the current caret position.

[Visual Basic]
Public Sub ScrollToCaret()
[C#]
public void ScrollToCaret();

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.SelectAll Method

Selects all text in the text box.

[Visual Basic]
Public Sub SelectAll()
[C#]
public void SelectAll();

See Also

TextBoxBase Class | Kixforms Namespace


TextBoxBase.Undo Method

Undoes the last edit operation in the text box.

[Visual Basic]
Public Sub Undo()
[C#]
public void Undo();

See Also

TextBoxBase Class | Kixforms Namespace


TextureBrush Class

Each property of the TextureBrush class is a Brush object that uses an image to fill the interior of a shape.

For a list of all members of this type, see TextureBrush Members.

System.Object
Kixforms.Brush
Kixforms.TextureBrush

[Visual Basic]
Public Class TextureBrush
Inherits Brush
[C#]
public class TextureBrush : Brush

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TextureBrush Members | Kixforms Namespace


TextureBrush Members

TextureBrush overview

Public Instance Constructors

TextureBrush Constructor Initializes a new instance of the TextureBrush class.

See Also

TextureBrush Class | Kixforms Namespace


TextureBrush Constructor

Initializes a new instance of the TextureBrush class.

[Visual Basic]
Public Sub New( _
ByVal bitmap As Image _
)
[C#]
public TextureBrush(
Image bitmap
);

See Also

TextureBrush Class | Kixforms Namespace


Timer Class

Implements a timer that raises an event at user-defined intervals.

For a list of all members of this type, see Timer Members.

System.Object
Kixforms.Component
Kixforms.Timer

[Visual Basic]
Public Class Timer
Inherits Component
[C#]
public class Timer : Component

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Timer Members | Kixforms Namespace


Timer Members

Timer overview

Public Instance Constructors

Timer Constructor Initializes a new instance of the Timer class.

Public Instance Properties

Interval | Gets or sets the time, in milliseconds, between timer ticks.
Tag | Gets or sets the object that contains data about the timer.
Tick | Gets or sets the code to execute when the specified timer interval has elapsed and the timer is enabled.
Type (inherited from Component) | Gets the Type of the current instance.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Start | Starts the timer.
Stop | Stops the timer.

See Also

Timer Class | Kixforms Namespace


Timer Constructor

Initializes a new instance of the Timer class.

[Visual Basic]
Public Sub New()
[C#]
public Timer();

See Also

Timer Class | Kixforms Namespace


Timer Properties

The properties of the Timer class are listed below. For a complete list of Timer class members, see the Timer Members topic.

Public Instance Properties

Interval | Gets or sets the time, in milliseconds, between timer ticks.
Tag | Gets or sets the object that contains data about the timer.
Tick | Gets or sets the code to execute when the specified timer interval has elapsed and the timer is enabled.
Type (inherited from Component) | Gets the Type of the current instance.

See Also

Timer Class | Kixforms Namespace


Interval Property

KiXforms.NET Class Library

Timer.Interval Property

Gets or sets the time, in milliseconds, between timer ticks.

[Visual Basic]
Public Property Interval As Integer
[C#]
public int Interval {get; set;}

See Also

Timer Class | Kixforms Namespace


Tag Property

KiXforms.NET Class Library

Timer.Tag Property

Gets or sets the object that contains data about the timer.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

Timer Class | Kixforms Namespace


Tick Property

KiXforms.NET Class Library

Timer.Tick Property

Gets or sets the code to execute when the specified timer interval has elapsed and the timer is enabled.

[Visual Basic]
Public Property Tick As String
[C#]
public string Tick {get; set;}

See Also

Timer Class | Kixforms Namespace


Timer Methods

The methods of the Timer class are listed below. For a complete list of Timer class members, see the Timer Members topic.

Public Instance Methods

Dispose (inherited from Component) | Releases the resources used by the Component.
Start | Starts the timer.
Stop | Stops the timer.

See Also

Timer Class | Kixforms Namespace


Timer.Start Method

Starts the timer.

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

Timer Class | Kixforms Namespace


Timer.Stop Method

Stops the timer.

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

Timer Class | Kixforms Namespace


ToolBar Class

Represents a Windows toolbar.

For a list of all members of this type, see ToolBar Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ToolBar

[Visual Basic]
Public Class ToolBar
Inherits Control
[C#]
public class ToolBar : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ToolBar Members | Kixforms Namespace


ToolBar Members

ToolBar overview

Public Instance Constructors

ToolBar Constructor Initializes a new instance of the ToolBar class.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or set the value that determines the appearance of a toolbar control and its buttons.
AutoSize | Gets or sets a value indicating whether the toolbar adjusts its size automatically, based on the size of the buttons and the dock style.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style of the toolbar control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
ButtonClick | Gets or sets the code to execute when a ToolBarButton on the ToolBar is clicked.
Buttons | Gets the collection of ToolBarButton controls assigned to the toolbar control.
ButtonSize | Gets or sets the size of the buttons on the toolbar control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Divider | Gets or sets a value indicating whether the toolbar displays a divider.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
DropDownArrows | Gets or sets a value indicating whether drop-down buttons on a toolbar display down arrows.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageList | Gets or sets the collection of images available to the toolbar button controls.
ImageSize | Gets the size of the images in the image list assigned to the toolbar.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowToolTips | Gets or sets a value indicating whether the toolbar displays a ToolTip for each button.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of text in relation to each image displayed on the toolbar button controls.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
Wrappable | Gets or sets a value indicating whether the toolbar buttons wrap to the next line if the toolbar becomes too small to display all the buttons on the same line.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

ToolBar Class | Kixforms Namespace


ToolBar Constructor

Initializes a new instance of the ToolBar class.

[Visual Basic]
Public Sub New()
[C#]
public ToolBar();

See Also

ToolBar Class | Kixforms Namespace


ToolBar Properties

The properties of the ToolBar class are listed below. For a complete list of ToolBar class members, see the ToolBar Members topic.

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
Appearance | Gets or set the value that determines the appearance of a toolbar control and its buttons.
AutoSize | Gets or sets a value indicating whether the toolbar adjusts its size automatically, based on the size of the buttons and the dock style.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style of the toolbar control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
ButtonClick | Gets or sets the code to execute when a ToolBarButton on the ToolBar is clicked.
Buttons | Gets the collection of ToolBarButton controls assigned to the toolbar control.
ButtonSize | Gets or sets the size of the buttons on the toolbar control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Divider | Gets or sets a value indicating whether the toolbar displays a divider.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
DropDownArrows | Gets or sets a value indicating whether drop-down buttons on a toolbar display down arrows.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
ImageList | Gets or sets the collection of images available to the toolbar button controls.
ImageSize | Gets the size of the images in the image list assigned to the toolbar.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
ShowToolTips | Gets or sets a value indicating whether the toolbar displays a ToolTip for each button.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextAlign | Gets or sets the alignment of text in relation to each image displayed on the toolbar button controls.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
Wrappable | Gets or sets a value indicating whether the toolbar buttons wrap to the next line if the toolbar becomes too small to display all the buttons on the same line.

See Also

ToolBar Class | Kixforms Namespace


Appearance Property

KiXforms.NET Class Library

ToolBar.Appearance Property

Gets or set the value that determines the appearance of a toolbar control and its buttons.

[Visual Basic]
Public Property Appearance As ToolBarAppearance
[C#]
public ToolBarAppearance Appearance {get; set;}

See Also

ToolBar Class | Kixforms Namespace


AutoSize Property

KiXforms.NET Class Library

ToolBar.AutoSize Property

Gets or sets a value indicating whether the toolbar adjusts its size automatically, based on the size of the buttons and the dock style.

[Visual Basic]
Public Property AutoSize As Boolean
[C#]
public bool AutoSize {get; set;}

See Also

ToolBar Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

ToolBar.BorderStyle Property

Gets or sets the border style of the toolbar control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

ToolBar Class | Kixforms Namespace


ButtonClick Property

KiXforms.NET Class Library

ToolBar.ButtonClick Property

Gets or sets the code to execute when a ToolBarButton on the ToolBar is clicked.

[Visual Basic]
Public Property ButtonClick As String
[C#]
public string ButtonClick {get; set;}

Remarks

The Event property receives a value of type ToolBarButtonClickEventArgs containing data related to this event.

See Also

ToolBar Class | Kixforms Namespace


Buttons Property

KiXforms.NET Class Library

ToolBar.Buttons Property

Gets the collection of ToolBarButton controls assigned to the toolbar control.

[Visual Basic]
Public ReadOnly Property Buttons As ToolBarButtonCollection
[C#]
public ToolBarButtonCollection Buttons {get;}

See Also

ToolBar Class | Kixforms Namespace


ButtonSize Property

KiXforms.NET Class Library

ToolBar.ButtonSize Property

Gets or sets the size of the buttons on the toolbar control.

[Visual Basic]
Public Property ButtonSize As Size
[C#]
public Size ButtonSize {get; set;}

See Also

ToolBar Class | Kixforms Namespace


Divider Property

KiXforms.NET Class Library

ToolBar.Divider Property

Gets or sets a value indicating whether the toolbar displays a divider.

[Visual Basic]
Public Property Divider As Boolean
[C#]
public bool Divider {get; set;}

See Also

ToolBar Class | Kixforms Namespace


DropDownArrows Property

KiXforms.NET Class Library

ToolBar.DropDownArrows Property

Gets or sets a value indicating whether drop-down buttons on a toolbar display down arrows.

[Visual Basic]
Public Property DropDownArrows As Boolean
[C#]
public bool DropDownArrows {get; set;}

See Also

ToolBar Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

ToolBar.ImageList Property

Gets or sets the collection of images available to the toolbar button controls.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}

See Also

ToolBar Class | Kixforms Namespace


ImageSize Property

KiXforms.NET Class Library

ToolBar.ImageSize Property

Gets the size of the images in the image list assigned to the toolbar.

[Visual Basic]
Public ReadOnly Property ImageSize As Size
[C#]
public Size ImageSize {get;}

See Also

ToolBar Class | Kixforms Namespace


ShowToolTips Property

KiXforms.NET Class Library

ToolBar.ShowToolTips Property

Gets or sets a value indicating whether the toolbar displays a ToolTip for each button.

[Visual Basic]
Public Property ShowToolTips As Boolean
[C#]
public bool ShowToolTips {get; set;}

See Also

ToolBar Class | Kixforms Namespace


TextAlign Property

KiXforms.NET Class Library

ToolBar.TextAlign Property

Gets or sets the alignment of text in relation to each image displayed on the toolbar button controls.

[Visual Basic]
Public Property TextAlign As ToolBarTextAlign
[C#]
public ToolBarTextAlign TextAlign {get; set;}

See Also

ToolBar Class | Kixforms Namespace


Wrappable Property

KiXforms.NET Class Library

ToolBar.Wrappable Property

Gets or sets a value indicating whether the toolbar buttons wrap to the next line if the toolbar becomes too small to display all the buttons on the same line.

[Visual Basic]
Public Property Wrappable As Boolean
[C#]
public bool Wrappable {get; set;}

See Also

ToolBar Class | Kixforms Namespace


ToolBarAppearance Enumeration

[Visual Basic]
Public Enum ToolBarAppearance
[C#]
public enum ToolBarAppearance

Members

Member Name | Description
Flat |
Normal |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ToolBarButton Class

Represents a Windows toolbar button.

For a list of all members of this type, see ToolBarButton Members.

System.Object
Kixforms.ToolBarButton

[Visual Basic]
Public Class ToolBarButton
[C#]
public class ToolBarButton

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ToolBarButton Members | Kixforms Namespace


ToolBarButton Members

ToolBarButton overview

Public Instance Constructors

ToolBarButton Constructor Initializes a new instance of the ToolBarButton class.

Public Instance Properties

DropDownMenu | Gets or sets the menu to be displayed in the drop-down toolbar button.
Enabled | Gets or sets a value indicating whether the button is enabled.
ImageIndex | Gets or sets the index value of the image assigned to the button.
ParitalPush | Gets or sets a value indicating whether a toggle-style toolbar button is partially pushed.
Pushed | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the pushed state.
Rectangle | Gets the bounding rectangle for a toolbar button.
Style | Gets or sets the style of the toolbar button.
Tag | Gets or sets the object that contains data about the toolbar button.
Text | Gets or sets the text displayed on the toolbar button.
ToolTipText | Gets or sets the text that appears as a ToolTip for a control.
Visible | Gets or sets a value indicating whether the toolbar button is visible.

See Also

ToolBarButton Class | Kixforms Namespace


ToolBarButton Constructor

Initializes a new instance of the ToolBarButton class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal text As String = "Nothing" _
)
[C#]
public ToolBarButton(
string text
);

See Also

ToolBarButton Class | Kixforms Namespace


ToolBarButton Properties

The properties of the ToolBarButton class are listed below. For a complete list of ToolBarButton class members, see the ToolBarButton Members topic.

Public Instance Properties

DropDownMenu | Gets or sets the menu to be displayed in the drop-down toolbar button.
Enabled | Gets or sets a value indicating whether the button is enabled.
ImageIndex | Gets or sets the index value of the image assigned to the button.
ParitalPush | Gets or sets a value indicating whether a toggle-style toolbar button is partially pushed.
Pushed | Gets or sets a value indicating whether a toggle-style toolbar button is currently in the pushed state.
Rectangle | Gets the bounding rectangle for a toolbar button.
Style | Gets or sets the style of the toolbar button.
Tag | Gets or sets the object that contains data about the toolbar button.
Text | Gets or sets the text displayed on the toolbar button.
ToolTipText | Gets or sets the text that appears as a ToolTip for a control.
Visible | Gets or sets a value indicating whether the toolbar button is visible.

See Also

ToolBarButton Class | Kixforms Namespace


DropDownMenu Property

KiXforms.NET Class Library

ToolBarButton.DropDownMenu Property

Gets or sets the menu to be displayed in the drop-down toolbar button.

[Visual Basic]
Public Property DropDownMenu As ContextMenu
[C#]
public ContextMenu DropDownMenu {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Enabled Property

KiXforms.NET Class Library

ToolBarButton.Enabled Property

Gets or sets a value indicating whether the button is enabled.

[Visual Basic]
Public Property Enabled As Boolean
[C#]
public bool Enabled {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

ToolBarButton.ImageIndex Property

Gets or sets the index value of the image assigned to the button.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


ParitalPush Property

KiXforms.NET Class Library

ToolBarButton.ParitalPush Property

Gets or sets a value indicating whether a toggle-style toolbar button is partially pushed.

[Visual Basic]
Public Property ParitalPush As Boolean
[C#]
public bool ParitalPush {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Pushed Property

KiXforms.NET Class Library

ToolBarButton.Pushed Property

Gets or sets a value indicating whether a toggle-style toolbar button is currently in the pushed state.

[Visual Basic]
Public Property Pushed As Boolean
[C#]
public bool Pushed {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Rectangle Property

KiXforms.NET Class Library

ToolBarButton.Rectangle Property

Gets the bounding rectangle for a toolbar button.

[Visual Basic]
Public ReadOnly Property Rectangle As Rectangle
[C#]
public Rectangle Rectangle {get;}

See Also

ToolBarButton Class | Kixforms Namespace


Style Property

KiXforms.NET Class Library

ToolBarButton.Style Property

Gets or sets the style of the toolbar button.

[Visual Basic]
Public Property Style As ToolBarButtonStyle
[C#]
public ToolBarButtonStyle Style {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Tag Property

KiXforms.NET Class Library

ToolBarButton.Tag Property

Gets or sets the object that contains data about the toolbar button.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

ToolBarButton.Text Property

Gets or sets the text displayed on the toolbar button.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


ToolTipText Property

KiXforms.NET Class Library

ToolBarButton.ToolTipText Property

Gets or sets the text that appears as a ToolTip for a control.

[Visual Basic]
Public Property ToolTipText As String
[C#]
public string ToolTipText {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


Visible Property

KiXforms.NET Class Library

ToolBarButton.Visible Property

Gets or sets a value indicating whether the toolbar button is visible.

[Visual Basic]
Public Property Visible As Boolean
[C#]
public bool Visible {get; set;}

See Also

ToolBarButton Class | Kixforms Namespace


ToolBarButtonClickEventArgs Class

Provides data for the ButtonClick event.

For a list of all members of this type, see ToolBarButtonClickEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.ToolBarButtonClickEventArgs

[Visual Basic]
Public Class ToolBarButtonClickEventArgs
Inherits EventArgs
[C#]
public class ToolBarButtonClickEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ToolBarButtonClickEventArgs Members | Kixforms Namespace


ToolBarButtonClickEventArgs Members

ToolBarButtonClickEventArgs overview

Public Instance Properties

Button Gets or sets the ToolBarButton that was clicked.

See Also

ToolBarButtonClickEventArgs Class | Kixforms Namespace


ToolBarButtonClickEventArgs Properties

The properties of the ToolBarButtonClickEventArgs class are listed below. For a complete list of ToolBarButtonClickEventArgs class members, see the ToolBarButtonClickEventArgs Members topic.

Public Instance Properties

Button Gets or sets the ToolBarButton that was clicked.

See Also

ToolBarButtonClickEventArgs Class | Kixforms Namespace


Button Property

KiXforms.NET Class Library

ToolBarButtonClickEventArgs.Button Property

Gets or sets the ToolBarButton that was clicked.

[Visual Basic]
Public Property Button As ToolBarButton
[C#]
public ToolBarButton Button {get; set;}

See Also

ToolBarButtonClickEventArgs Class | Kixforms Namespace


ToolBarButtonCollection Class

Encapsulates a collection of ToolBarButton controls for use by the ToolBar class.

For a list of all members of this type, see ToolBarButtonCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.ToolBarButtonCollection

[Visual Basic]
Public Class ToolBarButtonCollection
Inherits CollectionBase
[C#]
public class ToolBarButtonCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ToolBarButtonCollection Members | Kixforms Namespace


ToolBarButtonCollection Members

ToolBarButtonCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the toolbar button at the specified indexed location in the toolbar button collection.

Public Instance Methods

Add | Adds a new toolbar button to the end of the toolbar button collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an existing toolbar button in the toolbar button collection at the specified location.
Remove | Removes a given button from the toolbar button collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonCollection Properties

The properties of the ToolBarButtonCollection class are listed below. For a complete list of ToolBarButtonCollection class members, see the ToolBarButtonCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets or sets the toolbar button at the specified indexed location in the toolbar button collection.

See Also

ToolBarButtonCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

ToolBarButtonCollection.Item Property

Gets or sets the toolbar button at the specified indexed location in the toolbar button collection.

[Visual Basic]
Overloads Public Default Property Item( _
ByVal Index As Integer _
) As ToolBarButton
[C#]
public ToolBarButton this[
int Index
] {get; set;}

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonCollection Methods

The methods of the ToolBarButtonCollection class are listed below. For a complete list of ToolBarButtonCollection class members, see the ToolBarButtonCollection Members topic.

Public Instance Methods

Add | Adds a new toolbar button to the end of the toolbar button collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts an existing toolbar button in the toolbar button collection at the specified location.
Remove | Removes a given button from the toolbar button collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonCollection.Add Method

Adds a new toolbar button to the end of the toolbar button collection.

[Visual Basic]
Public Function Add( _
ByVal ToolBarButton As ToolBarButton _
) As ToolBarButton
[C#]
public ToolBarButton Add(
ToolBarButton ToolBarButton
);

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonCollection.Insert Method

Inserts an existing toolbar button in the toolbar button collection at the specified location.

[Visual Basic]
Public Function Insert( _
ByVal index As Integer, _
ByVal ToolBarButton As ToolBarButton _
) As ToolBarButton
[C#]
public ToolBarButton Insert(
int index,
ToolBarButton ToolBarButton
);

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonCollection.Remove Method

Removes a given button from the toolbar button collection.

[Visual Basic]
Public Sub Remove( _
ByVal ToolBarButton As ToolBarButton _
)
[C#]
public void Remove(
ToolBarButton ToolBarButton
);

See Also

ToolBarButtonCollection Class | Kixforms Namespace


ToolBarButtonStyle Enumeration

[Visual Basic]
Public Enum ToolBarButtonStyle
[C#]
public enum ToolBarButtonStyle

Members

Member Name | Description
DropDownButton |
PushButton |
Separator |
ToggleButton |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ToolBarTextAlign Enumeration

[Visual Basic]
Public Enum ToolBarTextAlign
[C#]
public enum ToolBarTextAlign

Members

Member Name | Description
Right |
Underneath |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


ToolTip Class

Represents a small rectangular pop-up window that displays a brief description of a control's purpose when the mouse hovers over the control.

For a list of all members of this type, see ToolTip Members.

System.Object
Kixforms.ToolTip

[Visual Basic]
Public Class ToolTip
[C#]
public class ToolTip

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

ToolTip Members | Kixforms Namespace


ToolTip Members

ToolTip overview

Public Instance Constructors

ToolTip Constructor Initializes a new instance of the ToolTip class.

Public Instance Properties

Active | Gets or sets a value indicating whether the ToolTip is currently active.
AutomaticDelay | Gets or sets the automatic delay for the ToolTip.
AutoPopDelay | Gets or sets the period of time the ToolTip remains visible if the mouse pointer is stationary within a control with specified ToolTip text.
InitialDelay | Gets or sets the time that passes before the ToolTip appears.
ReshowDelay | Gets or sets the length of time that must transpire before subsequent ToolTip windows appear as the mouse pointer moves from one control to another.
ShowAlways | Gets or sets a value indicating whether a ToolTip window is displayed even when its parent control is not active.

Public Instance Methods

GetToolTip | Retrieves the ToolTip text associated with the specified control.
RemoveAll | Removes all ToolTip text currently associated with the ToolTip control.
SetToolTip | Associates ToolTip text with the specified control.

See Also

ToolTip Class | Kixforms Namespace


ToolTip Constructor

Initializes a new instance of the ToolTip class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public ToolTip();

See Also

ToolTip Class | Kixforms Namespace


ToolTip Properties

The properties of the ToolTip class are listed below. For a complete list of ToolTip class members, see the ToolTip Members topic.

Public Instance Properties

Active | Gets or sets a value indicating whether the ToolTip is currently active.
AutomaticDelay | Gets or sets the automatic delay for the ToolTip.
AutoPopDelay | Gets or sets the period of time the ToolTip remains visible if the mouse pointer is stationary within a control with specified ToolTip text.
InitialDelay | Gets or sets the time that passes before the ToolTip appears.
ReshowDelay | Gets or sets the length of time that must transpire before subsequent ToolTip windows appear as the mouse pointer moves from one control to another.
ShowAlways | Gets or sets a value indicating whether a ToolTip window is displayed even when its parent control is not active.

See Also

ToolTip Class | Kixforms Namespace


Active Property

KiXforms.NET Class Library

ToolTip.Active Property

Gets or sets a value indicating whether the ToolTip is currently active.

[Visual Basic]
Public Property Active As Boolean
[C#]
public bool Active {get; set;}

See Also

ToolTip Class | Kixforms Namespace


AutomaticDelay Property

KiXforms.NET Class Library

ToolTip.AutomaticDelay Property

Gets or sets the automatic delay for the ToolTip.

[Visual Basic]
Public Property AutomaticDelay As Integer
[C#]
public int AutomaticDelay {get; set;}

See Also

ToolTip Class | Kixforms Namespace


AutoPopDelay Property

KiXforms.NET Class Library

ToolTip.AutoPopDelay Property

Gets or sets the period of time the ToolTip remains visible if the mouse pointer is stationary within a control with specified ToolTip text.

[Visual Basic]
Public Property AutoPopDelay As Integer
[C#]
public int AutoPopDelay {get; set;}

See Also

ToolTip Class | Kixforms Namespace


InitialDelay Property

KiXforms.NET Class Library

ToolTip.InitialDelay Property

Gets or sets the time that passes before the ToolTip appears.

[Visual Basic]
Public Property InitialDelay As Integer
[C#]
public int InitialDelay {get; set;}

See Also

ToolTip Class | Kixforms Namespace


ReshowDelay Property

KiXforms.NET Class Library

ToolTip.ReshowDelay Property

Gets or sets the length of time that must transpire before subsequent ToolTip windows appear as the mouse pointer moves from one control to another.

[Visual Basic]
Public Property ReshowDelay As Integer
[C#]
public int ReshowDelay {get; set;}

See Also

ToolTip Class | Kixforms Namespace


ShowAlways Property

KiXforms.NET Class Library

ToolTip.ShowAlways Property

Gets or sets a value indicating whether a ToolTip window is displayed even when its parent control is not active.

[Visual Basic]
Public Property ShowAlways As Boolean
[C#]
public bool ShowAlways {get; set;}

See Also

ToolTip Class | Kixforms Namespace


ToolTip Methods

The methods of the ToolTip class are listed below. For a complete list of ToolTip class members, see the ToolTip Members topic.

Public Instance Methods

GetToolTip | Retrieves the ToolTip text associated with the specified control.
RemoveAll | Removes all ToolTip text currently associated with the ToolTip control.
SetToolTip | Associates ToolTip text with the specified control.

See Also

ToolTip Class | Kixforms Namespace


ToolTip.GetToolTip Method

Retrieves the ToolTip text associated with the specified control.

[Visual Basic]
Public Function GetToolTip( _
ByVal Control As Control _
) As String
[C#]
public string GetToolTip(
Control Control
);

See Also

ToolTip Class | Kixforms Namespace


ToolTip.RemoveAll Method

Removes all ToolTip text currently associated with the ToolTip control.

[Visual Basic]
Public Sub RemoveAll()
[C#]
public void RemoveAll();

See Also

ToolTip Class | Kixforms Namespace


ToolTip.SetToolTip Method

Associates ToolTip text with the specified control.

[Visual Basic]
Public Sub SetToolTip( _
ByVal Control As Control, _
ByVal Caption As String _
)
[C#]
public void SetToolTip(
Control Control,
string Caption
);

See Also

ToolTip Class | Kixforms Namespace


TreeNode Class

Represents a node of a TreeView.

For a list of all members of this type, see TreeNode Members.

System.Object
Kixforms.TreeNode

[Visual Basic]
Public Class TreeNode
[C#]
public class TreeNode

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TreeNode Members | Kixforms Namespace


TreeNode Members

TreeNode overview

Public Instance Constructors

TreeNode Constructor Initializes a new instance of the TreeNode class.

Public Instance Properties

Checked | Gets or sets a value indicating whether the tree node is in a checked state.
FullPath | Gets the path from the root tree node to the current tree node.
ImageIndex | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
Index | Gets the position of the tree node in the tree node collection.
NextVisibleNode | Gets the next visible tree node.
NodeFont | Gets or sets the font used to display the text on the tree node's label.
Nodes | Gets the collection of TreeNode objects assigned to the current tree node.
Parent | Gets the parent tree node of the current tree node.
PrevVisibleNode | Gets the previous visible tree node.
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Tag | Gets or sets the object that contains data about the tree node.
Text | Gets or sets the text displayed in the label of the tree node.
TreeView | Gets the parent tree view that the tree node is assigned to.

Public Instance Methods

BeginEdit | Initiates the editing of the tree node label.
Collapse | Collapses the tree node.
Expand | Expands the tree node.
Remove | Removes the current tree node from the tree view control.

See Also

TreeNode Class | Kixforms Namespace


TreeNode Constructor

Initializes a new instance of the TreeNode class.

[Visual Basic]
Public Sub New( _
Optional ByVal p1 As Object = Nothing _
)
[C#]
public TreeNode(
object p1
);

See Also

TreeNode Class | Kixforms Namespace


TreeNode Properties

The properties of the TreeNode class are listed below. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Instance Properties

Checked | Gets or sets a value indicating whether the tree node is in a checked state.
FullPath | Gets the path from the root tree node to the current tree node.
ImageIndex | Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.
Index | Gets the position of the tree node in the tree node collection.
NextVisibleNode | Gets the next visible tree node.
NodeFont | Gets or sets the font used to display the text on the tree node's label.
Nodes | Gets the collection of TreeNode objects assigned to the current tree node.
Parent | Gets the parent tree node of the current tree node.
PrevVisibleNode | Gets the previous visible tree node.
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.
Tag | Gets or sets the object that contains data about the tree node.
Text | Gets or sets the text displayed in the label of the tree node.
TreeView | Gets the parent tree view that the tree node is assigned to.

See Also

TreeNode Class | Kixforms Namespace


Checked Property

KiXforms.NET Class Library

TreeNode.Checked Property

Gets or sets a value indicating whether the tree node is in a checked state.

[Visual Basic]
Public Property Checked As Boolean
[C#]
public bool Checked {get; set;}

See Also

TreeNode Class | Kixforms Namespace


FullPath Property

KiXforms.NET Class Library

TreeNode.FullPath Property

Gets the path from the root tree node to the current tree node.

[Visual Basic]
Public ReadOnly Property FullPath As String
[C#]
public string FullPath {get;}

See Also

TreeNode Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

TreeNode.ImageIndex Property

Gets or sets the image list index value of the image displayed when the tree node is in the unselected state.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

Property Value

A zero-based index value that represents the image position in the assigned ImageList.

See Also

TreeNode Class | Kixforms Namespace


Index Property

KiXforms.NET Class Library

TreeNode.Index Property

Gets the position of the tree node in the tree node collection.

[Visual Basic]
Public ReadOnly Property Index As Integer
[C#]
public int Index {get;}

See Also

TreeNode Class | Kixforms Namespace


NextVisibleNode Property

KiXforms.NET Class Library

TreeNode.NextVisibleNode Property

Gets the next visible tree node.

[Visual Basic]
Public ReadOnly Property NextVisibleNode As TreeNode
[C#]
public TreeNode NextVisibleNode {get;}

See Also

TreeNode Class | Kixforms Namespace


NodeFont Property

KiXforms.NET Class Library

TreeNode.NodeFont Property

Gets or sets the font used to display the text on the tree node's label.

[Visual Basic]
Public Property NodeFont As Font
[C#]
public Font NodeFont {get; set;}

See Also

TreeNode Class | Kixforms Namespace


Nodes Property

KiXforms.NET Class Library

TreeNode.Nodes Property

Gets the collection of TreeNode objects assigned to the current tree node.

[Visual Basic]
Public ReadOnly Property Nodes As TreeNodeCollection
[C#]
public TreeNodeCollection Nodes {get;}

See Also

TreeNode Class | Kixforms Namespace


Parent Property

KiXforms.NET Class Library

TreeNode.Parent Property

Gets the parent tree node of the current tree node.

[Visual Basic]
Public ReadOnly Property Parent As TreeNode
[C#]
public TreeNode Parent {get;}

See Also

TreeNode Class | Kixforms Namespace


PrevVisibleNode Property

KiXforms.NET Class Library

TreeNode.PrevVisibleNode Property

Gets the previous visible tree node.

[Visual Basic]
Public ReadOnly Property PrevVisibleNode As TreeNode
[C#]
public TreeNode PrevVisibleNode {get;}

See Also

TreeNode Class | Kixforms Namespace


SelectedImageIndex Property

KiXforms.NET Class Library

TreeNode.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when the tree node is in the selected state.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}

Property Value

A zero-based index value that represents the image position in an ImageList.

See Also

TreeNode Class | Kixforms Namespace


Tag Property

KiXforms.NET Class Library

TreeNode.Tag Property

Gets or sets the object that contains data about the tree node.

[Visual Basic]
Public Property Tag As Object
[C#]
public object Tag {get; set;}

See Also

TreeNode Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

TreeNode.Text Property

Gets or sets the text displayed in the label of the tree node.

[Visual Basic]
Public Property Text As String
[C#]
public string Text {get; set;}

See Also

TreeNode Class | Kixforms Namespace


TreeView Property

KiXforms.NET Class Library

TreeNode.TreeView Property

Gets the parent tree view that the tree node is assigned to.

[Visual Basic]
Public ReadOnly Property TreeView As TreeView
[C#]
public TreeView TreeView {get;}

See Also

TreeNode Class | Kixforms Namespace


TreeNode Methods

The methods of the TreeNode class are listed below. For a complete list of TreeNode class members, see the TreeNode Members topic.

Public Instance Methods

BeginEdit | Initiates the editing of the tree node label.
Collapse | Collapses the tree node.
Expand | Expands the tree node.
Remove | Removes the current tree node from the tree view control.

See Also

TreeNode Class | Kixforms Namespace


TreeNode.BeginEdit Method

Initiates the editing of the tree node label.

[Visual Basic]
Public Sub BeginEdit()
[C#]
public void BeginEdit();

Remarks

This method only works if the LabelEdit property of the TreeView is set to true. If LabelEdit is set to false, an exception is thrown and the tree node will no be put into an editable state.

See Also

TreeNode Class | Kixforms Namespace


TreeNode.Collapse Method

Collapses the tree node.

[Visual Basic]
Public Sub Collapse()
[C#]
public void Collapse();

See Also

TreeNode Class | Kixforms Namespace


TreeNode.Expand Method

Expands the tree node.

[Visual Basic]
Public Sub Expand()
[C#]
public void Expand();

See Also

TreeNode Class | Kixforms Namespace


TreeNode.Remove Method

Removes the current tree node from the tree view control.

[Visual Basic]
Public Sub Remove()
[C#]
public void Remove();

See Also

TreeNode Class | Kixforms Namespace


TreeNodeCollection Class

Represents a collection of TreeNode objects.

For a list of all members of this type, see TreeNodeCollection Members.

System.Object
Kixforms.CollectionBase
Kixforms.TreeNodeCollection

[Visual Basic]
Public Class TreeNodeCollection
Inherits CollectionBase
[C#]
public class TreeNodeCollection : CollectionBase

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TreeNodeCollection Members | Kixforms Namespace


TreeNodeCollection Members

TreeNodeCollection overview

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets a reference to the node at the specified index location in the collection.

Public Instance Methods

Add | Adds a node to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a node into the collection at the specified index location.
Remove | Removes a node from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeNodeCollection Properties

The properties of the TreeNodeCollection class are listed below. For a complete list of TreeNodeCollection class members, see the TreeNodeCollection Members topic.

Public Instance Properties

Count (inherited from CollectionBase) | Gets the total number of objects in the collection.
IsReadOnly (inherited from CollectionBase) | Gets a value indicating whether the collection is read-only.
Item | Overloaded. Gets a reference to the node at the specified index location in the collection.

See Also

TreeNodeCollection Class | Kixforms Namespace


Item Property

KiXforms.NET Class Library

TreeNodeCollection.Item Property

Gets a reference to the node at the specified index location in the collection.

[Visual Basic]
Overloads Public Default ReadOnly Property Item( _
ByVal index As Integer _
) As TreeNode
[C#]
new public TreeNode this[
int index
] {get;}

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeNodeCollection Methods

The methods of the TreeNodeCollection class are listed below. For a complete list of TreeNodeCollection class members, see the TreeNodeCollection Members topic.

Public Instance Methods

Add | Adds a node to the collection.
Clear (inherited from CollectionBase) | Removes all objects from the collection.
Insert | Inserts a node into the collection at the specified index location.
Remove | Removes a node from the collection.
RemoveAt (inherited from CollectionBase) | Removes an object, at the specified index location, from the collection.

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeNodeCollection.Add Method

Adds a node to the collection.

[Visual Basic]
Public Function Add( _
ByVal TreeNode As TreeNode _
) As TreeNode
[C#]
public TreeNode Add(
TreeNode TreeNode
);

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeNodeCollection.Insert Method

Inserts a node into the collection at the specified index location.

[Visual Basic]
Public Function Insert( _
ByVal Index As Integer, _
ByVal TreeNode As TreeNode _
) As TreeNode
[C#]
public TreeNode Insert(
int Index,
TreeNode TreeNode
);

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeNodeCollection.Remove Method

Removes a node from the collection.

[Visual Basic]
Public Sub Remove( _
ByVal TreeNode As TreeNode _
)
[C#]
public void Remove(
TreeNode TreeNode
);

See Also

TreeNodeCollection Class | Kixforms Namespace


TreeView Class

Displays a hierarchical collection of labeled items, each represented by a TreeNode.

For a list of all members of this type, see TreeView Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.TreeView

[Visual Basic]
Public Class TreeView
Inherits Control
[C#]
public class TreeView : Control

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TreeView Members | Kixforms Namespace


TreeView Members

TreeView overview

Public Instance Constructors

TreeView Constructor Initializes a new instance of the TreeView class.

Public Instance Properties

AfterLabelEdit | Occurs after the tree node label text is edited.
AfterSelect | Gets or sets the code to execute after the tree node is selected.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BeforeExpand | Gets or sets the code to execute before the tree node is expanded.
BeforeSelectEventArgs | Gets data for the BeforeSelect event.
BorderStyle | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
Indent | Gets or sets the distance to indent each of the child tree node levels.
ItemHeight | Gets or sets the height of each tree node in the tree view control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TreeView Class | Kixforms Namespace


TreeView Constructor

Initializes a new instance of the TreeView class.

[Visual Basic]
Overloads Public Sub New()
[C#]
public TreeView();

See Also

TreeView Class | Kixforms Namespace


TreeView Properties

The properties of the TreeView class are listed below. For a complete list of TreeView class members, see the TreeView Members topic.

Public Instance Properties

AfterLabelEdit | Occurs after the tree node label text is edited.
AfterSelect | Gets or sets the code to execute after the tree node is selected.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BeforeExpand | Gets or sets the code to execute before the tree node is expanded.
BeforeSelectEventArgs | Gets data for the BeforeSelect event.
BorderStyle | Gets or sets the border style of the tree view control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
CheckBoxes | Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
FullRowSelect | Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.
Height (inherited from Control) | Gets or sets the height of the control.
HideSelection | Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.
HotTracking | Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.
ImageIndex | Gets or sets the image-list index value of the default image that is displayed by the tree nodes.
ImageList | Gets or sets the ImageList that contains the Image objects used by the tree nodes.
Indent | Gets or sets the distance to indent each of the child tree node levels.
ItemHeight | Gets or sets the height of each tree node in the tree view control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LabelEdit | Gets or sets a value indicating whether the label text of the tree nodes can be edited.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Nodes | Gets the collection of tree nodes that are assigned to the tree view control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PathSeparator | Gets or sets the delimiter string that the tree node path uses.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Scrollable | Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.
SelectedImageIndex | Gets or sets the image list index value of the image that is displayed when a tree node is selected.
SelectedNode | Gets or sets the tree node that is currently selected in the tree view control.
ShowLines | Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.
ShowPlusMinus | Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.
ShowRootLines | Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
Sorted | Gets or sets a value indicating whether the tree nodes in the tree view are sorted.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

TreeView Class | Kixforms Namespace


AfterLabelEdit Property

KiXforms.NET Class Library

TreeView.AfterLabelEdit Property

Occurs after the tree node label text is edited.

[Visual Basic]
Public Property AfterLabelEdit As String
[C#]
public string AfterLabelEdit {get; set;}

Property Value

The code to execute after the tree node label text is edited.

Remarks

Use the System.EventArgs property to return a value of type NodeLabelEditEventArgs containing data related to this event.

See Also

TreeView Class | Kixforms Namespace


AfterSelect Property

KiXforms.NET Class Library

TreeView.AfterSelect Property

Gets or sets the code to execute after the tree node is selected.

[Visual Basic]
Public Property AfterSelect As String
[C#]
public string AfterSelect {get; set;}

Remarks

The System.EventArgs property receives a value of type TreeViewEventArgs containing data related to this event.

See Also

TreeView Class | Kixforms Namespace


BeforeExpand Property

KiXforms.NET Class Library

TreeView.BeforeExpand Property

Gets or sets the code to execute before the tree node is expanded.

[Visual Basic]
Public Property BeforeExpand As String
[C#]
public string BeforeExpand {get; set;}

Remarks

The Event property receives a value of type TreeViewCancelEventArgs containing data related to this event.

See Also

TreeView Class | Kixforms Namespace


BeforeSelectEventArgs Property

KiXforms.NET Class Library

TreeView.BeforeSelectEventArgs Property

Gets data for the BeforeSelect event.

[Visual Basic]
Public Property BeforeSelectEventArgs As TreeViewCancelEventArgs
[C#]
public TreeViewCancelEventArgs BeforeSelectEventArgs {get; set;}

Remarks

The Event property receives a value of type TreeViewCancelEventArgs containing data related to this event.

See Also

TreeView Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

TreeView.BorderStyle Property

Gets or sets the border style of the tree view control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

See Also

TreeView Class | Kixforms Namespace


CheckBoxes Property

KiXforms.NET Class Library

TreeView.CheckBoxes Property

Gets or sets a value indicating whether check boxes are displayed next to the tree nodes in the tree view control.

[Visual Basic]
Public Property CheckBoxes As Boolean
[C#]
public bool CheckBoxes {get; set;}

See Also

TreeView Class | Kixforms Namespace


FullRowSelect Property

KiXforms.NET Class Library

TreeView.FullRowSelect Property

Gets or sets a value indicating whether the selection highlight spans the width of the tree view control.

[Visual Basic]
Public Property FullRowSelect As Boolean
[C#]
public bool FullRowSelect {get; set;}

Property Value

True if the selection highlight spans the width of the tree view control; otherwise, false. The default is false.

Remarks

When FullRowSelect is true, a selection highlight spans the entire width of the tree view, display rather than the width of just the tree node label. The FullRowSelect property is ignored if ShowLines is set to true.

See Also

TreeView Class | Kixforms Namespace


HideSelection Property

KiXforms.NET Class Library

TreeView.HideSelection Property

Gets or sets a value indicating whether the selected tree node remains highlighted even when the tree view has lost the focus.

[Visual Basic]
Public Property HideSelection As Boolean
[C#]
public bool HideSelection {get; set;}

See Also

TreeView Class | Kixforms Namespace


HotTracking Property

KiXforms.NET Class Library

TreeView.HotTracking Property

Gets or sets a value indicating whether a tree node label takes on the appearance of a hyperlink as the mouse pointer passes over it.

[Visual Basic]
Public Property HotTracking As Boolean
[C#]
public bool HotTracking {get; set;}

See Also

TreeView Class | Kixforms Namespace


ImageIndex Property

KiXforms.NET Class Library

TreeView.ImageIndex Property

Gets or sets the image-list index value of the default image that is displayed by the tree nodes.

[Visual Basic]
Public Property ImageIndex As Integer
[C#]
public int ImageIndex {get; set;}

See Also

TreeView Class | Kixforms Namespace


ImageList Property

KiXforms.NET Class Library

TreeView.ImageList Property

Gets or sets the ImageList that contains the Image objects used by the tree nodes.

[Visual Basic]
Public Property ImageList As ImageList
[C#]
public ImageList ImageList {get; set;}

See Also

TreeView Class | Kixforms Namespace


Indent Property

KiXforms.NET Class Library

TreeView.Indent Property

Gets or sets the distance to indent each of the child tree node levels.

[Visual Basic]
Public Property Indent As Integer
[C#]
public int Indent {get; set;}

See Also

TreeView Class | Kixforms Namespace


ItemHeight Property

KiXforms.NET Class Library

TreeView.ItemHeight Property

Gets or sets the height of each tree node in the tree view control.

[Visual Basic]
Public Property ItemHeight As Integer
[C#]
public int ItemHeight {get; set;}

See Also

TreeView Class | Kixforms Namespace


LabelEdit Property

KiXforms.NET Class Library

TreeView.LabelEdit Property

Gets or sets a value indicating whether the label text of the tree nodes can be edited.

[Visual Basic]
Public Property LabelEdit As Boolean
[C#]
public bool LabelEdit {get; set;}

See Also

TreeView Class | Kixforms Namespace


Nodes Property

KiXforms.NET Class Library

TreeView.Nodes Property

Gets the collection of tree nodes that are assigned to the tree view control.

[Visual Basic]
Public ReadOnly Property Nodes As TreeNodeCollection
[C#]
public TreeNodeCollection Nodes {get;}

See Also

TreeView Class | Kixforms Namespace


PathSeparator Property

KiXforms.NET Class Library

TreeView.PathSeparator Property

Gets or sets the delimiter string that the tree node path uses.

[Visual Basic]
Public Property PathSeparator As String
[C#]
public string PathSeparator {get; set;}

See Also

TreeView Class | Kixforms Namespace


Scrollable Property

KiXforms.NET Class Library

TreeView.Scrollable Property

Gets or sets a value indicating whether the tree view control displays scroll bars when they are needed.

[Visual Basic]
Public Property Scrollable As Boolean
[C#]
public bool Scrollable {get; set;}

See Also

TreeView Class | Kixforms Namespace


SelectedImageIndex Property

KiXforms.NET Class Library

TreeView.SelectedImageIndex Property

Gets or sets the image list index value of the image that is displayed when a tree node is selected.

[Visual Basic]
Public Property SelectedImageIndex As Integer
[C#]
public int SelectedImageIndex {get; set;}

See Also

TreeView Class | Kixforms Namespace


SelectedNode Property

KiXforms.NET Class Library

TreeView.SelectedNode Property

Gets or sets the tree node that is currently selected in the tree view control.

[Visual Basic]
Public Property SelectedNode As TreeNode
[C#]
public TreeNode SelectedNode {get; set;}

See Also

TreeView Class | Kixforms Namespace


ShowLines Property

KiXforms.NET Class Library

TreeView.ShowLines Property

Gets or sets a value indicating whether lines are drawn between tree nodes in the tree view control.

[Visual Basic]
Public Property ShowLines As Boolean
[C#]
public bool ShowLines {get; set;}

See Also

TreeView Class | Kixforms Namespace


ShowPlusMinus Property

KiXforms.NET Class Library

TreeView.ShowPlusMinus Property

Gets or sets a value indicating whether plus-sign (+) and minus-sign (-) buttons are displayed next to tree nodes that contain child tree nodes.

[Visual Basic]
Public Property ShowPlusMinus As Boolean
[C#]
public bool ShowPlusMinus {get; set;}

See Also

TreeView Class | Kixforms Namespace


ShowRootLines Property

KiXforms.NET Class Library

TreeView.ShowRootLines Property

Gets or sets a value indicating whether lines are drawn between the tree nodes that are at the root of the tree view.

[Visual Basic]
Public Property ShowRootLines As Boolean
[C#]
public bool ShowRootLines {get; set;}

See Also

TreeView Class | Kixforms Namespace


Sorted Property

KiXforms.NET Class Library

TreeView.Sorted Property

Gets or sets a value indicating whether the tree nodes in the tree view are sorted.

[Visual Basic]
Public Property Sorted As Boolean
[C#]
public bool Sorted {get; set;}

See Also

TreeView Class | Kixforms Namespace


TreeView Methods

The methods of the TreeView class are listed below. For a complete list of TreeView class members, see the TreeView Members topic.

Public Instance Methods

BeginUpdate | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate | Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

TreeView Class | Kixforms Namespace


TreeView.BeginUpdate Method

Prevents the control from drawing until the EndUpdate method is called.

[Visual Basic]
Overrides Public Sub BeginUpdate()
[C#]
public override void BeginUpdate();

See Also

TreeView Class | Kixforms Namespace


TreeView.EndUpdate Method

Resumes drawing of the tree view control after drawing is suspended by the BeginUpdate method.

[Visual Basic]
Overrides Public Sub EndUpdate()
[C#]
public override void EndUpdate();

See Also

TreeView Class | Kixforms Namespace


TreeViewAction Enumeration

[Visual Basic]
Public Enum TreeViewAction
[C#]
public enum TreeViewAction

Members

Member Name | Description
ByKeyboard |
ByMouse |
Collapse |
Expand |
Unknown |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


TreeViewCancelEventArgs Class

Provides data for the BeforeCheck, BeforeCollapse, BeforeExpand, or BeforeSelect events of a TreeView control.

For a list of all members of this type, see TreeViewCancelEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.CancelEventArgs
Kixforms.TreeViewCancelEventArgs

[Visual Basic]
Public Class TreeViewCancelEventArgs
Inherits CancelEventArgs
[C#]
public class TreeViewCancelEventArgs : CancelEventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TreeViewCancelEventArgs Members | Kixforms Namespace


TreeViewCancelEventArgs Members

TreeViewCancelEventArgs overview

Public Instance Properties

Action | Gets the type of TreeViewAction that raised the event.
Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Node | Gets the tree node to be checked, expanded, collapsed, or selected.

See Also

TreeViewCancelEventArgs Class | Kixforms Namespace


TreeViewCancelEventArgs Properties

The properties of the TreeViewCancelEventArgs class are listed below. For a complete list of TreeViewCancelEventArgs class members, see the TreeViewCancelEventArgs Members topic.

Public Instance Properties

Action | Gets the type of TreeViewAction that raised the event.
Cancel (inherited from CancelEventArgs) | Gets or sets a value indicating whether the event should be canceled.
Node | Gets the tree node to be checked, expanded, collapsed, or selected.

See Also

TreeViewCancelEventArgs Class | Kixforms Namespace


Action Property

KiXforms.NET Class Library

TreeViewCancelEventArgs.Action Property

Gets the type of TreeViewAction that raised the event.

[Visual Basic]
Public Property Action As TreeViewAction
[C#]
public TreeViewAction Action {get; set;}

See Also

TreeViewCancelEventArgs Class | Kixforms Namespace


Node Property

KiXforms.NET Class Library

TreeViewCancelEventArgs.Node Property

Gets the tree node to be checked, expanded, collapsed, or selected.

[Visual Basic]
Public Property Node As TreeNode
[C#]
public TreeNode Node {get; set;}

See Also

TreeViewCancelEventArgs Class | Kixforms Namespace


TreeViewEventArgs Class

Provides data for the AfterCheck, AfterCollapse, AfterExpand, or AfterSelect events of a TreeView control.

For a list of all members of this type, see TreeViewEventArgs Members.

System.Object
Kixforms.EventArgs
Kixforms.TreeViewEventArgs

[Visual Basic]
Public Class TreeViewEventArgs
Inherits EventArgs
[C#]
public class TreeViewEventArgs : EventArgs

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

TreeViewEventArgs Members | Kixforms Namespace


TreeViewEventArgs Members

TreeViewEventArgs overview

Public Instance Properties

Action | Gets the type of TreeViewAction that raised the event.
Node | Gets the tree node to be checked, expanded, collapsed, or selected.

See Also

TreeViewEventArgs Class | Kixforms Namespace


TreeViewEventArgs Properties

The properties of the TreeViewEventArgs class are listed below. For a complete list of TreeViewEventArgs class members, see the TreeViewEventArgs Members topic.

Public Instance Properties

Action | Gets the type of TreeViewAction that raised the event.
Node | Gets the tree node to be checked, expanded, collapsed, or selected.

See Also

TreeViewEventArgs Class | Kixforms Namespace


Action Property

KiXforms.NET Class Library

TreeViewEventArgs.Action Property

Gets the type of TreeViewAction that raised the event.

[Visual Basic]
Public Property Action As TreeViewAction
[C#]
public TreeViewAction Action {get; set;}

See Also

TreeViewEventArgs Class | Kixforms Namespace


Node Property

KiXforms.NET Class Library

TreeViewEventArgs.Node Property

Gets the tree node to be checked, expanded, collapsed, or selected.

[Visual Basic]
Public Property Node As TreeNode
[C#]
public TreeNode Node {get; set;}

See Also

TreeViewEventArgs Class | Kixforms Namespace


Type Class

For a list of all members of this type, see Type Members.

System.Object
Kixforms.Type

[Visual Basic]
Public Class Type
[C#]
public class Type

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Type Members | Kixforms Namespace


Type Members

Type overview

Public Instance Constructors

Type Overloaded. Initializes a new instance of the Type class.

Public Instance Properties

IsClass |
Name | Gets the name of this member.

Public Instance Methods

IsInstanceOfType |
IsSubclassOf |
ToString | Returns a String representing the name of the current Type.

See Also

Type Class | Kixforms Namespace


Type Constructor

Initializes a new instance of the Type class.

Overload List

Initializes a new instance of the Type class.

public Type(string);

public Type(Type);

See Also

Type Class | Kixforms Namespace


Type Constructor (String)

Initializes a new instance of the Type class.

[Visual Basic]
Overloads Public Sub New( _
Optional ByVal typeName As String = "Nothing" _
)
[C#]
public Type(
string typeName
);

See Also

Type Class | Kixforms Namespace | Type Constructor Overload List


Type Constructor (Type)

[Visual Basic]
Overloads Public Sub New( _
ByVal type As Type _
)
[C#]
public Type(
Type type
);

See Also

Type Class | Kixforms Namespace | Type Constructor Overload List


Type Properties

The properties of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Instance Properties

IsClass |
Name | Gets the name of this member.

See Also

Type Class | Kixforms Namespace


IsClass Property

KiXforms.NET Class Library

Type.IsClass Property

[Visual Basic]
Public ReadOnly Property IsClass As Boolean
[C#]
public bool IsClass {get;}

See Also

Type Class | Kixforms Namespace


Name Property

KiXforms.NET Class Library

Type.Name Property

Gets the name of this member.

[Visual Basic]
Public ReadOnly Property Name As String
[C#]
public string Name {get;}

See Also

Type Class | Kixforms Namespace


Type Methods

The methods of the Type class are listed below. For a complete list of Type class members, see the Type Members topic.

Public Instance Methods

IsInstanceOfType |
IsSubclassOf |
ToString | Returns a String representing the name of the current Type.

See Also

Type Class | Kixforms Namespace


Type.IsInstanceOfType Method

[Visual Basic]
Public Function IsInstanceOfType( _
ByVal type As Type _
) As Boolean
[C#]
public bool IsInstanceOfType(
Type type
);

See Also

Type Class | Kixforms Namespace


Type.IsSubclassOf Method

[Visual Basic]
Public Function IsSubclassOf( _
ByVal type As Type _
) As Boolean
[C#]
public bool IsSubclassOf(
Type type
);

See Also

Type Class | Kixforms Namespace


Type.ToString Method

Returns a String representing the name of the current Type.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

See Also

Type Class | Kixforms Namespace


UpDownBase Class

Implements the basic functionality required by an up-down control.

For a list of all members of this type, see UpDownBase Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.UpDownBase
Kixforms.NumericUpDown

[Visual Basic]
Public Class UpDownBase
Inherits ContainerControl
[C#]
public class UpDownBase : ContainerControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

UpDownBase Members | Kixforms Namespace


UpDownBase Members

UpDownBase overview

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the text may be changed by the use of the up or down buttons only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

UpDownBase Class | Kixforms Namespace


UpDownBase Properties

The properties of the UpDownBase class are listed below. For a complete list of UpDownBase class members, see the UpDownBase Members topic.

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
BorderStyle | Gets or sets the border style for the up-down control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
ReadOnly | Gets or sets a value indicating whether the text may be changed by the use of the up or down buttons only.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

UpDownBase Class | Kixforms Namespace


BorderStyle Property

KiXforms.NET Class Library

UpDownBase.BorderStyle Property

Gets or sets the border style for the up-down control.

[Visual Basic]
Public Property BorderStyle As BorderStyle
[C#]
public BorderStyle BorderStyle {get; set;}

Property Value

One of the BorderStyle values. The default value is Fixed3D.

See Also

UpDownBase Class | Kixforms Namespace


ReadOnly Property

KiXforms.NET Class Library

UpDownBase.ReadOnly Property

Gets or sets a value indicating whether the text may be changed by the use of the up or down buttons only.

[Visual Basic]
Public Property ReadOnly As Boolean
[C#]
public bool ReadOnly {get; set;}

Property Value

True if the text may be changed by the use of the up or down buttons only; otherwise, false. The default value is false.

See Also

UpDownBase Class | Kixforms Namespace


UserControl Class

Experimental. Provides an empty control that can be used to create other controls.

For a list of all members of this type, see UserControl Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.UserControl

[Visual Basic]
Public Class UserControl
Inherits ContainerControl
[C#]
public class UserControl : ContainerControl

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

UserControl Members | Kixforms Namespace


UserControl Members

UserControl overview

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | A user-defined value.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | A user-defined value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

UserControl Class | Kixforms Namespace


UserControl Properties

The properties of the UserControl class are listed below. For a complete list of UserControl class members, see the UserControl Members topic.

Public Instance Properties

ActiveControl (inherited from ContainerControl) | Gets or sets the active control on the container control.
Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container will allow the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text | A user-defined value.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value | A user-defined value.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

See Also

UserControl Class | Kixforms Namespace


Text Property

KiXforms.NET Class Library

UserControl.Text Property

A user-defined value.

[Visual Basic]
Overrides Public Property Text As String
[C#]
public override string Text {get; set;}

See Also

UserControl Class | Kixforms Namespace


Value Property

KiXforms.NET Class Library

UserControl.Value Property

A user-defined value.

[Visual Basic]
Public Property Value As Object
[C#]
public object Value {get; set;}

See Also

UserControl Class | Kixforms Namespace


Version Class

Represents the version number for a common language runtime assembly.

For a list of all members of this type, see Version Members.

System.Object
Kixforms.Version

[Visual Basic]
Public Class Version
[C#]
public class Version

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Version Members | Kixforms Namespace


Version Members

Version overview

Public Instance Properties

Build | Gets the value of the build component of the version number for this instance.
Major | Gets the value of the major component of the version number for this instance.
Minor | Gets the value of the minor component of the version number for this instance.
Revision | Gets the value of the revision component of the version number for this instance.

See Also

Version Class | Kixforms Namespace


Version Properties

The properties of the Version class are listed below. For a complete list of Version class members, see the Version Members topic.

Public Instance Properties

Build | Gets the value of the build component of the version number for this instance.
Major | Gets the value of the major component of the version number for this instance.
Minor | Gets the value of the minor component of the version number for this instance.
Revision | Gets the value of the revision component of the version number for this instance.

See Also

Version Class | Kixforms Namespace


Build Property

KiXforms.NET Class Library

Version.Build Property

Gets the value of the build component of the version number for this instance.

[Visual Basic]
Public ReadOnly Property Build As Integer
[C#]
public int Build {get;}

Property Value

The build number, or -1 if the build number is undefined.

Remarks

For example, if the version number is 6.2.1.3, the build number is 1. If the version number is 6.2, the build number is undefined.

See Also

Version Class | Kixforms Namespace


Major Property

KiXforms.NET Class Library

Version.Major Property

Gets the value of the major component of the version number for this instance.

[Visual Basic]
Public ReadOnly Property Major As Integer
[C#]
public int Major {get;}

Property Value

The major version number.

Remarks

For example, if the version number is 6.2, the major version is 6.

See Also

Version Class | Kixforms Namespace


Minor Property

KiXforms.NET Class Library

Version.Minor Property

Gets the value of the minor component of the version number for this instance.

[Visual Basic]
Public ReadOnly Property Minor As Integer
[C#]
public int Minor {get;}

Property Value

The minor version number.

Remarks

For example, if the version number is 6.2, the minor version is 2.

See Also

Version Class | Kixforms Namespace


Revision Property

KiXforms.NET Class Library

Version.Revision Property

Gets the value of the revision component of the version number for this instance.

[Visual Basic]
Public ReadOnly Property Revision As Integer
[C#]
public int Revision {get;}

Property Value

The revision number, or -1 if the revision number is undefined.

Remarks

For example, if the version number is 6.2.1.3, the revision number is 3. If the version number is 6.2, the revision number is undefined.

See Also

Version Class | Kixforms Namespace


View Enumeration

[Visual Basic]
Public Enum View
[C#]
public enum View

Members

Member Name | Description
Details |
LargeIcon |
List |
SmallIcon |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


VScrollBar Class

Represents a standard Windows vertical scroll bar.

For a list of all members of this type, see VScrollBar Members.

System.Object
Kixforms.Component
Kixforms.Control
Kixforms.ScrollBar
Kixforms.VScrollBar

[Visual Basic]
Public Class VScrollBar
Inherits ScrollBar
[C#]
public class VScrollBar : ScrollBar

Remarks

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

VScrollBar Members | Kixforms Namespace


VScrollBar Members

VScrollBar overview

Public Instance Properties

Anchor (inherited from Control) | Gets or sets a bitwise combination of AnchorStyles indicating which edges of the control are anchored to the edges of its container.
BackColor (inherited from Control) | Gets or sets a Color representing the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets an Image representing the image to display in the background of the control.
Bottom (inherited from Control) | Gets the distance (in pixels) between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets a Rectangle representing the size and location of the control.
CanFocus (inherited from Control) | Gets or sets whether the control can receive focus.
Capture (inherited from Control) | Gets or sets whether the control has captured the mouse.
Click (inherited from Control) | Gets or sets the code to execute when the control is clicked.
ClientHeight (inherited from Control) | Gets or sets the height of the client area of the control.
ClientRectangle (inherited from Control) | Gets a Rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets a Size representing the height and width of the client area of the control.
ClientWidth (inherited from Control) | Gets or sets the width (in pixels) of the client area of the control.
ContextMenu (inherited from Control) | Gets or sets the ContextMenu associated with the control.
ControlAdded (inherited from Control) | Gets or sets the code to execute when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Gets or sets the code to execute when a control is removed from the ControlCollection.
Controls (inherited from Control) | Gets a ControlCollection that represents all the controls contained within the control.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
Dock (inherited from Control) | Gets or sets which edge of the parent container a control is docked to.
DoubleClick (inherited from Control) | Gets or sets the code to execute when the control is double-clicked.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Enter (inherited from Control) | Gets or sets the code to execute when the control is entered.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
FontBold (inherited from Control) | Gets or sets whether the font used by the control is bold.
FontHeight (inherited from Control) | Gets the height (in pixels) of the font used by the control.
FontName (inherited from Control) | Gets or sets the face name of the font used by the control.
FontSize (inherited from Control) | Gets or sets the size (in points) of the font used by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Height (inherited from Control) | Gets or sets the height of the control.
KeyDown (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyPress (inherited from Control) | Gets or sets the code to execute when a key is pressed while the control has focus.
KeyUp (inherited from Control) | Gets or sets the code to execute when a key is released while the control has focus.
LargeChange (inherited from ScrollBar) | Gets or sets a value to be added to or subtracted from to the Value property when the scroll box is moved a large distance.
Leave (inherited from Control) | Gets or sets the code to execute when input focus leaves the control.
Left (inherited from Control) | Gets or sets the x-coordinate of a control's left edge in pixels.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
LocationChanged (inherited from Control) | Gets or sets the code to execute when the Location property value has changed.
Maximum (inherited from ScrollBar) | Gets or sets the upper limit of values of the scrollable range.
Minimum (inherited from ScrollBar) | Gets or sets the lower limit of values of the scrollable range.
MouseButtons (inherited from Control) | Gets a value indicating which of the mouse buttons is in a pressed state.
MouseDown (inherited from Control) | Gets or sets the code to execute when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Gets or sets the code to execute when the mouse pointer enters the control.
MouseHover (inherited from Control) | Gets or sets the code to execute when the mouse pointer hovers over the control.
MouseLeave (inherited from Control) | Gets or sets the code to execute when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Gets or sets the code to execute when the mouse pointer is moved over the control.
MousePosition (inherited from Control) | Gets the position of the mouse cursor in screen coordinates.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
Move (inherited from Control) | Gets or sets the code to execute when the control is moved.
Name (inherited from Control) | Gets or sets the name of the control.
Paint (inherited from Control) | Gets or sets the code to execute when the control is redrawn.
Parent (inherited from Control) | Gets or sets the parent container of the control.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
Right (inherited from Control) | Gets the distance between the right edge of the control and the left edge of its container.
Size (inherited from Control) | Gets or sets the height and width of the control.
SizeChanged (inherited from Control) | Gets or sets the code to execute when the Size property value changes.
SmallChange (inherited from ScrollBar) | Gets or sets the value to be added to or subtracted from to the Value property when the scroll box is moved a small distance.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Control) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Control) | Gets or sets the text associated with this control.
TextChanged (inherited from Control) | Gets or sets the code to execute when the Text property changes.
Top (inherited from Control) | Gets or sets the y-coordinate of the control's top edge in pixels.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
Type (inherited from Component) | Gets the Type of the current instance.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
Value (inherited from ScrollBar) | Gets or sets a numeric value that represents the current position of the scroll box on the scroll bar control.
ValueChanged (inherited from ScrollBar) | Occurs when the Value property has changed, either by a Scroll event or programatically.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.

Public Instance Methods

BeginUpdate (inherited from Control) | Prevents the control from drawing until the EndUpdate method is called.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Center (inherited from Control) | Centers the control inside its container.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics object for the control.
Dispose (inherited from Component) | Releases the resources used by the Component.
EndUpdate (inherited from Control) | Resumes drawing of the control after drawing is suspended by the BeginUpdate method.
FindControl (inherited from Control) | Searches the ControlCollection for a control with the specified name.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Retrieves the child control that is located at the specified coordinates.
GetNextControl (inherited from Control) | Under development.
Hide (inherited from Control) | Conceals the control from the user.
Invalidate (inherited from Control) | Invalidates a specific region of the control and causes a paint message to be sent to the control.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackgroundImage (inherited from Control) | Resets the BackgroundImage property to its default value.
ResumeLayout (inherited from Control) | Resumes normal layout logic. Optionally forces an immediate layout of pending layout requests.
Select (inherited from Control) | Activates a control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions with its client area.

See Also

VScrollBar Class | Kixforms Namespace


XmlReadMode Enumeration

[Visual Basic]
Public Enum XmlReadMode
[C#]
public enum XmlReadMode

Members

Member Name | Description
Auto |
DiffGram |
Fragment |
IgnoreSchema |
InferSchema |
ReadSchema |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


XmlWriteMode Enumeration

[Visual Basic]
Public Enum XmlWriteMode
[C#]
public enum XmlWriteMode

Members

Member Name | Description
DiffGram |
IgnoreSchema |
WriteSchema |

Requirements

Namespace: Kixforms

Assembly: Kixforms.System (in Kixforms.System.dll)

See Also

Kixforms Namespace


CollectionBase Hierarchy

System.Object
CollectionBase
Collection
ComboBoxObjectCollection
ControlCollection
GridColumnStylesCollection
GridTableStylesCollection
ImageCollection
ListBoxObjectCollection
ListBoxSelectedIndexCollection
ListBoxSelectedObjectCollection
ListViewCheckedItemCollection
ListViewColumnHeaderCollection
ListViewItemCollection
ListViewSelectedItemCollection
ListViewSubItemCollection
MenuItemCollection
StatusBarPanelCollection
TabPageCollection
ToolBarButtonCollection
TreeNodeCollection

See Also

CollectionBase Class | CollectionBase Members | Kixforms Namespace


Component Hierarchy

System.Object
Component
CommonDialog
Control
DataGridColumnStyle
DataGridTableStyle
NotifyIcon
StatusBarPanel
Timer

See Also

Component Class | Component Members | Kixforms Namespace


Control Hierarchy

System.Object
Component
Control
ButtonBase
DataGrid
GroupBox
Label
ListControl
ListView
PictureBox
ProgressBar
ScrollableControl
ScrollBar
Splitter
StatusBar
TabControl
TextBoxBase
ToolBar
TreeView

See Also

Control Class | Control Members | Kixforms Namespace


EventArgs Hierarchy

System.Object
EventArgs
CancelEventArgs
ColumnClickEventArgs
ControlEventArgs
ItemCheckEventArgs
KeyEventArgs
KeyPressEventArgs
LinkClickedEventArgs
MouseEventArgs
NodeLabelEditEventArgs
PaintEventArgs
PropertyValueChangedEventArgs
ToolBarButtonClickEventArgs
TreeViewEventArgs

See Also

EventArgs Class | Kixforms Namespace


KixformsHierarchy

KiXforms.NET Class Library

Kixforms Hierarchy

System.Object
Kixforms.Application
Kixforms.ArrayList ---- System.Collections.IEnumerable, System.Collections.IEnumerator
Kixforms.Brush
Kixforms.HatchBrush
Kixforms.SolidBrush
Kixforms.TextureBrush
Kixforms.CollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IEnumerator, System.Collections.IList
Kixforms.Collection
Kixforms.ComboBoxObjectCollection
Kixforms.ControlCollection
Kixforms.GridColumnStylesCollection
Kixforms.GridTableStylesCollection
Kixforms.ImageCollection
Kixforms.ListBoxObjectCollection
Kixforms.ListBoxSelectedIndexCollection
Kixforms.ListBoxSelectedObjectCollection
Kixforms.ListViewCheckedItemCollection
Kixforms.ListViewColumnHeaderCollection
Kixforms.ListViewItemCollection
Kixforms.ListViewSelectedItemCollection
Kixforms.ListViewSubItemCollection
Kixforms.MenuItemCollection
Kixforms.StatusBarPanelCollection
Kixforms.TabPageCollection
Kixforms.ToolBarButtonCollection
Kixforms.TreeNodeCollection
Kixforms.Color
Kixforms.ColumnHeader
Kixforms.Component
Kixforms.CommonDialog
Kixforms.FileDialog
Kixforms.OpenFileDialog
Kixforms.SaveFileDialog
Kixforms.FolderBrowserDialog
Kixforms.FontDialog
Kixforms.Control
Kixforms.ButtonBase
Kixforms.Button
Kixforms.CheckBox
Kixforms.RadioButton
Kixforms.DataGrid
Kixforms.GroupBox
Kixforms.Label
Kixforms.ListControl
Kixforms.ComboBox
Kixforms.ListBox
Kixforms.ListView
Kixforms.PictureBox
Kixforms.ProgressBar
Kixforms.ScrollableControl
Kixforms.ContainerControl
Kixforms.Form
Kixforms.PropertyGrid
Kixforms.UpDownBase
Kixforms.NumericUpDown
Kixforms.UserControl
Kixforms.Panel
Kixforms.TabPage
Kixforms.ScrollBar
Kixforms.VScrollBar
Kixforms.Splitter
Kixforms.StatusBar
Kixforms.TabControl
Kixforms.TextBoxBase
Kixforms.RichTextBox
Kixforms.TextBox
Kixforms.ToolBar
Kixforms.TreeView
Kixforms.DataGridColumnStyle
Kixforms.DataGridTableStyle
Kixforms.NotifyIcon
Kixforms.StatusBarPanel
Kixforms.Timer
Kixforms.Cursor
Kixforms.Cursors
Kixforms.DataCollectionBase ---- System.Collections.ICollection, System.Collections.IEnumerable
Kixforms.DataColumn
Kixforms.DataColumnCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IEnumerator
Kixforms.DataGridCell
Kixforms.DataItem
Kixforms.DataRow
Kixforms.DataRowCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IEnumerator
Kixforms.DataRowView
Kixforms.DataSet
Kixforms.DataTable
Kixforms.DataTableCollection ---- System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IEnumerator
Kixforms.DataView ---- System.Collections.IEnumerable, System.Collections.IEnumerator
Kixforms.DictionaryEntry
Kixforms.Dns
Kixforms.DockPaddingEdges
Kixforms.Encoding
Kixforms.Environment
Kixforms.EventArgs
Kixforms.CancelEventArgs
Kixforms.TreeViewCancelEventArgs
Kixforms.ColumnClickEventArgs
Kixforms.ControlEventArgs
Kixforms.ItemCheckEventArgs
Kixforms.KeyEventArgs
Kixforms.KeyPressEventArgs
Kixforms.LinkClickedEventArgs
Kixforms.MouseEventArgs
Kixforms.NodeLabelEditEventArgs
Kixforms.PaintEventArgs
Kixforms.PropertyValueChangedEventArgs
Kixforms.ToolBarButtonClickEventArgs
Kixforms.TreeViewEventArgs
Kixforms.File
Kixforms.Font
Kixforms.Graphics
Kixforms.Icon
Kixforms.Image
Kixforms.Bitmap
Kixforms.ImageFormat
Kixforms.ImageList
Kixforms.InputBox
Kixforms.IpAddress
Kixforms.IpHostEntry
Kixforms.ListItem
Kixforms.ListViewItem
Kixforms.ListViewSubItem
Kixforms.Math
Kixforms.Menu
Kixforms.ContextMenu
Kixforms.MainMenu
Kixforms.MenuItem
Kixforms.MessageBox
Kixforms.NetworkStream
Kixforms.Pen
Kixforms.Point
Kixforms.Process
Kixforms.ProcessStartInfo
Kixforms.Rectangle
Kixforms.Screen
Kixforms.Size
Kixforms.SortedList ---- System.Collections.IEnumerator
Kixforms.Sound
Kixforms.Stream
Kixforms.FileStream
Kixforms.MemoryStream
Kixforms.StreamReader
Kixforms.StreamWriter
Kixforms.System
Kixforms.TCPClient
Kixforms.TCPListener
Kixforms.ToolBarButton
Kixforms.ToolTip
Kixforms.TreeNode
Kixforms.Type
Kixforms.Version
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Kixforms.AnchorStyles
Kixforms.Appearance
Kixforms.BorderStyle
Kixforms.CharacterCasing
Kixforms.CheckState
Kixforms.ColorDepth
Kixforms.ColumnHeaderStyle
Kixforms.ComboBoxStyle
Kixforms.ContentAlignment
Kixforms.DialogResult
Kixforms.DockStyle
Kixforms.FileAccess
Kixforms.FileMode
Kixforms.FileShare
Kixforms.FlatStyle
Kixforms.FontStyle
Kixforms.FormBorderStyle
Kixforms.FormStartPosition
Kixforms.FormWindowState
Kixforms.HatchStyle
Kixforms.HorizontalAlignment
Kixforms.ItemActivation
Kixforms.Keys
Kixforms.ListViewAlignment
Kixforms.MdiLayout
Kixforms.MenuMerge
Kixforms.MessageBoxButtons
Kixforms.MessageBoxIcon
Kixforms.MouseButtons
Kixforms.PictureBoxSizeMode
Kixforms.ProcessWindowStyle
Kixforms.PropertySort
Kixforms.RichTextBoxFinds
Kixforms.RichTextBoxStreamType
Kixforms.ScrollBars
Kixforms.SeekOrigin
Kixforms.SelectionMode
Kixforms.Shortcut
Kixforms.SortOrder
Kixforms.SpecialFolder
Kixforms.StatusBarPanelAutoSize
Kixforms.StatusBarPanelBorderStyle
Kixforms.TabAlignment
Kixforms.TabAppearance
Kixforms.TabSizeMode
Kixforms.ToolBarAppearance
Kixforms.ToolBarButtonStyle
Kixforms.ToolBarTextAlign
Kixforms.TreeViewAction
Kixforms.View
Kixforms.XmlReadMode
Kixforms.XmlWriteMode

See Also

Kixforms Namespace